]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- redesign: allow to be used as a library
[packages/rpm.git] / rpm.spec
index 98abd99746220e20ab94e87332a42528fe898fc4..21f83ea81d2ffbb0e7ce7da9dca1e6cc5883c4dc 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -7,6 +7,7 @@
 #
 # Conditional build:
 # _without_static      - build shared /bin/rpm (doesn't work at the moment)
+# _without_docs                - don't generate documentation with doxygen
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
@@ -17,6 +18,7 @@
 %define        reqdb_ver       4.1.25-1
 %define        reqpopt_ver     1.9
 %define        beecrypt_ver    3.0.0-0.20030610.1
+%define rpm_macros_rev 1.118
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -27,7 +29,7 @@ Summary(uk):  
 Name:          rpm
 %define        ver     4.3
 Version:       %{ver}
-%define        rel     0.%{snap}.15
+%define        rel     0.%{snap}.18
 Release:       %{rel}
 License:       GPL
 Group:         Base
@@ -88,6 +90,7 @@ Patch30:      %{name}-man-pl.patch
 Patch31:       %{name}-fdClose-typo.patch
 Patch32:       %{name}-userpmdepswrappers.patch
 Patch33:       %{name}-provides-dont-obsolete.patch
+Patch34:       %{name}-examplesaredoc.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -95,7 +98,7 @@ BuildRequires:        automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.1
 BuildRequires: db-devel >= %{reqdb_ver}
-BuildRequires: doxygen
+%{!?_without_docs:BuildRequires:       doxygen}
 BuildRequires: gettext-devel >= 0.11.4-2
 BuildRequires: elfutils-devel
 #BuildRequires:        libmagic-devel
@@ -421,6 +424,7 @@ Summary(pt_BR):     Scripts e programas execut
 Summary(ru):   óËÒÉÐÔÙ É ÕÔÉÌÉÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÓÂÏÒËÉ ÐÁËÅÔÏ×
 Summary(uk):   óËÒÉÐÔÉ ÔÁ ÕÔÉ̦ÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÐÏÂÕÄÏ×É ÐÁËÅÔ¦×
 Group:         Applications/File
+Provides:      rpmbuild(macros) = %{rpm_macros_rev}
 Requires(pre): findutils
 Requires:      %{name} = %{version}
 Requires:      %{name}-utils = %{version}
@@ -550,6 +554,7 @@ cat %{SOURCE14} >> macros.in
 %patch31 -p1
 %patch32 -p1
 %patch33 -p1
+%patch34 -p1
 
 cd scripts;
 mv -f perl.req perl.req.in
@@ -597,7 +602,7 @@ mv -f macros.tmp macros.in
        CC="%{__cc}" CXX="%{__cxx}" CPP="%{__cpp}" \
        --enable-shared \
        --enable-static \
-       --with-apidocs \
+       %{!?_without_docs:--with-apidocs} \
        --with-python=auto \
        --without-db
 
This page took 0.036644 seconds and 4 git commands to generate.