]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- ugly gcc hack not needed.
[packages/rpm.git] / rpm.spec
index fbe1b0cb7e65365933316e92ed9971b4d104e08c..0c5e524f38b929c3082d9242dfd6ddd3fac830f9 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,13 +1,12 @@
 #
 # TODO:
-# - detected Requires lists are not printed at the end of build (Provides etc. are)
-# - fix pythondeps detection (*.py[co] should belong to python class; autodetect P(abi))
+# - python(abi) cap is not provided automatically (because /usr/bin/python matches
+#   ELF first; it should be provided by python-libs not binary anyway)
 # - consider using system libmagic not internal libfmagic
 #   (but internal has different method of passing output)
 # - after ac drop amd64 patch and make x86_64 generic arch + subarchs amd64 and ia32e
 # 
 # Conditional build:
-%bcond_with    distver # build with distversion field
 %bcond_with    static  # build static rpmi (not supported at the moment)
 %bcond_without apidocs # don't generate documentation with doxygen
 %bcond_with    pkgnameinautoreq        # don't put package name in autogenerated dependancy
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
 
-%define        snap    20041121
 # versions of required libraries
 %define        reqdb_ver       4.3.27-1
 %define        reqpopt_ver     1.10.1
 %define        beecrypt_ver    2:4.1.0
-%define        rpm_macros_rev  1.196
+%define        rpm_macros_rev  1.197
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
 Summary(es):   Gestor de paquetes RPM
@@ -33,11 +31,9 @@ Summary(uk): 
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.1
-Release:       0.6
+Release:       0.9
 License:       GPL
 Group:         Base
-#Source0:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x/%{name}-%{version}.%{snap}.tar.gz
-# Snap tarball is generated from rpm-4_4 branch
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
 # Source0-md5: 90ded9047b1b69d918c6c7c7b56fd7a9
 Source1:       %{name}.groups
@@ -97,9 +93,10 @@ Patch34:     %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
 Patch37:       %{name}-doxygen_hack.patch
-Patch38:       %{name}-distver.patch
-Patch39:       %{name}-gcc4.patch
-Patch40:       %{name}-pythondeps.patch
+Patch38:       %{name}-gcc4.patch
+Patch39:       %{name}-pythondeps.patch
+Patch40:       %{name}-print-requires.patch
+Patch41:       %{name}-reduce-stack-usage.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -216,7 +213,6 @@ Group:              Libraries
 Requires:      db >= %{reqdb_ver}
 %{?with_selinux:BuildRequires: libselinux >= 1.18}
 Requires:      popt >= %{reqpopt_ver}
-%{?with_distver:Provides:      rpm-lib(distver)}
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
 
@@ -398,7 +394,7 @@ Requires:   chrpath >= 0.10-4
 Requires:      cpio
 Requires:      diffutils
 Requires:      elfutils
-Requires:      file >= 4.01
+Requires:      file >= 4.13-2
 Requires:      fileutils
 Requires:      findutils
 %ifarch athlon
@@ -632,9 +628,10 @@ cat %{SOURCE11} >> macros.in
 %patch35 -p0
 %patch36 -p1
 %patch37 -p1
-%{?with_distver:%patch38 -p1}
+%patch38 -p1
 %patch39 -p1
 %patch40 -p1
+%patch41 -p1
 %patch0 -p1
 %patch3 -p1
 
This page took 0.037574 seconds and 4 git commands to generate.