]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- fix !dist_kernel with non-built tree
[packages/rpm.git] / rpm.spec
index 775047dd400d6f64ff8f40055611bc70dc3c0a5d..0613b98792d5dfb768086f45dcf3bdfeb7c169f8 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 #   /usr/lib/rpm/vcheck
 #   /usr/share/man/man8/rpmconstant.8
 #
+# - headerGet() making poldek segfault http://rpm5.org/cvs/tktview?tn=38,1
+# - LUA segfault - http://rpm5.org/cvs/tktview?tn=39,1
+# - rpm doesn't exit when no sources/patches available http://rpm5.org/cvs/tktview?tn=40,1
+# - http://rpm5.org/cvs/tktview?tn=38&_submit=Show
+# - http://rpm5.org/cvs/tktview?tn=39&_submit=Show
+# - http://rpm5.org/cvs/tktview?tn=40&_submit=Show
+# - http://rpm5.org/cvs/tktview?tn=41&_submit=Show
+#
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
-%bcond_without apidocs         # don't generate documentation with doxygen
+%bcond_with    apidocs         # don't generate documentation with doxygen
 %bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
@@ -59,7 +67,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.1.4
-Release:       0.7
+Release:       0.9
 License:       LGPL
 Group:         Base
 Source0:       http://rpm5.org/files/rpm/rpm-5.1/%{name}-%{version}.tar.gz
@@ -128,6 +136,8 @@ Patch34:    %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
 Patch37:       %{name}-doxygen_hack.patch
+Patch38:       %{name}-perl_req-use_base.patch
+Patch39:       %{name}-perl_req-skip_multiline.patch
 
 Patch42:       %{name}-old-fileconflicts-behaviour.patch
 
@@ -687,6 +697,8 @@ install %{SOURCE12} scripts/perl.prov
 %patch35 -p0
 %patch36 -p1
 %patch37 -p1
+%patch38 -p1
+%patch39 -p1
 %patch42 -p1
 %patch46 -p1
 %patch47 -p1
@@ -1103,7 +1115,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_bindir}/rpmsign
 #%attr(755,root,root) %{_bindir}/rpmverify
 
-%dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
 %dir %{_sysconfdir}/rpm/sysinfo
 # these are ok to be replaced
@@ -1141,6 +1152,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %files base
 %defattr(644,root,root,755)
+%dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
 %dir %{_rpmlibdir}
 %attr(755,root,root) %{_bindir}/banner.sh
This page took 0.043297 seconds and 4 git commands to generate.