]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.macros
- fixed (s/-bi/-bb/) and enhanced comment
[packages/rpm.git] / rpm.macros
index c9053dec045cb2cc86be4cb15cd56b73c14efcca..f1cc633259bd41f77ec6141d91edf19803583622 100644 (file)
@@ -5,51 +5,43 @@
 %__chown_Rhf           @__CHOWN_RHF@
 %__chgrp_Rhf           @__CHGRP_RHF@
 
-%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
+%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root:@ROOT_GROUP@
 %_fixgroup       true
 %_fixperms             %{__chmod} -Rf @FIXPERMS@
 %_topdir         %(echo $HOME)/rpm
-%_exec_prefix    %{_prefix}
-%_bindir         %{_exec_prefix}/bin
-%_sbindir        %{_exec_prefix}/sbin
-%_libexecdir     %{_exec_prefix}/lib
-%_datadir        %{_prefix}/share
-%_sharedstatedir /var/lib
-%_lib            lib
-%_libdir         %{_exec_prefix}/%{_lib}
-%_includedir     %{_prefix}/include
-%_oldincludedir  /usr/include
-%_sysconfdir     /etc
-%_localstatedir  /var
-%_infodir        /usr/share/info
-%_mandir         %{_prefix}/share/man
-%_defaultdocdir  %{_usr}/share/doc
 #-----------------------------------------------------------------
 # CFLAGS and LDFLAGS used to build
 
 %debugcflags   -O0 -g -Wall
 %rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}
-%rpmldflags    %{!?debug:-s}
+# %rpmldflags  %{!?debug:-s}
+%rpmldflags    %{nil}
 
 # kernel compiler
-%kgcc          gcc2
-%kgcc_package  gcc2
+%kgcc          gcc
+%kgcc_package  gcc
+
+# other macros
+%_enable_debug_packages 1
 
 # Build system path macros.
 #
 %__libtoolize           libtoolize --copy --force
 %__gettextize { \
-    if gettextize --version | grep -q '0\.11\.' ; then \
-       if [ -f po/Makevars ]; then \
-           gettextize --copy --force --no-changelog; \
-       else \
-           gettextize --copy --force --no-changelog --intl; \
-              cp -f po/Makevars{.template,}; \
-          fi; \
+    if ! gettextize --version | grep -q '0\.10\.' ; then \
+       if grep -qs 'AM_GNU_GETTEXT.*external' configure.{ac,in} ; then \
+           gettextize --copy --force --no-changelog; \
        else \
-               gettextize --copy --force; \
+           gettextize --copy --force --no-changelog --intl; \
+       fi; \
+       if [ ! -f po/Makevars ]; then \
+           cp -f po/Makevars{.template,}; \
+       fi; \
+    else \
+       gettextize --copy --force; \
     fi; \
-}              
+}
+%__autopoint            autopoint --force
 %__automake             automake -a -c -f --foreign
 %__autoconf             autoconf %{?debug:-Wall}
 
@@ -61,8 +53,8 @@
  CXXFLAGS="${CXXFLAGS:-%rpmcflags}" ; export CXXFLAGS ; \
  FFLAGS="${FFLAGS:-%rpmcflags}" ; export FFLAGS ; \
  CPPFLAGS="${CPPFLAGS:-}" ; export CPPFLAGS ; \
- %{?__cc:CC=%{__cc} ; export CC ; } \
- %{?__cxx:CXX=%{__cxx} ; export CXX ; } \
+ %{?__cc:CC="%{__cc}" ; export CC ; } \
+ %{?__cxx:CXX="%{__cxx}" ; export CXX ; } \
  %{?configuredir:%{configuredir}}%{!?configuredir:.}/configure \
        --host=%{_target_platform} \
        --prefix=%{_prefix} \
@@ -78,6 +70,7 @@
        --sharedstatedir=%{_sharedstatedir} \
        --mandir=%{_mandir} \
        --infodir=%{_infodir} \
+       --x-libraries=/usr/X11R6/%{_lib} \
 }
 
 #----------------------------------------------------------------
@@ -87,8 +80,8 @@
        CXXFLAGS="${CXXFLAGS:-%rpmcflags}" \
        FFLAGS="${FFLAGS:-%rpmcflags}" \
        CPPFLAGS="${CPPFLAGS:-}" \
-       %{?__cc:CC=%{__cc}} \
-       %{?__cxx:CXX=%{__cxx}} \
+       %{?__cc:CC="%{__cc}"} \
+       %{?__cxx:CXX="%{__cxx}"} \
        --build=%{_target_platform} \
        --prefix=%{_prefix} \
        --exec-prefix=%{_exec_prefix} \
        --sharedstatedir=%{_sharedstatedir} \
        --mandir=%{_mandir} \
        --infodir=%{_infodir} \
+       --x-libraries=/usr/X11R6/%{_lib} \
 }
 
+# ------------------------------------------------------------------------
+# Overloading of some basic macros
+%prep \
+%%prep\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
+%build %%build\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
+%install %{?_enable_debug_packages:%{?buildsubdir:%{debug_package}}}\
+%%install\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
+# ------------------------------------------------------------------------
+# Conditional build stuff.
+
+# Check if symbol is defined.
+# Example usage: %if %{defined with_foo} && %{undefined with_bar} ...
+%defined()     %{expand:%%{?%{1}:1}%%{!?%{1}:0}}
+%undefined()   %{expand:%%{?%{1}:0}%%{!?%{1}:1}}
+
+# Shorthand for %{defined with_...}
+%with()                %{expand:%%{?with_%{1}:1}%%{!?with_%{1}:0}}
+%without()     %{expand:%%{?with_%{1}:0}%%{!?with_%{1}:1}}
+
+# Handle conditional builds. %bcond_with is for case when feature is
+# default off and needs to be activated with --with ... command line 
+# switch. %bcond_without is for the dual case.
+#
+# %bcond_with foo defines symbol with_foo if --with foo was specified on
+# command line.
+# %bcond_without foo defines symbol with_foo if --without foo was *not* 
+# specified on command line.
+#
+# For example:
+#
+# %bcond_with extra_fonts
+# %bcond_without static
+# %if %{with extra_fonts}
+# ...
+# %endif
+# %ifdef %{with static}
+# ...
+# %endif
+# %{?with_static: ... }
+# %{!?with_static: ... }
+# %{?with_extra_fonts: ... }
+# %{!?with_extra_fonts: ... }
+# 
+# The bottom line: never use without_foo, _with_foo nor _without_foo, only
+# with_foo. This way changing default set of bconds for given spec is just
+# a matter of changing single line in it and syntax is more readable.
+%bcond_with()          %{expand:%%{?_with_%{1}:%%global with_%{1} 1}}
+%bcond_without()       %{expand:%%{!?_without_%{1}:%%global with_%{1} 1}}
+# ------------------------------------------------------------------------
+
 # Location of autoconf macros
 %_aclocaldir   %(aclocal --print-ac-dir)
 
 %_omf_dest_dir %(scrollkeeper-config --omfdir)
 
 # Location of pkgconfig files
-%_pkgconfigdir /usr/lib/pkgconfig
+%_pkgconfigdir /usr/%{_lib}/pkgconfig
 
 # Location of top applink dir
-%_applnkdir      /usr/X11R6/share/applnk
+%_applnkdir    /usr/X11R6/share/applnk
 
-# Location pixmaps for applnk/desktop files
-%_pixmapsdir   /usr/X11R6/share/pixmaps
+# Location of desktop files
+%_desktopdir   /usr/share/applications
+
+# Location of pixmaps for applnk/desktop files
+%_pixmapsdir   /usr/share/pixmaps
+
+# Location of themable icons for applnk/desktop files
+%_iconsdir     /usr/share/icons
 
 # Location of fonts directories
 %_fontsdir     /usr/share/fonts
 
+# Location of Gtk and associated libraries documentation
+%_gtkdocdir  %{_defaultdocdir}/gtk-doc/html
+
+# Location of KDE documentation
+%_kdedocdir  %{_defaultdocdir}/kde/HTML
+
 # Current date
 %date          %(LC_ALL="C" date +"%a %b %d %Y")
 
 %requires_releq()              %(LC_ALL="C" echo '%*' | xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}-%%{release}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
 %requires_releq_kernel_up()    %(LC_ALL="C" rpm -qf --qf 'Prereq: kernel-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
 %requires_releq_kernel_smp()   %(LC_ALL="C" rpm -qf --qf 'Prereq: kernel-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
+%requires_eq_to() %(LC_ALL="C" rpm -q --qf 'Requires: %1 = %%{epoch}:%%{version}\\n' %2 | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
+
+%apache_modules_api %(awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' /usr/include/apache/ap_mmn.h 2>/dev/null || echo ERROR)
 
 # kernel version-release handling
-%__kernel_ver    %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
-%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/version.h --queryformat "%{RELEASE}" | grep -v "is not")
+%__kernel_ver   %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } END { printf("%d.%d.%d", ver, plev, slev); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
+%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h --queryformat "%{RELEASE}" | grep -v "is not")
 %_kernel_ver     %(echo %{__kernel_ver}%{!?_without_dist_kernel:-%{__kernel_rel}})
 %_kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
 
@@ -194,9 +268,10 @@ echo "Compress man and info pages."; \
 #%no_install_post_strip        1
 %__spec_install_post_strip {%{!?debug: \
 %{!?no_install_post_strip: \
-       %{?verbose:set -x;} \
+    %{?verbose:set -x;} \
+    if [ -d "$RPM_BUILD_ROOT" ]; then \
        echo "Strip executable binaries, archives and shared object files."; \
-       filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`; \
+       filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" %{?_noautostrip:! -regex "%{_noautostrip}"}`; \
        elfexelist=`echo $filelist | xargs -r file | \
                awk '/ELF.*executable/ {print $1}' | cut -d: -f1`; \
        elfsharedlist=`echo $filelist | xargs -r file | \
@@ -204,16 +279,49 @@ echo "Compress man and info pages."; \
        elfarchiveslist=`echo $filelist | xargs -r file | \
                awk '/current ar archive/ {print $1}' | cut -d: -f1`; \
        if [ -n "$elfexelist" ]; then \
-               strip --remove-section=.note  --remove-section=.comment $elfexelist; \
+               %{__strip} --remove-section=.note  --remove-section=.comment $elfexelist; \
        fi; \
        if [ -n "$elfsharedlist" ]; then \
-               strip --strip-unneeded --remove-section=.note  --remove-section=.comment $elfsharedlist; \
+               %{__strip} --strip-unneeded --remove-section=.note  --remove-section=.comment $elfsharedlist; \
        fi; \
        if [ -n "$elfarchiveslist" ]; then \
-               strip --strip-debug --remove-section=.note  --remove-section=.comment $elfarchiveslist; \
-       fi; } \
+               %{__strip} --strip-debug --remove-section=.note  --remove-section=.comment $elfarchiveslist; \
+       fi; \
+    fi; } \
+} }
+#-----------------------------------------------------------------
+# remove all RPATH from executable binaries and shared object files
+#
+# Requires: find, awk, cut, xargs, chrpath, uname
+#
+#%no_install_post_chrpath      1
+%__spec_install_post_chrpath {%{!?debug: \
+%{!?no_install_post_chrpath: \
+       %{?verbose:set -x;} \
+if [ -d "$RPM_BUILD_ROOT" ]; then \
+echo "Remove RPATH from executable binaries and shared object files."; \
+find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" %{?_noautochrpath:! -regex "%{_noautochrpath}"} | xargs -r file | \
+       awk '/ELF.*(executable|shared object)/ {print $1}' | cut -d: -f1 | \
+while read file ; do \
+       rpath= ; \
+       chmod u+w "$file"; \
+       for dir in `chrpath -l "$file" | \
+                   awk '/RPATH=/ { gsub(/.*RPATH=/,""); gsub(/:/," "); print $0 }'` ; do \
+                       case $dir in \
+                       /home/* | /tmp/* | /usr/lib | /usr/lib64 | /lib | /lib64 | /usr/local/lib | /usr/local/lib64 | /usr/X11R6/lib | /usr/X11R6/lib64 ) \
+                               echo "remove-rpath: $dir in $file"; \
+                               ;; \
+                       * ) \
+                               if [ "$rpath" = "" ] ; then rpath="$dir" ; \
+                               else rpath="$rpath:$dir" ; fi ; \
+                               ;; \
+                       esac ; \
+       done ; \
+       if [ "$rpath" = "" ] ; then chrpath -d "$file" > /dev/null ; \
+       else chrpath -r "$rpath" "$file" > /dev/null ; fi ; \
+done; \
+fi; } \
 } }
-
 #-----------------------------------------------------------------
 # Find and gzip all kernel modules
 #
@@ -222,14 +330,16 @@ echo "Compress man and info pages."; \
 #%no_install_post_compress_modules  1
 %__spec_install_post_compress_modules { \
 %{!?no_install_post_compress_modules: \
-echo "Compress kernel modules if any."; \
     %{?verbose:set -x;} \
+    if [ -d "$RPM_BUILD_ROOT" ]; then \
+echo "Compress kernel modules if any."; \
     if test -d $RPM_BUILD_ROOT/lib/modules ; then \
-       find $RPM_BUILD_ROOT/lib/modules -name \*.o -type f -print | \
+       find $RPM_BUILD_ROOT/lib/modules -name \*o -type f -print | \
        xargs -r %{__gzip} -9nf; \
-          find $RPM_BUILD_ROOT/lib/modules -name \*.o -type l -printf "%p %l\n" | \
+          find $RPM_BUILD_ROOT/lib/modules -name \*o -type l -printf "%p %l\n" | \
           while read a b; do ln -sf $b.gz $a.gz; rm -f $a; done; \
     fi; \
+    fi; \
 } }
 
 %_source_payload        w9.gzdio
@@ -240,10 +350,10 @@ echo "Compress kernel modules if any."; \
 #
 # Requires: GConf2
 #
-%gconf_schema_install { \
-    GCONF_CONFIG_SOURCE="" \
-    %{_bindir}/gconftool-2 --makefile-install-rule \
-    /etc/X11/GNOME2/gconf/schemas/*.schemas > /dev/null \
+%gconf_schema_install { umask 022; \
+    GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" \
+    /usr/bin/gconftool-2 --makefile-install-rule \
+    /etc/gconf/schemas/*.schemas > /dev/null \
 }
 
 #-----------------------------------------------------------------
@@ -256,58 +366,80 @@ echo "Compress kernel modules if any."; \
 ###################################################################
 # Requires/Provides automation
 # exceptions system by Jacek Konieczny <jajcus@pld.org.pl>
-%__spec_prep_pre \
-_autoreqprov=n \
-%{?_noautoreqfiles:_autoreqprov=y}\
-%{?_noautoreq:_autoreqprov=y}\
-%{?_noautoreqdep:_autoreqprov=y}\
-%{?_noautoprovfiles:_autoreqprov=y}\
-%{?_noautoprov:_autoreqprov=y}\
-%{?_noautocompressdoc:_autoreqprov=y}\
-if [ "$_autoreqprov" = "y" ] ; then \
-    if [ -f %{_builddir}/__rpm_lock ] ; then \
-       echo "Some package using \%_noauto*  macros is already being built" >&2 \
-       echo "If it is not true delete %{_builddir}/__rpm_lock" >&2 \
-       exit 1 \
-    else \
-       rm -f %{_builddir}/__rpm_*\
-       touch %{_builddir}/__rpm_lock \
-    fi \
-fi \
-%{?_noautocompressdoc:echo '%{_noautocompressdoc}' > %{_builddir}/__rpm_noautocompressdoc}\
-%{nil}
-
-%__os_install_post \
-%{?_noautoreqfiles:for f in %{_noautoreqfiles} ; do echo %{?buildroot:%{buildroot}}$f >> %{_builddir}/__rpm_noautoreqfiles ; done }\
-%{?_noautoreq:for f in %{_noautoreq} ; do echo "$f" >> %{_builddir}/__rpm_noautoreq ; done }\
-%{?_noautoreqdep:for f in %{_noautoreqdep} ; do echo "$f" >> %{_builddir}/__rpm_noautoreqdep ; done }\
-%{?_noautoprovfiles:for f in %{_noautoprovfiles} ; do echo %{?buildroot:%{buildroot}}$f >> %{_builddir}/__rpm_noautoprovfiles ; done }\
-%{?_noautoprov:for f in %{_noautoprov} ; do echo "$f" >> %{_builddir}/__rpm_noautoprov ; done }\
-%{__spec_install_post_strip}\
-%{__spec_install_post_compress_docs}\
-%{__spec_install_post_compress_modules}\
-%{__arch_install_post}\
-%{nil}
-
-%__spec_clean_pre      %{___build_pre}\
-_autoreqprov=n \
-%{?_noautoreqfiles:_autoreqprov=y}\
-%{?_noautoreq:_autoreqprov=y}\
-%{?_noautoreqdep:_autoreqprov=y}\
-%{?_noautoprovfiles:_autoreqprov=y}\
-%{?_noautoprov:_autoreqprov=y}\
-%{?_noautoreqfiles:_autoreqprov=y}\
-%{?_noautocompressdoc:_autoreqprov=y}\
-if [ "$_autoreqprov" = "y" ] ; then \
-       rm -f %{_builddir}/__rpm_* \
-fi \
-%{nil}
-
-
-#%_noautoreqfiles      "%{_defaultdocdir}.*" "%{_examplesdir}.*"
-#%_noautoreq           %{nil}
-#%_noautoreqdep                %{nil}
-#%_noautoprovfiles     %{nil}
-#%_noautoprov          %{nil}
+#
+%_noautoreqfiles       %(sed -e s'/#.*//' /etc/rpm/noautoreqfiles)
+%_noautoprovfiles      %(sed -e s'/#.*//' /etc/rpm/noautoprovfiles)
+%_noautoreq            %(sed -e s'/#.*//' /etc/rpm/noautoreq)
+%_noautoreqdep         %(sed -e s'/#.*//' /etc/rpm/noautoreqdep)
+%_noautoprov           %(sed -e s'/#.*//' /etc/rpm/noautoprov)
+#%_noautocompressdoc   %{nil}
+#
 %_missing_doc_files_terminate_build    1%{nil}
 %_unpackaged_files_terminate_build     %{nil}
+# (X)emacs support
+%___emacs_lispdir_helper  -batch -q -eval '(while load-path (princ (concat (car load-path) "\\n")) (setq load-path (cdr load-path)))' 2> /dev/null|sed -n '/\\(.*\\/x\\?emacs\\/site-lisp\\)\\/\\?$/{s,,\\1,p;q;}'
+%_emacs_lispdir %(emacs %___emacs_lispdir_helper)
+%_xemacs_lispdir %(xemacs %___emacs_lispdir_helper)
+
+%__php_provides        %{nil}
+%__php_requires %{nil}
+%__perl_provides %{nil}
+%__perl_requires %{nil}
+
+# Perl specific macro definitions.
+%perl_privlib  %(eval "`%{__perl} -V:installprivlib`"; echo $installprivlib)
+%perl_archlib  %(eval "`%{__perl} -V:installarchlib`"; echo $installarchlib)
+%perl_vendorlib        %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
+%perl_vendorarch       %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)
+%perl_sitelib  %(eval "`%{__perl} -V:installsitelib`"; echo $installsitelib)
+%perl_sitearch %(eval "`%{__perl} -V:installsitearch`"; echo $installsitearch)
+
+%php_pear_dir  %{_datadir}/pear
+
+# Python specific macro definitions.
+# python main version
+%py_ver         %(echo `python -c "import sys; print sys.version[:3]"`)
+
+# directories
+%py_prefix      %(echo `python -c "import sys; print sys.prefix"`)
+%py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
+%py_scriptdir  %{py_prefix}/share/python%{py_ver}
+%py_incdir      /usr/include/python%{py_ver}
+%py_sitedir    %{py_libdir}/site-packages
+%py_sitescriptdir %{py_scriptdir}/site-packages
+%py_dyndir      %{py_libdir}/lib-dynload
+
+# pure python modules compilation
+%py_comp        python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
+
+%py_ocomp       python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
+
+# Software written in Python language require Python with main version
+# unchanged
+%pyrequires_eq() Requires:       %1 >= 1:%py_ver %1 < 1:%(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
+
+# depmod macro
+%depmod() { \
+if [ -e /boot/System.map-%1 ]; then \
+        /sbin/depmod -a -F /boot/System.map-%1 %1; \
+else \
+        if [ -e /boot/System.map ]; then \
+                /sbin/depmod -a -F /boot/System.map %1; \
+        else \
+                /sbin/depmod -a %1; \
+        fi \
+fi; \
+}
+
+# XMMS specific macros
+%xmms_prefix                  %(xmms-config --prefix)
+%xmms_exec_prefix             %(xmms-config --exec-prefix)
+%xmms_version                 %(xmms-config --version)
+%xmms_datadir                 %(xmms-config --data-dir)
+%xmms_plugindir               %(xmms-config --plugin-dir)
+%xmms_visualization_plugindir %(xmms-config --visualization-plugin-dir)
+%xmms_input_plugindir         %(xmms-config --input-plugin-dir)
+%xmms_output_plugindir        %(xmms-config --output-plugin-dir)
+%xmms_effect_plugindir        %(xmms-config --effect-plugin-dir)
+%xmms_general_plugindir       %(xmms-config --general-plugin-dir)
+
This page took 0.043322 seconds and 4 git commands to generate.