]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.macros
- added %ifarch for PPC port of PLD :)
[packages/rpm.git] / rpm.macros
index 2257c07f4ce00c485c32bf9b6fcba7c3ab5b825b..c4c5b061d17b9c10efd31c462e4baaedb51fd578 100644 (file)
@@ -1,3 +1,23 @@
+# PLD rpm macros
+
+%_defaultdocdir  %{_usr}/share/doc
+%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
+%_fixgroup       true
+%_topdir         %(echo $HOME)/rpm
+%_exec_prefix    %{_prefix}
+%_bindir         %{_exec_prefix}/bin
+%_sbindir        %{_exec_prefix}/sbin
+%_libexecdir     %{_exec_prefix}/lib
+%_datadir        %{_prefix}/share
+%_sharedstatedir %{_prefix}/com
+%_lib            lib
+%_libdir         %{_exec_prefix}/%{_lib}
+%_includedir     %{_prefix}/include
+%_oldincludedir  /usr/include
+%_sysconfdir     /etc
+%_localstatedir  /var
+%_infodir        /usr/share/info
+%_mandir         %{_prefix}/share/man
 #-----------------------------------------------------------------
 # CFLAGS and LDFLAGS used to build
 
@@ -12,6 +32,8 @@
  CFLAGS="${CFLAGS:-%rpmcflags}" ; export CFLAGS ; \
  CXXFLAGS="${CXXFLAGS:-%rpmcflags}" ; export CXXFLAGS ; \
  FFLAGS="${FFLAGS:-%rpmcflags}" ; export FFLAGS ; \
+ %{?__cc:CC=%{__cc} ; export CC ; } \
+ %{?__cxx:CXX=%{__cxx} ; export CXX ; } \
  ./configure \
        --host=%{_target_platform} \
        --prefix=%{_prefix} \
        --infodir=%{_infodir} \
 }
 
-#------------------------------------------------------------------------------
-# The GNUconfigure macro does the following:
-#       update config.guess and config.sub.
-#       regenerate all autoconf/automake files
-#       optionally change to a directory (make the directory if requested).
-#       run configure with correct prefix, platform, and CFLAGS.
-#       optionally restore current directory.
-#
-# Based on autogen.sh from GNOME and orginal GNUconfigure
-#
-%GNUconfigure(MCs:)      \
-  %{-C:_mydir="`pwd`"; %{-M: %{__mkdir} -p %{-C*};} cd %{-C*}} \
-  dirs="`find ${_mydir} -name configure.in -print`"; export dirs; \
-    for coin in `echo ${dirs}` \
-do \
-  dr=`dirname ${coin}`; \
-if test -f ${dr}/NO-AUTO-GEN; then \
- : \
-else \
-     macrodirs=`sed -n -e 's,AM_ACLOCAL_INCLUDE(\(.*\)),\1,gp' < ${coin}`; \
-    ( cd ${dr}; \
-      aclocalinclude="${ACLOCAL_FLAGS}"; \
-      for k in ${macrodirs}; do \
-        if test -d ${k}; then \
-          aclocalinclude="${aclocalinclude} -I ${k}"; \
-        ##else \
-        ##  echo "**Warning**: No such directory \`${k}'.  Ignored." \
-        fi \
-      done \
-      if grep "^AM_GNU_GETTEXT" configure.in >/dev/null; then \
-        if grep "sed.*POTFILES" configure.in >/dev/null; then \
-          : do nothing -- we still have an old unmodified configure.in \
-        else \
-          test -r ${dr}/aclocal.m4 || touch ${dr}/aclocal.m4; \
-          echo "no" | gettextize --force --copy; \
-          test -r ${dr}/aclocal.m4 && %{__chmod} u+w ${dr}/aclocal.m4; \
-        fi \
-      fi \
-      if grep "^AM_PROG_LIBTOOL" configure.in >/dev/null; then \
-        %{__libtoolize} --force --copy; \
-      fi \
-      aclocal ${aclocalinclude}; \
-      if grep "^AM_CONFIG_HEADER" configure.in >/dev/null; then \
-        %{__autoheader}; \
-      fi \
-      echo "Running automake --gnu ${am_opt} ..."; \
-      %{__automake} --add-missing --gnu ${am_opt}; \
-      %{__autoconf}; \
-    ); \
-  fi \
-done \
-  %{-C:${_mydir}}%{!-C:.}/%{configure} \
-  %{-C:cd ${_mydir}; unset _mydir}
-
 # Location of autoconf macros
 %_aclocaldir   %(aclocal --print-ac-dir)
 
@@ -131,6 +99,9 @@ done \
 # Example files, programs, scripts...
 %_examplesdir  /usr/src/examples
 
+# The directory holding Linux kernel sources
+%_kernelsrcdir /usr/src/linux
+
 # If non-empty "debug" macro defined, add "dbg" suffix to release number
 %_rpmfilename          %%{NAME}-%%{VERSION}-%%{RELEASE}%{?debug:dbg}.%%{ARCH}.rpm
 
@@ -207,7 +178,7 @@ if [ "$_autoreqprov" = "y" ] ; then \
 fi \
 %{nil}
 
-%__spec_install_post \
+%__os_install_post \
 %{?_noautoreqfiles:for f in %{_noautoreqfiles} ; do echo %{?buildroot:%{buildroot}}$f >> %{_builddir}/__rpm_noautoreqfiles ; done }\
 %{?_noautoreq:for f in %{_noautoreq} ; do echo "$f" >> %{_builddir}/__rpm_noautoreq ; done }\
 %{?_noautoreqdep:for f in %{_noautoreqdep} ; do echo "$f" >> %{_builddir}/__rpm_noautoreqdep ; done }\
@@ -216,7 +187,6 @@ fi \
 %{__spec_install_post_strip}\
 %{__spec_install_post_compress_docs}\
 %{__arch_install_post}\
-%{__os_install_post}\
 %{nil}
 
 %__spec_clean_pre      %{___build_pre}\
This page took 0.029386 seconds and 4 git commands to generate.