]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.macros
- user/group staff backported from ac-branch
[packages/rpm.git] / rpm.macros
index 244fbd1675579db653adda4aba61ef57f577a104..9ad8377fd18d6abdd820bae73f5127890484191b 100644 (file)
@@ -1,20 +1,25 @@
 # PLD rpm macros
 
+# other macros
+%_enable_debug_packages 1
+
 %__id          @__ID@
 %__id_u                %{__id} -u 
 %__chown_Rhf           @__CHOWN_RHF@
 %__chgrp_Rhf           @__CHGRP_RHF@
 
-%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
+%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root:@ROOT_GROUP@
 %_fixgroup       true
 %_fixperms             %{__chmod} -Rf @FIXPERMS@
 %_topdir         %(echo $HOME)/rpm
 #-----------------------------------------------------------------
 # CFLAGS and LDFLAGS used to build
 
+%debuginfocflags       %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -ggdb}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
+
 %debugcflags   -O0 -g -Wall
-%rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}
-%rpmldflags    %{!?debug:-s}
+%rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
+%rpmldflags    %{nil}
 
 # kernel compiler
 %kgcc          gcc
@@ -49,8 +54,8 @@
  CXXFLAGS="${CXXFLAGS:-%rpmcflags}" ; export CXXFLAGS ; \
  FFLAGS="${FFLAGS:-%rpmcflags}" ; export FFLAGS ; \
  CPPFLAGS="${CPPFLAGS:-}" ; export CPPFLAGS ; \
- %{?__cc:CC=%{__cc} ; export CC ; } \
- %{?__cxx:CXX=%{__cxx} ; export CXX ; } \
+ %{?__cc:CC="%{__cc}" ; export CC ; } \
+ %{?__cxx:CXX="%{__cxx}" ; export CXX ; } \
  %{?configuredir:%{configuredir}}%{!?configuredir:.}/configure \
        --host=%{_target_platform} \
        --prefix=%{_prefix} \
@@ -66,6 +71,7 @@
        --sharedstatedir=%{_sharedstatedir} \
        --mandir=%{_mandir} \
        --infodir=%{_infodir} \
+       --x-libraries=/usr/X11R6/%{_lib} \
 }
 
 #----------------------------------------------------------------
@@ -75,8 +81,8 @@
        CXXFLAGS="${CXXFLAGS:-%rpmcflags}" \
        FFLAGS="${FFLAGS:-%rpmcflags}" \
        CPPFLAGS="${CPPFLAGS:-}" \
-       %{?__cc:CC=%{__cc}} \
-       %{?__cxx:CXX=%{__cxx}} \
+       %{?__cc:CC="%{__cc}"} \
+       %{?__cxx:CXX="%{__cxx}"} \
        --build=%{_target_platform} \
        --prefix=%{_prefix} \
        --exec-prefix=%{_exec_prefix} \
        --sharedstatedir=%{_sharedstatedir} \
        --mandir=%{_mandir} \
        --infodir=%{_infodir} \
+       --x-libraries=/usr/X11R6/%{_lib} \
 }
 
+# ------------------------------------------------------------------------
+# Overloading of some basic macros
+%prep \
+%%prep\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
+%build %%build\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
+%install %{?_enable_debug_packages:%{?buildsubdir:%{debug_package}}}\
+%%install\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
 # ------------------------------------------------------------------------
 # Conditional build stuff.
 
 %_omf_dest_dir %(scrollkeeper-config --omfdir)
 
 # Location of pkgconfig files
-%_pkgconfigdir /usr/lib/pkgconfig
+%_pkgconfigdir /usr/%{_lib}/pkgconfig
 
 # Location of top applink dir
 %_applnkdir    /usr/X11R6/share/applnk
 # Location of desktop files
 %_desktopdir   /usr/share/applications
 
-# Location pixmaps for applnk/desktop files
+# Location of pixmaps for applnk/desktop files
 %_pixmapsdir   /usr/share/pixmaps
 
+# Location of themable icons for applnk/desktop files
+%_iconsdir     /usr/share/icons
+
 # Location of fonts directories
 %_fontsdir     /usr/share/fonts
 
 # Location of Gtk and associated libraries documentation
 %_gtkdocdir  %{_defaultdocdir}/gtk-doc/html
 
+# Location of KDE documentation
+%_kdedocdir  %{_defaultdocdir}/kde/HTML
+
 # Current date
 %date          %(LC_ALL="C" date +"%a %b %d %Y")
 
 %requires_releq()              %(LC_ALL="C" echo '%*' | xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}-%%{release}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
 %requires_releq_kernel_up()    %(LC_ALL="C" rpm -qf --qf 'Prereq: kernel-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
 %requires_releq_kernel_smp()   %(LC_ALL="C" rpm -qf --qf 'Prereq: kernel-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
-%requires_eq_to %(LC_ALL="C" rpm -q --qf 'Requires: %1 = %%{epoch}:%%{version}\\n' %2 | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
+%requires_eq_to() %(LC_ALL="C" rpm -q --qf 'Requires: %1 = %%{epoch}:%%{version}\\n' %2 | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
 
-%apache_modules_api %(awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' `apr-config --includedir`/ap_mmn.h)
+%apache_modules_api %(awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' /usr/include/apache/ap_mmn.h 2>/dev/null || echo ERROR)
 
 # kernel version-release handling
-%__kernel_ver    %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
-%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/version.h --queryformat "%{RELEASE}" | grep -v "is not")
+%__kernel_ver   %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } END { printf("%d.%d.%d", ver, plev, slev); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
+%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h --queryformat "%{RELEASE}" | grep -v "is not")
 %_kernel_ver     %(echo %{__kernel_ver}%{!?_without_dist_kernel:-%{__kernel_rel}})
 %_kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
 
 #
 #%no_install_post_compress_docs        1
 %__spec_install_post_compress_docs { \
-echo "Compress man and info pages."; \
 %{!?no_install_post_compress_docs: \
+       echo "Compress man and info pages."; \
        %{?verbose:set -x;} \
        for i in /usr/share/man /usr/X11R6/man /usr/share/info; do \
                if [ -d "$RPM_BUILD_ROOT$i" ]; then \
@@ -234,9 +269,10 @@ echo "Compress man and info pages."; \
 #%no_install_post_strip        1
 %__spec_install_post_strip {%{!?debug: \
 %{!?no_install_post_strip: \
-       %{?verbose:set -x;} \
+    %{?verbose:set -x;} \
+    if [ -d "$RPM_BUILD_ROOT" ]; then \
        echo "Strip executable binaries, archives and shared object files."; \
-       filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`; \
+       filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" %{?_noautostrip:! -regex "%{_noautostrip}"}`; \
        elfexelist=`echo $filelist | xargs -r file | \
                awk '/ELF.*executable/ {print $1}' | cut -d: -f1`; \
        elfsharedlist=`echo $filelist | xargs -r file | \
@@ -244,14 +280,15 @@ echo "Compress man and info pages."; \
        elfarchiveslist=`echo $filelist | xargs -r file | \
                awk '/current ar archive/ {print $1}' | cut -d: -f1`; \
        if [ -n "$elfexelist" ]; then \
-               strip --remove-section=.note  --remove-section=.comment $elfexelist; \
+               %{__strip} --remove-section=.note  --remove-section=.comment $elfexelist; \
        fi; \
        if [ -n "$elfsharedlist" ]; then \
-               strip --strip-unneeded --remove-section=.note  --remove-section=.comment $elfsharedlist; \
+               %{__strip} --strip-unneeded --remove-section=.note  --remove-section=.comment $elfsharedlist; \
        fi; \
        if [ -n "$elfarchiveslist" ]; then \
-               strip --strip-debug --remove-section=.note  --remove-section=.comment $elfarchiveslist; \
-       fi; } \
+               %{__strip} --strip-debug --remove-section=.note  --remove-section=.comment $elfarchiveslist; \
+       fi; \
+    fi; } \
 } }
 #-----------------------------------------------------------------
 # remove all RPATH from executable binaries and shared object files
@@ -262,9 +299,9 @@ echo "Compress man and info pages."; \
 %__spec_install_post_chrpath {%{!?debug: \
 %{!?no_install_post_chrpath: \
        %{?verbose:set -x;} \
+if [ -d "$RPM_BUILD_ROOT" ]; then \
 echo "Remove RPATH from executable binaries and shared object files."; \
-if [ "$(uname -m)" != alpha ] ; then \
-find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" | xargs -r file | \
+find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" %{?_noautochrpath:! -regex "%{_noautochrpath}"} | xargs -r file | \
        awk '/ELF.*(executable|shared object)/ {print $1}' | cut -d: -f1 | \
 while read file ; do \
        rpath= ; \
@@ -272,7 +309,7 @@ while read file ; do \
        for dir in `chrpath -l "$file" | \
                    awk '/RPATH=/ { gsub(/.*RPATH=/,""); gsub(/:/," "); print $0 }'` ; do \
                        case $dir in \
-                       /home/* | /tmp/* | /usr/lib | /lib | /usr/local/lib | /usr/X11R6/lib ) \
+                       /home/* | /tmp/* | /usr/lib | /usr/lib64 | /lib | /lib64 | /usr/local/lib | /usr/local/lib64 | /usr/X11R6/lib | /usr/X11R6/lib64 ) \
                                echo "remove-rpath: $dir in $file"; \
                                ;; \
                        * ) \
@@ -283,7 +320,8 @@ while read file ; do \
        done ; \
        if [ "$rpath" = "" ] ; then chrpath -d "$file" > /dev/null ; \
        else chrpath -r "$rpath" "$file" > /dev/null ; fi ; \
-done; fi; } \
+done; \
+fi; } \
 } }
 #-----------------------------------------------------------------
 # Find and gzip all kernel modules
@@ -293,14 +331,16 @@ done; fi; } \
 #%no_install_post_compress_modules  1
 %__spec_install_post_compress_modules { \
 %{!?no_install_post_compress_modules: \
-echo "Compress kernel modules if any."; \
     %{?verbose:set -x;} \
+    if [ -d "$RPM_BUILD_ROOT" ]; then \
+echo "Compress kernel modules if any."; \
     if test -d $RPM_BUILD_ROOT/lib/modules ; then \
-       find $RPM_BUILD_ROOT/lib/modules -name \*.o -type f -print | \
+       find $RPM_BUILD_ROOT/lib/modules -name \*o -type f -print | \
        xargs -r %{__gzip} -9nf; \
-          find $RPM_BUILD_ROOT/lib/modules -name \*.o -type l -printf "%p %l\n" | \
+          find $RPM_BUILD_ROOT/lib/modules -name \*o -type l -printf "%p %l\n" | \
           while read a b; do ln -sf $b.gz $a.gz; rm -f $a; done; \
     fi; \
+    fi; \
 } }
 
 %_source_payload        w9.gzdio
@@ -327,48 +367,14 @@ echo "Compress kernel modules if any."; \
 ###################################################################
 # Requires/Provides automation
 # exceptions system by Jacek Konieczny <jajcus@pld.org.pl>
-%__spec_prep_pre \
-_autoreqprov=n \
-%{?_noautoreqfiles:_autoreqprov=y}\
-%{?_noautoreq:_autoreqprov=y}\
-%{?_noautoreqdep:_autoreqprov=y}\
-%{?_noautoprovfiles:_autoreqprov=y}\
-%{?_noautoprov:_autoreqprov=y}\
-%{?_noautocompressdoc:_autoreqprov=y}\
-if [ "$_autoreqprov" = "y" ] ; then \
-    if [ -f %{_builddir}/__rpm_lock ] ; then \
-       echo "Some package using \%_noauto*  macros is already being built" >&2 \
-       echo "If it is not true delete %{_builddir}/__rpm_lock" >&2 \
-       exit 1 \
-    else \
-       rm -f %{_builddir}/__rpm_*\
-       touch %{_builddir}/__rpm_lock \
-    fi \
-fi \
-%{?_noautocompressdoc:echo '%{_noautocompressdoc}' > %{_builddir}/__rpm_noautocompressdoc}\
-%{nil}
-
-
-%__spec_clean_pre      %{___build_pre}\
-_autoreqprov=n \
-%{?_noautoreqfiles:_autoreqprov=y}\
-%{?_noautoreq:_autoreqprov=y}\
-%{?_noautoreqdep:_autoreqprov=y}\
-%{?_noautoprovfiles:_autoreqprov=y}\
-%{?_noautoprov:_autoreqprov=y}\
-%{?_noautoreqfiles:_autoreqprov=y}\
-%{?_noautocompressdoc:_autoreqprov=y}\
-if [ "$_autoreqprov" = "y" ] ; then \
-       rm -f %{_builddir}/__rpm_* \
-fi \
-%{nil}
-
-
-#%_noautoreqfiles      "%{_defaultdocdir}.*" "%{_examplesdir}.*"
-#%_noautoreq           %{nil}
-#%_noautoreqdep                %{nil}
-#%_noautoprovfiles     %{nil}
-#%_noautoprov          %{nil}
+#
+%_noautoreqfiles       %(sed -e s'/#.*//' /etc/rpm/noautoreqfiles)
+%_noautoprovfiles      %(sed -e s'/#.*//' /etc/rpm/noautoprovfiles)
+%_noautoreq            %(sed -e s'/#.*//' /etc/rpm/noautoreq)
+%_noautoreqdep         %(sed -e s'/#.*//' /etc/rpm/noautoreqdep)
+%_noautoprov           %(sed -e s'/#.*//' /etc/rpm/noautoprov)
+#%_noautocompressdoc   %{nil}
+#
 %_missing_doc_files_terminate_build    1%{nil}
 %_unpackaged_files_terminate_build     %{nil}
 # (X)emacs support
@@ -376,8 +382,10 @@ fi \
 %_emacs_lispdir %(emacs %___emacs_lispdir_helper)
 %_xemacs_lispdir %(xemacs %___emacs_lispdir_helper)
 
-%__php_provides        @RPMCONFIGDIR@/php.prov
-%__php_requires @RPMCONFIGDIR@/php.req
+%__php_provides        %{nil}
+%__php_requires %{nil}
+%__perl_provides %{nil}
+%__perl_requires %{nil}
 
 # Perl specific macro definitions.
 %perl_privlib  %(eval "`%{__perl} -V:installprivlib`"; echo $installprivlib)
@@ -395,9 +403,11 @@ fi \
 
 # directories
 %py_prefix      %(echo `python -c "import sys; print sys.prefix"`)
-%py_libdir      %{py_prefix}/lib/python%{py_ver}
+%py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
+%py_scriptdir  %{py_prefix}/share/python%{py_ver}
 %py_incdir      /usr/include/python%{py_ver}
-%py_sitedir     %{py_libdir}/site-packages
+%py_sitedir    %{py_libdir}/site-packages
+%py_sitescriptdir %{py_scriptdir}/site-packages
 %py_dyndir      %{py_libdir}/lib-dynload
 
 # pure python modules compilation
@@ -407,7 +417,7 @@ fi \
 
 # Software written in Python language require Python with main version
 # unchanged
-%pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
+%pyrequires_eq() Requires:       %1 >= 1:%py_ver %1 < 1:%(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
 
 # depmod macro
 %depmod() { \
@@ -422,3 +432,35 @@ else \
 fi; \
 }
 
+# XMMS specific macros
+%xmms_prefix                  %(xmms-config --prefix)
+%xmms_exec_prefix             %(xmms-config --exec-prefix)
+%xmms_version                 %(xmms-config --version)
+%xmms_datadir                 %(xmms-config --data-dir)
+%xmms_plugindir               %(xmms-config --plugin-dir)
+%xmms_visualization_plugindir %(xmms-config --visualization-plugin-dir)
+%xmms_input_plugindir         %(xmms-config --input-plugin-dir)
+%xmms_output_plugindir        %(xmms-config --output-plugin-dir)
+%xmms_effect_plugindir        %(xmms-config --effect-plugin-dir)
+%xmms_general_plugindir       %(xmms-config --general-plugin-dir)
+
+%_target_base_arch     %(echo %{_target_cpu} | sed 's/i.86/i386/;s/athlon/i386/;s/pentium./i386/;s/amd64/x86_64/')
+
+# user/group checking macros
+#
+# Usage:
+#      %userremove myuser
+#
+%userremove    /usr/lib/rpm/user_group.sh user del
+%groupremove   /usr/lib/rpm/user_group.sh group del
+#
+# Usage:
+#      if %usertestrm myuser; then
+#              /usr/sbin/userdel -r myuser
+# Note:
+#      use these macros only if you need to call userdel/groupdel with
+#      a non-standard option or take an extra action; otherwise use the
+#      %userremove/%groupremove macros
+#
+%usertestrm    /usr/lib/rpm/user_group.sh user testrm
+%grouptestrm   /usr/lib/rpm/user_group.sh group testrm
This page took 0.05107 seconds and 4 git commands to generate.