]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.macros
- support for configuredir in %%configure (but you don't need to use it as in %%confi...
[packages/rpm.git] / rpm.macros
index b6f613aeb2cac9266f2ca33a97c1ca875cf4bbad..4ff4b71d6290940d417e8dbfcd0ce50c6d4fcaba 100644 (file)
@@ -1,10 +1,61 @@
+# PLD rpm macros
+
+%__id          @__ID@
+%__id_u                %{__id} -u 
+%__chown_Rhf           @__CHOWN_RHF@
+%__chgrp_Rhf           @__CHGRP_RHF@
+
+%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
+%_fixgroup       true
+%_fixperms             %{__chmod} -Rf @FIXPERMS@
+%_topdir         %(echo $HOME)/rpm
+%_exec_prefix    %{_prefix}
+%_bindir         %{_exec_prefix}/bin
+%_sbindir        %{_exec_prefix}/sbin
+%_libexecdir     %{_exec_prefix}/lib
+%_datadir        %{_prefix}/share
+%_sharedstatedir /var/lib
+%_lib            lib
+%_libdir         %{_exec_prefix}/%{_lib}
+%_includedir     %{_prefix}/include
+%_oldincludedir  /usr/include
+%_sysconfdir     /etc
+%_localstatedir  /var
+%_infodir        /usr/share/info
+%_mandir         %{_prefix}/share/man
+%_defaultdocdir  %{_usr}/share/doc
 #-----------------------------------------------------------------
 # CFLAGS and LDFLAGS used to build
 
-%debugcflags   -O0 -g
+%debugcflags   -O0 -g -Wall
 %rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}
 %rpmldflags    %{!?debug:-s}
 
+# kernel compiler
+%kgcc          gcc
+%kgcc_package  gcc
+
+# Build system path macros.
+#
+%__libtoolize           libtoolize --copy --force
+%__gettextize { \
+    if ! gettextize --version | grep -q '0\.10\.' ; then \
+       if grep -qs 'AM_GNU_GETTEXT.*external' configure.{ac,in} ; then \
+           gettextize --copy --force --no-changelog; \
+       else \
+           gettextize --copy --force --no-changelog --intl; \
+       fi; \
+       if [ ! -f po/Makevars ]; then \
+           cp -f po/Makevars{.template,}; \
+       fi; \
+    else \
+       gettextize --copy --force; \
+    fi; \
+}
+%__autopoint            autopoint --force
+%__automake             automake -a -c -f --foreign
+%__autoconf             autoconf %{?debug:-Wall}
+
 #-----------------------------------------------------------------
 %configure2_13 { \
  if [ -n "$LINGUAS" ]; then unset LINGUAS; fi; \
  CFLAGS="${CFLAGS:-%rpmcflags}" ; export CFLAGS ; \
  CXXFLAGS="${CXXFLAGS:-%rpmcflags}" ; export CXXFLAGS ; \
  FFLAGS="${FFLAGS:-%rpmcflags}" ; export FFLAGS ; \
- ./configure \
+ CPPFLAGS="${CPPFLAGS:-}" ; export CPPFLAGS ; \
+ %{?__cc:CC=%{__cc} ; export CC ; } \
+ %{?__cxx:CXX=%{__cxx} ; export CXX ; } \
+ %{?configuredir:%{configuredir}}%{!?configuredir:.}/configure \
        --host=%{_target_platform} \
        --prefix=%{_prefix} \
        --exec-prefix=%{_exec_prefix} \
 }
 
 #----------------------------------------------------------------
-%configure {./configure \
+%configure { \
+       %{?configuredir:%{configuredir}}%{!?configuredir:.}/configure \
        LDFLAGS="${LDFLAGS:-%rpmldflags}" \
        CFLAGS="${CFLAGS:-%rpmcflags}" \
        CXXFLAGS="${CXXFLAGS:-%rpmcflags}" \
        FFLAGS="${FFLAGS:-%rpmcflags}" \
+       CPPFLAGS="${CPPFLAGS:-}" \
        %{?__cc:CC=%{__cc}} \
        %{?__cxx:CXX=%{__cxx}} \
        --build=%{_target_platform} \
        --infodir=%{_infodir} \
 }
 
-#------------------------------------------------------------------------------
-# The GNUconfigure macro does the following:
-#       update config.guess and config.sub.
-#       regenerate all autoconf/automake files
-#       optionally change to a directory (make the directory if requested).
-#       run configure with correct prefix, platform, and CFLAGS.
-#       optionally restore current directory.
-#
-# Based on autogen.sh from GNOME and orginal GNUconfigure
-#
-%GNUconfigure(MCs:)      \
-  %{-C:_mydir="`pwd`"; %{-M: %{__mkdir} -p %{-C*};} cd %{-C*}} \
-  dirs="`find ${_mydir} -name configure.in -print`"; export dirs; \
-    for coin in `echo ${dirs}` \
-do \
-  dr=`dirname ${coin}`; \
-if test -f ${dr}/NO-AUTO-GEN; then \
- : \
-else \
-     macrodirs=`sed -n -e 's,AM_ACLOCAL_INCLUDE(\(.*\)),\1,gp' < ${coin}`; \
-    ( cd ${dr}; \
-      aclocalinclude="${ACLOCAL_FLAGS}"; \
-      for k in ${macrodirs}; do \
-        if test -d ${k}; then \
-          aclocalinclude="${aclocalinclude} -I ${k}"; \
-        ##else \
-        ##  echo "**Warning**: No such directory \`${k}'.  Ignored." \
-        fi \
-      done \
-      if grep "^AM_GNU_GETTEXT" configure.in >/dev/null; then \
-        if grep "sed.*POTFILES" configure.in >/dev/null; then \
-          : do nothing -- we still have an old unmodified configure.in \
-        else \
-          test -r ${dr}/aclocal.m4 || touch ${dr}/aclocal.m4; \
-          echo "no" | gettextize --force --copy; \
-          test -r ${dr}/aclocal.m4 && %{__chmod} u+w ${dr}/aclocal.m4; \
-        fi \
-      fi \
-      if grep "^AM_PROG_LIBTOOL" configure.in >/dev/null; then \
-        %{__libtoolize} --force --copy; \
-      fi \
-      aclocal ${aclocalinclude}; \
-      if grep "^AM_CONFIG_HEADER" configure.in >/dev/null; then \
-        %{__autoheader}; \
-      fi \
-      echo "Running automake --gnu ${am_opt} ..."; \
-      %{__automake} --add-missing --gnu ${am_opt}; \
-      %{__autoconf}; \
-    ); \
-  fi \
-done \
-  %{-C:${_mydir}}%{!-C:.}/%{configure} \
-  %{-C:cd ${_mydir}; unset _mydir}
-
 # Location of autoconf macros
 %_aclocaldir   %(aclocal --print-ac-dir)
 
+# Location of omf files
+%_omf_dest_dir %(scrollkeeper-config --omfdir)
+
 # Location of pkgconfig files
 %_pkgconfigdir /usr/lib/pkgconfig
 
 # Location of top applink dir
-%_applnkdir      /usr/X11R6/share/applnk
+%_applnkdir    /usr/X11R6/share/applnk
+
+# Location of desktop files
+%_desktopdir   /usr/share/applications
 
 # Location pixmaps for applnk/desktop files
-%_pixmapsdir   /usr/X11R6/share/pixmaps
+%_pixmapsdir   /usr/share/pixmaps
 
 # Location of fonts directories
 %_fontsdir     /usr/share/fonts
 
+# Location of Gtk and associated libraries documentation
+%_gtkdocdir  %{_defaultdocdir}/gtk-doc/html
+
 # Current date
 %date          %(LC_ALL="C" date +"%a %b %d %Y")
 
@@ -137,6 +148,35 @@ done \
 # If non-empty "debug" macro defined, add "dbg" suffix to release number
 %_rpmfilename          %%{NAME}-%%{VERSION}-%%{RELEASE}%{?debug:dbg}.%%{ARCH}.rpm
 
+# Requires name = version-release
+%requires_releq()              %(LC_ALL="C" echo '%*' | xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}-%%{release}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
+%requires_releq_kernel_up()    %(LC_ALL="C" rpm -qf --qf 'Prereq: kernel-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
+%requires_releq_kernel_smp()   %(LC_ALL="C" rpm -qf --qf 'Prereq: kernel-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
+
+# kernel version-release handling
+%__kernel_ver    %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
+%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/version.h --queryformat "%{RELEASE}" | grep -v "is not")
+%_kernel_ver     %(echo %{__kernel_ver}%{!?_without_dist_kernel:-%{__kernel_rel}})
+%_kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
+
+# sgml macros
+%xmlcat_add()            /usr/bin/xmlcatalog --noout --add nextCatalog \"\" %1 /etc/xml/catalog
+%xmlcat_del()            /usr/bin/xmlcatalog --noout --del %1 /etc/xml/catalog
+%xmlcat_add_rewrite      /usr/bin/xmlcatalog --noout --add rewriteSystem
+%xmlcat_create()          /usr/bin/xmlcatalog --noout --create %1
+%sgmlcat_add()           /usr/bin/install-catalog --add %1 %2 > /dev/null
+%sgmlcat_del()           /usr/bin/install-catalog --remove %1 %2 > /dev/null
+%docbook_sgmlcat_fix() { for l in \
+'' \
+'  -- default decl --' \
+'DTDDECL "-//OASIS//DTD DocBook XML V%2//EN" "../../xml.dcl"' \
+'  -- hacks for opensp --' \
+'SYSTEM "file://%{_datadir}/sgml/docbook/xml-dtd-%2/docbookx.dtd" "%{_datadir}/sgml/docbook/xml-dtd-%2/docbookx.dtd"' \
+'SYSTEM "http://www.oasis-open.org/docbook/xml/%2/docbookx.dtd"                  "%{_datadir}/sgml/docbook/xml-dtd-%2/docbookx.dtd"' \
+'' \
+; do echo $l; done >> %1 \
+}
+
 #-----------------------------------------------------------------
 # find and gzip all files in %{_mandir} and %{infodir}
 #
@@ -165,28 +205,63 @@ echo "Compress man and info pages."; \
 %__spec_install_post_strip {%{!?debug: \
 %{!?no_install_post_strip: \
        %{?verbose:set -x;} \
-       echo "Strip executable binaries and shared object files."; \
+       echo "Strip executable binaries, archives and shared object files."; \
        filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`; \
        elfexelist=`echo $filelist | xargs -r file | \
                awk '/ELF.*executable/ {print $1}' | cut -d: -f1`; \
        elfsharedlist=`echo $filelist | xargs -r file | \
                awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
+       elfarchiveslist=`echo $filelist | xargs -r file | \
+               awk '/current ar archive/ {print $1}' | cut -d: -f1`; \
        if [ -n "$elfexelist" ]; then \
                strip --remove-section=.note  --remove-section=.comment $elfexelist; \
        fi; \
        if [ -n "$elfsharedlist" ]; then \
                strip --strip-unneeded --remove-section=.note  --remove-section=.comment $elfsharedlist; \
+       fi; \
+       if [ -n "$elfarchiveslist" ]; then \
+               strip --strip-debug --remove-section=.note  --remove-section=.comment $elfarchiveslist; \
        fi; } \
 } }
 
+#-----------------------------------------------------------------
+# Find and gzip all kernel modules
+#
+# Requires: find
+#
+#%no_install_post_compress_modules  1
+%__spec_install_post_compress_modules { \
+%{!?no_install_post_compress_modules: \
+echo "Compress kernel modules if any."; \
+    %{?verbose:set -x;} \
+    if test -d $RPM_BUILD_ROOT/lib/modules ; then \
+       find $RPM_BUILD_ROOT/lib/modules -name \*.o -type f -print | \
+       xargs -r %{__gzip} -9nf; \
+          find $RPM_BUILD_ROOT/lib/modules -name \*.o -type l -printf "%p %l\n" | \
+          while read a b; do ln -sf $b.gz $a.gz; rm -f $a; done; \
+    fi; \
+} }
+
 %_source_payload        w9.gzdio
 %_binary_payload        w9.bzdio
 
+#-----------------------------------------------------------------
+# Update all GConf2 schemas
+#
+# Requires: GConf2
+#
+%gconf_schema_install { umask 022; \
+    GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" \
+    /usr/bin/gconftool-2 --makefile-install-rule \
+    /etc/gconf/schemas/*.schemas > /dev/null \
+}
+
 #-----------------------------------------------------------------
 # post %install sequence:
 # - autodeps exceptions
 # - compress all man and info pages,
 # - strip all ELF executables and ELF shared objects if not %debug.
+# - compress kernel modules if any
 
 ###################################################################
 # Requires/Provides automation
@@ -198,6 +273,7 @@ _autoreqprov=n \
 %{?_noautoreqdep:_autoreqprov=y}\
 %{?_noautoprovfiles:_autoreqprov=y}\
 %{?_noautoprov:_autoreqprov=y}\
+%{?_noautocompressdoc:_autoreqprov=y}\
 if [ "$_autoreqprov" = "y" ] ; then \
     if [ -f %{_builddir}/__rpm_lock ] ; then \
        echo "Some package using \%_noauto*  macros is already being built" >&2 \
@@ -208,9 +284,10 @@ if [ "$_autoreqprov" = "y" ] ; then \
        touch %{_builddir}/__rpm_lock \
     fi \
 fi \
+%{?_noautocompressdoc:echo '%{_noautocompressdoc}' > %{_builddir}/__rpm_noautocompressdoc}\
 %{nil}
 
-%__spec_install_post \
+%__os_install_post \
 %{?_noautoreqfiles:for f in %{_noautoreqfiles} ; do echo %{?buildroot:%{buildroot}}$f >> %{_builddir}/__rpm_noautoreqfiles ; done }\
 %{?_noautoreq:for f in %{_noautoreq} ; do echo "$f" >> %{_builddir}/__rpm_noautoreq ; done }\
 %{?_noautoreqdep:for f in %{_noautoreqdep} ; do echo "$f" >> %{_builddir}/__rpm_noautoreqdep ; done }\
@@ -218,8 +295,8 @@ fi \
 %{?_noautoprov:for f in %{_noautoprov} ; do echo "$f" >> %{_builddir}/__rpm_noautoprov ; done }\
 %{__spec_install_post_strip}\
 %{__spec_install_post_compress_docs}\
+%{__spec_install_post_compress_modules}\
 %{__arch_install_post}\
-%{__os_install_post}\
 %{nil}
 
 %__spec_clean_pre      %{___build_pre}\
@@ -230,6 +307,7 @@ _autoreqprov=n \
 %{?_noautoprovfiles:_autoreqprov=y}\
 %{?_noautoprov:_autoreqprov=y}\
 %{?_noautoreqfiles:_autoreqprov=y}\
+%{?_noautocompressdoc:_autoreqprov=y}\
 if [ "$_autoreqprov" = "y" ] ; then \
        rm -f %{_builddir}/__rpm_* \
 fi \
@@ -241,3 +319,5 @@ fi \
 #%_noautoreqdep                %{nil}
 #%_noautoprovfiles     %{nil}
 #%_noautoprov          %{nil}
+%_missing_doc_files_terminate_build    1%{nil}
+%_unpackaged_files_terminate_build     %{nil}
This page took 0.040939 seconds and 4 git commands to generate.