]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.macros
- no need to set WAF_HOME
[packages/rpm.git] / rpm.macros
index 9c38eec07df6e1f043c0ac2da22a6165a4cd2a25..3dfbcc14043d5fd876fa7c1f80984036567db8a6 100644 (file)
@@ -1,5 +1,5 @@
 # $Revision$, $Date$
-# PLD rpm macros
+# PLD Linux rpm macros
 
 %epoch         0
 %x8664         x86_64 amd64 ia32e
@@ -91,6 +91,20 @@ fi; \
        %{filter_out}
 }')
 
+# rpmldflags with stripped -Wl, -- in the form flags have to be passed to 'ld'
+# but, don't use it, better use gcc as linker
+%ld_rpmldflags %(awk 'BEGIN {
+        split("%{rpmldflags}",F);
+        for (f in F) {
+                s = F[f];
+                if (s ~ /^-Wl,/) {
+                        s = substr(s,5);
+                        gsub(/,/," ",s);
+                };
+                printf(s FS);
+        };
+}')
+
 #-----------------------------------------------------------------
 %configure2_13 { \
  if [ -n "$LINGUAS" ]; then unset LINGUAS; fi; \
@@ -128,6 +142,18 @@ CXXFLAGS="%{rpmcxxflags}" \
 cmake \
 }
 
+# waf. see waf.spec
+# override __waf to add -j1 in your ~/.rpmmacros
+%__waf /usr/bin/waf
+%waf { \
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+CPP="%{__cpp}" \
+CFLAGS="%{rpmcflags}" \
+CXXFLAGS="%{rpmcxxflags}" \
+%{__waf} \
+}
+
 #----------------------------------------------------------------
 %global configure_cache 0
 %configure_cache_file  %{buildroot}.configure.cache
@@ -251,7 +277,7 @@ unset LINGUAS ||:\
 %apache_modules_api %(awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' /usr/include/apache/ap_mmn.h 2>/dev/null || echo ERROR)
 
 # kernel version-release handling
-%__kernel_ver  %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | head -n 1 | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } /^EXTRAVERSION/ { ever = $0; gsub(/EXTRAVERSION.*=/, NIL, ever); gsub(/ /, NIL, ever); } END { printf("%d.%d.%d%s", ver, plev, slev, ever); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
+%__kernel_ver  %( VER_H=%{_kernelsrcdir}/include/linux/utsrelease.h; [ -f $VER_H ] || VER_H=%{_kernelsrcdir}/include/linux/version.h; [ -f $VER_H ] && (grep UTS_RELEASE $VER_H 2>/dev/null | head -n 1 | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } /^EXTRAVERSION/ { ever = $0; gsub(/EXTRAVERSION.*=/, NIL, ever); gsub(/ /, NIL, ever); } END { printf("%d.%d.%d%s", ver, plev, slev, ever); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
 %__kernel_rel  %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h 2>/dev/null --qf "%{RELEASE}" | grep -v "is not")
 %__kernel_rpmvr        %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h 2>/dev/null --qf "%{VERSION}-%{RELEASE}" | grep -v "is not")
 %_kernel_ver   %{__kernel_ver}%{?with_dist_kernel:%(echo %{__kernel_ver} | grep -q -e - || echo -%{__kernel_rel})}
@@ -496,7 +522,7 @@ fi \
 
 # Ruby
 %ruby_archdir          %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]' 2>/dev/null || echo ERROR)
-%ruby_ridir            %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"], "system")' 2>/dev/null || echo ERROR)
+%ruby_ridir                    %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"], "system")' 2>/dev/null || echo ERROR)
 %ruby_rubylibdir       %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]' 2>/dev/null || echo ERROR)
 %ruby_sitearchdir      %(ruby -r rbconfig -e 'print Config::CONFIG["sitearchdir"]' 2>/dev/null || echo ERROR)
 %ruby_sitelibdir       %(ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]' 2>/dev/null || echo ERROR)
@@ -504,7 +530,7 @@ fi \
 %ruby_ver_requires_eq  Requires:       ruby(ver) = %ruby_version
 %ruby_mod_ver_requires_eq      Requires:       ruby-modules(ver) = %ruby_version
 
-%php_pear_dir  %{_datadir}/pear
+%php_pear_dir          /usr/share/pear
 
 # directory where php includes are installed on system.
 %__php_includedir              /usr/include/php
@@ -523,6 +549,7 @@ fi \
 # macros for public use
 # for php extensions (php-pecl)
 %requires_php_extension %{__php_api_requires modules_api php_api_version} \
+%{__php_api_requires zend_module_api} \
 %{__php_api_requires -v %php_major_version debug php_debug} \
 %{__php_api_requires -v %php_major_version thread-safety zend_zts}
 
@@ -537,14 +564,14 @@ fi \
 
 # Python specific macro definitions.
 # python main version
-%py_ver                %(python -c "import sys; print sys.version[:3]")
+%py_ver                        %(python -c "import sys; print sys.version[:3]")
 
 # directories
 %py_prefix             %(python -c "import sys; print sys.prefix")
 %py_libdir             %{py_prefix}/%{_lib}/python%{py_ver}
 %py_scriptdir  %{py_prefix}/share/python%{py_ver}
 %py_incdir             /usr/include/python%{py_ver}
-%py_sitedir    %{py_libdir}/site-packages
+%py_sitedir            %{py_libdir}/site-packages
 %py_sitescriptdir %{py_scriptdir}/site-packages
 %py_dyndir             %{py_libdir}/lib-dynload
 
@@ -654,8 +681,8 @@ fi \
 eval $CMD %2%{?3: %3} \
 %nil
 
-# useradd/groupadd macros written by glen@pld-linux.org.
-# All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
+# useradd/groupadd macros
+# Author: Elan Ruusamäe <glen@pld-linux.org>
 #
 # Usage:
 #   %useradd [-P package] [-u uid] [-d home_dir] [-s shell] [-c comment]
@@ -693,7 +720,7 @@ else \
                %{-M} \\\
                %{-G:-G %{-G*}} \\\
                %{expand:%{%{#}}} 1>&2 || exit $? \
-       [ ! -x /usr/sbin/nscd ] || /usr/sbin/nscd -i passwd \
+       [ ! -x /usr/sbin/nscd ] || /usr/sbin/nscd -i passwd || : \
 fi;
 
 # Usage:
@@ -715,13 +742,14 @@ if [ -n "`/usr/bin/getgid %{1}`" ]; then \
 else \
        echo "Adding group %{1} GID=%{-g*}." \
        /usr/sbin/groupadd -g %{-g*} -r %{1} 1>&2 || exit $? \
-       [ ! -x /usr/sbin/nscd ] || /usr/sbin/nscd -i group \
+       [ ! -x /usr/sbin/nscd ] || /usr/sbin/nscd -i group || : \
 fi;
 
-# apache_config_{install/uninstall} macros written by glen@pld-linux.org.
-# All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
+# apache_config_{install/uninstall} macros *DEPRECATED*
+# Author: Elan Ruusamäe <glen@pld-linux.org>
 #
-# You should use webapp macros instead. these are here until single piece of them is gone from specs ;)
+# You should use webapp macros instead. these are here until single piece of
+# them is gone from specs ;)
 #
 # The config is installed/removed inside trigger, this means that you can any
 # time install apache1 or apache package and the configuration file is updated.
@@ -787,6 +815,7 @@ fi \
 %{nil}
 
 # webapp macros
+# Author: Elan Ruusamäe <glen@pld-linux.org>
 #
 # The config is installed/removed inside trigger, this means that you can any
 # time install apache1/apache/lighttpd package and the configuration file is
@@ -824,7 +853,7 @@ fi \
 %{nil}
 
 # see browser-plugins.spec / template-browser-plugin.spec
-# written by glen@pld-linux.org.
+# Author: Elan Ruusamäe <glen@pld-linux.org>
 %nsplugin_install(d:f) { \
 # create link if it's first install of either of the packages \
 if [ -n "%{-f:1}" ] || ([ "$1" = "1" ] && [ "$2" = "1" ] && [ -d %{-d*} ]); then \
@@ -850,14 +879,12 @@ if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
 }
 
 # service macro.
+# Author: Elan Ruusamäe <glen@pld-linux.org>
 #
 # calls usual service restart on package %post, but skips the restart if
 # administrator has disabled automatic service restarts in either global
 # /etc/sysconfig/rpm or per service /etc/sysconfig/SERVICE file.
 #
-# written by glen@pld-linux.org.
-# All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
-#
 # Usage:
 #   %service [-q] SERVICE ACTION ["SERVICE NICE DESCRIPTION"]
 #
@@ -925,16 +952,15 @@ set_options $BASE_OPTIONS\
 run "$@"\
 EOF
 
-# pear install macros written by glen@pld-linux.org.
-# All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
+# PEAR install macros
+# Author: Elan Ruusamäe <glen@pld-linux.org>
 #
 # Usage:
 #      %%pear_package_setup [-a #] [-n FMT]
 #
-# -a #   - unpack SOURCE# instead of SOURCE0
+# -a #   - also unpack SOURCE#. for PEAR bootstrapping
 # -n FMT - create builddir with FMT, instead of default %%{_pearname}-%%{version}
-# -z     - unpack pear package and let pear use package.xml (not tarball) for install. use this for buggy packages.
-# -f     - force pear install. use with care.
+# -z     - unpack pear package and let pear use package.xml (not tarball) for install. for PEAR bootstrapping
 #
 # unpack PEAR package to %%{_builddir}/FMT. package is extracted with already
 # destination hierarchy. you should copy the tree to buildroot after
@@ -944,42 +970,57 @@ EOF
 # line endings.
 #
 # the pear install process output is recorded to install.log, you should put it
-# to %%doc for latter debug or just information.
+# to %%doc for later debug or just for information.
 #
 # additionally additional-packages.txt is produced if it was detected that the
 # package has optional dependencies. the file format is suitable of displaying
 # in %%post of a package. you should put this file to %%doc. noautocompressdoc is
 # automatically added for this file.
-#
-%pear_package_setup(a:n:zf) \
-%setup -q -c -T -n %{-n*}%{!-n:%{_pearname}-%{version}}\
-D=%{_builddir}/%{-n*}%{!-n:%{_pearname}-%{version}} \
-%{-z:tar zxf %{S:%{-a*}%{!-a:0}}; P=%{_pearname}-%{version}/package.xml; [ -f $P ] || P=package.xml} \
-pear \\\
+
+
+# records install.log and transforms PEAR names to PLD Linux rpm package names.
+%__pear_install_log \
+tee install.log \
+# make post message of optional packages \
+grep 'can optionally use' install.log | sed -e 's,package "pear/,package "php-pear-,g;s,^pear/,php-pear-,' > optional-packages.txt \
+if [ -s optional-packages.txt ]; then \
+       awk -F'"' '/use package/{print $2}' optional-packages.txt | sed -e "s,_,/,g;s,php-pear-, 'pear(,;s,$,.*)'," | tr -d '\\\n' > _noautoreq \
+else \
+       rm -f optional-packages.txt \
+fi \
+%{nil}
+
+# command invoking pear cli
+%__pear /usr/bin/pear
+
+# the main macro.
+# using this macro will append optional-packages.txt to the nocompressdoc list
+# as it's displayed to user after package install. and adding additional gzip
+# dep is just waste ;)
+%pear_package_setup(a:n:z) \
+%define srcdir %{-n*}%{!-n:%{_pearname}-%{version}} \
+%define builddir %{_builddir}/%{srcdir} \
+%setup -q -c -T -n %{srcdir} \
+%{-z:tar zxf %{S:0}; %{-a:tar zxf %{S:%{-a*}}}} \
+%{-z:_P=package2.xml; [ -f $_P ] || _P=package.xml; _N=%{srcdir}; mv $_P $_N; cd $_N} \
+%__pear \\\
+       -c pearrc \\\
        -d doc_dir=/docs \\\
        -d php_dir=%{php_pear_dir} \\\
        -d bin_dir=%{_bindir} \\\
        -d data_dir=%{php_pear_dir}/data \\\
        -d test_dir=%{php_pear_dir}/tests \\\
        install \\\
-       --installroot=${D} \\\
+       --packagingroot=%{builddir} \\\
        --offline \\\
        --nodeps \\\
        %{-f:--force} \\\
-       %{!-z:%{S:%{-a*}%{!-a:0}}}%{-z:$P} | tee install.log \
-# make post message of optional packages \
-grep 'can optionally use' install.log | sed -e 's,package "pear/,package "php-pear-,g;s,^pear/,php-pear-,' > optional-packages.txt \
-if [ -s optional-packages.txt ]; then \
-       awk -F'"' '/use package/{print $2}' optional-packages.txt | sed -e "s,_,/,g;s,php-pear-, 'pear(,;s,$,.*)'," | tr -d '\\\n' > _noautoreq \
-else \
-       rm -f optional-packages.txt \
-fi \
-rm ./%{php_pear_dir}/.{lock,filemap} \
+       %{!-z:%{S:%{-a*}%{!-a:0}}}%{-z:$_P} > .install.log || { c=$?; cat .install.log; exit $c; } \
+%{-z:cd ..} \
+cat %{-z:$_N/}.install.log | %__pear_install_log \
+\
 # undos sources \
 find . -type f -print0 | xargs -0 sed -i -e 's,\\r$,,' \
-# bug in PEAR --installroot. \
-# http://pear.php.net/bugs/bug.php?id=5448 \
-grep -rl "${D}" ./{%{_bindir},%{php_pear_dir}}/* | xargs -r sed -i -e "s,${D},," \
 %{!?_noautocompressdoc:%global _noautocompressdoc %{nil}}%{expand:%%global _noautocompressdoc %{_noautocompressdoc} optional-packages.txt} \
 %{!?_noautoprov:%global _noautoprov %{nil}}%{expand:%%global _noautoprov %{_noautoprov} 'pear(tests/.*)'} \
 %{nil}
@@ -1043,6 +1084,141 @@ for schema in %*; do \
 done \
 %{nil}
 
-%env_update [ -x /sbin/env-update ] || /sbin/env-update -u
+%env_update [ ! -x /sbin/env-update ] || /sbin/env-update -u || :
+
+
+# Build modules for kernels 2.6
+# Author: Przemyslaw Iskra <sparky@pld-linux.org>
+#
+# Usage:
+#      %build_kernel_modules -m <modules> -C <directory>
+#
+#  remember that proper Makefile is still required
+# Options:
+#  -m <modules> (required) -- comma-separated list of modules to save,
+#              without .ko extension, may be placed in subdirectory
+#  -C <directory> -- change to <directory> before doing anything
+#  -p <arg>, -P <arg> -- arguments passeed to make scripts
+#  -c -- do not execute make clean
+#  <additional arguments> -- all additional arguments will be passed to
+#              make modules
+#
+# Additional patching supported via here document. Try:
+#      %build_kernel_modules -m module <<'EOF'
+#      your patch script here
+#      EOF
+# Don't use it unless patching depends on config options.
+
+# Developer note: don't touch it unless you know how to handle '\'.
+# - \ in script expands to nothing
+# - \\\ in script expands to \
+# - \\\ inside definition expands to noting
+# - \\\\\\\ inside definition expands to \
+# - in last line \ has to touch arguments so arguments passing
+#   in new lines (using \) will be supported
+
+%build_kernel_modules(p:P:m:C:c)                                                                       \
+%{!?-m:%{error:%{0}: Required module name/list missing} exit 1}                \
+                                                                                                                                       \
+%define Opts                                                                                                           \\\\\\\
+%if "%{_target_base_arch}" != "%{_arch}"                                                       \\\
+       %if "%{_arch}" == "x86_64" && "%{_target_base_arch}" == "i386"  \\\
+       CC="%{__cc}" CPP="%{__cpp}" ARCH=%{_target_base_arch}                   \\\
+       %else                                                                                                                   \\\
+       ARCH=%{_target_base_arch} CROSS_COMPILE=%{_target_cpu}-pld-linux- \\\
+       %endif                                                                                                                  \\\
+%else                                                                                                                          \\\
+       CC="%{__cc}" CPP="%{__cpp}"                                                                             \\\
+%endif                                                                                                                         \
+%define        MakeOpts HOSTCC="%{__cc}" SYSSRC=%{_kernelsrcdir} SYSOUT=$PWD/o \\\\\\\
+               O=$PWD/o %{?with_verbose:V=1} %{Opts}                                           \
+                                                                                                                                       \
+%{?-C:cd %{-C*}}                                                                                                       \
+compile() {                                                                                                                    \
+       L="<"; [[ '%{*}' != *$L$L* ]] || PATCH_SH="set -x -e;$(cat)"    \
+       set -e -x                                                                                                               \
+                                                                                                                                       \
+for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do \
+       [ -r "%{_kernelsrcdir}/config-$cfg" ] || exit 1                                 \
+                                                                                                                                       \
+       rm -rf o                                                                                                                \
+       install -d o/include/linux                                                                              \
+       ln -sf %{_kernelsrcdir}/config-$cfg o/.config                                   \
+       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers    \
+       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h \
+                                                                                                                                       \
+       set +x                                                                                                                  \
+       [ -z "$PATCH_SH" ] || echo "$PATCH_SH" | %__spec_build_shell    \
+       set -x                                                                                                                  \
+                                                                                                                                       \
+       %if %{with dist_kernel}                                                                                 \
+               %{__make} -j1 -C %{_kernelsrcdir} prepare scripts                       \\\
+                       %{-p*} %{-P*}                                                                                   \\\
+                       %{MakeOpts}                                                                                             \
+       %else                                                                                                                   \
+               install -d o/include/config                                                                     \
+               touch o/include/config/MARKER                                                           \
+               ln -sf %{_kernelsrcdir}/scripts o/scripts                                       \
+       %endif                                                                                                                  \
+                                                                                                                                       \
+       %{!?-c:%{__make} -C %{_kernelsrcdir} clean                                              \\\
+               RCS_FIND_IGNORE="-name '*.ko' -o"                                                       \\\
+               M=$PWD %{MakeOpts}}                                                                                     \
+       %{__make} -C %{_kernelsrcdir} modules                                                   \\\
+               ${1+"$@"}                                                                                                       \\\
+               M=$PWD %{MakeOpts}                                                                                      \
+                                                                                                                                       \
+       for MODULE in {%{-m*},}; do                                                                             \
+               [ -z "${MODULE}" ] || mv ${MODULE}{,-$cfg}.ko                           \
+       done                                                                                                                    \
+done                                                                                                                           \
+%{?-C:cd -}                                                                                                                    \
+}                                                                                                                                      \
+compile %{*}\
+%{nil}
+
+
+# Install kernel modules built by %build_kernel_modules
+# Author: Przemyslaw Iskra <sparky@pld-linux.org>
+#
+# Usage:
+#      %install_kernel_modules -m <modules> -d <directory>
+#
+# Options:
+#  -m <modules> (required) -- comma-separated list of modules to install,
+#              without .ko extension, may be placed in subdirectory
+#  -d <directory> (required) -- in what subdirectory modules should be
+#              installed (eg. misc, kernel/drivers/net)
+#  -s <suffix> -- suffix to use when installing modules, useful when module
+#              with same name exists in kernel already
+#  -n <file> -- name of modprobe config file to use (without .conf extension)
+#              for definig aliases, only useful with -s
+
+%install_kernel_modules(m:d:s:n:)                                                                      \
+%{!?-m:%{error:%{0}: Required module name (-m) missing}exit 1}         \
+%{!?-d:%{error:%{0}: Required module directory missing}exit 1}         \
+%{?-n:%{!?-s:%{error:%{0}: Modprobe .conf file requires module suffix}exit 1}} \
+                                                                                                                                       \
+%define KernelD $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}                     \
+%define ModprobeD $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d/%{_kernel_ver} \
+                                                                                                                                       \
+install -d %{KernelD}{,smp}/%{-d*}                                                                     \
+%{?-s:install -d %{ModprobeD}{,smp}}                                                           \
+                                                                                                                                       \
+for MODULE in {%{-m*},}; do                                                                                    \
+       [ -n "${MODULE}" ] || continue                                                                  \
+       MNAME=${MODULE##*/}                                                                                             \
+       install ${MODULE}-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \\\
+               %{KernelD}/%{-d*}/${MNAME}%{-s:-%{-s*}}.ko                                      \
+       %{?-s:echo "alias ${MNAME} ${MNAME}-%{-s*}"                                             \\\
+               >> %{ModprobeD}/%{-n*}.conf}                                                            \
+    %if %{with smp} && %{with dist_kernel}                                                     \
+       install ${MODULE}-smp.ko                                                                                \\\
+               %{KernelD}smp/%{-d*}/${MNAME}%{-s:-%{-s*}}.ko                           \
+       %{?-s:echo "alias ${MNAME} ${MNAME}-%{-s*}"                                             \\\
+               >> %{ModprobeD}smp/%{-n*}.conf}                                                         \
+    %endif                                                                                                                     \
+done                                                                                                                           \
+%{nil}
 
-# vim:ts=4 sw=4 noet
+# vim:ts=4 sw=4 noet syn=spec
This page took 0.041783 seconds and 4 git commands to generate.