]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.macros
- try to avoid package ordering mess caused by defining RPMSENSE_PREREQ to 0
[packages/rpm.git] / rpm.macros
index dadd3d8f7bcba8dd426c6104c49d1e595440942e..1bfd19391f5f5cda5638f3d8e79aecbd7b8570e2 100644 (file)
@@ -21,8 +21,6 @@
 %debugcflags   -O0 -g -Wall
 %rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
 %rpmcxxflags   %{rpmcflags}
-# -fvisibility-inlines-hidden disabled. see gcc/PR(19664,20218) for details.
-# %rpmcxxflags %{rpmcflags} -fvisibility-inlines-hidden
 %rpmldflags    %{nil}
 # %rpmldflags  -Wl,--as-needed
 
@@ -32,8 +30,8 @@
 
 # Build system path macros.
 #
-%__autoconf                    autoconf %{?debug:-Wall}
-%__automake                    automake -a -c -f --foreign
+%__autoconf            autoconf %{?debug:-Wall}
+%__automake            automake -a -c -f --foreign
 %__autopoint           autopoint --force
 
 %__gettextize { \
@@ -88,6 +86,9 @@
 }
 
 #----------------------------------------------------------------
+%global configure_cache 0
+%configure_cache_file   %{buildroot}.configure.cache
+
 %configure {./configure \
        LDFLAGS="${LDFLAGS:-%rpmldflags}" \
        CFLAGS="${CFLAGS:-%rpmcflags}" \
@@ -96,6 +97,7 @@
        CPPFLAGS="${CPPFLAGS:-}" \
        %{?__cc:CC="%{__cc}"} \
        %{?__cxx:CXX="%{__cxx}"} \
+       --host=%{_target_platform} \
        --build=%{_target_platform} \
        --prefix=%{_prefix} \
        --exec-prefix=%{_exec_prefix} \
        --infodir=%{_infodir} \
        --x-libraries=/usr/X11R6/%{_lib} \
        %{dependencytracking} \
+       %{?configure_cache:--cache-file=%{configure_cache_file:-%{buildroot}.configure.cache}} \
 }
 
 # ------------------------------------------------------------------------
@@ -231,10 +234,10 @@ unset LINGUAS ||:\
 # Requires name = version-release
 %requires_releq()              %(LC_ALL="C" echo '%*' | xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}-%%{release}\\n' | sed -e 's/ (none):/ /' | grep -v "is not")
 
-%releq_kernel_up()             %(LC_ALL="C" rpm -qf --qf 'kernel-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | grep -vE "(is not|no such)")
-%releq_kernel_smp()            %(LC_ALL="C" rpm -qf --qf 'kernel-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | grep -vE "(is not|no such)")
-%requires_releq_kernel_up()    %(LC_ALL="C" rpm -qf --qf 'PreReq: kernel-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | grep -vE "(is not|no such)")
-%requires_releq_kernel_smp()   %(LC_ALL="C" rpm -qf --qf 'PreReq: kernel-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | grep -vE "(is not|no such)")
+%releq_kernel_up()             %(LC_ALL="C" rpm -qf --qf '%%{name}-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%releq_kernel_smp()            %(LC_ALL="C" rpm -qf --qf '%%{name}-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%requires_releq_kernel_up()    %(LC_ALL="C" rpm -qf --qf 'PreReq: %%{name}-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%requires_releq_kernel_smp()   %(LC_ALL="C" rpm -qf --qf 'PreReq: %%{name}-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
 
 %requires_eq_to() %(LC_ALL="C" rpm -q --qf 'Requires: %1 = %%{epoch}:%%{version}\\n' %2 | sed -e 's/ (none):/ /' | grep -v "is not")
 
@@ -242,8 +245,8 @@ unset LINGUAS ||:\
 
 # kernel version-release handling
 %__kernel_ver    %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | head -n 1 | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } /^EXTRAVERSION/ { ever = $0; gsub(/EXTRAVERSION.*=/, NIL, ever); gsub(/ /, NIL, ever); } END { printf("%d.%d.%d%s", ver, plev, slev, ever); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
-%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h --queryformat "%{RELEASE}" | grep -v "is not")
-%__kernel_rpmvr  %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h --queryformat "%{VERSION}-%{RELEASE}" | grep -v "is not")
+%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h 2>/dev/null --qf "%{RELEASE}" | grep -v "is not")
+%__kernel_rpmvr  %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h 2>/dev/null --qf "%{VERSION}-%{RELEASE}" | grep -v "is not")
 %_kernel_ver     %{__kernel_ver}%{?with_dist_kernel:%(echo %{__kernel_ver} | grep -q -e - || echo -%{__kernel_rel})}
 %_kernel_ver_str %(echo %{!?_without_dist_kernel:%{__kernel_rpmvr}}%{?_without_dist_kernel:%{__kernel_ver}} | sed -e 's/-/_/g')
 
@@ -388,14 +391,14 @@ fi \
 
 #-----------------------------------------------------------------
 # Update desktop MIME database
-# requries: desktop-file-utils
+# requires: desktop-file-utils
 #
-%update_desktop_database_post() {{\
+%update_desktop_database_post() {{ \
        umask 022; \
        /usr/bin/update-desktop-database; \
 }}
 
-%update_desktop_database_postun() {{\
+%update_desktop_database_postun() {{ \
 if [ $1 = 0 ]; then \
        umask 022; \
        /usr/bin/update-desktop-database; \
@@ -456,6 +459,8 @@ fi \
 %__php_requires %{nil}
 %__perl_provides %{nil}
 %__perl_requires %{nil}
+%__mono_provides %{nil}
+%__mono_requires %{nil}
 
 # Perl specific macro definitions.
 %perl_privlib  %(eval "`%{__perl} -V:installprivlib`"; echo $installprivlib)
@@ -467,6 +472,27 @@ fi \
 
 %php_pear_dir  %{_datadir}/pear
 
+# extract php/zend api versions
+%php_api_version %(awk '/#define PHP_API_VERSION/{print $3}' /usr/include/php/main/php.h)
+%zend_module_api %(awk '/#define ZEND_MODULE_API_NO/{print $3}' /usr/include/php/Zend/zend_modules.h)
+%zend_extension_api %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' /usr/include/php/Zend/zend_extensions.h)
+
+# directory where php includes are installed on system.
+%__php_includedir              /usr/include/php
+%php_api_version               %(awk '/#define PHP_API_VERSION/{print $3}' %{__php_includedir}/main/php.h 2>/dev/null || echo ERROR)
+%zend_module_api               %(awk '/#define ZEND_MODULE_API_NO/{print $3}' %{__php_includedir}/Zend/zend_modules.h 2>/dev/null || echo ERROR)
+%zend_extension_api            %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' %{__php_includedir}/Zend/zend_extensions.h 2>/dev/null || echo ERROR)
+
+# helper macro
+%__php_api_requires() Requires: php(%{expand:%1}) = %{expand:%{%{!?2:%{1}}%{?2}}}
+
+# macros for public use
+# for php extensions (php-pecl)
+%requires_php_extension %{__php_api_requires modules_api php_api_version}
+# for zend extensions
+%requires_zend_extension %{__php_api_requires zend_module_api} \
+%{__php_api_requires zend_extension_api}
+
 # Python specific macro definitions.
 # python main version
 %py_ver         %(echo `python -c "import sys; print sys.version[:3]"`)
@@ -504,8 +530,8 @@ done \
 # remove python sources, so that check-files won't complain
 # (idea by glen <at> pld-linux <dot> org)
 %py_postclean() \
-for d in %{py_sitescriptdir} %{py_sitedir}; do \
- [ ! -d "$RPM_BUILD_ROOT$d" ] || find "$RPM_BUILD_ROOT$d" -name '*.py' -exec rm {} \; ;\
+for d in %{py_sitescriptdir} %{py_sitedir} %*; do \
+ [ ! -d "$RPM_BUILD_ROOT$d" ] || find "$RPM_BUILD_ROOT$d" -name '*.py' -print0 | xargs -0r -l512 rm;\
 done \
 %{nil}
 
@@ -524,20 +550,20 @@ fi; \
 }
 
 # XMMS specific macros
-%xmms_prefix                  %(xmms-config --prefix)
-%xmms_exec_prefix             %(xmms-config --exec-prefix)
-%xmms_version                 %(xmms-config --version)
-%xmms_datadir                 %(xmms-config --data-dir)
-%xmms_plugindir               %(xmms-config --plugin-dir)
-%xmms_visualization_plugindir %(xmms-config --visualization-plugin-dir)
-%xmms_input_plugindir         %(xmms-config --input-plugin-dir)
-%xmms_output_plugindir        %(xmms-config --output-plugin-dir)
-%xmms_effect_plugindir        %(xmms-config --effect-plugin-dir)
-%xmms_general_plugindir       %(xmms-config --general-plugin-dir)
+%xmms_prefix                  %(xmms-config --prefix 2>/dev/null)
+%xmms_exec_prefix             %(xmms-config --exec-prefix 2>/dev/null)
+%xmms_version                 %(xmms-config --version 2>/dev/null)
+%xmms_datadir                 %(xmms-config --data-dir 2>/dev/null)
+%xmms_plugindir               %(xmms-config --plugin-dir 2>/dev/null)
+%xmms_visualization_plugindir %(xmms-config --visualization-plugin-dir 2>/dev/null)
+%xmms_input_plugindir         %(xmms-config --input-plugin-dir 2>/dev/null)
+%xmms_output_plugindir        %(xmms-config --output-plugin-dir 2>/dev/null)
+%xmms_effect_plugindir        %(xmms-config --effect-plugin-dir 2>/dev/null)
+%xmms_general_plugindir       %(xmms-config --general-plugin-dir 2>/dev/null)
 
 %_target_base_arch     %(echo %{_target_cpu} | sed 's/i.86/i386/;s/athlon/i386/;s/pentium./i386/;s/amd64/x86_64/;s/ia32e/x86_64/')
 
-%x8664                 "x86_64 amd64 ia32e"
+%x8664                 x86_64 amd64 ia32e
 
 # user/group checking macros
 #
@@ -586,7 +612,7 @@ if [ -x /usr/bin/banner.sh ]; then \
 else \
        CMD="cat%{-e: >&2}" \
 fi \
-$CMD %2%{?3: %3} \
+eval $CMD %2%{?3: %3} \
 %nil
 
 # useradd/groupadd macros written by glen@pld-linux.org.
@@ -648,3 +674,127 @@ else \
        echo "Adding group %{1} GID=%{-g*}." \
        /usr/sbin/groupadd -g %{-g*} -r %{1} 1>&2 \
 fi;
+
+# apache_config_{install/uninstall} macros written by glen@pld-linux.org.
+# All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
+#
+# The config is installed/removed inside trigger, this means that you can any
+# time install apache1 or apache package and the configuration file is updated.
+# if you don't need the config for various reason for specific apache, just
+# remove the symlink from apache config directory. the trigger will not put the
+# config again to that version of apache. In other words the config is linked
+# to apache config directory on first install of PACKAGE or apache.
+#
+# should be called in trigger body:
+#  %triggerin -- apache1 >= 1.3.33-2
+#  %apache_config_install -v 1
+#
+# Add package's apache config to apache config.
+#
+# Usage:
+#   %apache_config_install -v {1|2} -c %{_sysconfdir}/apache-%{name}.conf -n 99
+#
+#  -v REQUIRED: specify apache version. can be 1 or 2.
+#  -c OPTIONAL: specify full path to PACKAGE's config. Defaults to %{_sysconfdir}/apache-%{name}.conf.
+#  -n OPTIONAL: specify config "slot". defaults to 99
+#
+# Internal macros. don't use ;).
+# expands apache config dir by apache version at build time.
+%__apache_confdir() %(if [ %{1} = 1 ]; then echo /etc/apache/conf.d; elif [ %{1} = 2 ]; then echo /etc/httpd/httpd.conf; else echo >&2 Unknown apache version specified; fi)
+# expands apache service name by apache version at build time.
+%__apache_svcname() %(if [ %{1} = 1 ]; then echo apache; elif [ %{1} = 2 ]; then echo httpd; else echo >&2 Unknown apache version specified; fi)
+
+%apache_config_install(v:c:n:) \
+%{!-v:%{error:apache_config_install: Required argument -v missing}} \
+%{?debug:set -x; echo "apache_config_install:%{-v*} %{name}-%{version}-%{release} 1:[$1]; 2:[$2]"} \
+if [ "$1" = "1" ] && [ "$2" = "1" ] && [ -d %{__apache_confdir %{-v*}} ]; then\
+       ln -sf %{-c*}%{!-c:%{_sysconfdir}/apache-%{name}.conf} %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf\
+fi\
+# reload apache if the config symlink is there\
+if [ -L %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf ]; then\
+       # additionally don't reload if target package (the webserver) is upgraded, as webserver is restarted anyway in %post \
+       if [ "$2" != "2" ] && [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then\
+               /etc/rc.d/init.d/%{__apache_svcname %{-v*}} reload 1>&2\
+       fi\
+fi\
+%{nil}
+
+# Remove package's apache config from apache config.
+#
+# Usage:
+#   %apache_config_uninstall -v {1|2} -n 99
+#
+#  -v REQUIRED: specify apache version. can be 1 or 2.
+#  -n OPTIONAL: specify config "slot". defaults to 99
+%apache_config_uninstall(v:n:) \
+%{!-v:%{error:apache_config_uninstall: Required argument -v missing}} \
+%{?debug:set -x; echo "apache_config_uninstall:%{-v*} %{name}-%{version}-%{release}: 1:[$1]; 2:[$2]"} \
+# remove link if either of the packages are gone \
+if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
+       if [ -L %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf ]; then \
+               rm -f %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf \
+               if [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then \
+                       /etc/rc.d/init.d/%{__apache_svcname %{-v*}} reload 1>&2 \
+               fi \
+       fi \
+fi \
+%{nil}
+
+# see browser-plugins.spec / template-browser-plugin.spec
+# written by glen@pld-linux.org.
+%nsplugin_install(d:f) { \
+# create link if it's first install of either of the packages \
+if [ -n "%{-f:1}" ] || ([ "$1" = "1" ] && [ "$2" = "1" ] && [ -d %{-d*} ]); then \
+( \
+%( \
+       for file in %{*}; do \
+               echo echo Installing $file to %{-d*}; \
+               echo "ln -sf %{_libdir}/browser-plugins/$file %{-d*};"; \
+       done ) \
+) | ( %banner -t 5 -e %{name}-in ); fi; \
+}
+
+%nsplugin_uninstall(d:) { \
+# remove link if either of the packages are gone \
+if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
+( \
+%( \
+       for file in %{*}; do \
+               echo echo Removing $file from %{-d*}; \
+               echo "rm -f %{-d*}/$file;"; \
+       done ) \
+) | ( %banner -t 5 -e %{name}-un ); fi; \
+}
+
+# service macro.
+#
+# calls usual service restart on package %post, but skips the restart if
+# administrator has disabled automatic service restarts in either global
+# /etc/sysconfig/rpm or per service /etc/sysconfig/SERVICE file.
+#
+# written by glen@pld-linux.org.
+# All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
+#
+# Usage:
+#   %service [-q] SERVICE ACTION
+#
+#  -q be silent when service isn't started (for postun scriplets)
+#
+%service(q) {{ \
+# we use function, not to globber namespace with useless variables \
+skip_auto_restart() { \
+       . /etc/sysconfig/rpm; # global setting \
+       [ -f /etc/sysconfig/%1 ] && . /etc/sysconfig/%1; # per service setting \
+       echo ${RPM_SKIP_AUTO_RESTART:-no}; \
+}; \
+if [ -f /var/lock/subsys/%1 ]; then \
+       if [ $(skip_auto_restart) = no ]; then \
+               /etc/rc.d/init.d/%1 %2 1>&2; \
+       else \
+               echo 'Run "/etc/rc.d/init.d/%1 %2" to %2 %1 service.'; \
+       fi \
+else \
+       %{!-q:echo 'Run "/etc/rc.d/init.d/%1 start" to start %1 service.';} \
+       %{-q::;} \
+fi }; }
+
This page took 0.050418 seconds and 4 git commands to generate.