]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.macros
- try to avoid package ordering mess caused by defining RPMSENSE_PREREQ to 0
[packages/rpm.git] / rpm.macros
index 3b374576203404f6faa237dc6349ffa429692bee..1bfd19391f5f5cda5638f3d8e79aecbd7b8570e2 100644 (file)
@@ -20,7 +20,7 @@
 
 %debugcflags   -O0 -g -Wall
 %rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
-%rpmcxxflags   %{rpmcflags} -fvisibility-inlines-hidden
+%rpmcxxflags   %{rpmcflags}
 %rpmldflags    %{nil}
 # %rpmldflags  -Wl,--as-needed
 
@@ -97,6 +97,7 @@
        CPPFLAGS="${CPPFLAGS:-}" \
        %{?__cc:CC="%{__cc}"} \
        %{?__cxx:CXX="%{__cxx}"} \
+       --host=%{_target_platform} \
        --build=%{_target_platform} \
        --prefix=%{_prefix} \
        --exec-prefix=%{_exec_prefix} \
@@ -390,7 +391,7 @@ fi \
 
 #-----------------------------------------------------------------
 # Update desktop MIME database
-# requries: desktop-file-utils
+# requires: desktop-file-utils
 #
 %update_desktop_database_post() {{ \
        umask 022; \
@@ -458,6 +459,8 @@ fi \
 %__php_requires %{nil}
 %__perl_provides %{nil}
 %__perl_requires %{nil}
+%__mono_provides %{nil}
+%__mono_requires %{nil}
 
 # Perl specific macro definitions.
 %perl_privlib  %(eval "`%{__perl} -V:installprivlib`"; echo $installprivlib)
@@ -469,6 +472,27 @@ fi \
 
 %php_pear_dir  %{_datadir}/pear
 
+# extract php/zend api versions
+%php_api_version %(awk '/#define PHP_API_VERSION/{print $3}' /usr/include/php/main/php.h)
+%zend_module_api %(awk '/#define ZEND_MODULE_API_NO/{print $3}' /usr/include/php/Zend/zend_modules.h)
+%zend_extension_api %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' /usr/include/php/Zend/zend_extensions.h)
+
+# directory where php includes are installed on system.
+%__php_includedir              /usr/include/php
+%php_api_version               %(awk '/#define PHP_API_VERSION/{print $3}' %{__php_includedir}/main/php.h 2>/dev/null || echo ERROR)
+%zend_module_api               %(awk '/#define ZEND_MODULE_API_NO/{print $3}' %{__php_includedir}/Zend/zend_modules.h 2>/dev/null || echo ERROR)
+%zend_extension_api            %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' %{__php_includedir}/Zend/zend_extensions.h 2>/dev/null || echo ERROR)
+
+# helper macro
+%__php_api_requires() Requires: php(%{expand:%1}) = %{expand:%{%{!?2:%{1}}%{?2}}}
+
+# macros for public use
+# for php extensions (php-pecl)
+%requires_php_extension %{__php_api_requires modules_api php_api_version}
+# for zend extensions
+%requires_zend_extension %{__php_api_requires zend_module_api} \
+%{__php_api_requires zend_extension_api}
+
 # Python specific macro definitions.
 # python main version
 %py_ver         %(echo `python -c "import sys; print sys.version[:3]"`)
@@ -506,7 +530,7 @@ done \
 # remove python sources, so that check-files won't complain
 # (idea by glen <at> pld-linux <dot> org)
 %py_postclean() \
-for d in %{py_sitescriptdir} %{py_sitedir}; do \
+for d in %{py_sitescriptdir} %{py_sitedir} %*; do \
  [ ! -d "$RPM_BUILD_ROOT$d" ] || find "$RPM_BUILD_ROOT$d" -name '*.py' -print0 | xargs -0r -l512 rm;\
 done \
 %{nil}
@@ -526,16 +550,16 @@ fi; \
 }
 
 # XMMS specific macros
-%xmms_prefix                  %(xmms-config --prefix)
-%xmms_exec_prefix             %(xmms-config --exec-prefix)
-%xmms_version                 %(xmms-config --version)
-%xmms_datadir                 %(xmms-config --data-dir)
-%xmms_plugindir               %(xmms-config --plugin-dir)
-%xmms_visualization_plugindir %(xmms-config --visualization-plugin-dir)
-%xmms_input_plugindir         %(xmms-config --input-plugin-dir)
-%xmms_output_plugindir        %(xmms-config --output-plugin-dir)
-%xmms_effect_plugindir        %(xmms-config --effect-plugin-dir)
-%xmms_general_plugindir       %(xmms-config --general-plugin-dir)
+%xmms_prefix                  %(xmms-config --prefix 2>/dev/null)
+%xmms_exec_prefix             %(xmms-config --exec-prefix 2>/dev/null)
+%xmms_version                 %(xmms-config --version 2>/dev/null)
+%xmms_datadir                 %(xmms-config --data-dir 2>/dev/null)
+%xmms_plugindir               %(xmms-config --plugin-dir 2>/dev/null)
+%xmms_visualization_plugindir %(xmms-config --visualization-plugin-dir 2>/dev/null)
+%xmms_input_plugindir         %(xmms-config --input-plugin-dir 2>/dev/null)
+%xmms_output_plugindir        %(xmms-config --output-plugin-dir 2>/dev/null)
+%xmms_effect_plugindir        %(xmms-config --effect-plugin-dir 2>/dev/null)
+%xmms_general_plugindir       %(xmms-config --general-plugin-dir 2>/dev/null)
 
 %_target_base_arch     %(echo %{_target_cpu} | sed 's/i.86/i386/;s/athlon/i386/;s/pentium./i386/;s/amd64/x86_64/;s/ia32e/x86_64/')
 
@@ -588,7 +612,7 @@ if [ -x /usr/bin/banner.sh ]; then \
 else \
        CMD="cat%{-e: >&2}" \
 fi \
-$CMD %2%{?3: %3} \
+eval $CMD %2%{?3: %3} \
 %nil
 
 # useradd/groupadd macros written by glen@pld-linux.org.
@@ -686,10 +710,11 @@ fi;
 if [ "$1" = "1" ] && [ "$2" = "1" ] && [ -d %{__apache_confdir %{-v*}} ]; then\
        ln -sf %{-c*}%{!-c:%{_sysconfdir}/apache-%{name}.conf} %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf\
 fi\
-# restart apache if the config symlink is there\
-if [ -L /etc/apache/conf.d/%{-n*}%{!-n:99}_%{name}.conf ]; then\
-       if [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then\
-               /etc/rc.d/init.d/%{__apache_svcname %{-v*}} restart 1>&2\
+# reload apache if the config symlink is there\
+if [ -L %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf ]; then\
+       # additionally don't reload if target package (the webserver) is upgraded, as webserver is restarted anyway in %post \
+       if [ "$2" != "2" ] && [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then\
+               /etc/rc.d/init.d/%{__apache_svcname %{-v*}} reload 1>&2\
        fi\
 fi\
 %{nil}
@@ -704,14 +729,72 @@ fi\
 %apache_config_uninstall(v:n:) \
 %{!-v:%{error:apache_config_uninstall: Required argument -v missing}} \
 %{?debug:set -x; echo "apache_config_uninstall:%{-v*} %{name}-%{version}-%{release}: 1:[$1]; 2:[$2]"} \
-# remove link if eighter of the packages are gone \
+# remove link if either of the packages are gone \
 if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
        if [ -L %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf ]; then \
                rm -f %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf \
                if [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then \
-                       /etc/rc.d/init.d/%{__apache_svcname %{-v*}} restart 1>&2 \
+                       /etc/rc.d/init.d/%{__apache_svcname %{-v*}} reload 1>&2 \
                fi \
        fi \
 fi \
 %{nil}
 
+# see browser-plugins.spec / template-browser-plugin.spec
+# written by glen@pld-linux.org.
+%nsplugin_install(d:f) { \
+# create link if it's first install of either of the packages \
+if [ -n "%{-f:1}" ] || ([ "$1" = "1" ] && [ "$2" = "1" ] && [ -d %{-d*} ]); then \
+( \
+%( \
+       for file in %{*}; do \
+               echo echo Installing $file to %{-d*}; \
+               echo "ln -sf %{_libdir}/browser-plugins/$file %{-d*};"; \
+       done ) \
+) | ( %banner -t 5 -e %{name}-in ); fi; \
+}
+
+%nsplugin_uninstall(d:) { \
+# remove link if either of the packages are gone \
+if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
+( \
+%( \
+       for file in %{*}; do \
+               echo echo Removing $file from %{-d*}; \
+               echo "rm -f %{-d*}/$file;"; \
+       done ) \
+) | ( %banner -t 5 -e %{name}-un ); fi; \
+}
+
+# service macro.
+#
+# calls usual service restart on package %post, but skips the restart if
+# administrator has disabled automatic service restarts in either global
+# /etc/sysconfig/rpm or per service /etc/sysconfig/SERVICE file.
+#
+# written by glen@pld-linux.org.
+# All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
+#
+# Usage:
+#   %service [-q] SERVICE ACTION
+#
+#  -q be silent when service isn't started (for postun scriplets)
+#
+%service(q) {{ \
+# we use function, not to globber namespace with useless variables \
+skip_auto_restart() { \
+       . /etc/sysconfig/rpm; # global setting \
+       [ -f /etc/sysconfig/%1 ] && . /etc/sysconfig/%1; # per service setting \
+       echo ${RPM_SKIP_AUTO_RESTART:-no}; \
+}; \
+if [ -f /var/lock/subsys/%1 ]; then \
+       if [ $(skip_auto_restart) = no ]; then \
+               /etc/rc.d/init.d/%1 %2 1>&2; \
+       else \
+               echo 'Run "/etc/rc.d/init.d/%1 %2" to %2 %1 service.'; \
+       fi \
+else \
+       %{!-q:echo 'Run "/etc/rc.d/init.d/%1 start" to start %1 service.';} \
+       %{-q::;} \
+fi }; }
+
This page took 0.038502 seconds and 4 git commands to generate.