]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.macros
- introduced _autostrip* as a general solution to adjust stripping options without...
[packages/rpm.git] / rpm.macros
index fce9a6628b57a5c7c8ba3fa9d26d98508813bb9d..1911af6f68fda777ff64dceb34a7226af80408d0 100644 (file)
@@ -15,7 +15,6 @@
 %__autopoint           autopoint --force
 
 %__gettextize { \
-if ! gettextize --version | grep -q '0\.10\.' ; then \
        if grep -qs 'AM_GNU_GETTEXT.*external' configure.{ac,in} ; then \
                gettextize --copy --force --no-changelog; \
        else \
@@ -24,9 +23,6 @@ if ! gettextize --version | grep -q '0\.10\.' ; then \
        if [ ! -f po/Makevars ]; then \
                cp -f po/Makevars{.template,}; \
        fi; \
-else \
-       gettextize --copy --force; \
-fi; \
 }
 
 %__glib_gettextize     glib-gettextize --copy --force
@@ -51,6 +47,9 @@ fi; \
 #      and that both p and q are package names (i.e. no version/release).
 %_dependency_whiteout  %{nil}
 
+%_smp_mflags %([ -z "$RPM_BUILD_NCPUS" ] \\\
+       && RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"; \\\
+       [ "$RPM_BUILD_NCPUS" -gt 1 ] && echo "-j$RPM_BUILD_NCPUS")
 
 #-----------------------------------------------------------------
 #
@@ -113,6 +112,7 @@ fi; \
  CFLAGS="${CFLAGS:-%rpmcflags}" ; export CFLAGS ; \
  CXXFLAGS="${CXXFLAGS:-%rpmcxxflags}" ; export CXXFLAGS ; \
  FFLAGS="${FFLAGS:-%rpmcflags}" ; export FFLAGS ; \
+ FCFLAGS="${FCFLAGS:-%rpmcflags}" ; export FCFLAGS ; \
  CPPFLAGS="${CPPFLAGS:-}" ; export CPPFLAGS ; \
  %{?__cc:CC="%{__cc}" ; export CC ; } \
  %{?__cxx:CXX="%{__cxx}" ; export CXX ; } \
@@ -146,10 +146,18 @@ CXXFLAGS="%{rpmcxxflags}" \
 }
 
 # override __scons to add -j4 in your ~/.rpmmacros for parallel make
-# TODO: find way to pass CC/CXX and CC/CXXFLAGS
 %__scons       /usr/bin/scons
 %scons { \
 %{__scons} \
+       LDFLAGS="${LDFLAGS:-%rpmldflags}" \
+       CFLAGS="${CFLAGS:-%rpmcflags}" \
+       CXXFLAGS="${CXXFLAGS:-%rpmcxxflags}" \
+       FFLAGS="${FFLAGS:-%rpmcflags}" \
+       CPPFLAGS="${CPPFLAGS:-}" \
+       %{?__cc:CC="%{__cc}"} \
+       %{?__cxx:CXX="%{__cxx}"} \
+       libsuffix=%{_lib} \
+       prefix=%{_prefix} \
 }
 
 # waf. see waf.spec
@@ -173,6 +181,7 @@ CXXFLAGS="%{rpmcxxflags}" \
        CFLAGS="${CFLAGS:-%rpmcflags}" \
        CXXFLAGS="${CXXFLAGS:-%rpmcxxflags}" \
        FFLAGS="${FFLAGS:-%rpmcflags}" \
+       FCFLAGS="${FCFLAGS:-%rpmcflags}" \
        CPPFLAGS="${CPPFLAGS:-}" \
        %{?__cc:CC="%{__cc}"} \
        %{?__cxx:CXX="%{__cxx}"} \
@@ -282,8 +291,12 @@ unset DISPLAY ||:\
 # Requires name = version-release
 %requires_releq()              %(echo '%*' | LC_ALL="C" xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}-%%{release}\\n' | sed -e 's/ (none):/ /' | grep -v "is not")
 
-%releq_kernel()                %((LC_ALL="C" rpm -qf --qf '%%{name} = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h 2>/dev/null || echo ERROR) | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
-%requires_releq_kernel(s:)     Requires%{-s:(%{-s*})}: %releq_kernel
+%releq_kernel()                        %((LC_ALL="C" rpm -qf --qf '%%{name} = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h 2>/dev/null || echo ERROR) | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%releq_kernel_up()             %((LC_ALL="C" rpm -qf --qf '%%{name}-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h 2>/dev/null || echo ERROR) | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%releq_kernel_smp()            %((LC_ALL="C" rpm -qf --qf '%%{name}-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h 2>/dev/null || echo ERROR) | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%requires_releq_kernel(s:)             Requires%{-s:(%{-s*})}: %releq_kernel
+%requires_releq_kernel_up(s:)  Requires%{-s:(%{-s*})}: %releq_kernel_up
+%requires_releq_kernel_smp(s:) Requires%{-s:(%{-s*})}: %releq_kernel_smp
 
 %requires_eq()         %(echo '%*' | LC_ALL="C" xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
 %requires_eq_to() %(LC_ALL="C" rpm -q --qf 'Requires: %1 = %%{epoch}:%%{version}\\n' %2 | sed -e 's/ (none):/ /' | grep -v "is not")
@@ -333,14 +346,26 @@ unset DISPLAY ||:\
 #%no_install_post_compress_docs        1
 %__spec_install_post_compress_docs { \
 %{!?no_install_post_compress_docs:__spec_install_post_compress_docs() { \
-       for i in /usr/share/man /usr/X11R6/man /usr/share/info; do \
+       for i in /usr/share/man /usr/X11R6/man; do \
                if [ -d "$RPM_BUILD_ROOT$i" ]; then \
-                       echo "Compress $(basename $i) pages: $i"; \
+                       echo "Compress man pages: $i"; \
                        find "$RPM_BUILD_ROOT$i" -name '*.bz2' -print | xargs -r %{__bzip2} -df; \
                        find "$RPM_BUILD_ROOT$i" -name '*.gz' -print | xargs -r %{__gzip} -dnf; \
+                       find $RPM_BUILD_ROOT$i -type l | while read a; do \
+                               m=$(readlink $a); \
+                               rm -f $a; \
+                               echo .so ${m##*/} > $a; \
+                               echo >&2 "Converted ${a#$RPM_BUILD_ROOT} from symlink to man link: ${m##*/}"; \
+                       done; \
                        find "$RPM_BUILD_ROOT$i" -type f -size +%{_min_compress_bytes}c -print | xargs -r %{__gzip} -9nf; \
                fi; \
        done; \
+       if [ -d "$RPM_BUILD_ROOT%{_infodir}" ]; then \
+               echo "Compress info pages: %{_infodir}"; \
+               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.bz2' -print | xargs -r %{__bzip2} -df; \
+               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.gz' -print | xargs -r %{__gzip} -dnf; \
+               find "$RPM_BUILD_ROOT%{_infodir}" -name '*.info*' -type f -size +%{_min_compress_bytes}c -print | xargs -r %{__gzip} -9nf; \
+       fi; \
 }; __spec_install_post_compress_docs } }
 
 #-----------------------------------------------------------------
@@ -354,36 +379,58 @@ unset DISPLAY ||:\
 if [ -d "$RPM_BUILD_ROOT" ]; then \
        if [ -d $RPM_BUILD_ROOT/lib/modules ]; then \
                modulelist=$(find $RPM_BUILD_ROOT/lib/modules -name '*o' -type f -print); \
-               printf "Stripping %d kernel modules..." $(echo "$modulelist" | wc -l); \
-               echo "$modulelist" | xargs -l512 chmod u+w; \
-               echo "$modulelist" | xargs -l512 %{__strip} --strip-unneeded --remove-section=.comment --remove-section=.note.GNU-stack; \
-               echo "DONE"; \
+               modulecount=$(echo -n "$modulelist" | wc -l); \
+               if [ "$modulecount" -gt 0 ]; then \
+                       printf "Stripping %d kernel modules..."; \
+                       echo "$modulelist" | xargs -l512 chmod u+w; \
+                       echo "$modulelist" | xargs -l512 %{__strip} --strip-unneeded --remove-section=.comment --remove-section=.note.GNU-stack; \
+                       echo "DONE"; \
+               fi; \
        fi; \
-       filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" ! -regex ".*/usr/lib[0-9]*/debug/.*\.debug" ! -regex ".*%{_docdir}/.*" ! -regex ".*%{_includedir}/.*" %{?_noautostrip:! -regex "%{_noautostrip}"}`; \
-       # vim - " \
-       if [ -z "$filelist" ]; then \
-               return; \
+       filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*/usr/lib[0-9]*/debug/.*\.debug" ! -regex ".*%{_docdir}/.*" ! -regex ".*%{_includedir}/.*" %{?_noautostrip:! -regex "%{_noautostrip}"} %{?_autostripall:! -regex "%{_autostripall}"} %{?_autostripunneeded:! -regex "%{_autostripunneeded}"} %{?_autostripdebug:! -regex "%{_autostripdebug}"}`; \
+       if [ -n "$filelist" ]; then \
+               filetypes=`echo "$filelist" | xargs -r -d'\\n' file`; \
+               elfexelist=`echo "$filetypes" | awk -F: '/ELF.*executable/ {print $1}'`; \
+               elfsharedlist=`echo "$filetypes" | awk -F: '/LF.*shared object/ {print $1}'`; \
+               archiveslist=`echo "$filetypes" | awk -F '/current ar archive/ {print $1}'`; \
+               if [ -n "$elfexelist" ]; then \
+                       printf "Stripping %d ELF executables..." $(echo "$elfexelist" | wc -l); \
+                       chmod u+w $elfexelist; \
+                       %{__strip} --remove-section=.note --remove-section=.comment $elfexelist; \
+                       echo "DONE"; \
+               fi; \
+               if [ -n "$elfsharedlist" ]; then \
+                       printf "Stripping %d ELF shared libraries..." $(echo "$elfsharedlist" | wc -l); \
+                       chmod u+w $elfsharedlist; \
+                       %{__strip} --strip-unneeded --remove-section=.note --remove-section=.comment $elfsharedlist; \
+                       echo "DONE"; \
+               fi; \
+               if [ -n "$archiveslist" ]; then \
+                       printf "Stripping %d ar archives..." $(echo "$elfsharedlist" | wc -l); \
+                       chmod u+w $archiveslist; \
+                       %{__strip} --strip-debug --remove-section=.note --remove-section=.comment $archiveslist; \
+                       echo "DONE"; \
+               fi; \
        fi; \
-       filetypes=`echo "$filelist" | xargs -r -d'\\n' file`; \
-       elfexelist=`echo "$filetypes" | awk -F: '/ELF.*executable/ {print $1}'`; \
-       elfsharedlist=`echo "$filetypes" | awk -F: '/LF.*shared object/ {print $1}'`; \
-       archiveslist=`echo "$filetypes" | awk -F '/current ar archive/ {print $1}'`; \
-       if [ -n "$elfexelist" ]; then \
-               printf "Stripping %d ELF executables..." $(echo "$elfexelist" | wc -l); \
+    filelist_all=%{?_autostripall:`find $RPM_BUILD_ROOT -type f -regex "%{_autostripall}"} \
+    filelist_unneeded=%{?_autostripunneeded:`find $RPM_BUILD_ROOT -type f -regex "%{_autostripunneeded}"} \
+    filelist_debug=%{?_autostripdebug:`find $RPM_BUILD_ROOT -type f -regex "%{_autostripdebug}"} \
+       if [ -n "$filelist_all" ]; then \
+               printf "Stripping everything from %d additional files..." $(echo "$filelist_all" | wc -l); \
                chmod u+w $elfexelist; \
-               %{__strip} --remove-section=.note --remove-section=.comment $elfexelist; \
+               %{__strip} --remove-section=.note --remove-section=.comment $filelist_all; \
                echo "DONE"; \
        fi; \
-       if [ -n "$elfsharedlist" ]; then \
-               printf "Stripping %d ELF shared libraries..." $(echo "$elfsharedlist" | wc -l); \
+       if [ -n "$filelist_unneeded" ]; then \
+               printf "Stripping unneeded from %d additional files..." $(echo "$filelist_unneeded" | wc -l); \
                chmod u+w $elfsharedlist; \
-               %{__strip} --strip-unneeded --remove-section=.note --remove-section=.comment $elfsharedlist; \
+               %{__strip} --strip-unneeded --remove-section=.note --remove-section=.comment $filelist_unneeded; \
                echo "DONE"; \
        fi; \
-       if [ -n "$archiveslist" ]; then \
-               printf "Stripping %d ar archives..." $(echo "$elfsharedlist" | wc -l); \
+       if [ -n "$filelist_debug" ]; then \
+               printf "Stripping debuginfo from %d additional files..." $(echo "$filelist_debug" | wc -l); \
                chmod u+w $archiveslist; \
-               %{__strip} --strip-debug --remove-section=.note --remove-section=.comment $archiveslist; \
+               %{__strip} --strip-debug --remove-section=.note --remove-section=.comment $filelist_debug; \
                echo "DONE"; \
        fi; \
 fi; }; __spec_install_post_strip } } }
@@ -474,14 +521,16 @@ fi \
 %update_desktop_database_post() {{ \
        umask 022; \
        /usr/bin/update-desktop-database -q; \
-}}
+}} \
+%{nil}
 
 %update_desktop_database_postun() {{ \
 if [ $1 = 0 ]; then \
        umask 022; \
        /usr/bin/update-desktop-database -q; \
 fi \
-}}
+}} \
+%{nil}
 
 #-----------------------------------------------------------------
 # Update shared MIME info database
@@ -490,7 +539,8 @@ fi \
 %update_mime_database() {{ \
        umask 022; \
        /usr/bin/update-mime-database %{_datadir}/mime; \
-}}
+}} \
+%{nil}
 
 #-----------------------------------------------------------------
 # Update icon cache
@@ -499,7 +549,8 @@ fi \
 %update_icon_cache() {{ \
        umask 022; \
        /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/%1; \
-}}
+}} \
+%{nil}
 
 #-----------------------------------------------------------------
 # Update scrollkeeper database
@@ -559,6 +610,8 @@ fi \
 %ruby_archdir          %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]' 2>/dev/null || echo ERROR)
 %ruby_ridir                    %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"], "system")' 2>/dev/null || echo ERROR)
 %ruby_rubylibdir       %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]' 2>/dev/null || echo ERROR)
+%ruby_vendorarchdir    %(ruby -r rbconfig -e 'print Config::CONFIG["vendorarchdir"]' 2>/dev/null || echo ERROR)
+%ruby_vendorlibdir     %(ruby -r rbconfig -e 'print Config::CONFIG["vendorlibdir"]' 2>/dev/null || echo ERROR)
 %ruby_sitearchdir      %(ruby -r rbconfig -e 'print Config::CONFIG["sitearchdir"]' 2>/dev/null || echo ERROR)
 %ruby_sitelibdir       %(ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]' 2>/dev/null || echo ERROR)
 %ruby_version          %(ruby -r rbconfig -e 'print Config::CONFIG["ruby_version"]' 2>/dev/null || echo ERROR)
@@ -568,17 +621,16 @@ fi \
 %php_pear_dir          /usr/share/pear
 %php_extensiondir      %(php-config --extension-dir 2>/dev/null || echo ERROR)
 %php_sysconfdir                %(php-config --sysconfdir 2>/dev/null || echo ERROR)
+%php_includedir                %(php-config --include-dir 2>/dev/null || echo ERROR)
 
-# directory where php includes are installed on system.
-%__php_includedir              /usr/include/php
 # extract php/zend api versions
-%php_major_version             %(awk '/#define PHP_MAJOR_VERSION/{print $3}' %{__php_includedir}/main/php_version.h 2>/dev/null || echo ERROR)
-%php_api_version               %(awk '/#define PHP_API_VERSION/{print $3}' %{__php_includedir}/main/php.h 2>/dev/null || echo ERROR)
-%php_pdo_api_version   %(awk '/#define PDO_DRIVER_API/{print $3}' %{__php_includedir}/ext/pdo/php_pdo_driver.h 2>/dev/null || echo ERROR)
-%php_debug                             %(awk '/#define ZEND_DEBUG/{print $3}' %{__php_includedir}/main/php_config.h 2>/dev/null || echo ERROR)
-%zend_module_api               %(awk '/#define ZEND_MODULE_API_NO/{print $3}' %{__php_includedir}/Zend/zend_modules.h 2>/dev/null || echo ERROR)
-%zend_extension_api            %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' %{__php_includedir}/Zend/zend_extensions.h 2>/dev/null || echo ERROR)
-%zend_zts                              %(Z=$(grep -sc '^#define ZTS 1' %{__php_includedir}/main/php_config.h); echo ${Z:-ERROR})
+%php_major_version             %(awk '/#define PHP_MAJOR_VERSION/{print $3}' %{php_includedir}/main/php_version.h 2>/dev/null || echo ERROR)
+%php_api_version               %(awk '/#define PHP_API_VERSION/{print $3}' %{php_includedir}/main/php.h 2>/dev/null || echo ERROR)
+%php_pdo_api_version   %(awk '/#define PDO_DRIVER_API/{print $3}' %{php_includedir}/ext/pdo/php_pdo_driver.h 2>/dev/null || echo ERROR)
+%php_debug                             %(awk '/#define ZEND_DEBUG/{print $3}' %{php_includedir}/main/php_config.h 2>/dev/null || echo ERROR)
+%zend_module_api               %(awk '/#define ZEND_MODULE_API_NO/{print $3}' %{php_includedir}/Zend/zend_modules.h 2>/dev/null || echo ERROR)
+%zend_extension_api            %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' %{php_includedir}/Zend/zend_extensions.h 2>/dev/null || echo ERROR)
+%zend_zts                              %(Z=$(grep -sc '^#define ZTS 1' %{php_includedir}/main/php_config.h); echo ${Z:-ERROR})
 
 # helper macro
 %__php_api_requires(v:) Requires: php%{-v*}(%{expand:%1}) = %{expand:%{%{!?2:%{1}}%{?2}}}
@@ -623,6 +675,25 @@ if [ -f /etc/rc.d/init.d/php-fcgi ]; then \
 fi \
 %{nil}
 
+
+# X.org helper macros
+%__xorg_abi_requires() Requires: xorg-xserver-server(%{expand:%1}-abi) = %{expand:%{%{!?2:%{1}}%{?2}}}
+#
+%xorg_xserver_ansic_abi                %(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' /usr/include/xorg/xf86Module.h 2> /dev/null || echo ERROR)
+%xorg_xserver_extension_abi    %(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' /usr/include/xorg/xf86Module.h 2> /dev/null || echo ERROR)
+%xorg_xserver_font_abi         %(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' /usr/include/xorg/xf86Module.h 2> /dev/null | echo ERROR)
+%xorg_xserver_videodrv_abi     %(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' /usr/include/xorg/xf86Module.h 2> /dev/null || echo ERROR)
+%xorg_xserver_xinput_abi       %(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' /usr/include/xorg/xf86Module.h 2> /dev/null || echo ERROR)
+
+%requires_xorg_xserver_extension %{__xorg_abi_requires ansic xorg_xserver_ansic_abi} \
+%{__xorg_abi_requires extension xorg_xserver_extension_abi}
+%requires_xorg_xserver_xinput %{__xorg_abi_requires ansic xorg_xserver_ansic_abi} \
+%{__xorg_abi_requires xinput xorg_xserver_xinput_abi}
+%requires_xorg_xserver_font %{__xorg_abi_requires ansic xorg_xserver_ansic_abi} \
+%{__xorg_abi_requires font xorg_xserver_font_abi}
+%requires_xorg_xserver_videodrv %{__xorg_abi_requires ansic xorg_xserver_ansic_abi} \
+%{__xorg_abi_requires videodrv xorg_xserver_videodrv_abi}
+
 # Python specific macro definitions.
 # python main version
 %py_ver                        %(python -c "import sys; print sys.version[:3]")
@@ -649,7 +720,7 @@ fi \
 %__spec_install_post_py_hardlink {\
 %{!?no_install_post_py_hardlink: __spec_install_post_py_hardlink() { \
 [ ! -d "$RPM_BUILD_ROOT" ] || find "$RPM_BUILD_ROOT" -name '*.pyc' | while read a; do \
-       b="$(echo $a|sed -e 's/.pyc$/.pyo/')"; \
+       b="${a%.pyc}.pyo"; \
        if cmp -s "$a" "$b"; then \
                ln -f "$a" "$b"; \
        fi; \
@@ -806,75 +877,6 @@ else \
        [ ! -x /usr/sbin/nscd ] || /usr/sbin/nscd -i group || : \
 fi;
 
-# apache_config_{install/uninstall} macros *DEPRECATED*
-# Author: Elan Ruusamäe <glen@pld-linux.org>
-#
-# You should use webapp macros instead. these are here until single piece of
-# them is gone from specs ;)
-#
-# The config is installed/removed inside trigger, this means that you can any
-# time install apache1 or apache package and the configuration file is updated.
-# if you don't need the config for various reason for specific apache, just
-# remove the symlink from apache config directory. the trigger will not put the
-# config again to that version of apache. In other words the config is linked
-# to apache config directory on first install of PACKAGE or apache.
-#
-# should be called in trigger body:
-#  %triggerin -- apache1 >= 1.3.33-2
-#  %apache_config_install -v 1
-#
-# Add package's apache config to apache config.
-#
-# Usage:
-#   %apache_config_install -v {1|2} -c %{_sysconfdir}/apache-%{name}.conf -n 99
-#
-#  -v REQUIRED: specify apache version. can be 1 or 2.
-#  -c OPTIONAL: specify full path to PACKAGE's config. Defaults to %{_sysconfdir}/apache-%{name}.conf.
-#  -n OPTIONAL: specify config "slot". defaults to 99
-#  -f OPTIONAL: force symlink creation regardless if package was upraded. useful in triggers
-#
-# Internal macros. don't use ;).
-# expands apache config dir by apache version at build time.
-%__apache_confdir() %(if [ %{1} = 1 ]; then echo /etc/apache/conf.d; elif [ %{1} = 2 ]; then echo /etc/httpd/httpd.conf; else echo >&2 Unknown apache version specified; fi)
-# expands apache service name by apache version at build time.
-%__apache_svcname() %(if [ %{1} = 1 ]; then echo apache; elif [ %{1} = 2 ]; then echo httpd; else echo >&2 Unknown apache version specified; fi)
-
-%apache_config_install(fv:c:n:) \
-%{!-v:%{error:apache_config_install: Required argument -v missing}} \
-%{?debug:set -x; echo "apache_config_install:%{-v*} %{name}-%{version}-%{release} 1:[$1]; 2:[$2]"} \
-if [ -n "%{-f:1}" ] || ([ "$1" = "1" ] && [ "$2" = "1" ]) && [ -d %{__apache_confdir %{-v*}} ]; then\
-       ln -sf %{-c*}%{!-c:%{_sysconfdir}/apache-%{name}.conf} %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf\
-fi\
-# reload apache if the config symlink is there\
-if [ -L %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf ]; then\
-       # additionally don't reload if target package (the webserver) is upgraded, as webserver is restarted anyway in %post \
-       if [ "$2" != "2" ] && [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then\
-               /etc/rc.d/init.d/%{__apache_svcname %{-v*}} reload 1>&2\
-       fi\
-fi\
-%{nil}
-
-# Remove package's apache config from apache config.
-#
-# Usage:
-#   %apache_config_uninstall -v {1|2} -n 99
-#
-#  -v REQUIRED: specify apache version. can be 1 or 2.
-#  -n OPTIONAL: specify config "slot". defaults to 99
-%apache_config_uninstall(v:n:) \
-%{!-v:%{error:apache_config_uninstall: Required argument -v missing}} \
-%{?debug:set -x; echo "apache_config_uninstall:%{-v*} %{name}-%{version}-%{release}: 1:[$1]; 2:[$2]"} \
-# remove link if either of the packages are gone \
-if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
-       if [ -L %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf ]; then \
-               rm -f %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf \
-               if [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then \
-                       /etc/rc.d/init.d/%{__apache_svcname %{-v*}} reload 1>&2 \
-               fi \
-       fi \
-fi \
-%{nil}
-
 # webapp macros
 # Author: Elan Ruusamäe <glen@pld-linux.org>
 #
@@ -913,32 +915,6 @@ if [ -n "%{-f:1}" ] || [ "$1" = "0" ] || [ "$2" = "0" ] && [ -L /etc/%1/webapps.
 fi \
 %{nil}
 
-# see browser-plugins.spec / template-browser-plugin.spec
-# Author: Elan Ruusamäe <glen@pld-linux.org>
-%nsplugin_install(d:f) { \
-# create link if it's first install of either of the packages \
-if [ -n "%{-f:1}" ] || ([ "$1" = "1" ] && [ "$2" = "1" ] && [ -d %{-d*} ]); then \
-( \
-%( \
-       for file in %{*}; do \
-               echo echo Installing $file to %{-d*}; \
-               echo "ln -sf %{_libdir}/browser-plugins/$file %{-d*};"; \
-       done ) \
-) | ( %banner -t 5 -e %{name}-in ); fi; \
-}
-
-%nsplugin_uninstall(d:) { \
-# remove link if either of the packages are gone \
-if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
-( \
-%( \
-       for file in %{*}; do \
-               echo echo Removing $file from %{-d*}; \
-               echo "rm -f %{-d*}/$file;"; \
-       done ) \
-) | ( %banner -t 5 -e %{name}-un ); fi; \
-}
-
 # service macro.
 # Author: Elan Ruusamäe <glen@pld-linux.org>
 #
@@ -986,7 +962,6 @@ if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
 # Directory where arch-specific (JNI) version-independent jars are installed.
 %_jnidir               %{_libdir}/java
 
-
 %java_home             %([ -f %{_javadir}-utils/java-functions ] || { echo ERROR; exit 0; }; unset JAVA_HOME; . %{_javadir}-utils/java-functions; set_jvm; echo ${JAVA_HOME:-ERROR})
 
 %ant                   JAVA_HOME=%{java_home} ant
@@ -1034,6 +1009,53 @@ set_options $BASE_OPTIONS\
 run "$@"\
 EOF
 
+# jpackage 1.7
+# Directory for maven depmaps
+#
+%_mavendepmapdir /etc/maven
+%_mavendepmapfragdir /etc/maven/fragments
+
+#
+# add_to_depmap adds an entry to the depmap. The arguments are:
+#
+# %1 the original groupid
+# %2 the original artifact id
+# %3 the version
+# %4 the new groupid
+# %5 the new artifactid
+#
+
+%add_to_maven_depmap() \
+install -dm 755 $RPM_BUILD_ROOT/%{_mavendepmapfragdir}\
+cat >>$RPM_BUILD_ROOT/%{_mavendepmapfragdir}/%{name}<< EOF\
+<dependency>\
+    <maven>\
+        <groupId>%1</groupId>\
+        <artifactId>%2</artifactId>\
+        <version>%3</version>\
+    </maven>\
+    <jpp>\
+        <groupId>%4</groupId>\
+        <artifactId>%5</artifactId>\
+        <version>%3</version>\
+    </jpp>\
+</dependency>\
+\
+EOF\
+%{nil}
+
+#==============================================================================
+#
+# update_maven_depmap updates the main maven depmap
+#
+%update_maven_depmap() \
+echo -e "<dependencies>\\n" > %{_mavendepmapdir}/maven2-depmap.xml\
+if [ -d %{_mavendepmapfragdir} ] && [ -n "`find %{_mavendepmapfragdir} -type f`" ]; then\
+cat %{_mavendepmapfragdir}/* >> %{_mavendepmapdir}/maven2-depmap.xml\
+fi\
+echo -e "</dependencies>\\n" >> %{_mavendepmapdir}/maven2-depmap.xml
+
+
 # PEAR install macros
 # Author: Elan Ruusamäe <glen@pld-linux.org>
 #
@@ -1075,16 +1097,7 @@ fi \
 # command invoking pear cli
 %__pear /usr/bin/pear
 
-# The main macro.
-# using this macro will append optional-packages.txt to the nocompressdoc list
-# as it's displayed to user after package install. and adding additional gzip
-# dep is just waste ;)
-%pear_package_setup(a:n:zD) \
-%define srcdir %{-n*}%{!-n:%{_pearname}-%{version}} \
-%define builddir %{_builddir}/%{srcdir} \
-%setup -q -c -T %{-D:-D} -n %{srcdir} \
-%{-z:tar zxf %{S:0}; %{-a:tar zxf %{S:%{-a*}}}} \
-%{-z:_P=package2.xml; [ -f $_P ] || _P=package.xml; _N=%{srcdir}; mv $_P $_N; cd $_N} \
+%pear_install(a:n:zD) \
 %__pear \\\
        -c pearrc \\\
        -d doc_dir=/docs \\\
@@ -1097,7 +1110,20 @@ fi \
        --offline \\\
        --nodeps \\\
        %{-f:--force} \\\
-       %{!-z:%{S:%{-a*}%{!-a:0}}}%{-z:$_P} > .install.log || { c=$?; cat .install.log; exit $c; } \
+       %{!-z:%{S:%{-a*}%{!-a:0}}}%{-z:$_P} > .install.log || { c=$?; cat .install.log; exit $c; }; \
+%{nil}
+
+# The main macro.
+# using this macro will append optional-packages.txt to the nocompressdoc list
+# as it's displayed to user after package install. and adding additional gzip
+# dep is just waste ;)
+%pear_package_setup(a:n:zD) \
+%define srcdir %{-n*}%{!-n:%{_pearname}-%{version}} \
+%define builddir %{_builddir}/%{srcdir} \
+%setup -q -c -T %{-D:-D} -n %{srcdir} \
+%{-z:tar zxf %{S:0}; %{-a:tar zxf %{S:%{-a*}}}} \
+%{-z:_P=package2.xml; [ -f $_P ] || _P=package.xml; _N=%{srcdir}; mv $_P $_N; cd $_N} \
+%pear_install \
 %{-z:cd ..} \
 cat %{-z:$_N/}.install.log | %__pear_install_log \
 \
@@ -1218,8 +1244,9 @@ done \
 compile() {                                                                                                                    \
        L="<"; [[ '%{*}' != *$L$L* ]] || PATCH_SH="set -x -e;$(cat)"    \
        set -e -x                                                                                                               \
+       local cfgs='%{?with_dist_kernel:%{?with_smp: smp}%{?with_up: up}}%{!?with_dist_kernel: nondist}' \
                                                                                                                                        \
-for cfg in %{?with_dist_kernel:dist}%{!?with_dist_kernel:nondist}; do \
+for cfg in ${cfgs:-dist}; do                                        \
        [ -r "%{_kernelsrcdir}/config-$cfg" ] || exit 1                                 \
                                                                                                                                        \
        rm -rf o                                                                                                                \
@@ -1230,7 +1257,7 @@ for cfg in %{?with_dist_kernel:dist}%{!?with_dist_kernel:nondist}; do \
 %ifarch ppc ppc64                                                                                                      \
        install -d o/include/asm                                                                                \
        [ ! -d %{_kernelsrcdir}/include/asm-%{_target_base_arch} ] || ln -snf %{_kernelsrcdir}/include/asm-%{_target_base_arch}/* o/include/asm \
-       [ ! -d %{_kernelsrcdir}/include/asm-powerpc ] || ln -sf %{_kernelsrcdir}/include/asm-powerpc/* o/include/asm    \
+       [ ! -d %{_kernelsrcdir}/include/asm-powerpc ] || ln -snf %{_kernelsrcdir}/include/asm-powerpc/* o/include/asm \
 %else                                                                                                                          \
        ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} o/include/asm \
 %endif                                                                                                                         \
@@ -1280,7 +1307,7 @@ compile %{*}\
 #  -s <suffix> -- suffix to use when installing modules, useful when module
 #              with same name exists in kernel already
 #  -n <file> -- name of modprobe config file to use (without .conf extension)
-#              for definig aliases, only useful with -s
+#              for defining aliases, only useful with -s
 
 %install_kernel_modules(m:d:s:n:)                                                                      \
 %{!?-m:%{error:%{0}: Required module name (-m) missing}exit 1}         \
@@ -1290,23 +1317,19 @@ compile %{*}\
 %define KernelD $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}                     \
 %define ModprobeD $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d/%{_kernel_ver} \
                                                                                                                                        \
-install -d %{KernelD}/%{-d*}                                                                   \
-%{?-s:install -d %{ModprobeD}}                                                         \
+local cfgs='%{?with_dist_kernel:%{?with_smp: smp}%{?with_up: up}}%{!?with_dist_kernel: nondist}' \
                                                                                                                                        \
 for MODULE in {%{-m*},}; do                                                                                    \
        [ -n "${MODULE}" ] || continue                                                                  \
-       MNAME=${MODULE##*/}                                                                                             \
-       %if %{without dist_kernel}                                                                              \
-               install ${MODULE}-nondist.ko                                                            \\\
-                       %{KernelD}/%{-d*}/${MNAME}%{-s:-%{-s*}}.ko                              \
-               %{?-s:echo "alias ${MNAME} ${MNAME}-%{-s*}"                                     \\\
-                       >> %{ModprobeD}/%{-n*}.conf}                                                    \
-       %else                                                                                                                   \
-               install ${MODULE}-dist.ko                                                                               \\\
-                       %{KernelD}/%{-d*}/${MNAME}%{-s:-%{-s*}}.ko                              \
-               %{?-s:echo "alias ${MNAME} ${MNAME}-%{-s*}"                                     \\\
-                       >> %{ModprobeD}/%{-n*}.conf}                                                    \
-       %endif                                                                                                                  \
+       for cfg in ${cfgs:-dist}; do                                    \
+               [ "$cfg" = smp ] && suf=smp || suf=                                                     \
+               MNAME=${MODULE##*/}                                                                                     \
+               install -D ${MODULE}-$cfg.ko                                                            \\\
+                       %{KernelD}$suf/%{-d*}/${MNAME}%{-s:-%{-s*}}.ko                  \
+               %{?-s:install -d %{ModprobeD}$suf                                                       \
+                       echo "alias ${MNAME} ${MNAME}-%{-s*}"                                   \\\
+                       >> %{ModprobeD}$suf/%{-n*}.conf}                                                \
+       done                                                                                                                    \
 done                                                                                                                           \
 %{nil}
 
This page took 0.080289 seconds and 4 git commands to generate.