]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-pld-autodep.patch
- let's call it a typo
[packages/rpm.git] / rpm-pld-autodep.patch
index 846df7e6ddf5e8fba1da36e2390ebb06481221fb..3723aae6cec56819313347074a18dab9a6f883e6 100644 (file)
@@ -20,9 +20,9 @@
  };
  
  /**
---- rpm-4.4.8/lib/rpmfc.c.orig 2007-04-08 18:54:35.134367044 +0200
-+++ rpm-4.4.8/lib/rpmfc.c      2007-04-08 19:10:18.196109070 +0200
-@@ -11,6 +11,8 @@
+--- rpm-4.4.9/lib/rpmfc.c.orig 2007-05-22 08:11:41.155736775 +0200
++++ rpm-4.4.9/lib/rpmfc.c      2007-05-22 08:23:39.964699364 +0200
+@@ -15,6 +15,8 @@
  #define       _RPMDS_INTERNAL
  #include <rpmds.h>
  #include <rpmfi.h>
@@ -31,7 +31,7 @@
  
  #include "debug.h"
  
-@@ -305,14 +307,83 @@
+@@ -309,14 +311,83 @@
      return buf;
  };
  
        /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
        /*@modifies fc, rpmGlobalMacroContext, fileSystem, internalState @*/
  {
-@@ -398,6 +469,8 @@
+@@ -402,6 +473,8 @@
            }
  /*@=branchstate@*/
  
  
            /* Add tracking dependency for versioned Provides: */
            if (!fc->tracked && deptype == 'P' && *EVR != '\0') {
-@@ -710,7 +783,7 @@
+@@ -714,7 +787,7 @@
        *se = '\0';
        se++;
  
            /* Add to package requires. */
            ds = rpmdsSingle(RPMTAG_REQUIRENAME, s, "", RPMSENSE_FIND_REQUIRES);
            xx = rpmdsMerge(&fc->requires, ds);
-@@ -738,43 +811,51 @@
-     (void) fclose(fp);
+@@ -743,44 +816,52 @@
  
      if (fc->fcolor->vals[fc->ix] & RPMFC_PERL) {
--      if (fc->fcolor->vals[fc->ix] & RPMFC_MODULE)
--          xx = rpmfcHelper(fc, 'P', "perl");
--      if (is_executable || (fc->fcolor->vals[fc->ix] & RPMFC_MODULE))
--          xx = rpmfcHelper(fc, 'R', "perl");
-+      if (fc->findprov && (fc->fcolor->vals[fc->ix] & RPMFC_MODULE))
-+          xx = rpmfcHelper(fc, 'P', "perl", fc->noautoprov, fc->noautoprov_c);
-+      if (fc->findreq && (is_executable || (fc->fcolor->vals[fc->ix] & RPMFC_MODULE)))
-+          xx = rpmfcHelper(fc, 'R', "perl", fc->noautoreq, fc->noautoreq_c);
+       if (strncmp(fn, "/usr/share/doc/", sizeof("/usr/share/doc/")-1)) {
+-          if (fc->fcolor->vals[fc->ix] & RPMFC_MODULE)
+-              xx = rpmfcHelper(fc, 'P', "perl");
+-          if (is_executable || (fc->fcolor->vals[fc->ix] & RPMFC_MODULE))
+-              xx = rpmfcHelper(fc, 'R', "perl");
++          if (fc->findprov && (fc->fcolor->vals[fc->ix] & RPMFC_MODULE))
++              xx = rpmfcHelper(fc, 'P', "perl", fc->noautoprov, fc->noautoprov_c);
++          if (fc->findreq && (is_executable || (fc->fcolor->vals[fc->ix] & RPMFC_MODULE)))
++              xx = rpmfcHelper(fc, 'R', "perl", fc->noautoreq, fc->noautoreq_c);
+       }
      } else
      if (fc->fcolor->vals[fc->ix] & RPMFC_PYTHON) {
 -      xx = rpmfcHelper(fc, 'P', "python");
        /* not only executable, files run by httpd usually are not */
 -          xx = rpmfcHelper(fc, 'R', "php");
 +      if (fc->findreq)
-+          xx = rpmfcHelper(fc, 'R', "php". fc->noautoreq, fc->noautoreq_c);
++          xx = rpmfcHelper(fc, 'R', "php", fc->noautoreq, fc->noautoreq_c);
      }
  
      return 0;
-@@ -802,20 +883,26 @@
+@@ -808,20 +889,26 @@
      default:
        break;
      case RPMTAG_PROVIDENAME:
        break;
      }
      return rc;
-@@ -856,6 +943,109 @@
+@@ -862,6 +949,109 @@
      { NULL, 0 }
  };
  
  int rpmfcApply(rpmfc fc)
  {
      rpmfcApplyTbl fcat;
-@@ -874,6 +1064,26 @@
+@@ -880,6 +1070,26 @@
      int i;
      int xx;
      int skipping;
  
      /* Generate package and per-file dependencies. */
      for (fc->ix = 0; fc->fn[fc->ix] != NULL; fc->ix++) {
-@@ -894,9 +1104,43 @@
+@@ -900,9 +1110,43 @@
        for (fcat = rpmfcApplyTable; fcat->func != NULL; fcat++) {
            if (!(fc->fcolor->vals[fc->ix] & fcat->colormask))
                /*@innercontinue@*/ continue;
  
  /*@-boundswrite@*/
      /* Generate per-file indices into package dependencies. */
---- rpm-4.3/po/POTFILES.in.orig        2004-01-04 03:13:02.000000000 +0100
-+++ rpm-4.3/po/POTFILES.in     2004-02-01 21:05:50.567248776 +0100
-@@ -22,6 +22,7 @@
- build/parseSpec.c
- build/poptBT.c
- build/reqprov.c
-+lib/rpmfc.c
- build/spec.c
- lib/cpio.c
- lib/depends.c
---- rpm-4.3/po/pl.po.orig      2004-02-01 20:53:10.000000000 +0100
-+++ rpm-4.3/po/pl.po   2004-02-01 21:20:36.532561576 +0100
-@@ -1295,6 +1295,127 @@
- msgid "lookup i18N strings in specfile catalog"
- msgstr "wyszukaj wpisy I18N w katalogu pliku spec"
+--- rpm-4.4.9/po/pl.po.orig    2007-05-22 08:11:40.947724921 +0200
++++ rpm-4.4.9/po/pl.po 2007-05-22 08:24:24.091213990 +0200
+@@ -2937,6 +2937,86 @@
+ msgid "Failed to find %s:\n"
+ msgstr "Nie uda³o siê odnale¼æ %s:\n"
  
-+#: build/rpmfc.c:94
-+#, c-format
-+msgid "\texecv(%s) pid %d\n"
-+msgstr "\texecv(%s) pid %d\n"
-+
-+#. XXX this error message is probably not seen.
-+#: build/rpmfc.c:100
-+#, c-format
-+msgid "Couldn't exec %s: %s\n"
-+msgstr "Nie mo¿na uruchomiæ %s: %s\n"
-+
-+#: build/rpmfc.c:105
-+#, c-format
-+msgid "Couldn't fork %s: %s\n"
-+msgstr "Nie mo¿na wykonaæ fork %s: %s\n"
-+
-+#: build/rpmfc.c:190
-+#, c-format
-+msgid "\twaitpid(%d) rc %d status %x\n"
-+msgstr "\twaitpid(%d) rc %d status %x\n"
-+
-+#: build/rpmfc.c:194
-+#, c-format
-+msgid "%s failed\n"
-+msgstr "%s nie powiod³o siê\n"
-+
-+#: build/rpmfc.c:198
-+#, c-format
-+msgid "failed to write all data to %s\n"
-+msgstr "Nie uda³o siê zapisaæ wszystkich danych do %s\n"
-+
-+#: build/rpmfc.c:334
++#: lib/rpmfc.c:334
 +#, c-format
 +msgid "Compilation of regular expresion '%s' (expanded from '%s') failed. Skipping it.\n"
 +msgstr "Kompilacja wyra¿enia regularnego '%s' (powsta³ego z '%s') nie powiod³a siê; pominiêto.\n"
 +
-+#: build/rpmfc.c:395
++#: lib/rpmfc.c:395
 +#, c-format
 +msgid "%i _noautoprov patterns.\n"
 +msgstr "%i wzorców _noautoprov.\n"
 +
-+#: build/rpmfc.c:405
++#: lib/rpmfc.c:405
 +#, c-format
 +msgid "%i _noautoreq patterns.\n"
 +msgstr "%i wzorców _noautoreq.\n"
 +
-+#: build/rpmfc.c:459
++#: lib/rpmfc.c:459
 +#, c-format
 +msgid "Checking %c: '%s' against _noauto expr. #%i\n"
 +msgstr "Sprawdzanie %c: '%s' z wyra¿eniem _noauto #%i\n"
 +
-+#: build/rpmfc.c:462
++#: lib/rpmfc.c:462
 +#, c-format
 +msgid "Skipping %c: '%s' as it matches _noauto expr. #%i\n"
 +msgstr "Pominiêto %c: '%s' pasuj±ce do wyra¿enia _noauto #%i\n"
 +
 +#. XXX ts created in main() should be used
-+#: build/rpmfc.c:1173
++#: lib/rpmfc.c:1173
 +msgid "Searching for required packages....\n"
 +msgstr "Poszukiwanie wymaganych pakietów...\n"
 +
-+#: build/rpmfc.c:1197
++#: lib/rpmfc.c:1197
 +#, c-format
 +msgid "#%i requires: %s,%s,%i\n"
 +msgstr "#%i wymaga: %s,%s,%i\n"
 +
-+#: build/rpmfc.c:1199
++#: lib/rpmfc.c:1199
 +#, c-format
 +msgid "skipping #%i require\n"
 +msgstr "pominiêto zale¿no¶æ #%i\n"
 +
-+#: build/rpmfc.c:1205
++#: lib/rpmfc.c:1205
 +#, c-format
 +msgid "skipping %s requirement processing (matches noautoreqdep pattern #%i)\n"
 +msgstr "pominiêto przetwarzanie zale¿no¶ci %s (pasuje do wzorca noautoreqdep #%i)\n"
 +
-+#: build/rpmfc.c:1211
++#: lib/rpmfc.c:1211
 +#, c-format
 +msgid "skipping #%i require (is file requirement)\n"
 +msgstr "pominiêto zale¿no¶æ #%i (zale¿no¶æ od pliku)\n"
 +
-+#: build/rpmfc.c:1216
++#: lib/rpmfc.c:1216
 +#, c-format
 +msgid "%s -> not found\n"
 +msgstr "%s -> nie znaleziono\n"
 +
-+#: build/rpmfc.c:1219
++#: lib/rpmfc.c:1219
 +#, c-format
 +msgid "Iterator: %p\n"
 +msgstr "Iterator: %p\n"
 +
-+#: build/rpmfc.c:1221
++#: lib/rpmfc.c:1221
 +#, c-format
 +msgid "%s -> multiple (skipping)\n"
 +msgstr "%s -> wiele (pominiêto)\n"
 +
-+#: build/rpmfc.c:1230
++#: lib/rpmfc.c:1230
 +#, c-format
 +msgid "%s -> %s (skipping)\n"
 +msgstr "%s -> %s (pominiêto)\n"
 +
-+#: build/rpmfc.c:1295
++#: lib/rpmfc.c:1295
 +#, c-format
 +msgid "skipping %s provides detection (matches noautoprovfiles pattern #%i)\n"
 +msgstr "pominiêto wykrywanie w³asno¶ci %s (pasuje do wzorca noautoprovfiles #%i)\n"
 +
-+#: build/rpmfc.c:1306
++#: lib/rpmfc.c:1306
 +#, c-format
 +msgid "skipping %s requires detection (matches noautoreqfiles pattern #%i)\n"
 +msgstr "pominiêto wykrywanie w³asno¶ci %s (pasuje do wzorca noautoreqfiles #%i)\n"
 +
-+#: build/rpmfc.c:1642
-+#, c-format
-+msgid "Finding  %s: %s\n"
-+msgstr "Poszukiwanie %s: %s\n"
-+
-+#: build/rpmfc.c:1648 build/rpmfc.c:1657
-+#, c-format
-+msgid "Failed to find %s:\n"
-+msgstr "Nie uda³o siê odnale¼æ %s:\n"
-+
- #: build/spec.c:237
+ #: lib/rpmfi.c:622
  #, c-format
- msgid "line %d: Bad number: %s\n"
+ msgid "%s skipped due to missingok flag\n"
 --- rpm/configure.ac.orig      2004-08-22 13:02:30.000000000 +0200
 +++ rpm/configure.ac   2004-08-22 13:25:37.000000000 +0200
 @@ -971,6 +971,18 @@
This page took 0.062821 seconds and 4 git commands to generate.