]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-php-requires.php
- cleanup java deps generator
[packages/rpm.git] / rpm-php-requires.php
index cad6c674dd7058e5538ea46782e1a8fbee5894bc..b39802993bc09d5d25656eb32939a69a054b101e 100644 (file)
@@ -1,5 +1,9 @@
 #!/usr/bin/php
 <?php
+/*
+ * minify.spec does not see these: pear(HTTP/ConditionalGet.php) pear(HTTP/Encoder.php)
+ * perl version does
+ */
 /**
  *
  * Check system dependences between php-pear modules.
@@ -8,6 +12,8 @@
  * Michał Moskal <malekith@pld-linux.org> (Perl version)
  * Elan Ruusamäe <glen@pld-linux.org>
  *
+ * URL: <http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/rpm/rpm-php-requires.php>
+ *
  * Requires: php-pear-PHP_CompatInfo
  * Requires: php-pcre
  */
@@ -140,15 +146,16 @@ function extdeps($files) {
                if ($ext == 'bz2') {
                        $ext = 'bzip2';
                }
-               // SPL ext is in php-spl package
-               if ($ext == 'SPL') {
-                       $ext = 'spl';
+               // libxml ext is in php-xml package
+               if ($ext == 'libxml') {
+                       $ext = 'xml';
                }
-               // ereg
-               if ($ext == 'ereg') {
-                       // not yet
-                       continue;
+
+               // these need to be lowercased
+               if (in_array($ext, array('SPL', 'PDO', 'SQLite', 'Reflection', 'SimpleXML'))) {
+                       $ext = strtolower($ext);
                }
+
                printf("$fmt\n", $ext);
        }
 }
This page took 0.02358 seconds and 4 git commands to generate.