]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-php-requires.php
- cleanup java deps generator
[packages/rpm.git] / rpm-php-requires.php
index 85686bfcabb430664d1a3c7a9090c9aa03a76823..b39802993bc09d5d25656eb32939a69a054b101e 100644 (file)
@@ -1,5 +1,9 @@
 #!/usr/bin/php
 <?php
+/*
+ * minify.spec does not see these: pear(HTTP/ConditionalGet.php) pear(HTTP/Encoder.php)
+ * perl version does
+ */
 /**
  *
  * Check system dependences between php-pear modules.
@@ -8,6 +12,8 @@
  * Michał Moskal <malekith@pld-linux.org> (Perl version)
  * Elan Ruusamäe <glen@pld-linux.org>
  *
+ * URL: <http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/rpm/rpm-php-requires.php>
+ *
  * Requires: php-pear-PHP_CompatInfo
  * Requires: php-pcre
  */
@@ -140,6 +146,10 @@ function extdeps($files) {
                if ($ext == 'bz2') {
                        $ext = 'bzip2';
                }
+               // libxml ext is in php-xml package
+               if ($ext == 'libxml') {
+                       $ext = 'xml';
+               }
 
                // these need to be lowercased
                if (in_array($ext, array('SPL', 'PDO', 'SQLite', 'Reflection', 'SimpleXML'))) {
This page took 0.0273 seconds and 4 git commands to generate.