]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-perl-macros.patch
- @__PERL@ is never substituted by the build system, do not use it
[packages/rpm.git] / rpm-perl-macros.patch
index 33923595dc3faba95bc080cd774915a947e57814..a486444e4de3ad3e116469d730d84cd118bbfcc1 100644 (file)
@@ -1,22 +1,16 @@
-diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
---- rpm-4.3.org/configure.ac   2004-01-07 01:51:35.251160244 +0100
-+++ rpm-4.3/configure.ac       2004-01-07 01:55:53.198560246 +0100
-@@ -1313,6 +1313,7 @@
-     Doxyfile Makefile macros rpmpopt rpm.spec
-     rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
-     scripts/Makefile scripts/macros.perl scripts/macros.php
-+    scripts/perl.req scripts/perl.prov
-     scripts/macros.python tools/Makefile misc/Makefile doc/Makefile
-     doc/manual/Makefile doc/fr/Makefile doc/ja/Makefile doc/ko/Makefile
-     doc/pl/Makefile doc/ru/Makefile doc/sk/Makefile python/Makefile
---- rpm-4.4.9/scripts/perl.req.orig    2006-07-08 16:13:50.000000000 +0200
-+++ rpm-4.4.9/scripts/perl.req 2008-03-24 01:13:31.985544655 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!@__PERL@
- # RPM (and its source code) is covered under two separate licenses. 
+--- rpm-5.3.1/configure.ac.wiget       2010-05-22 17:15:11.000000000 +0200
++++ rpm-5.3.1/configure.ac     2010-05-30 16:37:59.526924459 +0200
+@@ -1100,7 +1100,7 @@ AC_CONFIG_FILES([ po/Makefile.in
  
+ AC_CONFIG_FILES([Makefile
+       rpmio/Makefile lib/Makefile build/Makefile sign/Makefile
+-      po/Makefile.in scripts/Makefile fileattrs/Makefile
++      po/Makefile.in scripts/Makefile scripts/perl.req scripts/perl.prov fileattrs/Makefile
+       misc/Makefile 
+       doc/Makefile
+       python/Makefile
+--- rpm-5.3.1/scripts/perl.req.wiget   2008-10-26 10:50:53.000000000 +0100
++++ rpm-5.3.1/scripts/perl.req 2010-05-30 16:35:36.999438206 +0200
 @@ -41,7 +41,11 @@
  
  if ("@ARGV") {
@@ -29,10 +23,10 @@ diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
 +    }
    }
  } else {
-   
-@@ -49,7 +53,11 @@
+@@ -49,7 +53,11 @@ if ("@ARGV") {
    # contents of the file.
-   
    foreach (<>) {
 -    process_file($_);
 +     if (m=/usr/(sbin|bin|lib|share|X11R6/(lib|bin))/=) {
@@ -43,7 +37,7 @@ diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
    }
  }
  
-@@ -203,19 +211,41 @@
+@@ -215,19 +223,41 @@ sub process_file {
  
        $module =~ s/\(\s*\)$//;
  
@@ -52,13 +46,13 @@ diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
        # if module is a number then both require and use interpret that
        # to mean that a particular version of perl is specified
  
--      my $ver=$1;
+-      my $ver = $1;
 -      if ($ver =~ /5.00/) {
--        print "perl >= 0:$ver\n";
+-        $perlreq{"0:$ver"} = 1;
 -        next;
 -      }
 -      else {
--        print "perl >= 1:$ver\n";
+-        $perlreq{"1:$ver"} = 1;
 -        next;
 -      }
 +      my $ver=$2;
@@ -95,13 +89,13 @@ diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
  
        };
  
-@@ -232,7 +262,31 @@
-       # will be included with the name sys/systeminfo.ph so only use the
+@@ -244,7 +274,31 @@ sub process_file {
+       #  will be included with the name sys/systeminfo.ph so only use the
        # basename of *.ph files
  
--      ($module  =~ m/\.ph$/) && next;
+-      ($module =~ m/\.ph$/) && next;
 +      # ($module  =~ m/\.ph$/) && ($module =~ s!.*/!!g );
-+ 
++
 +      # there is no need to generate dependencies for ph, pl or test files
 +      # so let's just skip them.
 +
@@ -126,5 +120,5 @@ diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
 +
 +      $module =~ s/\(\s*\)$//;
  
-       $require{$module}=$version;
-       $line{$module}=$_;
+       # use base|parent qw(Foo) dependencies
+       if ($statement eq "use" && ($module eq "base" || $module eq "parent")) {
This page took 0.034637 seconds and 4 git commands to generate.