]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-perl-macros.patch
updated to 4.0
[packages/rpm.git] / rpm-perl-macros.patch
index 3985ec63645ebe27d571e49a13d0068a26f3a7b8..80e85b15b923548369e4c5da7e0669e17212aa55 100644 (file)
-diff -ruN rpm-3.0.3/macros.in rpm-3.0.3.new/macros.in
---- rpm-3.0.3/macros.in        Sat Oct 30 11:59:36 1999
-+++ rpm-3.0.3.new/macros.in    Sat Oct 30 11:24:39 1999
-@@ -248,6 +248,8 @@
- #     %{perl_sitearch}/Image
- #     %dir %{perl_sitearch}/auto/Image
- #
-+#
-+# NOTE: %{perl_sitearch}, %{perl_archlib} and %{perl_sitelib} macros 
-+#     has been moved to macros.perl (see info in this file for details).
-+#
- %requires_eq()        %(LC_ALL="C" rpm -q --queryformat 'Requires:%%{NAME} = %%{VERSION}' %1| grep -v "is not")
--%perl_sitearch        %(eval "`perl -V:installsitearch`"; echo $installsitearch)
--%perl_archlib %(eval "`perl -V:installarchlib`"; echo $installarchlib)
-diff -ruN rpm-3.0.3/macros.perl.in rpm-3.0.3.new/macros.perl.in
---- rpm-3.0.3/macros.perl.in   Thu Jan  1 01:00:00 1970
-+++ rpm-3.0.3.new/macros.perl.in       Sat Oct 30 11:24:39 1999
-@@ -0,0 +1,11 @@
-+# Perl specific macro definitions.
-+# To make use of these macros insert the following line into your spec file:
-+# %include @RPMCONFIGDIR@/macros.perl
-+
-+%define               __find_requires @RPMCONFIGDIR@/find-perl-requires
-+%define               __find_provides @RPMCONFIGDIR@/find-perl-provides
-+
-+%define               perl_sitelib    %(eval "`perl -V:installsitelib`"; echo $installsitelib)
-+%define               perl_sitearch   %(eval "`perl -V:installsitearch`"; echo $installsitearch)
-+%define               perl_archlib    %(eval "`perl -V:installarchlib`"; echo $installarchlib)
-+
-diff -ruN rpm-3.0.3/scripts/Makefile.am rpm-3.0.3.new/scripts/Makefile.am
---- rpm-3.0.3/scripts/Makefile.am      Sat Jun  5 22:52:30 1999
-+++ rpm-3.0.3.new/scripts/Makefile.am  Sat Oct 30 11:24:39 1999
-@@ -4,7 +4,8 @@
- EXTRA_DIST = \
-       convertrpmrc.sh find-lang.sh freshen.sh getpo.sh \
--      perl.prov perl.req vpkg-provides.sh
-+      perl.prov perl.req find-perl-requires find-perl-provides \
-+      vpkg-provides.sh
+--- rpm-4.0/scripts/Makefile.am.wiget  Wed Jul  5 14:26:37 2000
++++ rpm-4.0/scripts/Makefile.am        Wed Nov 15 21:31:03 2000
+@@ -8,7 +8,8 @@
+       find-prov.pl find-req.pl cpanflute find-provides.perl \
+       find-requires.perl get_magic.pl getpo.sh http.req \
+       magic.prov magic.req perl.prov perl.req rpmdiff rpmdiff.cgi u_pkg.sh \
+-      vpkg-provides.sh vpkg-provides2.sh
++      vpkg-provides.sh vpkg-provides2.sh \
++      find-perl-requires find-perl-provides
  
  installprefix = $(DESTDIR)
  
-@@ -13,5 +14,6 @@
- configdir = ${prefix}/lib/rpm
- config_SCRIPTS = \
-       convertrpmrc.sh find-lang.sh freshen.sh getpo.sh \
--      perl.prov perl.req vpkg-provides.sh
-+      perl.prov perl.req find-perl-requires find-perl-provides \
-+      vpkg-provides.sh
-diff -ruN rpm-3.0.3/scripts/find-perl-provides rpm-3.0.3.new/scripts/find-perl-provides
---- rpm-3.0.3/scripts/find-perl-provides       Thu Jan  1 01:00:00 1970
-+++ rpm-3.0.3.new/scripts/find-perl-provides   Sat Oct 30 11:24:39 1999
-@@ -0,0 +1,8 @@
-+#!/bin/sh
-+ulimit -c 0
-+
-+filelist=`sed "s/['\"]/\\\&/g"`
-+
-+echo $filelist|/usr/lib/rpm/find-provides
-+/usr/lib/rpm/perl.prov $filelist
-+
-diff -ruN rpm-3.0.3/scripts/find-perl-requires rpm-3.0.3.new/scripts/find-perl-requires
---- rpm-3.0.3/scripts/find-perl-requires       Thu Jan  1 01:00:00 1970
-+++ rpm-3.0.3.new/scripts/find-perl-requires   Sat Oct 30 11:24:39 1999
-@@ -0,0 +1,11 @@
-+#!/bin/sh
-+ulimit -c 0
-+
-+filelist=`sed "s/['\"]/\\\&/g"`
-+
-+requires="`echo $filelist|/usr/lib/rpm/find-requires`"
-+requires_perl="`/usr/lib/rpm/perl.req $filelist`"
-+requires_mod="`rpm -q --whatprovides --qf "%{NAME}\n"  $requires_perl 2>/dev/null`"
-+echo "$requires
-+$requires_perl
-+$requires_mod"|  sort -u
-diff -ruN rpm-3.0.3/scripts/perl.prov rpm-3.0.3.new/scripts/perl.prov
---- rpm-3.0.3/scripts/perl.prov        Sat Jun  5 22:52:31 1999
-+++ rpm-3.0.3.new/scripts/perl.prov    Sat Oct 30 11:24:39 1999
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!@PERL@
- # a simple script to print the proper name for perl libraries.
+@@ -21,4 +22,5 @@
+       find-prov.pl find-req.pl cpanflute find-provides.perl \
+       find-requires.perl get_magic.pl getpo.sh http.req \
+       magic.prov magic.req perl.prov perl.req rpmdiff rpmdiff.cgi u_pkg.sh \
+-      vpkg-provides.sh vpkg-provides2.sh
++      vpkg-provides.sh vpkg-provides2.sh \
++      find-perl-requires find-perl-provides
+--- rpm-4.0/scripts/perl.prov.wiget    Mon Jan 17 19:58:36 2000
++++ rpm-4.0/scripts/perl.prov  Wed Nov 15 21:31:03 2000
+@@ -47,7 +47,9 @@
  
-@@ -30,12 +30,12 @@
-   if (length($require{$module}) == 0) {
-     print "perl($module)\n";
-   } else {
--    print "perl($module)=$require{$module}\n";
-+    print "perl($module) = $require{$module}\n";
+ if ("@ARGV") {
+   foreach (@ARGV) {
+-    process_file($_);
++     if (! m=(/(doc|usr/src)/|\.(so|gz|ph|pod|h|html)$)=) {
++      process_file($_);
++    }
+   }
+ } else {
  
-     # we need to print it without the version number until the
-     # requires syntax accepts version numbers correctly.
+@@ -55,7 +57,9 @@
+   # contents of the file.
  
--    print "perl($module)\n";
-+#    print "perl($module)\n";
+   foreach (<>) {
+-    process_file($_);
++     if (! m=(/(doc|usr/src)/|\.(so|gz|ph|pod|h|html)$)=) {
++      process_file($_);
++    }
    }
  }
  
-diff -ruN rpm-3.0.3/scripts/perl.req rpm-3.0.3.new/scripts/perl.req
---- rpm-3.0.3/scripts/perl.req Sat Jun  5 22:52:31 1999
-+++ rpm-3.0.3.new/scripts/perl.req     Sat Oct 30 11:50:03 1999
+--- rpm-4.0/scripts/perl.req.wiget     Mon Jan 17 19:58:36 2000
++++ rpm-4.0/scripts/perl.req   Wed Nov 15 21:31:03 2000
 @@ -1,4 +1,4 @@
 -#!/usr/bin/perl
 +#!@PERL@
  
- # a simple makedepends like script for perl.
+ # RPM (and it's source code) is covered under two separate licenses. 
  
-@@ -12,7 +12,11 @@
+@@ -41,7 +41,11 @@
  
  if ("@ARGV") {
    foreach (@ARGV) {
 -    process_file($_);
-+    if (m=/usr/(bin|lib|share|X11R6/(lib|bin))/=) {
-+      if (! m=(/((doc|man|info)|/usr/src)/)\.so$)=) {
++    if (m=/usr/(sbin|bin|lib|share|X11R6/(lib|bin))/=) {
++      if (! m=(/(doc|man|info|usr/src)/|\.(so|ph|h|html|pod)$)=) {
 +        process_file($_);
 +      }
 +    }
    }
  } else {
    
-@@ -20,22 +24,30 @@
+@@ -49,14 +53,22 @@
    # contents of the file.
    
    foreach (<>) {
 -    process_file($_);
-+    if (m=/usr/(bin|lib|share|X11R6/(lib|bin))/=) {
-+      if (! m=(/((doc|man|info)|/usr/src)/)\.so$)=) {
-+        process_file($_);
-+      }
-+    }
++     if (m=/usr/(sbin|bin|lib|share|X11R6/(lib|bin))/=) {
++       if (! m=(/(doc|man|info|usr/src)/|\.(so|ph|h|html|pod)$)=) {
++         process_file($_);
++       }
++     }
    }
  }
  
@@ -138,30 +79,78 @@ diff -ruN rpm-3.0.3/scripts/perl.req rpm-3.0.3.new/scripts/perl.req
  foreach $module (sort keys %require) {
    if (length($require{$module}) == 0) {
 -    print "perl($module)\n";
-+    if ($module =~ /^[0-9._]+$/) {
-+      print "perl >= $module\n";
-+    } else {
-+      print "perl($module)\n";
-+    }
++     if ($module =~ /^[0-9._]+$/) {
++       print "perl >= $module\n";
++     } else {
++         print "perl($module)\n";
++     }
    } else {
  
--    print "perl($module)>=$require{$module}\n";
-+    print "perl($module) >= $require{$module}\n";
+     # I am not using rpm3.0 so I do not want spaces arround my
+@@ -183,7 +195,31 @@
+       # will be included with the name sys/systeminfo.ph so only use the
+       # basename of *.ph files
  
-     # we need to print it without the version number until the
-     # requires syntax accepts version numbers correctly.
--    print "perl($module)\n";
-+#    print "perl($module)\n";
-   }
- }
-@@ -54,7 +66,7 @@
-   while (<FILE>) {
-     
-     # skip the documentation
--    if ( (m/^=(head1|head2|pod)/) .. (m/^=(cut)/) ) {
-+    if ( (m/^=(head1|head2|pod|item)/) .. (m/^=(cut)/) ) {
-       next;
-     }
+-      ($module  =~ m/\.ph$/) && ($module =~ s!.*/!!g );
++      # ($module  =~ m/\.ph$/) && ($module =~ s!.*/!!g );
++
++      # there is no need to generate dependencies for ph, pl or test files
++      # so let's just skip them.
++
++      ($module =~ m/\.(ph|pl|t)$/) && next;
++
++      # skip all modules for platforms other than linux.
++
++      ($module =~ m/Mac|OS2|MSDOS|Win32|VMS|vmsish/) && next;
++
++      # if the module name starts in a dot it is not a module name.
++
++      ($module =~ m/^\./) && next;
++
++      # if the module ends with .pm strip it to leave only basename.
++
++      $module =~ s/\.pm$//;
++
++      $module =~ s/\//::/;
++
++      # trim off trailing parenthesis if any.  Sometimes people pass
++      # the module an empty list.
++
++      $module =~ s/\(\s*\)$//;
+       $require{$module}=$version;
+--- rpm-4.0/configure.in.wiget Wed Nov 15 21:31:03 2000
++++ rpm-4.0/configure.in       Wed Nov 15 21:34:55 2000
+@@ -181,6 +181,7 @@
+     AC_PATH_PROG(__MKDIR, mkdir, /bin/mkdir, $MYPATH)
+     AC_PATH_PROG(__MV, mv, /bin/mv, $MYPATH)
+     AC_PATH_PROG(__PATCH, patch, /usr/bin/patch, $MYPATH)
++    AC_PATH_PROG(PERL, perl, /usr/bin/perl, $MYPATH)
+     AC_MSG_CHECKING(old version of patch)
+     PATCHVERSION=`patch --version 2>&1`
+@@ -952,6 +953,7 @@
+ AC_CONFIG_SUBDIRS(popt)
+ AC_OUTPUT([Doxyfile Makefile rpmrc macros macros.pld platform rpmpopt scripts/brp-redhat
++      macros.perl scripts/perl.req scripts/perl.prov
+       rpmio/Makefile lib/Makefile build/Makefile tools/Makefile
+       scripts/Makefile
+       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
+--- rpm-4.0/macros.in.wiget    Wed Nov 15 21:31:03 2000
++++ rpm-4.0/macros.in  Wed Nov 15 21:31:03 2000
+@@ -623,9 +623,11 @@
+ #     %{perl_sitearch}/Image
+ #     %dir %{perl_sitearch}/auto/Image
+ #
++#
++# NOTE: %{perl_sitearch}, %{perl_archlib} and %{perl_sitelib} macros 
++#     has been moved to macros.perl (see info in this file for details).
++#
+ %requires_eq()        %(LC_ALL="C" rpm -q --queryformat 'Requires:%%{NAME} = %%{VERSION}' %1| grep -v "is not")
+-%perl_sitearch        %(eval "`perl -V:installsitearch`"; echo $installsitearch)
+-%perl_archlib %(eval "`perl -V:installarchlib`"; echo $installarchlib)
  
+ #------------------------------------------------------------------------------
+ # arch macro for all Intel i?86 compatibile processors
This page took 0.03441 seconds and 4 git commands to generate.