]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-perl-macros.patch
- versioned Provides rpmbuild(find_lang)
[packages/rpm.git] / rpm-perl-macros.patch
index 8fbf13ac12fc1720e60b6af95e413623ed318e3e..2648466887bda5884a6a0945714365c1b74a239f 100644 (file)
@@ -1,51 +1,20 @@
---- rpm-4.0.2/scripts/Makefile.am.wiget        Tue Dec 12 17:47:59 2000
-+++ rpm-4.0.2/scripts/Makefile.am      Fri Aug 10 12:44:47 2001
-@@ -9,7 +9,8 @@
-       find-prov.pl find-req.pl cpanflute find-provides.perl \
-       find-requires.perl get_magic.pl getpo.sh http.req \
-       magic.prov magic.req perl.prov perl.req rpmdiff rpmdiff.cgi \
--      trpm u_pkg.sh vpkg-provides.sh vpkg-provides2.sh
-+      trpm u_pkg.sh vpkg-provides.sh vpkg-provides2.sh \
-+      find-perl-requires find-perl-provides
- installprefix = $(DESTDIR)
-@@ -23,4 +24,5 @@
-       find-prov.pl find-req.pl cpanflute find-provides.perl \
-       find-requires.perl get_magic.pl getpo.sh http.req \
-       magic.prov magic.req perl.prov perl.req rpmdiff rpmdiff.cgi u_pkg.sh \
--      vpkg-provides.sh vpkg-provides2.sh
-+      vpkg-provides.sh vpkg-provides2.sh \
-+      find-perl-requires find-perl-provides
---- rpm-4.0.2/scripts/perl.prov.wiget  Mon Jan 17 19:58:36 2000
-+++ rpm-4.0.2/scripts/perl.prov        Fri Aug 10 12:44:47 2001
-@@ -47,7 +47,9 @@
- if ("@ARGV") {
-   foreach (@ARGV) {
--    process_file($_);
-+     if (! m=(/(doc|usr/src)/|\.(so|gz|ph|pod|h|html)$)=) {
-+      process_file($_);
-+    }
-   }
- } else {
-@@ -55,7 +57,9 @@
-   # contents of the file.
-   foreach (<>) {
--    process_file($_);
-+     if (! m=(/(doc|usr/src)/|\.(so|gz|ph|pod|h|html)$)=) {
-+      process_file($_);
-+    }
-   }
- }
---- rpm-4.0.2/scripts/perl.req.wiget   Mon Jan 17 19:58:36 2000
-+++ rpm-4.0.2/scripts/perl.req Fri Aug 10 12:44:47 2001
+diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
+--- rpm-4.3.org/configure.ac   2004-01-07 01:51:35.251160244 +0100
++++ rpm-4.3/configure.ac       2004-01-07 01:55:53.198560246 +0100
+@@ -1313,6 +1313,7 @@
+     Doxyfile Makefile macros rpmpopt rpm.spec
+     rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
+     scripts/Makefile scripts/macros.perl scripts/macros.php
++    scripts/perl.req scripts/perl.prov
+     scripts/macros.python tools/Makefile misc/Makefile doc/Makefile
+     doc/manual/Makefile doc/fr/Makefile doc/ja/Makefile doc/ko/Makefile
+     doc/pl/Makefile doc/ru/Makefile doc/sk/Makefile python/Makefile
+diff -urN rpm-4.3.org/scripts/perl.req rpm-4.3/scripts/perl.req
+--- rpm-4.3.org/scripts/perl.req       2004-01-07 01:51:04.911464416 +0100
++++ rpm-4.3/scripts/perl.req   2004-01-07 01:55:17.030076058 +0100
 @@ -1,4 +1,4 @@
 -#!/usr/bin/perl
-+#!@PERL@
++#!@__PERL@
  
  # RPM (and it's source code) is covered under two separate licenses. 
  
    } else {
  
      # I am not using rpm3.0 so I do not want spaces arround my
-@@ -183,7 +195,31 @@
+@@ -219,7 +231,31 @@
        # will be included with the name sys/systeminfo.ph so only use the
        # basename of *.ph files
  
--      ($module  =~ m/\.ph$/) && ($module =~ s!.*/!!g );
+-      ($module  =~ m/\.ph$/) && next;
 +      # ($module  =~ m/\.ph$/) && ($module =~ s!.*/!!g );
-+
++ 
 +      # there is no need to generate dependencies for ph, pl or test files
 +      # so let's just skip them.
 +
 +
 +      $module =~ s/\(\s*\)$//;
  
        $require{$module}=$version;
---- rpm-4.0.2/configure.in.wiget       Sun Feb 25 18:13:26 2001
-+++ rpm-4.0.2/configure.in     Fri Aug 10 12:48:21 2001
-@@ -186,6 +186,7 @@
-     AC_PATH_PROG(__MKDIR, mkdir, /bin/mkdir, $MYPATH)
-     AC_PATH_PROG(__MV, mv, /bin/mv, $MYPATH)
-     AC_PATH_PROG(__PATCH, patch, /usr/bin/patch, $MYPATH)
-+    AC_PATH_PROG(PERL, perl, /usr/bin/perl, $MYPATH)
-     AC_MSG_CHECKING(old version of patch)
-     PATCHVERSION=`patch --version 2>&1`
-@@ -1086,6 +1087,7 @@
- AC_CONFIG_SUBDIRS(popt)
- AC_OUTPUT([Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec scripts/brp-redhat
-+      macros.perl scripts/perl.req scripts/perl.prov
-       rpmio/Makefile lib/Makefile build/Makefile tools/Makefile
-       scripts/Makefile
-       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
---- rpm-4.0.2/macros.in.wiget  Fri Aug 10 12:44:47 2001
-+++ rpm-4.0.2/macros.in        Fri Aug 10 12:44:47 2001
-@@ -626,9 +626,11 @@
- #     %{perl_sitearch}/Image
- #     %dir %{perl_sitearch}/auto/Image
- #
-+#
-+# NOTE: %{perl_sitearch}, %{perl_archlib} and %{perl_sitelib} macros 
-+#     has been moved to macros.perl (see info in this file for details).
-+#
- %requires_eq()        %(LC_ALL="C" rpm -q --queryformat 'Requires:%%{NAME} = %%{VERSION}' %1| grep -v "is not")
--%perl_sitearch        %(eval "`perl -V:installsitearch`"; echo $installsitearch)
--%perl_archlib %(eval "`perl -V:installarchlib`"; echo $installarchlib)
- #------------------------------------------------------------------------------
- # arch macro for all Intel i?86 compatibile processors
+       $line{$module}=$_;
This page took 0.034317 seconds and 4 git commands to generate.