]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-perl-macros.patch
- fix lua BRs, lua51-devel provides lua-devel however it does not have lua.pc expecte...
[packages/rpm.git] / rpm-perl-macros.patch
index c99ad2e3e51fa754270c0af85d235c8405ea085f..1d09638388873b813cebea16cf0c88c90b1798ad 100644 (file)
@@ -1,22 +1,17 @@
 --- rpm-5.3.1/configure.ac.wiget       2010-05-22 17:15:11.000000000 +0200
 +++ rpm-5.3.1/configure.ac     2010-05-30 16:37:59.526924459 +0200
-@@ -2198,6 +2198,7 @@ AC_CONFIG_FILES([ po/Makefile.in
-     build/Makefile build/auto/Makefile build/auto/desc build/auto/types
-     tools/Makefile
-     scripts/Makefile
-+    scripts/perl.req scripts/perl.prov
-     rpmdb/DB_CONFIG
-     macros/macros macros/macros.rpmbuild
-     macros/java macros/libtool macros/mono macros/perl 
+@@ -1100,7 +1100,7 @@ AC_CONFIG_FILES([ po/Makefile.in
+ AC_CONFIG_FILES([Makefile
+       rpmio/Makefile lib/Makefile build/Makefile sign/Makefile
+-      po/Makefile.in scripts/Makefile fileattrs/Makefile
++      po/Makefile.in scripts/Makefile scripts/perl.req scripts/perl.prov fileattrs/Makefile
+       misc/Makefile 
+       doc/Makefile
+       python/Makefile
 --- rpm-5.3.1/scripts/perl.req.wiget   2008-10-26 10:50:53.000000000 +0100
 +++ rpm-5.3.1/scripts/perl.req 2010-05-30 16:35:36.999438206 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!@__PERL@
- # RPM (and its source code) is covered under two separate licenses. 
-@@ -41,7 +41,11 @@
+@@ -45,7 +45,11 @@
  
  if ("@ARGV") {
    foreach (@ARGV) {
 +    }
    }
  } else {
-   
-@@ -49,7 +53,11 @@ if ("@ARGV") {
+@@ -53,7 +57,11 @@
    # contents of the file.
-   
    foreach (<>) {
 -    process_file($_);
 +     if (m=/usr/(sbin|bin|lib|share|X11R6/(lib|bin))/=) {
@@ -42,7 +37,7 @@
    }
  }
  
-@@ -215,19 +223,41 @@ sub process_file {
+@@ -261,19 +269,41 @@
  
        $module =~ s/\(\s*\)$//;
  
        # if module is a number then both require and use interpret that
        # to mean that a particular version of perl is specified
  
--      my $ver=$1;
+-      my $ver = $1;
 -      if ($ver =~ /5.00/) {
--        print "perl >= 0:$ver\n";
+-        $perlreq{"0:$ver"} = 1;
 -        next;
 -      }
 -      else {
--        print "perl >= 1:$ver\n";
+-        $perlreq{"1:$ver"} = 1;
 -        next;
 -      }
 +      my $ver=$2;
  
        };
  
-@@ -244,7 +274,31 @@ sub process_file {
+@@ -290,7 +320,31 @@
        # will be included with the name sys/systeminfo.ph so only use the
        # basename of *.ph files
  
--      ($module  =~ m/\.ph$/) && next;
+-      ($module =~ m/\.ph$/) && next;
 +      # ($module  =~ m/\.ph$/) && ($module =~ s!.*/!!g );
-+ 
++
 +      # there is no need to generate dependencies for ph, pl or test files
 +      # so let's just skip them.
 +
 +
 +      $module =~ s/\(\s*\)$//;
  
-       $require{$module}=$version;
-       $line{$module}=$_;
+       # use base|parent qw(Foo) dependencies
+       if ($statement eq "use" && ($module eq "base" || $module eq "parent")) {
This page took 0.037597 seconds and 4 git commands to generate.