]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-perl-macros.patch
- at least use macros that are used
[packages/rpm.git] / rpm-perl-macros.patch
index 601c0598ba2a04eba380519de79cc5cdabf561d7..0744b9f822d54c69b333e55dc8e415519167b15d 100644 (file)
@@ -1,91 +1,48 @@
-diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
---- rpm-4.3.org/configure.ac   2004-01-07 01:51:35.251160244 +0100
-+++ rpm-4.3/configure.ac       2004-01-07 01:55:53.198560246 +0100
-@@ -1196,6 +1196,7 @@
- AC_CONFIG_SUBDIRS(popt beecrypt zlib elfutils file db3)
+--- rpm-4.5/scripts/perl.req   2008-07-09 12:38:31.000000000 +0300
++++ rpm-4.4.9/scripts/perl.req.in      2008-08-12 23:08:33.518675858 +0300
+@@ -277,20 +277,20 @@
+         # $V-style
+         if ($ver =~ m/5\.([0-5])(\.([0-9]+))?$/) {
+           if (defined $3) {
+-            print "perl >= 0:5.00$1_$3\n";
++            print "perl-base >= 0:5.00$1_$3\n";
+           } else {
+-            print "perl >= 0:5.00$1\n";
++            print "perl-base >= 0:5.00$1\n";
+           }
+         } else {
+-          print "perl >= 1:$ver\n";
++          print "perl-base >= 1:$ver\n";
+         }
+       } else {
+         # $]-style
+         if ($ver =~ m/5\.(00[0-5])_?([0-9]+)?$/) {
+           if (defined $2) {
+-            print "perl >= 0:5.$1_$2\n";
++            print "perl-base >= 0:5.$1_$2\n";
+           } else {
+-            print "perl >= 0:5.$1\n";
++            print "perl-base >= 0:5.$1\n";
+           }
+         } else {
+           # expand to M.NNN_nnn form
+@@ -299,7 +299,7 @@
+           $ver =~ s/^([0-9]\.[0-9]{3})_?([0-9]{3})0*$/$1_$2/;
+           # match trimming leading 0s
+           $ver =~ m/^([0-9])\.0*([1-9][0-9]*|0)_0*([1-9][0-9]*|0)$/;
+-          print "perl >= 1:$1.$2.$3\n";
++          print "perl-base >= 1:$1.$2.$3\n";
+         }
+       }
+       next;
+@@ -326,6 +326,10 @@
+       ($module =~ m/\.(ph|pl|t)$/) && next;
  
- AC_CONFIG_FILES([ Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec
-+      scripts/perl.req scripts/perl.prov
-       rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
-       scripts/Makefile scripts/brp-redhat
-       scripts/macros.perl scripts/macros.php scripts/macros.python
-diff -urN rpm-4.3.org/scripts/perl.req rpm-4.3/scripts/perl.req
---- rpm-4.3.org/scripts/perl.req       2004-01-07 01:51:04.911464416 +0100
-+++ rpm-4.3/scripts/perl.req   2004-01-07 01:55:17.030076058 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!@__PERL@
- # RPM (and it's source code) is covered under two separate licenses. 
-@@ -41,7 +41,11 @@
- if ("@ARGV") {
-   foreach (@ARGV) {
--    process_file($_);
-+    if (m=/usr/(sbin|bin|lib|share|X11R6/(lib|bin))/=) {
-+      if (! m=(/(doc|man|info|usr/src)/|\.(so|ph|h|html|pod)$)=) {
-+        process_file($_);
-+      }
-+    }
-   }
- } else {
-   
-@@ -49,14 +53,22 @@
-   # contents of the file.
-   
-   foreach (<>) {
--    process_file($_);
-+     if (m=/usr/(sbin|bin|lib|share|X11R6/(lib|bin))/=) {
-+       if (! m=(/(doc|man|info|usr/src)/|\.(so|ph|h|html|pod)$)=) {
-+         process_file($_);
-+       }
-+     }
-   }
- }
- foreach $module (sort keys %require) {
-   if (length($require{$module}) == 0) {
--    print "perl($module)\n";
-+     if ($module =~ /^[0-9._]+$/) {
-+       print "perl >= $module\n";
-+     } else {
-+         print "perl($module)\n";
-+     }
-   } else {
-     # I am not using rpm3.0 so I do not want spaces arround my
-@@ -219,7 +231,31 @@
-       # will be included with the name sys/systeminfo.ph so only use the
-       # basename of *.ph files
--      ($module  =~ m/\.ph$/) && next;
-+      # ($module  =~ m/\.ph$/) && ($module =~ s!.*/!!g );
-+ 
-+      # there is no need to generate dependencies for ph, pl or test files
-+      # so let's just skip them.
-+
-+      ($module =~ m/\.(ph|pl|t)$/) && next;
-+
 +      # skip all modules for platforms other than linux.
 +
 +      ($module =~ m/Mac|OS2|MSDOS|Win32|VMS|vmsish/) && next;
 +
-+      # if the module name starts in a dot it is not a module name.
-+
-+      ($module =~ m/^\./) && next;
-+
-+      # if the module ends with .pm strip it to leave only basename.
-+
-+      $module =~ s/\.pm$//;
-+
-+      $module =~ s/\//::/;
-+
-+      # trim off trailing parenthesis if any.  Sometimes people pass
-+      # the module an empty list.
-+
-+      $module =~ s/\(\s*\)$//;
+       # if the module name starts in a dot it is not a module name.
  
-       $require{$module}=$version;
-       $line{$module}=$_;
+       ($module =~ m/^\./) && next;
This page took 0.04872 seconds and 4 git commands to generate.