]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-no-neon.patch
- javaprov improved to find deps recursively from jar (eclipse pkgs)
[packages/rpm.git] / rpm-no-neon.patch
index d1f81c32c927957e3e4a97a0382b1217ffd6531e..a75d5f09a3d49311956258ae06c43ca71520af79 100644 (file)
  #ifdef __cplusplus
  }
  #endif
---- rpm-4.4.7.org/rpmio/rpmio.c        2006-08-08 08:55:01.000000000 +0200
-+++ rpm-4.4.7/rpmio/rpmio.c    2006-10-17 22:18:38.135311750 +0200
-@@ -406,13 +406,6 @@
+--- rpm-4.5/rpmio/rpmio.c      2008-09-04 18:04:37.362241187 +0300
++++ rpm-4.5/rpmio/rpmio.c      2008-09-04 18:05:08.695569896 +0300
+@@ -155,11 +155,6 @@
+ /*@unchecked@*/
+ int _ftp_debug = 0;
+-/**
+- */
+-/*@unchecked@*/
+-int _dav_debug = 0;
+-
+ /* =============================================================== */
+ /*@-boundswrite@*/
+@@ -386,13 +381,6 @@
  
      fdstat_enter(fd, FDSTAT_READ);
  /*@-boundswrite@*/
        rc = read(fdFileno(fd), buf, (count > fd->bytesRemain ? fd->bytesRemain : count));
  /*@=boundswrite@*/
      fdstat_exit(fd, FDSTAT_READ, rc);
-@@ -440,10 +433,6 @@
+@@ -420,10 +408,6 @@
  
      fdstat_enter(fd, FDSTAT_WRITE);
  /*@-boundsread@*/
        rc = write(fdno, buf, (count > fd->bytesRemain ? fd->bytesRemain : count));
  /*@=boundsread@*/
      fdstat_exit(fd, FDSTAT_WRITE, rc);
-@@ -490,11 +479,6 @@
+@@ -470,11 +454,6 @@
      fdSetFdno(fd, -1);
  
      fdstat_enter(fd, FDSTAT_CLOSE);
        rc = ((fdno >= 0) ? close(fdno) : -2);
  /*@=branchstate@*/
      fdstat_exit(fd, FDSTAT_CLOSE, rc);
-@@ -547,10 +531,6 @@
+@@ -544,10 +523,6 @@
      FD_ZERO(&wrfds);
  #endif
        
      if ((fdno = fdFileno(fd)) < 0)
        return -1;      /* XXX W2DO? */
        
-@@ -602,10 +582,6 @@
+@@ -599,10 +574,6 @@
      FD_ZERO(&rdfds);
  #endif
  
      if ((fdno = fdFileno(fd)) < 0)
        return -1;      /* XXX W2DO? */
        
-@@ -1758,159 +1734,6 @@
-     return rc;
- }
--#ifdef DEAD
--static int httpResp(urlinfo u, FD_t ctrl, /*@out@*/ char ** str)
--      /*@globals fileSystem @*/
--      /*@modifies ctrl, *str, fileSystem @*/
--{
--    int ec = 0;
--    int rc;
--
--    URLSANE(u);
--    rc = checkResponse(u, ctrl, &ec, str);
--
--if (_ftp_debug && !(rc == 0 && (ec == 200 || ec == 201)))
--fprintf(stderr, "*** httpResp: rc %d ec %d\n", rc, ec);
--
--    switch (ec) {
--    case 200:
--    case 201:                 /* 201 Created. */
--      break;
--    case 204:                 /* HACK: if overwriting, 204 No Content. */
--    case 403:                 /* 403 Forbidden. */
--      ctrl->syserrno = EACCES;        /* HACK */
--      rc = FTPERR_UNKNOWN;
--      break;
--    default:
--      rc = FTPERR_FILE_NOT_FOUND;
--      break;
--    }
--    return rc;
--}
--
--static int httpReq(FD_t ctrl, const char * httpCmd, const char * httpArg)
--      /*@globals h_errno, fileSystem, internalState @*/
--      /*@modifies ctrl, fileSystem, internalState @*/
--{
--    urlinfo u;
--    const char * host;
--    const char * path;
--    char hthost[NI_MAXHOST];
--    int port;
--    int rc;
--    char * req;
--    size_t len;
--    int retrying = 0;
--
--assert(ctrl != NULL);
--    u = ctrl->url;
--    URLSANE(u);
--
--    if (((host = (u->proxyh ? u->proxyh : u->host)) == NULL))
--      return FTPERR_BAD_HOSTNAME;
--    if (strchr(host, ':'))
--      sprintf(hthost, "[%s]", host);
--    else
--      strcpy(hthost, host);
--
--    if ((port = (u->proxyp > 0 ? u->proxyp : u->port)) < 0) port = 80;
--    path = (u->proxyh || u->proxyp > 0) ? u->url : httpArg;
--    /*@-branchstate@*/
--    if (path == NULL) path = "";
--    /*@=branchstate@*/
--
--reopen:
--    /*@-branchstate@*/
--    if (fdFileno(ctrl) >= 0 && (rc = fdWritable(ctrl, 0)) < 1) {
--      /*@-refcounttrans@*/ (void) fdClose(ctrl); /*@=refcounttrans@*/
--    }
--    /*@=branchstate@*/
--
--/*@-usereleased@*/
--    if (fdFileno(ctrl) < 0) {
--      rc = tcpConnect(ctrl, host, port);
--      if (rc < 0)
--          goto errxit2;
--      ctrl = fdLink(ctrl, "open ctrl (httpReq)");
--    }
--
--    len = sizeof("\
--req x HTTP/1.0\r\n\
--User-Agent: rpm/3.0.4\r\n\
--Host: y:z\r\n\
--Accept: text/plain\r\n\
--Transfer-Encoding: chunked\r\n\
--\r\n\
--") + strlen(httpCmd) + strlen(path) + sizeof(VERSION) + strlen(hthost) + 20;
--
--/*@-boundswrite@*/
--    req = alloca(len);
--    *req = '\0';
--
--  if (!strcmp(httpCmd, "PUT")) {
--    sprintf(req, "\
--%s %s HTTP/1.%d\r\n\
--User-Agent: rpm/%s\r\n\
--Host: %s:%d\r\n\
--Accept: text/plain\r\n\
--Transfer-Encoding: chunked\r\n\
--\r\n\
--",    httpCmd, path, (u->httpVersion ? 1 : 0), VERSION, hthost, port);
--} else {
--    sprintf(req, "\
--%s %s HTTP/1.%d\r\n\
--User-Agent: rpm/%s\r\n\
--Host: %s:%d\r\n\
--Accept: text/plain\r\n\
--\r\n\
--",    httpCmd, path, (u->httpVersion ? 1 : 0), VERSION, hthost, port);
--}
--/*@=boundswrite@*/
--
--if (_ftp_debug)
--fprintf(stderr, "-> %s", req);
--
--    len = strlen(req);
--    if (fdWrite(ctrl, req, len) != len) {
--      rc = FTPERR_SERVER_IO_ERROR;
--      goto errxit;
--    }
--
--    /*@-branchstate@*/
--    if (!strcmp(httpCmd, "PUT")) {
--      ctrl->wr_chunked = 1;
--    } else {
--
--      rc = httpResp(u, ctrl, NULL);
--
--      if (rc) {
--          if (!retrying) {    /* not HTTP_OK */
--              retrying = 1;
--              /*@-refcounttrans@*/ (void) fdClose(ctrl); /*@=refcounttrans@*/
--              goto reopen;
--          }
--          goto errxit;
--      }
--    }
--    /*@=branchstate@*/
--
--    ctrl = fdLink(ctrl, "open data (httpReq)");
--    return 0;
--
--errxit:
--    /*@-observertrans@*/
--    fdSetSyserrno(ctrl, errno, ftpStrerror(rc));
--    /*@=observertrans@*/
--errxit2:
--    /*@-branchstate@*/
--    if (fdFileno(ctrl) >= 0)
--      /*@-refcounttrans@*/ (void) fdClose(ctrl); /*@=refcounttrans@*/
--    /*@=branchstate@*/
--    return rc;
--/*@=usereleased@*/
--}
--#endif
--
- /* XXX DYING: unused */
- void * ufdGetUrlinfo(FD_t fd)
- {
-@@ -2268,29 +2091,6 @@
+@@ -2265,29 +2236,6 @@
            fd->wr_chunked = 0;
        }
        break;
      case URL_IS_DASH:
        assert(!(flags & O_RDWR));
        fd = fdDup( ((flags & O_WRONLY) ? STDOUT_FILENO : STDIN_FILENO) );
-@@ -2908,10 +2708,8 @@
+@@ -2911,10 +2859,8 @@
            if (fd->nfps > 0 && fpno == -1 &&
                fd->fps[fd->nfps-1].io == ufdio &&
                fd->fps[fd->nfps-1].fp == fp &&
                if (fp)
                    rc = fflush(fp);
                fd->nfps--;
-@@ -2921,26 +2719,9 @@
+@@ -2924,26 +2870,9 @@
  /*@-usereleased@*/
                if (fdGetFdno(fd) >= 0)
                    break;
                        rc = fclose(fp);
                }
                fdPop(fd);
-@@ -3195,18 +2976,9 @@
-           return NULL;
-       }
-     } else {
--      FILE *fp;
--      int fdno;
--      int isHTTP = 0;
--
-       /* XXX gzdio and bzdio here too */
-       switch (urlIsURL(path)) {
--      case URL_IS_HTTPS:
--      case URL_IS_HTTP:
--      case URL_IS_HKP:
--          isHTTP = 1;
--          /*@fallthrough@*/
-       case URL_IS_PATH:
-       case URL_IS_DASH:
-       case URL_IS_FTP:
-@@ -3214,7 +2986,7 @@
+@@ -3223,7 +3152,7 @@
  if (_rpmio_debug)
  fprintf(stderr, "*** Fopen ufdio path %s fmode %s\n", path, fmode);
            fd = ufdOpen(path, flags, perms);
                return fd;
            break;
        default:
-@@ -3223,15 +2995,6 @@
-           return NULL;
-           /*@notreached@*/ break;
+@@ -3234,7 +3163,7 @@
        }
--
--      /* XXX persistent HTTP/1.1 returns the previously opened fp */
--      if (isHTTP && ((fp = fdGetFp(fd)) != NULL) && ((fdno = fdGetFdno(fd)) >= 0 || fd->req != NULL))
--      {
--          /*@+voidabstract@*/
--          fdPush(fd, fpio, fp, fileno(fp));   /* Push fpio onto stack */
--          /*@=voidabstract@*/
--          return fd;
--      }
-     }
-     /*@=branchstate@*/
  
-@@ -3267,10 +3030,6 @@
+       /* XXX persistent HTTP/1.1 returns the previously opened fp */
+-      if (isHTTP && ((fp = fdGetFp(fd)) != NULL) && ((fdno = fdGetFdno(fd)) >= 0 || fd->req != NULL))
++      if (isHTTP && ((fp = fdGetFp(fd)) != NULL) && ((fdno = fdGetFdno(fd)) >= 0))
+       {
+           /*@+voidabstract@*/
+           fdPush(fd, fpio, fp, fileno(fp));   /* Push fpio onto stack */
+@@ -3276,10 +3205,6 @@
      int i, rc = 0;
  
      if (fd == NULL) return -1;
      for (i = fd->nfps; rc == 0 && i >= 0; i--) {
  /*@-boundsread@*/
        FDSTACK_t * fps = &fd->fps[i];
-@@ -3305,9 +3064,6 @@
+@@ -3317,9 +3242,6 @@
  {
      int i, rc = -1;
  
      for (i = fd->nfps ; rc == -1 && i >= 0; i--) {
  /*@-boundsread@*/
        rc = fd->fps[i].fdno;
-diff -ur rpm-4.4.7.org/rpmio/rpmio_internal.h rpm-4.4.7/rpmio/rpmio_internal.h
---- rpm-4.4.7.org/rpmio/rpmio_internal.h       2006-06-18 20:54:59.000000000 +0200
-+++ rpm-4.4.7/rpmio/rpmio_internal.h   2006-10-17 22:18:51.308135000 +0200
-@@ -157,7 +157,6 @@
- /*@dependent@*/
-     void *    url;            /* ufdio: URL info */
- /*@relnull@*/
--    void *    req;            /* ufdio: HTTP request */
+--- rpm-4.5/rpmio/librpmio.vers~       2008-07-09 12:38:31.000000000 +0300
++++ rpm-4.5/rpmio/librpmio.vers        2008-09-04 17:52:56.158976430 +0300
+@@ -29,25 +29,6 @@
+     Chmod;
+     Chown;
+     Chroot;
+-    davClose;
+-    davClosedir;
+-    _dav_debug;
+-    davLstat;
+-    davmagicdir;
+-    davMkdir;
+-    davOpen;
+-    davOpendir;
+-    davRead;
+-    davReaddir;
+-    davRealpath;
+-    davRename;
+-    davReq;
+-    davResp;
+-    davRmdir;
+-    davSeek;
+-    davStat;
+-    davUnlink;
+-    davWrite;
+     delMacro;
+     expandMacros;
+     Fclose;
+--- rpm-4.5/lib/poptALL.c~     2007-10-23 18:53:08.000000000 +0300
++++ rpm-4.5/lib/poptALL.c      2008-09-04 17:53:21.845642132 +0300
+@@ -126,8 +126,6 @@
+ extern int _ftp_debug;
+ /*@unchecked@*/
+ extern int _av_debug;
+-/*@unchecked@*/
+-extern int _dav_debug;
  
-     int               rd_timeoutsecs; /* ufdRead: per FD_t timer */
-     ssize_t   bytesRemain;    /* ufdio: */
-diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
---- rpm-4.4.7.org/rpmio/rpmrpc.c       2006-10-03 06:38:01.000000000 +0200
-+++ rpm-4.4.7/rpmio/rpmrpc.c   2006-10-17 22:35:59.040364250 +0200
-@@ -91,10 +91,6 @@
+ /*@unchecked@*/
+ extern int noLibio;
+@@ -424,8 +422,6 @@
+       N_("debug FTP/HTTP data stream"), NULL},
+  { "avdebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_av_debug, -1,
+       N_("debug argv collections"), NULL},
+- { "davdebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_dav_debug, -1,
+-      N_("debug WebDAV data stream"), NULL},
+  { "hdrdebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_hdr_debug, -1,
+       NULL, NULL},
+  { "miredebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_mire_debug, -1,
+--- rpm-4.5/rpmio/rpmrpc.c     2008-09-04 17:56:39.132287618 +0300
++++ rpm-4.5/rpmio/rpmrpc.c     2008-09-04 17:57:38.618948392 +0300
+@@ -78,10 +78,6 @@
      case URL_IS_FTP:
        return ftpMkdir(path, mode);
        /*@notreached@*/ break;
@@ -2238,7 +2100,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_PATH:
        path = lpath;
        /*@fallthrough@*/
-@@ -118,15 +114,6 @@
+@@ -105,15 +101,6 @@
      case URL_IS_FTP:
        return ftpChdir(path);
        /*@notreached@*/ break;
@@ -2254,7 +2116,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_PATH:
        path = lpath;
        /*@fallthrough@*/
-@@ -151,10 +138,6 @@
+@@ -138,10 +125,6 @@
      case URL_IS_FTP:
        return ftpRmdir(path);
        /*@notreached@*/ break;
@@ -2265,16 +2127,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_PATH:
        path = lpath;
        /*@fallthrough@*/
-@@ -185,8 +168,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -208,10 +189,6 @@
+@@ -245,10 +228,6 @@
  
      oldut = urlPath(oldpath, &oe);
      switch (oldut) {
@@ -2285,34 +2138,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_FTP:          /* XXX WRONG WRONG WRONG */
      case URL_IS_PATH:
      case URL_IS_UNKNOWN:
-@@ -233,8 +210,6 @@
-           return -2;
-       return ftpRename(oldpath, newpath);
-       /*@notreached@*/ break;
--    case URL_IS_HTTPS:                /* XXX WRONG WRONG WRONG */
--    case URL_IS_HTTP:         /* XXX WRONG WRONG WRONG */
-     case URL_IS_PATH:
-       oldpath = oe;
-       newpath = ne;
-@@ -258,8 +233,6 @@
-     oldut = urlPath(oldpath, &oe);
-     switch (oldut) {
--    case URL_IS_HTTPS:                /* XXX WRONG WRONG WRONG */
--    case URL_IS_HTTP:         /* XXX WRONG WRONG WRONG */
-     case URL_IS_FTP:          /* XXX WRONG WRONG WRONG */
-     case URL_IS_PATH:
-     case URL_IS_UNKNOWN:
-@@ -273,8 +246,6 @@
-     newut = urlPath(newpath, &ne);
-     switch (newut) {
--    case URL_IS_HTTPS:                /* XXX WRONG WRONG WRONG */
--    case URL_IS_HTTP:         /* XXX WRONG WRONG WRONG */
-     case URL_IS_FTP:          /* XXX WRONG WRONG WRONG */
-     case URL_IS_PATH:
- if (_rpmio_debug)
-@@ -306,10 +277,6 @@
+@@ -343,10 +322,6 @@
      case URL_IS_FTP:
        return ftpUnlink(path);
        /*@notreached@*/ break;
@@ -2323,7 +2149,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_PATH:
        path = lpath;
        /*@fallthrough@*/
-@@ -1308,10 +1275,6 @@
+@@ -1354,10 +1329,6 @@
      case URL_IS_FTP:
        return ftpStat(path, st);
        /*@notreached@*/ break;
@@ -2334,7 +2160,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_PATH:
        path = lpath;
        /*@fallthrough@*/
-@@ -1338,10 +1301,6 @@
+@@ -1384,10 +1355,6 @@
      case URL_IS_FTP:
        return ftpLstat(path, st);
        /*@notreached@*/ break;
@@ -2345,79 +2171,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_PATH:
        path = lpath;
        /*@fallthrough@*/
-@@ -1373,8 +1332,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -1399,8 +1356,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -1425,8 +1380,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -1451,8 +1404,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -1477,8 +1428,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -1503,8 +1452,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -1529,8 +1476,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -1558,8 +1503,6 @@
-     case URL_IS_DASH:
-     case URL_IS_HKP:
-     case URL_IS_FTP:          /* XXX TODO: implement. */
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-       return -2;
-@@ -1577,14 +1520,6 @@
+@@ -1630,14 +1597,6 @@
      case URL_IS_FTP:
        return ftpReadlink(path, buf, bufsiz);
        /*@notreached@*/ break;
@@ -2432,25 +2186,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_PATH:
        path = lpath;
        /*@fallthrough@*/
-@@ -1617,8 +1552,6 @@
-       break;
-     case URL_IS_DASH:
-     case URL_IS_HKP:
--    case URL_IS_HTTPS:                /* XXX TODO: implement. */
--    case URL_IS_HTTP:         /* XXX TODO: implement. */
-     case URL_IS_FTP:          /* XXX TODO: implement. */
-     default:
-       errno = EINVAL;         /* XXX W2DO? */
-@@ -1685,8 +1618,6 @@
- fprintf(stderr, "*** Glob(%s,0x%x,%p,%p)\n", pattern, (unsigned)flags, (void *)errfunc, pglob);
- /*@=castfcnptr@*/
-     switch (ut) {
--    case URL_IS_HTTPS:
--    case URL_IS_HTTP:
-     case URL_IS_FTP:
- /*@-type@*/
-       pglob->gl_closedir = Closedir;
-@@ -1730,10 +1661,6 @@
+@@ -1787,10 +1746,6 @@
      case URL_IS_FTP:
        return ftpOpendir(path);
        /*@notreached@*/ break;
@@ -2461,7 +2197,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      case URL_IS_PATH:
        path = lpath;
        /*@fallthrough@*/
-@@ -1758,8 +1685,6 @@
+@@ -1815,8 +1770,6 @@
        return NULL;
      if (ISAVMAGIC(dir))
        return avReaddir(dir);
@@ -2470,7 +2206,7 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      return readdir(dir);
  }
  
-@@ -1771,8 +1696,6 @@
+@@ -1828,8 +1781,6 @@
        return 0;
      if (ISAVMAGIC(dir))
        return avClosedir(dir);
@@ -2479,93 +2215,52 @@ diff -ur rpm-4.4.7.org/rpmio/rpmrpc.c rpm-4.4.7/rpmio/rpmrpc.c
      return closedir(dir);
  }
  
-diff -ur rpm-4.4.7.org/rpmio/tget.c rpm-4.4.7/rpmio/tget.c
---- rpm-4.4.7.org/rpmio/tget.c 2004-11-19 17:52:58.000000000 +0100
-+++ rpm-4.4.7/rpmio/tget.c     2006-10-17 22:20:47.995427500 +0200
-@@ -9,8 +9,6 @@
- static int _debug = 0;
--int noNeon;
--
- #define       HTTPSPATH       "https://localhost/test.txt"
- #define       HTTPPATH        "http://localhost/test.txt"
- #define       FTPPATH         "ftp://localhost/test.txt"
-@@ -40,8 +38,6 @@
-  { "debug", 'd', POPT_ARG_VAL,        &_debug, -1,            NULL, NULL },
-  { "ftpdebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_ftp_debug, -1,
-       N_("debug protocol data stream"), NULL},
-- { "noneon", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &noNeon, 1,
--      N_("disable use of libneon for HTTP"), NULL},
-  { "rpmiodebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_rpmio_debug, -1,
-       N_("debug rpmio I/O"), NULL},
-  { "urldebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_url_debug, -1,
-diff -ur rpm-4.4.7.org/rpmio/tglob.c rpm-4.4.7/rpmio/tglob.c
---- rpm-4.4.7.org/rpmio/tglob.c        2004-11-19 17:53:05.000000000 +0100
-+++ rpm-4.4.7/rpmio/tglob.c    2006-10-17 22:21:01.712284750 +0200
-@@ -9,8 +9,6 @@
- static int _debug = 0;
--int noNeon;
--
- #define       HTTPSPATH       "https://localhost/rawhide/test/*.rpm"
- #if 0
- #define       HTTPPATH        "http://localhost/rawhide/test/*.rpm"
-@@ -52,8 +50,6 @@
-  { "debug", 'd', POPT_ARG_VAL,        &_debug, -1,            NULL, NULL },
-  { "ftpdebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_ftp_debug, -1,
-       N_("debug protocol data stream"), NULL},
-- { "noneon", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &noNeon, 1,
--      N_("disable use of libneon for HTTP"), NULL},
-  { "rpmiodebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_rpmio_debug, -1,
-       N_("debug rpmio I/O"), NULL},
-  { "urldebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_url_debug, -1,
-diff -ur rpm-4.4.7.org/rpmio/thkp.c rpm-4.4.7/rpmio/thkp.c
---- rpm-4.4.7.org/rpmio/thkp.c 2005-01-04 17:35:12.000000000 +0100
-+++ rpm-4.4.7/rpmio/thkp.c     2006-10-17 22:21:10.696846250 +0200
-@@ -10,8 +10,6 @@
- static int _debug = 0;
- static int _printing = 0;
--int noNeon;
--
- #if 0
- #define       HKPPATH         "hkp://pgp.mit.edu:11371/pks/lookup?op=get&search=0xF5C75256"
- #else
-@@ -95,8 +93,6 @@
-       N_("debug protocol data stream"), NULL},
-  { "ftpdebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_ftp_debug, -1,
-       N_("debug protocol data stream"), NULL},
-- { "noneon", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &noNeon, 1,
--      N_("disable use of libneon for HTTP"), NULL},
-  { "rpmiodebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_rpmio_debug, -1,
-       N_("debug rpmio I/O"), NULL},
-  { "urldebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_url_debug, -1,
-diff -ur rpm-4.4.7.org/rpmio/tput.c rpm-4.4.7/rpmio/tput.c
---- rpm-4.4.7.org/rpmio/tput.c 2004-11-19 17:53:11.000000000 +0100
-+++ rpm-4.4.7/rpmio/tput.c     2006-10-17 22:21:25.841792750 +0200
-@@ -9,8 +9,6 @@
+@@ -1852,14 +1803,6 @@
+     case URL_IS_FTP:
+       return ftpRealpath(path, resolved_path);
+       /*@notreached@*/ break;
+-    case URL_IS_HTTPS:        
+-    case URL_IS_HTTP:
+-    case URL_IS_HKP:
+-#ifdef WITH_NEON
+-      return davRealpath(path, resolved_path);
+-      /*@notreached@*/ break;
+-#endif
+-      /*@fallthrough@*/
+     default:
+       return xstrdup(path);
+       /*@notreached@*/ break;
+--- rpm-4.5/./rpmio/rpmio_internal.h~  2008-06-10 02:19:26.000000000 +0300
++++ rpm-4.5/./rpmio/rpmio_internal.h   2008-09-04 18:00:31.015598325 +0300
+@@ -182,7 +182,6 @@
+ /*@dependent@*/
+     void *    url;            /* ufdio: URL info */
+ /*@relnull@*/
+-    void *    req;            /* ufdio: HTTP request */
  
- static int _debug = 0;
+     int               rd_timeoutsecs; /* ufdRead: per FD_t timer */
+     ssize_t   bytesRemain;    /* ufdio: */
+--- rpm-4.5/rpmio/rpmurl.h~    2008-06-10 02:19:26.000000000 +0300
++++ rpm-4.5/rpmio/rpmurl.h     2008-09-04 18:14:00.546141703 +0300
+@@ -54,15 +54,6 @@
+ /*@relnull@*/
+     FD_t data;                        /*!< per-xfer data channel */
  
--int noNeon;
--
- #define       HTTPSPATH       "https://localhost/rawhide/toad/tput.txt"
- #define       HTTPPATH        "http://localhost/rawhide/toad/tput.txt"
- #define       FTPPATH         "ftp://localhost/home/test/tput.txt"
-@@ -100,8 +98,6 @@
-  { "debug", 'd', POPT_ARG_VAL,        &_debug, -1,            NULL, NULL },
-  { "ftpdebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_ftp_debug, -1,
-       N_("debug protocol data stream"), NULL},
-- { "noneon", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &noNeon, 1,
--      N_("disable use of libneon for HTTP"), NULL},
-  { "rpmiodebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_rpmio_debug, -1,
-       N_("debug rpmio I/O"), NULL},
-  { "urldebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_url_debug, -1,
---- rpm-4.4.8/rpmio/url.c.orig 2007-01-20 21:33:50.000000000 +0100
-+++ rpm-4.4.8/rpmio/url.c      2007-04-08 19:57:45.646376012 +0200
-@@ -146,7 +146,6 @@
+-/*@relnull@*/
+-    void * capabilities;      /*!< neon: ne_server_capabilities ptr */
+-/*@relnull@*/
+-    void * lockstore;         /*!< neon: ne_lock_store ptr */
+-/*@relnull@*/
+-    void * sess;              /*!< neon: ne_session ptr */
+-    off_t current;            /*!< neon: current body offset. */
+-    off_t total;              /*!< neon: total body length. */
+-    int connstatus;           /*!< neon: connection status. */
+ #ifdef  REFERENCE
+ typedef enum {
+     ne_conn_namelookup,       /* lookup up hostname (info = hostname) */
+--- rpm-4.5/rpmio/url.c~       2008-06-10 02:19:26.000000000 +0300
++++ rpm-4.5/rpmio/url.c        2008-09-04 20:05:19.011716915 +0300
+@@ -134,7 +134,6 @@
                        (u->scheme ? u->scheme : ""));
        /*@=usereleased@*/
      }
@@ -2573,13 +2268,14 @@ diff -ur rpm-4.4.7.org/rpmio/tput.c rpm-4.4.7/rpmio/tput.c
      u->buf = _free(u->buf);
      u->url = _free(u->url);
      u->scheme = _free((void *)u->scheme);
-@@ -348,9 +347,6 @@
- } urlstrings[] = {
-     { "file://",      URL_IS_PATH },
-     { "ftp://",               URL_IS_FTP },
--    { "hkp://",               URL_IS_HKP },
--    { "http://",      URL_IS_HTTP },
--    { "https://",     URL_IS_HTTPS },
-     { "-",            URL_IS_DASH },
-     { NULL,           URL_IS_UNKNOWN }
- };
+--- rpm-4.5/perl/Makefile.PL.in~       2008-10-05 01:31:09.000000000 +0300
++++ rpm-4.5/perl/Makefile.PL.in        2008-10-05 01:32:12.688278120 +0300
+@@ -12,7 +12,7 @@
+     'NAME'            => 'RPM',
+     'VERSION_FROM'    => 'RPM.pm', # finds $VERSION
+     'PREREQ_PM'               => {}, # e.g., Module::Name => 1.1
+-    'LIBS'            => [join(' ', @ldaddp) . ' ' . join(' ', @ldadd) . ' @LIBS@ @WITH_POPT_LIB@ @WITH_BEECRYPT_LIB@ -lneon'],
++    'LIBS'            => [join(' ', @ldaddp) . ' ' . join(' ', @ldadd) . ' @LIBS@ @WITH_POPT_LIB@ @WITH_BEECRYPT_LIB@'],
+     'DEFINE'          => join(" ", @defines), # e.g., '-DHAVE_SOMETHING'
+     'INC' => join(' ', map { '-I@top_srcdir@/'. $_ } @libdir) . ' @CPPFLAGS@',
+     'TYPEMAPS'          => [ 'typemap' ],
This page took 0.05897 seconds and 4 git commands to generate.