]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-no-neon.patch
- more
[packages/rpm.git] / rpm-no-neon.patch
index 844f698f6232b14b6b32aede9bdbbf1131f79d31..27671e3721fd051b0491a37c677201b8fb019119 100644 (file)
@@ -1,3 +1,39 @@
+--- rpm-4.4.7.org/configure.ac 2006-10-17 22:12:03.110624000 +0200
++++ rpm-4.4.7/configure.ac     2006-10-17 22:12:43.117124500 +0200
+@@ -530,33 +530,6 @@
+ AC_SUBST(WITH_BEECRYPT_INCLUDE)
+ AC_SUBST(WITH_BEECRYPT_LIB)
+-#=================
+-# Check for neon library. Prefer external, otherwise internal.
+-WITH_NEON_SUBDIR=
+-WITH_NEON_INCLUDE=
+-WITH_NEON_LIB=
+-AC_CHECK_HEADER([neon/ne_session.h], [
+-  AC_CHECK_LIB(neon, ne_session_create, [
+-    AC_DEFINE(HAVE_LIBNEON, 1, [Define to 1 if you have the 'neon' library (-lneon).])
+-    AC_CHECK_LIB(neon, ne_get_response_header, [
+-      AC_DEFINE(HAVE_NEON_NE_GET_RESPONSE_HEADER, 1, [Define to 1 if you have ne_get_response_header() in libneon.])
+-    ])
+-    AC_CHECK_LIB(neon, ne_send_request_chunk, [
+-      AC_DEFINE(HAVE_NEON_NE_SEND_REQUEST_CHUNK, 1, [Define to 1 if you have ne_send_request_chunk() in libneon.])
+-    ])
+-    WITH_NEON_INCLUDE="-I${includedir}/neon"
+-    WITH_NEON_LIB="-lneon"
+-  ])
+-],[
+-  if test -d neon ; then
+-    AC_DEFINE(HAVE_LIBNEON, 1, [Define to 1 if you have the 'neon' library (-lneon).])
+-# XXX HAVE_NEON_NE_GET_RESPONSE_HEADER assumes libneon-0.25 devel internal
+-    AC_DEFINE(HAVE_NEON_NE_GET_RESPONSE_HEADER, 1, [Define to 1 if you have ne_get_response_header() in libneon.])
+-    WITH_NEON_SUBDIR=neon
+-    WITH_NEON_INCLUDE="-I\${top_srcdir}/${WITH_NEON_SUBDIR}/src"
+-    WITH_NEON_LIB="\${top_builddir}/${WITH_NEON_SUBDIR}/src/libneon.la"
+-  fi
+-])
+ AC_SUBST(WITH_NEON_SUBDIR)
+ AC_SUBST(WITH_NEON_INCLUDE)
+ AC_SUBST(WITH_NEON_LIB)
 --- rpm-4.4.8/rpmio/rpmdav.c.orig      2007-02-20 00:51:07.000000000 +0100
 +++ rpm-4.4.8/rpmio/rpmdav.c   2007-04-08 20:07:07.814412143 +0200
 @@ -9,31 +9,6 @@
@@ -2502,7 +2538,15 @@ diff -ur rpm-4.4.7.org/rpmio/tput.c rpm-4.4.7/rpmio/tput.c
   { "urldebug", '\0', POPT_ARG_VAL|POPT_ARGFLAG_DOC_HIDDEN, &_url_debug, -1,
 --- rpm-4.4.8/rpmio/url.c.orig 2007-01-20 21:33:50.000000000 +0100
 +++ rpm-4.4.8/rpmio/url.c      2007-04-08 19:57:45.646376012 +0200
-@@ -348,9 +348,6 @@
+@@ -146,7 +146,6 @@
+                       (u->scheme ? u->scheme : ""));
+       /*@=usereleased@*/
+     }
+-    xx = davFree(u);
+     u->buf = _free(u->buf);
+     u->url = _free(u->url);
+     u->scheme = _free((void *)u->scheme);
+@@ -348,9 +347,6 @@
  } urlstrings[] = {
      { "file://",      URL_IS_PATH },
      { "ftp://",               URL_IS_FTP },
This page took 0.026255 seconds and 4 git commands to generate.