]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-macros.patch
- rpm2cpio is a script now, rpm2cpio.sh vanished
[packages/rpm.git] / rpm-macros.patch
index f42801e49707e0a1cd756eb63f924e88a741686c..e1308851cc2694ca1d785dbd08f5fe6f6206b3e5 100644 (file)
@@ -1,62 +1,71 @@
-diff -urN rpm-4.0.2.org/configure.in rpm-4.0.2/configure.in
---- rpm-4.0.2.org/configure.in Mon Apr  2 10:12:52 2001
-+++ rpm-4.0.2/configure.in     Mon Apr  2 10:29:49 2001
-@@ -1085,7 +1085,7 @@
- dnl export LIBS INCPATH CONFIG_SITE
+--- rpm-4.4.8/macros.in.orig   2007-04-08 20:24:47.206783474 +0200
++++ rpm-4.4.8/macros.in        2007-04-08 20:36:08.925632417 +0200
+@@ -206,7 +206,7 @@
+ %endif\
+ %{nil}
  
- AC_CONFIG_SUBDIRS(popt)
--AC_OUTPUT([Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec scripts/brp-redhat
-+AC_OUTPUT([Doxyfile Makefile rpmrc macros macros.pld platform rpmpopt rpm.spec scripts/brp-redhat
-       rpmio/Makefile lib/Makefile build/Makefile tools/Makefile
-       scripts/Makefile
-       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
-diff -urN rpm-4.0.2.org/macros.in rpm-4.0.2/macros.in
---- rpm-4.0.2.org/macros.in    Mon Apr  2 10:12:52 2001
-+++ rpm-4.0.2/macros.in        Mon Apr  2 11:43:51 2001
-@@ -90,7 +90,7 @@
- %_bzip2bin            @BZIP2BIN@
- %_dbpath              %{_var}/lib/rpm
- %_dbpath_rebuild      %{_dbpath}
 -%_defaultdocdir               %{_usr}/doc
 +%_defaultdocdir               %{_usr}/share/doc
+ #     The path to the pgp executable (legacy, use %{__pgp} instead).
+ %_pgpbin              %{__pgp}
+@@ -233,12 +233,12 @@
+ #     The directory where newly built source packages will be written.
+ %_srcrpmdir           %{_topdir}/SRPMS
+-#     Directory where temporaray files can be created.
+-%_tmppath             %{_var}/tmp
++#     Directory where temporary files can be created.
++%_tmppath             %(echo "${TMPDIR:-/tmp}")
+ %tmpdir                       %{_tmppath}
+ #     Path to top of build area.
+-%_topdir              %{_usrsrc}/rpm
++%_topdir              %(echo $HOME)/rpm
+ #==============================================================================
+ # ---- Optional rpmrc macros.
+@@ -248,7 +248,7 @@
+ #     Configurable build root path, same as BuildRoot: in a specfile.
+ #     (Note: the configured macro value will override the spec file value).
  #
- %__find_provides      @FINDPROVIDES@
- %__find_requires      @FINDREQUIRES@
-@@ -102,8 +102,8 @@
- %__id_u                       @__ID_U@
- %__chown_Rhf          @__CHOWN_RHF@
- %__chgrp_Rhf          @__CHGRP_RHF@
--%_fixowner            [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root
--%_fixgroup            [ `%{__id_u}` = '0' ] && %{__chgrp_Rhf} @ROOT_GROUP@
-+%_fixowner            [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
-+#%_fixgroup           [ `%{__id_u}` = '0' ] && %{__chgrp_Rhf} @ROOT_GROUP@
- %_fixperms            %{__chmod} -Rf @FIXPERMS@
+-%buildroot            %{_tmppath}/%{name}-root
++%buildroot            %{_tmppath}/%{name}-%{version}-root-%(id -u -n)
+ #     The sub-directory (relative to %{_builddir}) where sources are compiled.
+ #     This macro is set after processing %setup, either explicitly from the
+@@ -347,8 +347,8 @@
+ #             "w9.bzdio"      bzip2 level 9.
+ #             "w9.lzdio"      lzma level 9.
  #
- %_gzipbin             @GZIPBIN@
-@@ -112,13 +112,13 @@
- %_rpmdir              %{_topdir}/RPMS
+-#%_source_payload     w9.gzdio
+-#%_binary_payload     w9.gzdio
++%_source_payload      w9.gzdio
++%_binary_payload      w9.lzdio
+ #     Archive formats to use for source/binary package payloads.
+ #             "cpio"          cpio archive (default)
+@@ -498,7 +498,7 @@
  #
- # XXX Note escaped %% for use in headerSprintf
--%_rpmfilename         %%{ARCH}/%%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
-+%_rpmfilename         %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
- %_signature           none
- %_sourcedir           %{_topdir}/SOURCES
- %_specdir             %{_topdir}/SPECS
- %_srcrpmdir           %{_topdir}/SRPMS
- %_tmppath             %{_var}/tmp
--%_topdir              %{_usrsrc}/redhat
-+%_topdir              %(echo $HOME)/rpm
- %_unzipbin            @UNZIPBIN@
+ # Path to magic file used for file classification.
+-%_rpmfc_magic_path    %{_usr}/lib/rpm/magic
++%_rpmfc_magic_path    /usr/share/file/magic
  
  #==============================================================================
-@@ -461,15 +461,15 @@
+ # ---- Database configuration macros.
+@@ -1127,17 +1127,17 @@
+ %_exec_prefix         %{_prefix}
+ %_bindir              %{_exec_prefix}/bin
  %_sbindir             %{_exec_prefix}/sbin
- %_libexecdir          %{_exec_prefix}/libexec
+-%_libexecdir          %{_exec_prefix}/libexec
++%_libexecdir          %{_exec_prefix}/lib
  %_datadir             %{_prefix}/share
 -%_sysconfdir          %{_prefix}/etc
-+%_sysconfdir          /etc
- %_sharedstatedir      %{_prefix}/com
+-%_sharedstatedir      %{_prefix}/com
 -%_localstatedir               %{_prefix}/var
++%_sysconfdir          /etc
++%_sharedstatedir      /var/lib
 +%_localstatedir               /var
  %_lib                 lib
  %_libdir              %{_exec_prefix}/%{_lib}
@@ -64,18 +73,46 @@ diff -urN rpm-4.0.2.org/macros.in rpm-4.0.2/macros.in
  %_oldincludedir               /usr/include
 -%_infodir             %{_prefix}/info
 -%_mandir              %{_prefix}/man
-+%_infodir             /usr/share/info
++%_infodir             %{_prefix}/share/info
 +%_mandir              %{_prefix}/share/man
+ %_localedir           %{_datadir}/locale
  
  #==============================================================================
- # ---- config.guess platform macros.
-@@ -518,7 +518,8 @@
- CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
- FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
- %{?__libtoolize:[ -f configure.in ] && %{__libtoolize} --copy --force} ; \
--./configure %{_target_platform} \\\
-+./configure \\\
-+      --host=%{_target_platform} \\\
-       --prefix=%{_prefix} \\\
-       --exec-prefix=%{_exec_prefix} \\\
-       --bindir=%{_bindir} \\\
+@@ -1428,7 +1428,25 @@
+ # helpers are also used by %{_usrlibrpm}/rpmdeps {--provides|--requires}.
+ #%__executable_provides       %{_usrlibrpm}/executabledeps.sh --provides
+ #%__executable_requires       %{_usrlibrpm}/executabledeps.sh --requires
+-%__scriptlet_requires /bin/bash --rpm-requires
++#%__scriptlet_requires        /bin/bash --rpm-requires
++# PLD rpm macros
++%_enable_debug_packages 1
++
++#-----------------------------------------------------------------
++# CFLAGS and LDFLAGS used to build
++
++%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-2 -g2}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++# -feliminate-dwarf2-dups disabled until PR ld/3290 is fixed.
++
++%debugcflags  -O0 -g -Wall
++%optldflags   -Wl,--as-needed
++
++# Warning: those macros are overwritten by macros.build,
++#          left here for compatibility
++%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
++%rpmcxxflags  %{rpmcflags}
++%rpmldflags   %{!?no_build_with_as_needed:-Wl,--as-needed}
++  
+ # \endverbatim
+ #*/
+--- rpm-4.4.8/configure.ac.orig        2007-04-08 20:24:47.210783702 +0200
++++ rpm-4.4.8/configure.ac     2007-04-08 20:32:18.216485052 +0200
+@@ -1462,7 +1462,7 @@
+       [Full path to rpm system configuration directory (usually /etc/rpm)])
+ AC_SUBST(SYSCONFIGDIR)
+-MACROFILES="${USRLIBRPM}/macros:${USRLIBRPM}/%{_target}/macros:${SYSCONFIGDIR}/macros.*:${SYSCONFIGDIR}/macros:${SYSCONFIGDIR}/%{_target}/macros:~/.rpmmacros"
++MACROFILES="${USRLIBRPM}/macros:${USRLIBRPM}/macros.build:${USRLIBRPM}/%{_target}/macros:${SYSCONFIGDIR}/macros.*:${SYSCONFIGDIR}/macros:${SYSCONFIGDIR}/%{_target}/macros:~/etc/.rpmmacros:~/.rpmmacros"
+ AC_DEFINE_UNQUOTED(MACROFILES, "$MACROFILES",
+       [Colon separated paths of macro files to read.])
+ AC_SUBST(MACROFILES)
This page took 0.047321 seconds and 4 git commands to generate.