]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-macros.patch
- let's call it a typo
[packages/rpm.git] / rpm-macros.patch
index ec86e8e146e1d7af81440844e87055276daf2620..e1308851cc2694ca1d785dbd08f5fe6f6206b3e5 100644 (file)
@@ -1,18 +1,42 @@
-diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
---- rpm-4.4.6.orig/macros.in   2006-08-05 20:52:48.000000000 +0200
-+++ rpm-4.4.6.macros/macros.in 2006-08-05 20:53:57.000000000 +0200
-@@ -219,7 +219,7 @@
- %_tmppath             %{_var}/tmp
+--- rpm-4.4.8/macros.in.orig   2007-04-08 20:24:47.206783474 +0200
++++ rpm-4.4.8/macros.in        2007-04-08 20:36:08.925632417 +0200
+@@ -206,7 +206,7 @@
+ %endif\
+ %{nil}
+-%_defaultdocdir               %{_usr}/doc
++%_defaultdocdir               %{_usr}/share/doc
+ #     The path to the pgp executable (legacy, use %{__pgp} instead).
+ %_pgpbin              %{__pgp}
+@@ -233,12 +233,12 @@
+ #     The directory where newly built source packages will be written.
+ %_srcrpmdir           %{_topdir}/SRPMS
+-#     Directory where temporaray files can be created.
+-%_tmppath             %{_var}/tmp
++#     Directory where temporary files can be created.
++%_tmppath             %(echo "${TMPDIR:-/tmp}")
+ %tmpdir                       %{_tmppath}
  
  #     Path to top of build area.
 -%_topdir              %{_usrsrc}/rpm
 +%_topdir              %(echo $HOME)/rpm
  
- #     The path to the unzip executable (legacy, use %{__unzip} instead).
- %_unzipbin            %{__unzip}
-@@ -330,8 +330,8 @@
- #             "w9.gzdio"      gzip level 9 (default).
+ #==============================================================================
+ # ---- Optional rpmrc macros.
+@@ -248,7 +248,7 @@
+ #     Configurable build root path, same as BuildRoot: in a specfile.
+ #     (Note: the configured macro value will override the spec file value).
+ #
+-%buildroot            %{_tmppath}/%{name}-root
++%buildroot            %{_tmppath}/%{name}-%{version}-root-%(id -u -n)
+ #     The sub-directory (relative to %{_builddir}) where sources are compiled.
+ #     This macro is set after processing %setup, either explicitly from the
+@@ -347,8 +347,8 @@
  #             "w9.bzdio"      bzip2 level 9.
+ #             "w9.lzdio"      lzma level 9.
  #
 -#%_source_payload     w9.gzdio
 -#%_binary_payload     w9.gzdio
@@ -21,22 +45,45 @@ diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
  
  #     Archive formats to use for source/binary package payloads.
  #             "cpio"          cpio archive (default)
-@@ -909,10 +909,10 @@
-   export RPM_BUILD_ROOT}\
-   %{?_javaclasspath:CLASSPATH=\"%{_javaclasspath}\"\
-   export CLASSPATH}\
--  unset PERL_MM_OPT\
-+  unset PERL_MM_OPT || :\
-   LANG=C\
-   export LANG\
--  unset DISPLAY\
-+  unset DISPLAY || :\
-   \
-   %{verbose:set -x}%{!verbose:exec > /dev/null}\
-   umask 022\
-@@ -1350,5 +1350,22 @@
- #%__executable_provides       @RPMCONFIGDIR@/executabledeps.sh --provides
- #%__executable_requires       @RPMCONFIGDIR@/executabledeps.sh --requires
+@@ -498,7 +498,7 @@
+ #
+ # Path to magic file used for file classification.
+-%_rpmfc_magic_path    %{_usr}/lib/rpm/magic
++%_rpmfc_magic_path    /usr/share/file/magic
+ #==============================================================================
+ # ---- Database configuration macros.
+@@ -1127,17 +1127,17 @@
+ %_exec_prefix         %{_prefix}
+ %_bindir              %{_exec_prefix}/bin
+ %_sbindir             %{_exec_prefix}/sbin
+-%_libexecdir          %{_exec_prefix}/libexec
++%_libexecdir          %{_exec_prefix}/lib
+ %_datadir             %{_prefix}/share
+-%_sysconfdir          %{_prefix}/etc
+-%_sharedstatedir      %{_prefix}/com
+-%_localstatedir               %{_prefix}/var
++%_sysconfdir          /etc
++%_sharedstatedir      /var/lib
++%_localstatedir               /var
+ %_lib                 lib
+ %_libdir              %{_exec_prefix}/%{_lib}
+ %_includedir          %{_prefix}/include
+ %_oldincludedir               /usr/include
+-%_infodir             %{_prefix}/info
+-%_mandir              %{_prefix}/man
++%_infodir             %{_prefix}/share/info
++%_mandir              %{_prefix}/share/man
+ %_localedir           %{_datadir}/locale
+ #==============================================================================
+@@ -1428,7 +1428,25 @@
+ # helpers are also used by %{_usrlibrpm}/rpmdeps {--provides|--requires}.
+ #%__executable_provides       %{_usrlibrpm}/executabledeps.sh --provides
+ #%__executable_requires       %{_usrlibrpm}/executabledeps.sh --requires
+-%__scriptlet_requires /bin/bash --rpm-requires
++#%__scriptlet_requires        /bin/bash --rpm-requires
  
 +# PLD rpm macros
 +%_enable_debug_packages 1
@@ -44,7 +91,8 @@ diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
 +#-----------------------------------------------------------------
 +# CFLAGS and LDFLAGS used to build
 +
-+%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-2 -g2 -feliminate-dwarf2-dups}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-2 -g2}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++# -feliminate-dwarf2-dups disabled until PR ld/3290 is fixed.
 +
 +%debugcflags  -O0 -g -Wall
 +%optldflags   -Wl,--as-needed
@@ -54,6 +102,17 @@ diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
 +%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
 +%rpmcxxflags  %{rpmcflags}
 +%rpmldflags   %{!?no_build_with_as_needed:-Wl,--as-needed}
-+
++  
  # \endverbatim
  #*/
+--- rpm-4.4.8/configure.ac.orig        2007-04-08 20:24:47.210783702 +0200
++++ rpm-4.4.8/configure.ac     2007-04-08 20:32:18.216485052 +0200
+@@ -1462,7 +1462,7 @@
+       [Full path to rpm system configuration directory (usually /etc/rpm)])
+ AC_SUBST(SYSCONFIGDIR)
+-MACROFILES="${USRLIBRPM}/macros:${USRLIBRPM}/%{_target}/macros:${SYSCONFIGDIR}/macros.*:${SYSCONFIGDIR}/macros:${SYSCONFIGDIR}/%{_target}/macros:~/.rpmmacros"
++MACROFILES="${USRLIBRPM}/macros:${USRLIBRPM}/macros.build:${USRLIBRPM}/%{_target}/macros:${SYSCONFIGDIR}/macros.*:${SYSCONFIGDIR}/macros:${SYSCONFIGDIR}/%{_target}/macros:~/etc/.rpmmacros:~/.rpmmacros"
+ AC_DEFINE_UNQUOTED(MACROFILES, "$MACROFILES",
+       [Colon separated paths of macro files to read.])
+ AC_SUBST(MACROFILES)
This page took 0.033551 seconds and 4 git commands to generate.