]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-macros.patch
- obsolete
[packages/rpm.git] / rpm-macros.patch
index 1fc165d4487a0e41590c03ce91926afdd2b715b9..664ad0bd79002f7bd192cd6fcc83444d82123acb 100644 (file)
@@ -1,8 +1,22 @@
-diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
---- rpm-4.4.6.orig/macros.in   2006-08-05 20:52:48.000000000 +0200
-+++ rpm-4.4.6.macros/macros.in 2006-08-05 20:53:57.000000000 +0200
-@@ -219,7 +219,7 @@
- %_tmppath             %{_var}/tmp
+diff -ur rpm-4.4.7.org/macros.in rpm-4.4.7/macros.in
+--- rpm-4.4.7.org/macros.in    2006-09-24 21:29:28.000000000 +0200
++++ rpm-4.4.7/macros.in        2007-01-24 11:20:36.000000000 +0100
+@@ -181,7 +181,7 @@
+ %endif\
+ %{nil}
+-%_defaultdocdir               %{_usr}/doc
++%_defaultdocdir               %{_usr}/share/doc
+ #     The path to the gzip executable (legacy, use %{__gzip} instead).
+ %_gzipbin             %{__gzip}
+@@ -212,10 +212,11 @@
+ %_srcrpmdir           %{_topdir}/SRPMS
+ #     Directory where temporaray files can be created.
+-%_tmppath             %{_var}/tmp
++%_tmppath             %(echo "${TMPDIR:-/tmp}")
++%tmpdir                       %{_tmppath}
  
  #     Path to top of build area.
 -%_topdir              %{_usrsrc}/rpm
@@ -10,7 +24,16 @@ diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
  
  #     The path to the unzip executable (legacy, use %{__unzip} instead).
  %_unzipbin            %{__unzip}
-@@ -330,8 +330,8 @@
+@@ -228,7 +229,7 @@
+ #     Configurable build root path, same as BuildRoot: in a specfile.
+ #     (Note: the configured macro value will override the spec file value).
+ #
+-%buildroot            %{_tmppath}/%{name}-root
++%buildroot            %{_tmppath}/%{name}-%{version}-root-%(id -u -n)
+ #     The sub-directory (relative to %{_builddir}) where sources are compiled.
+ #     This macro is set after processing %setup, either explicitly from the
+@@ -326,8 +327,8 @@
  #             "w9.gzdio"      gzip level 9 (default).
  #             "w9.bzdio"      bzip2 level 9.
  #
@@ -21,7 +44,16 @@ diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
  
  #     Archive formats to use for source/binary package payloads.
  #             "cpio"          cpio archive (default)
-@@ -909,10 +909,10 @@
+@@ -473,7 +474,7 @@
+ #
+ # Path to magic file used for file classification.
+-%_rpmfc_magic_path    %{_usr}/lib/rpm/magic
++%_rpmfc_magic_path    /usr/share/file/magic
+ #==============================================================================
+ # ---- Database configuration macros.
+@@ -921,10 +922,10 @@
    export RPM_BUILD_ROOT}\
    %{?_javaclasspath:CLASSPATH=\"%{_javaclasspath}\"\
    export CLASSPATH}\
@@ -34,17 +66,30 @@ diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
    \
    %{verbose:set -x}%{!verbose:exec > /dev/null}\
    umask 022\
-@@ -1350,5 +1350,22 @@
+@@ -1083,7 +1084,7 @@
+ %_includedir          %{_prefix}/include
+ %_oldincludedir               /usr/include
+ %_infodir             %{_prefix}/info
+-%_mandir              %{_prefix}/man
++%_mandir              %{_prefix}/share/man
+ #==============================================================================
+ # ---- config.guess platform macros.
+@@ -1361,7 +1362,25 @@
+ # helpers are also used by @RPMCONFIGDIR@/rpmdeps {--provides|--requires}.
  #%__executable_provides       @RPMCONFIGDIR@/executabledeps.sh --provides
  #%__executable_requires       @RPMCONFIGDIR@/executabledeps.sh --requires
+-%__scriptlet_requires /bin/bash --rpm-requires
++#%__scriptlet_requires        /bin/bash --rpm-requires
++
 +# PLD rpm macros
 +%_enable_debug_packages 1
 +
 +#-----------------------------------------------------------------
 +# CFLAGS and LDFLAGS used to build
 +
-+%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -ggdb}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-2 -g2}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++# -feliminate-dwarf2-dups disabled until PR ld/3290 is fixed.
 +
 +%debugcflags  -O0 -g -Wall
 +%optldflags   -Wl,--as-needed
@@ -54,6 +99,17 @@ diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
 +%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
 +%rpmcxxflags  %{rpmcflags}
 +%rpmldflags   %{!?no_build_with_as_needed:-Wl,--as-needed}
-+
  # \endverbatim
  #*/
+--- rpm/configure.ac.org       2007-02-08 09:16:46.554623000 +0100
++++ rpm/configure.ac   2007-02-08 09:18:16.386623000 +0100
+@@ -1368,7 +1368,7 @@
+       [Full path to rpm system configuration directory (usually /etc/rpm)])
+ AC_SUBST(SYSCONFIGDIR)
+-MACROFILES="${RPMCONFIGDIR}/macros:${RPMCONFIGDIR}/%{_target}/macros:${SYSCONFIGDIR}/macros.*:${SYSCONFIGDIR}/macros:${SYSCONFIGDIR}/%{_target}/macros:~/.rpmmacros"
++MACROFILES="${RPMCONFIGDIR}/macros:${RPMCONFIGDIR}/macros.build:${RPMCONFIGDIR}/%{_target}/macros:${SYSCONFIGDIR}/macros.*:${SYSCONFIGDIR}/macros:${SYSCONFIGDIR}/%{_target}/macros:~/etc/.rpmmacros:~/.rpmmacros"
+ AC_DEFINE_UNQUOTED(MACROFILES, "$MACROFILES",
+       [Colon separated paths of macro files to read.])
+ AC_SUBST(MACROFILES)
This page took 0.036321 seconds and 4 git commands to generate.