]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-macros.patch
- tmpdir moved to main macros; sane buildroot by default
[packages/rpm.git] / rpm-macros.patch
index 4fc43638c85839b46ed609717c4b5da70c1c13ca..495206302e777708b650870382acddfa9ae5a948 100644 (file)
@@ -1,66 +1,84 @@
-diff -ur rpm-3.0.1.old/configure.in rpm-3.0.1/configure.in
---- rpm-3.0.1.old/configure.in Fri Jun  4 18:21:31 1999
-+++ rpm-3.0.1/configure.in     Fri Jun  4 18:22:00 1999
-@@ -781,7 +781,7 @@
- export LIBS INCPATH
+diff -ur rpm-4.4.7.org/macros.in rpm-4.4.7/macros.in
+--- rpm-4.4.7.org/macros.in    2007-01-06 18:28:22.094067000 +0100
++++ rpm-4.4.7/macros.in        2007-01-06 18:37:05.250762500 +0100
+@@ -217,10 +217,11 @@
+ %_srcrpmdir           %{_topdir}/SRPMS
  
- AC_CONFIG_SUBDIRS(popt)
--AC_OUTPUT([Makefile rpmrc macros lib/Makefile
-+AC_OUTPUT([Makefile rpmrc macros macros.pld lib/Makefile
-       build/Makefile tools/Makefile scripts/Makefile
-       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
-       misc/Makefile po/Makefile.in intl/Makefile],
-
---- rpm-3.0.2/macros.in.macros Fri May 14 20:59:43 1999
-+++ rpm-3.0.2/macros.in        Tue Jul 20 12:44:52 1999
-@@ -60,12 +60,12 @@
- %_builddir            %{_topdir}/BUILD
- %_buildshell          /bin/sh
- %_bzip2bin            @BZIP2BIN@
--%_dbpath              %{_var}/lib/rpm
--%_defaultdocdir               %{_usr}/doc
-+%_dbpath              %{_var}/state/rpm
-+%_defaultdocdir               %{_usr}/share/doc
- #
- # XXX fixowner, fixgroup, and fixperms are run at the end of hardcoded setup
--%_fixowner            [ `%{__id} -u` = '0' ] && %{__chown} -Rf root
--%_fixgroup            [ `%{__id} -u` = '0' ] && %{__chgrp} -Rf @ROOT_GROUP@
-+%_fixowner            [ `%{__id} -u` = '0' ] && %{__chown} -Rf root.@ROOT_GROUP@
-+#%_fixgroup           [ `%{__id} -u` = '0' ] && %{__chgrp} -Rf @ROOT_GROUP@
- %_fixperms            %{__chmod} -Rf @FIXPERMS@
+ #     Directory where temporaray files can be created.
+-%_tmppath             %{_var}/tmp
++%_tmppath             %(echo "${TMPDIR:-/tmp}")
++%tmpdir                       %{_tmppath}
+ #     Path to top of build area.
+-%_topdir              %{_usrsrc}/rpm
++%_topdir              %(echo $HOME)/rpm
+ #     The path to the unzip executable (legacy, use %{__unzip} instead).
+ %_unzipbin            %{__unzip}
+@@ -233,7 +234,7 @@
+ #     Configurable build root path, same as BuildRoot: in a specfile.
+ #     (Note: the configured macro value will override the spec file value).
  #
- %_gzipbin             @GZIPBIN@
-@@ -74,13 +74,13 @@
- %_rpmdir              %{_topdir}/RPMS
+-%buildroot            %{_tmppath}/%{name}-root
++%buildroot            %{_tmppath}/%{name}-%{version}-root-%(id -u -n)
+ #     The sub-directory (relative to %{_builddir}) where sources are compiled.
+ #     This macro is set after processing %setup, either explicitly from the
+@@ -331,8 +332,8 @@
+ #             "w9.gzdio"      gzip level 9 (default).
+ #             "w9.bzdio"      bzip2 level 9.
  #
- # XXX Note escaped %% for use in headerSprintf
--%_rpmfilename         %%{ARCH}/%%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
-+%_rpmfilename         %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
- %_signature           none
- %_sourcedir           %{_topdir}/SOURCES
- %_specdir             %{_topdir}/SPECS
- %_srcrpmdir           %{_topdir}/SRPMS
- %_tmppath             %{_var}/tmp
--%_topdir              %{_usrsrc}/redhat
-+%_topdir              %(echo $HOME)/rpm
+-#%_source_payload     w9.gzdio
+-#%_binary_payload     w9.gzdio
++%_source_payload      w9.gzdio
++%_binary_payload      w9.lzdio
+ #     Archive formats to use for source/binary package payloads.
+ #             "cpio"          cpio archive (default)
+@@ -481,7 +482,7 @@
  #
- #==============================================================================
- # ---- Optional rpmrc macros.
-@@ -153,14 +153,14 @@
- %_sbindir             %{_exec_prefix}/sbin
- %_libexecdir          %{_exec_prefix}/libexec
- %_datadir             %{_prefix}/share
--%_sysconfdir          %{_prefix}/etc
-+%_sysconfdir          /etc
- %_sharedstatedir      %{_prefix}/com
- %_localstatedir               %{_prefix}/var
- %_libdir              %{_exec_prefix}/lib
- %_includedir          %{_prefix}/include
- %_oldincludedir               /usr/include
--%_infodir             %{_prefix}/include
--%_mandir              %{_prefix}/man
-+%_infodir             /usr/share/info
-+%_mandir              %{_prefix}/share/man
+ # Path to magic file used for file classification.
+-%_rpmfc_magic_path    %{_usr}/lib/rpm/magic
++%_rpmfc_magic_path    /usr/share/file/magic
  
  #==============================================================================
- # ---- config.guess platform macros.
+ # ---- Database configuration macros.
+@@ -929,10 +930,10 @@
+   export RPM_BUILD_ROOT}\
+   %{?_javaclasspath:CLASSPATH=\"%{_javaclasspath}\"\
+   export CLASSPATH}\
+-  unset PERL_MM_OPT\
++  unset PERL_MM_OPT || :\
+   LANG=C\
+   export LANG\
+-  unset DISPLAY\
++  unset DISPLAY || :\
+   \
+   %{verbose:set -x}%{!verbose:exec > /dev/null}\
+   umask 022\
+@@ -1371,5 +1372,23 @@
+ #%__executable_requires       @RPMCONFIGDIR@/executabledeps.sh --requires
+ %__scriptlet_requires /bin/bash --rpm-requires
++# PLD rpm macros
++%_enable_debug_packages 1
++
++#-----------------------------------------------------------------
++# CFLAGS and LDFLAGS used to build
++
++%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-2 -g2}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++# -feliminate-dwarf2-dups disabled until PR ld/3290 is fixed.
++
++%debugcflags  -O0 -g -Wall
++%optldflags   -Wl,--as-needed
++
++# Warning: those macros are overwritten by macros.build,
++#          left here for compatibility
++%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
++%rpmcxxflags  %{rpmcflags}
++%rpmldflags   %{!?no_build_with_as_needed:-Wl,--as-needed}
++
+ # \endverbatim
+ #*/
+
This page took 0.0355 seconds and 4 git commands to generate.