]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-macros.patch
- added _npkgconfigdir (noarch version of _pkgconfigdir)
[packages/rpm.git] / rpm-macros.patch
index 664ad0bd79002f7bd192cd6fcc83444d82123acb..43d56e3f82d0c3852c6eeba92c4ed59b81952bb6 100644 (file)
@@ -1,30 +1,32 @@
-diff -ur rpm-4.4.7.org/macros.in rpm-4.4.7/macros.in
---- rpm-4.4.7.org/macros.in    2006-09-24 21:29:28.000000000 +0200
-+++ rpm-4.4.7/macros.in        2007-01-24 11:20:36.000000000 +0100
-@@ -181,7 +181,7 @@
+diff -urN rpm.org/macros.in rpm/macros.in
+--- rpm.org/macros.in  2007-10-02 20:46:56.430390000 +0200
++++ rpm/macros.in      2007-10-02 20:49:01.480941544 +0200
+@@ -213,7 +213,7 @@
  %endif\
  %{nil}
  
 -%_defaultdocdir               %{_usr}/doc
 +%_defaultdocdir               %{_usr}/share/doc
  
- #     The path to the gzip executable (legacy, use %{__gzip} instead).
- %_gzipbin             %{__gzip}
-@@ -212,10 +212,11 @@
+ #     The path to the pgp executable (legacy, use %{__pgp} instead).
+ %_pgpbin              %{__pgp}
+@@ -242,12 +242,12 @@
+ #     The directory where newly built source packages will be written.
  %_srcrpmdir           %{_topdir}/SRPMS
  
- #     Directory where temporaray files can be created.
+-#     Directory where temporaray files can be created.
 -%_tmppath             %{_var}/tmp
++#     Directory where temporary files can be created.
 +%_tmppath             %(echo "${TMPDIR:-/tmp}")
-+%tmpdir                       %{_tmppath}
+ %tmpdir                       %{_tmppath}
  
  #     Path to top of build area.
--%_topdir              %{_usrsrc}/rpm
+-%_topdir              @PKGSRCDIR_MACRO@
 +%_topdir              %(echo $HOME)/rpm
  
- #     The path to the unzip executable (legacy, use %{__unzip} instead).
- %_unzipbin            %{__unzip}
-@@ -228,7 +229,7 @@
+ #==============================================================================
+ # ---- Optional rpmrc macros.
+@@ -257,7 +257,7 @@
  #     Configurable build root path, same as BuildRoot: in a specfile.
  #     (Note: the configured macro value will override the spec file value).
  #
@@ -33,9 +35,9 @@ diff -ur rpm-4.4.7.org/macros.in rpm-4.4.7/macros.in
  
  #     The sub-directory (relative to %{_builddir}) where sources are compiled.
  #     This macro is set after processing %setup, either explicitly from the
-@@ -326,8 +327,8 @@
- #             "w9.gzdio"      gzip level 9 (default).
+@@ -356,8 +356,8 @@
  #             "w9.bzdio"      bzip2 level 9.
+ #             "w9.lzdio"      lzma level 9.
  #
 -#%_source_payload     w9.gzdio
 -#%_binary_payload     w9.gzdio
@@ -44,47 +46,52 @@ diff -ur rpm-4.4.7.org/macros.in rpm-4.4.7/macros.in
  
  #     Archive formats to use for source/binary package payloads.
  #             "cpio"          cpio archive (default)
-@@ -473,7 +474,7 @@
+@@ -522,7 +522,7 @@
  
  #
  # Path to magic file used for file classification.
--%_rpmfc_magic_path    %{_usr}/lib/rpm/magic
+-%_rpmfc_magic_path    %{_rpmhome}/magic
 +%_rpmfc_magic_path    /usr/share/file/magic
  
  #==============================================================================
  # ---- Database configuration macros.
-@@ -921,10 +922,10 @@
-   export RPM_BUILD_ROOT}\
-   %{?_javaclasspath:CLASSPATH=\"%{_javaclasspath}\"\
-   export CLASSPATH}\
--  unset PERL_MM_OPT\
-+  unset PERL_MM_OPT || :\
-   LANG=C\
-   export LANG\
--  unset DISPLAY\
-+  unset DISPLAY || :\
-   \
-   %{verbose:set -x}%{!verbose:exec > /dev/null}\
-   umask 022\
-@@ -1083,7 +1084,7 @@
+@@ -1224,17 +1224,17 @@
+ %_exec_prefix         %{_prefix}
+ %_bindir              %{_exec_prefix}/bin
+ %_sbindir             %{_exec_prefix}/sbin
+-%_libexecdir          %{_exec_prefix}/libexec
++%_libexecdir          %{_exec_prefix}/lib
+ %_datadir             %{_prefix}/share
+-%_sysconfdir          %{_prefix}/etc
+-%_sharedstatedir      %{_prefix}/com
+-%_localstatedir               %{_prefix}/var
++%_sysconfdir          /etc
++%_sharedstatedir      /var/lib
++%_localstatedir               /var
+ %_lib                 lib
+ %_libdir              %{_exec_prefix}/%{_lib}
  %_includedir          %{_prefix}/include
  %_oldincludedir               /usr/include
- %_infodir             %{_prefix}/info
+-%_infodir             %{_prefix}/info
 -%_mandir              %{_prefix}/man
++%_infodir             %{_prefix}/share/info
 +%_mandir              %{_prefix}/share/man
+ %_localedir           %{_datadir}/locale
  
  #==============================================================================
- # ---- config.guess platform macros.
-@@ -1361,7 +1362,25 @@
- # helpers are also used by @RPMCONFIGDIR@/rpmdeps {--provides|--requires}.
- #%__executable_provides       @RPMCONFIGDIR@/executabledeps.sh --provides
- #%__executable_requires       @RPMCONFIGDIR@/executabledeps.sh --requires
+@@ -1535,7 +1535,33 @@
+ # helpers are also used by %{_rpmhome}/rpmdeps {--provides|--requires}.
+ #%__executable_provides       %{_rpmhome}/executabledeps.sh --provides
+ #%__executable_requires       %{_rpmhome}/executabledeps.sh --requires
 -%__scriptlet_requires /bin/bash --rpm-requires
 +#%__scriptlet_requires        /bin/bash --rpm-requires
-+
 +# PLD rpm macros
 +%_enable_debug_packages 1
 +
++# provides don't obsolete
++%_upgrade_tag name
++
 +#-----------------------------------------------------------------
 +# CFLAGS and LDFLAGS used to build
 +
@@ -99,17 +106,11 @@ diff -ur rpm-4.4.7.org/macros.in rpm-4.4.7/macros.in
 +%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
 +%rpmcxxflags  %{rpmcflags}
 +%rpmldflags   %{!?no_build_with_as_needed:-Wl,--as-needed}
++
++# arch macros
++%ix86 i386 i486 i586 i686 pentium3 pentium4 athlon
++%x8664        x86_64 amd64 ia32e
++%ppc  ppc ppc7400 ppc7450
++  
  # \endverbatim
  #*/
---- rpm/configure.ac.org       2007-02-08 09:16:46.554623000 +0100
-+++ rpm/configure.ac   2007-02-08 09:18:16.386623000 +0100
-@@ -1368,7 +1368,7 @@
-       [Full path to rpm system configuration directory (usually /etc/rpm)])
- AC_SUBST(SYSCONFIGDIR)
--MACROFILES="${RPMCONFIGDIR}/macros:${RPMCONFIGDIR}/%{_target}/macros:${SYSCONFIGDIR}/macros.*:${SYSCONFIGDIR}/macros:${SYSCONFIGDIR}/%{_target}/macros:~/.rpmmacros"
-+MACROFILES="${RPMCONFIGDIR}/macros:${RPMCONFIGDIR}/macros.build:${RPMCONFIGDIR}/%{_target}/macros:${SYSCONFIGDIR}/macros.*:${SYSCONFIGDIR}/macros:${SYSCONFIGDIR}/%{_target}/macros:~/etc/.rpmmacros:~/.rpmmacros"
- AC_DEFINE_UNQUOTED(MACROFILES, "$MACROFILES",
-       [Colon separated paths of macro files to read.])
- AC_SUBST(MACROFILES)
This page took 0.059971 seconds and 4 git commands to generate.