]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-macros.patch
- avoid -L poisoning in *.la
[packages/rpm.git] / rpm-macros.patch
index 721f82a5f17a8d1cfeae927baa51a59a7383d7da..3257e0de96074ca7b6a8d92ff130c7a4c0bb6a58 100644 (file)
@@ -1,70 +1,30 @@
-diff -urN rpm-3.0.5.orig/configure.in rpm-3.0.5/configure.in
---- rpm-3.0.5.orig/configure.in        Sun Jul 16 21:02:26 2000
-+++ rpm-3.0.5/configure.in     Sat Jul 29 23:58:18 2000
-@@ -913,7 +913,7 @@
- dnl export LIBS INCPATH CONFIG_SITE
- AC_CONFIG_SUBDIRS(popt)
--AC_OUTPUT([Doxyfile Makefile rpmrc macros platform rpmpopt scripts/brp-redhat
-+AC_OUTPUT([Doxyfile Makefile rpmrc macros macros.pld platform rpmpopt scripts/brp-redhat
-       lib/Makefile build/Makefile tools/Makefile scripts/Makefile
-       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
-       misc/Makefile po/Makefile.in intl/Makefile
-diff -Nru rpm-3.0.6/macros.in rpm-3.0.6.new/macros.in
---- rpm-3.0.6/macros.in        Mon Nov  6 20:36:09 2000
-+++ rpm-3.0.6.new/macros.in    Mon Nov  6 20:37:24 2000
-@@ -88,7 +88,7 @@
- %_bzip2bin            @BZIP2BIN@
- %_dbpath              %{_var}/lib/rpm
- %_dbpath_rebuild      %{_dbpath}
--%_defaultdocdir               %{_usr}/doc
-+%_defaultdocdir               %{_usr}/share/doc
- #
- %__find_provides      @FINDPROVIDES@
- %__find_requires      @FINDREQUIRES@
-@@ -100,8 +100,8 @@
- %__id_u                       @__ID_U@
- %__chown_Rhf          @__CHOWN_RHF@
- %__chgrp_Rhf          @__CHGRP_RHF@
--%_fixowner            [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root
--%_fixgroup            [ `%{__id_u}` = '0' ] && %{__chgrp_Rhf} @ROOT_GROUP@
-+%_fixowner            [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
-+#%_fixgroup           [ `%{__id_u}` = '0' ] && %{__chgrp_Rhf} @ROOT_GROUP@
- %_fixperms            %{__chmod} -Rf @FIXPERMS@
- #
- %_gzipbin             @GZIPBIN@
-@@ -110,13 +110,13 @@
- %_rpmdir              %{_topdir}/RPMS
- #
- # XXX Note escaped %% for use in headerSprintf
--%_rpmfilename         %%{ARCH}/%%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
-+%_rpmfilename         %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
- %_signature           none
- %_sourcedir           %{_topdir}/SOURCES
- %_specdir             %{_topdir}/SPECS
- %_srcrpmdir           %{_topdir}/SRPMS
+--- ./macros.in~       2005-10-30 16:24:30.000000000 +0200
++++ ./macros.in        2005-10-30 16:24:32.000000000 +0200
+@@ -223,7 +223,7 @@
  %_tmppath             %{_var}/tmp
+ #     Path to top of build area.
 -%_topdir              %{_usrsrc}/redhat
-+%_topdir              %(echo $HOME)/rpm
++%_topdir         %(echo $HOME)/rpm
  
- #==============================================================================
- # ---- Optional rpmrc macros.
-@@ -407,15 +407,15 @@
- %_sbindir             %{_exec_prefix}/sbin
- %_libexecdir          %{_exec_prefix}/libexec
- %_datadir             %{_prefix}/share
--%_sysconfdir          %{_prefix}/etc
-+%_sysconfdir          /etc
- %_sharedstatedir      %{_prefix}/com
- %_localstatedir               %{_prefix}/var
- %_lib                 lib
- %_libdir              %{_exec_prefix}/%{_lib}
- %_includedir          %{_prefix}/include
- %_oldincludedir               /usr/include
--%_infodir             %{_prefix}/info
--%_mandir              %{_prefix}/man
-+%_infodir             /usr/share/info
-+%_mandir              %{_prefix}/share/man
+ #     The path to the unzip executable (legacy, use %{__unzip} instead).
+ %_unzipbin            %{__unzip}
+@@ -1276,5 +1276,18 @@
+ #
+ %find_lang    @RPMCONFIGDIR@/find-lang.sh %{buildroot}
  
- #==============================================================================
- # ---- config.guess platform macros.
++# PLD rpm macros
++%_enable_debug_packages 1
++
++#-----------------------------------------------------------------
++# CFLAGS and LDFLAGS used to build
++
++%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -ggdb}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++
++%debugcflags  -O0 -g -Wall
++%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
++%rpmcxxflags  %{rpmcflags}
++%rpmldflags   %{nil}
++
+ # \endverbatim
+ #*/
This page took 0.116241 seconds and 4 git commands to generate.