]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-macros.patch
- added CVE-2006-5466 patch
[packages/rpm.git] / rpm-macros.patch
index 1325e074b55d3eb65d6f474bb4995c4148b1d320..2f96d3077116a0e384b76c8478f6f64eedf21624 100644 (file)
@@ -1,70 +1,70 @@
---- rpm-3.0.4/configure.in.wiget       Wed Mar 15 13:29:09 2000
-+++ rpm-3.0.4/configure.in     Wed Mar 22 17:30:33 2000
-@@ -932,7 +932,7 @@
- dnl export LIBS INCPATH CONFIG_SITE
+diff -Nur rpm-4.4.6.orig/macros.in rpm-4.4.6.macros/macros.in
+--- rpm-4.4.6.orig/macros.in   2006-08-05 20:52:48.000000000 +0200
++++ rpm-4.4.6.macros/macros.in 2006-08-05 20:53:57.000000000 +0200
+@@ -219,7 +219,7 @@
+ %_tmppath             %{_var}/tmp
  
- AC_CONFIG_SUBDIRS(popt)
--AC_OUTPUT([Doxyfile Makefile rpmrc macros platform rpmpopt scripts/brp-redhat
-+AC_OUTPUT([Doxyfile Makefile rpmrc macros macros.pld platform rpmpopt scripts/brp-redhat
-       lib/Makefile build/Makefile tools/Makefile scripts/Makefile
-       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
-       misc/Makefile po/Makefile.in intl/Makefile
---- rpm-3.0.4/macros.in.wiget  Thu Mar  9 19:13:03 2000
-+++ rpm-3.0.4/macros.in        Wed Mar 22 17:33:43 2000
-@@ -80,9 +80,9 @@
- %_builddir            %{_topdir}/BUILD
- %_buildshell          /bin/sh
- %_bzip2bin            @BZIP2BIN@
--%_dbpath              %{_var}/lib/rpm
-+%_dbpath              %{_var}/lib/rpm
- %_rebuilddbpath               %{_dbpath}
--%_defaultdocdir               %{_usr}/doc
-+%_defaultdocdir               %{_usr}/share/doc
- #
- %__find_provides      @FINDPROVIDES@
- %__find_requires      @FINDREQUIRES@
-@@ -94,8 +94,8 @@
- %__id_u                       @__ID_U@
- %__chown_Rhf          @__CHOWN_RHF@
- %__chgrp_Rhf          @__CHGRP_RHF@
--%_fixowner            [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root
--%_fixgroup            [ `%{__id_u}` = '0' ] && %{__chgrp_Rhf} @ROOT_GROUP@
-+%_fixowner            [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
-+#%_fixgroup           [ `%{__id_u}` = '0' ] && %{__chgrp_Rhf} @ROOT_GROUP@
- %_fixperms            %{__chmod} -Rf @FIXPERMS@
+ #     Path to top of build area.
+-%_topdir              %{_usrsrc}/rpm
++%_topdir              %(echo $HOME)/rpm
+ #     The path to the unzip executable (legacy, use %{__unzip} instead).
+ %_unzipbin            %{__unzip}
+@@ -330,8 +330,8 @@
+ #             "w9.gzdio"      gzip level 9 (default).
+ #             "w9.bzdio"      bzip2 level 9.
  #
- %_gzipbin             @GZIPBIN@
-@@ -104,13 +104,13 @@
- %_rpmdir              %{_topdir}/RPMS
+-#%_source_payload     w9.gzdio
+-#%_binary_payload     w9.gzdio
++%_source_payload      w9.gzdio
++%_binary_payload      w9.lzdio
+ #     Archive formats to use for source/binary package payloads.
+ #             "cpio"          cpio archive (default)
+@@ -481,7 +481,7 @@
  #
- # XXX Note escaped %% for use in headerSprintf
--%_rpmfilename         %%{ARCH}/%%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
-+%_rpmfilename         %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
- %_signature           none
- %_sourcedir           %{_topdir}/SOURCES
- %_specdir             %{_topdir}/SPECS
- %_srcrpmdir           %{_topdir}/SRPMS
- %_tmppath             %{_var}/tmp
--%_topdir              %{_usrsrc}/redhat
-+%_topdir              %(echo $HOME)/rpm
+ # Path to magic file used for file classification.
+-%_rpmfc_magic_path    %{_usr}/lib/rpm/magic
++%_rpmfc_magic_path    /usr/share/file/magic
  
  #==============================================================================
- # ---- Optional rpmrc macros.
-@@ -384,14 +384,14 @@
- %_sbindir             %{_exec_prefix}/sbin
- %_libexecdir          %{_exec_prefix}/libexec
- %_datadir             %{_prefix}/share
--%_sysconfdir          %{_prefix}/etc
-+%_sysconfdir          /etc
- %_sharedstatedir      %{_prefix}/com
- %_localstatedir               %{_prefix}/var
- %_libdir              %{_exec_prefix}/lib
- %_includedir          %{_prefix}/include
- %_oldincludedir               /usr/include
--%_infodir             %{_prefix}/info
--%_mandir              %{_prefix}/man
-+%_infodir             %{_prefix}/share/info
-+%_mandir              %{_prefix}/share/man
+ # ---- Database configuration macros.
+@@ -909,10 +909,10 @@
+   export RPM_BUILD_ROOT}\
+   %{?_javaclasspath:CLASSPATH=\"%{_javaclasspath}\"\
+   export CLASSPATH}\
+-  unset PERL_MM_OPT\
++  unset PERL_MM_OPT || :\
+   LANG=C\
+   export LANG\
+-  unset DISPLAY\
++  unset DISPLAY || :\
+   \
+   %{verbose:set -x}%{!verbose:exec > /dev/null}\
+   umask 022\
+@@ -1350,5 +1350,23 @@
+ #%__executable_provides       @RPMCONFIGDIR@/executabledeps.sh --provides
+ #%__executable_requires       @RPMCONFIGDIR@/executabledeps.sh --requires
  
- #==============================================================================
- # ---- config.guess platform macros.
++# PLD rpm macros
++%_enable_debug_packages 1
++
++#-----------------------------------------------------------------
++# CFLAGS and LDFLAGS used to build
++
++%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-2 -g2}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++# -feliminate-dwarf2-dups disabled until PR ld/3290 is fixed.
++
++%debugcflags  -O0 -g -Wall
++%optldflags   -Wl,--as-needed
++
++# Warning: those macros are overwritten by macros.build,
++#          left here for compatibility
++%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
++%rpmcxxflags  %{rpmcflags}
++%rpmldflags   %{!?no_build_with_as_needed:-Wl,--as-needed}
++
+ # \endverbatim
+ #*/
+
This page took 0.099221 seconds and 4 git commands to generate.