]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-macros.patch
updated desktop file mimetype() support patch to 5.4
[packages/rpm.git] / rpm-macros.patch
index a7e3d7d3073d568ea2f1d218657e68d43c61ab75..02e40168c71394e1c79bba61a4f1944ec564829c 100644 (file)
@@ -1,81 +1,95 @@
-diff -urN rpm-4.0.2.org/configure.in rpm-4.0.2/configure.in
---- rpm-4.0.2.org/configure.in Mon Apr  2 10:12:52 2001
-+++ rpm-4.0.2/configure.in     Mon Apr  2 10:29:49 2001
-@@ -1085,7 +1085,7 @@
- dnl export LIBS INCPATH CONFIG_SITE
+--- rpm-5.3.1/macros/macros.rpmbuild.in.wiget  2010-05-30 17:03:38.009271449 +0200
++++ rpm-5.3.1/macros/macros.rpmbuild.in        2010-05-30 17:08:25.676741951 +0200
+@@ -123,8 +123,8 @@
+ #             "w6.lzdio"      lzma level 6 (legacy, stable).
+ #             "w6.xzdio"      xz level 6 (obsoletes lzma, unstable).
+ #
+-#%_source_payload     w9.gzdio
+-#%_binary_payload     w9.gzdio
++%_source_payload      w9.gzdio
++%_binary_payload      w9.lzdio
+ #     Archive formats to use for source/binary package payloads.
+ #             "cpio"          cpio archive (default)
+--- rpm-5.3.1/macros/macros.in.wiget   2010-05-30 17:03:38.009271449 +0200
++++ rpm-5.3.1/macros/macros.in 2010-05-30 17:06:26.886075137 +0200
+@@ -150,7 +150,7 @@ pakietu oraz przy odpluskwianiu samego p
+ %endif\
+ %{nil}
  
- AC_CONFIG_SUBDIRS(popt)
--AC_OUTPUT([Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec scripts/brp-redhat
-+AC_OUTPUT([Doxyfile Makefile rpmrc macros macros.pld platform rpmpopt rpm.spec scripts/brp-redhat
-       rpmio/Makefile lib/Makefile build/Makefile tools/Makefile
-       scripts/Makefile
-       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
-diff -urN rpm-4.0.2.org/macros.in rpm-4.0.2/macros.in
---- rpm-4.0.2.org/macros.in    Mon Apr  2 10:12:52 2001
-+++ rpm-4.0.2/macros.in        Mon Apr  2 10:30:19 2001
-@@ -90,7 +90,7 @@
- %_bzip2bin            @BZIP2BIN@
- %_dbpath              %{_var}/lib/rpm
- %_dbpath_rebuild      %{_dbpath}
 -%_defaultdocdir               %{_usr}/doc
 +%_defaultdocdir               %{_usr}/share/doc
- #
- %__find_provides      @FINDPROVIDES@
- %__find_requires      @FINDREQUIRES@
-@@ -102,8 +102,8 @@
- %__id_u                       @__ID_U@
- %__chown_Rhf          @__CHOWN_RHF@
- %__chgrp_Rhf          @__CHGRP_RHF@
--%_fixowner            [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root
--%_fixgroup            [ `%{__id_u}` = '0' ] && %{__chgrp_Rhf} @ROOT_GROUP@
-+%_fixowner            [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
-+#%_fixgroup           [ `%{__id_u}` = '0' ] && %{__chgrp_Rhf} @ROOT_GROUP@
- %_fixperms            %{__chmod} -Rf @FIXPERMS@
- #
- %_gzipbin             @GZIPBIN@
-@@ -112,13 +112,13 @@
- %_rpmdir              %{_topdir}/RPMS
- #
- # XXX Note escaped %% for use in headerSprintf
--%_rpmfilename         %%{ARCH}/%%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
-+%_rpmfilename         %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
- %_signature           none
- %_sourcedir           %{_topdir}/SOURCES
- %_specdir             %{_topdir}/SPECS
- %_srcrpmdir           %{_topdir}/SRPMS
- %_tmppath             %{_var}/tmp
--%_topdir              %{_usrsrc}/redhat
+ #     The path to the pgp executable (legacy, use %{__pgp} instead).
+ %_pgpbin              %{__pgp}
+@@ -183,14 +183,14 @@ pakietu oraz przy odpluskwianiu samego p
+ %_buildrootdir                @BUILDROOTDIR_MACRO@
+ #       Build root path, where %install installs the package during build.
+-%buildroot              %{_buildrootdir}/%{name}-root
++%buildroot            %{_tmppath}/%{name}-%{version}-root-%(id -u -n)
+-#     Directory where temporaray files can be created.
+-%_tmppath             %{_var}/tmp
++#     Directory where temporary files can be created.
++%_tmppath             %(echo "${TMPDIR:-/tmp}")
+ %tmpdir                       %{_tmppath}
+ #     Path to top of build area.
+-%_topdir              @PKGSRCDIR_MACRO@
 +%_topdir              %(echo $HOME)/rpm
- %_unzipbin            @UNZIPBIN@
  
  #==============================================================================
-@@ -461,15 +461,15 @@
+ # ---- Optional macros.
+@@ -846,11 +846,11 @@ pakietu oraz przy odpluskwianiu samego p
+ %_datarootdir         %{_prefix}/share
+ %_bindir              %{_exec_prefix}/bin
  %_sbindir             %{_exec_prefix}/sbin
- %_libexecdir          %{_exec_prefix}/libexec
- %_datadir             %{_prefix}/share
+-%_libexecdir          %{_exec_prefix}/libexec
++%_libexecdir          %{_exec_prefix}/lib
+ %_datadir             %{_datarootdir}
 -%_sysconfdir          %{_prefix}/etc
-+%_sysconfdir          /etc
- %_sharedstatedir      %{_prefix}/com
+-%_sharedstatedir      %{_prefix}/com
 -%_localstatedir               %{_prefix}/var
++%_sysconfdir          /etc
++%_sharedstatedir      /var/lib
 +%_localstatedir               /var
  %_lib                 lib
  %_libdir              %{_exec_prefix}/%{_lib}
  %_includedir          %{_prefix}/include
- %_oldincludedir               /usr/include
--%_infodir             %{_prefix}/info
--%_mandir              %{_prefix}/man
-+%_infodir             /usr/share/info
-+%_mandir              %{_prefix}/share/man
+@@ -941,7 +941,33 @@ pakietu oraz przy odpluskwianiu samego p
+ # helpers are also used by %{_rpmhome}/rpmdeps {--provides|--requires}.
+ #%__executable_provides       %{_rpmhome}/executabledeps.sh --provides
+ #%__executable_requires       %{_rpmhome}/executabledeps.sh --requires
+-%__scriptlet_requires %{__bash} --rpm-requires
++#%__scriptlet_requires        %{__bash} --rpm-requires
  
++# PLD rpm macros
++%_enable_debug_packages 1
++
++# provides don't obsolete
++%_upgrade_tag name
++
++#-----------------------------------------------------------------
++# CFLAGS and LDFLAGS used to build
++
++%debuginfocflags      %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -gdwarf-2 -g2}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
++# -feliminate-dwarf2-dups disabled until PR ld/3290 is fixed.
++
++%debugcflags  -O0 -g -Wall
++%optldflags   -Wl,--as-needed
++
++# Warning: those macros are overwritten by macros.build,
++#          left here for compatibility
++%rpmcflags    %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
++%rpmcxxflags  %{rpmcflags}
++%rpmldflags   %{!?no_build_with_as_needed:-Wl,--as-needed}
++
++# arch macros
++%ix86 i386 i486 i586 i686 pentium3 pentium4 athlon
++%x8664        x86_64 amd64 ia32e
++%ppc  ppc ppc7400 ppc7450
++  
  #==============================================================================
- # ---- config.guess platform macros.
-@@ -518,7 +518,8 @@
- CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
- FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
- %{?__libtoolize:[ -f configure.in ] && %{__libtoolize} --copy --force} ; \
--./configure %{_target_platform} \\\
-+./configure \\\
-+      --host=%{_host} \\\
-       --prefix=%{_prefix} \\\
-       --exec-prefix=%{_exec_prefix} \\\
-       --bindir=%{_bindir} \\\
+ # XXX Caveat:
+ # XXX With %{load:...} being interpreted immediately -- not lazily --
This page took 0.187077 seconds and 4 git commands to generate.