]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-glob.patch
- obsolete
[packages/rpm.git] / rpm-glob.patch
index 9ece1e802552e71194c5b13b6b5a04ba779cddc5..87ee587d449ecbef370ca0184a7f6af4f81aeee6 100644 (file)
@@ -1,59 +1,37 @@
---- rpm-4.4.1/configure.ac.orig        2005-07-15 20:06:31.000000000 +0000
-+++ rpm-4.4.1/configure.ac     2005-07-15 20:22:45.000000000 +0000
-@@ -619,7 +619,6 @@
- dnl popt w float/double needs.
- AC_CHECK_HEADERS(float.h)
+diff -urN rpm-4.4.8.org/configure.ac rpm-4.4.8/configure.ac
+--- rpm-4.4.8.org/configure.ac 2007-02-11 03:21:02.000000000 +0100
++++ rpm-4.4.8/configure.ac     2007-04-10 18:00:13.715685518 +0200
+@@ -81,6 +81,8 @@
+ AC_PATH_PROG(CTAGS, ctags, /bin/true)
+ AC_PATH_PROG(CSCOPE, cscope, /bin/true)
  
--AC_CHECK_HEADERS(glob.h)
- dnl statfs portability fiddles.
- dnl
-@@ -843,10 +842,10 @@
- dnl XXX Glob is "fixed" in glibc-2.3.3-61, but the cost is that
- dnl dangling symlinks are no longer globbed. Always use the internal glob.
- dnl
--#AC_ARG_WITH(glob, [  --with-glob             use the internal GNU glob ],
--#    [rpm_cv_glob=yes],
--#    [AC_CHECK_FUNCS(glob, rpm_cv_glob=no, rpm_cv_glob=yes)])
--#
-+AC_ARG_WITH(glob, [  --with-glob             use the internal GNU glob ],
-+    [rpm_cv_glob=yes],
-+    [AC_CHECK_FUNCS(glob, rpm_cv_glob=no, rpm_cv_glob=yes)])
++CPPFLAGS="$CPPFLAGS -Dglob=rpm_glob -Dglobfree=rpm_globfree -Dglob64=rpm_glob64 -Dglobfree64=rpm_globfree64"
 +
- #if test $rpm_cv_glob = no ; then
- #    AC_CACHE_CHECK([for GNU extensions to glob], rpm_cv_glob_ext, [
- #    rm -f t
-@@ -870,11 +869,11 @@
- #    fi
- #fi
- #
--#if test "$rpm_cv_glob" = yes; then
-+if test "$rpm_cv_glob" = yes; then
-     AC_DEFINE(USE_GNU_GLOB, 1, [Use the included glob.c?])
-     AC_LIBOBJ(glob)
-     AC_LIBOBJ(fnmatch)
--#fi
-+fi
  dnl
- dnl Auto-detect which python bindings should be built.
- dnl
---- rpm-4.4.1/misc/glob.c.orig 2005-01-28 06:19:54.000000000 +0000
-+++ rpm-4.4.1/misc/glob.c      2005-07-15 20:35:31.000000000 +0000
-@@ -130,7 +130,7 @@
-    If memory cannot be allocated for PGLOB, GLOB_NOSPACE is returned.
-    Otherwise, `glob' returns zero.  */
- int
--glob (const char *pattern, int flags,
-+rpm_glob (const char *pattern, int flags,
-       int (*errfunc) __P ((const char *, int)), glob_t *pglob)
- {
-   const char *filename;
-@@ -831,7 +831,7 @@
- /* Free storage allocated in PGLOB by a previous `glob' call.  */
- void
--globfree (glob_t *pglob)
-+rpm_globfree (glob_t *pglob)
- {
-   if (pglob->gl_pathv != NULL)
-     {
+ dnl This now uses libtool. Put
+ dnl   LDFLAGS_STATIC="-all"
+diff -urN rpm-4.4.8.org/rpmio/librpmio.vers rpm-4.4.8/rpmio/librpmio.vers
+--- rpm-4.4.8.org/rpmio/librpmio.vers  2007-02-02 02:36:47.000000000 +0100
++++ rpm-4.4.8/rpmio/librpmio.vers      2007-04-10 17:59:13.905039270 +0200
+@@ -79,10 +79,8 @@
+     Fwrite;
+     gidToGname;
+     Glob;
+-    glob64;
+     Glob_error;
+     Globfree;
+-    globfree64;
+     Glob_pattern_p;
+     gnameToGid;
+     gzdio;
+@@ -164,6 +162,10 @@
+     rpmGetPath;
+     rpmGlob;
+     rpmGlobalMacroContext;
++    rpm_glob;
++    rpm_glob64;
++    rpm_globfree;
++    rpm_globfree64;
+     rpmhookArgsFree;
+     rpmhookArgsNew;
+     rpmhookCall;
This page took 0.024285 seconds and 4 git commands to generate.