]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm-glob.patch
- removed obsolete macros.python file
[packages/rpm.git] / rpm-glob.patch
index 9ece1e802552e71194c5b13b6b5a04ba779cddc5..189c9e5b1cee18f2f41f6fd8d37dfebde1efef71 100644 (file)
@@ -1,59 +1,34 @@
---- rpm-4.4.1/configure.ac.orig        2005-07-15 20:06:31.000000000 +0000
-+++ rpm-4.4.1/configure.ac     2005-07-15 20:22:45.000000000 +0000
-@@ -619,7 +619,6 @@
- dnl popt w float/double needs.
- AC_CHECK_HEADERS(float.h)
--AC_CHECK_HEADERS(glob.h)
- dnl statfs portability fiddles.
- dnl
-@@ -843,10 +842,10 @@
- dnl XXX Glob is "fixed" in glibc-2.3.3-61, but the cost is that
- dnl dangling symlinks are no longer globbed. Always use the internal glob.
- dnl
--#AC_ARG_WITH(glob, [  --with-glob             use the internal GNU glob ],
--#    [rpm_cv_glob=yes],
--#    [AC_CHECK_FUNCS(glob, rpm_cv_glob=no, rpm_cv_glob=yes)])
--#
-+AC_ARG_WITH(glob, [  --with-glob             use the internal GNU glob ],
-+    [rpm_cv_glob=yes],
-+    [AC_CHECK_FUNCS(glob, rpm_cv_glob=no, rpm_cv_glob=yes)])
+--- rpm-4.5/rpmio/rpmrpc.c~    2010-12-19 14:19:57.678043380 +0100
++++ rpm-4.5/rpmio/rpmrpc.c     2010-12-19 14:20:39.353812967 +0100
+@@ -1711,6 +1711,17 @@
+ if (_rpmio_debug)
+ fprintf(stderr, "*** Glob(%s,0x%x,%p,%p)\n", pattern, (unsigned)flags, (void *)errfunc, pglob);
+ /*@=castfcnptr@*/
++
++    /* same as upstream glob with difference that gl_stat is Lstat now */
++    pglob->gl_closedir = closedir;
++    pglob->gl_readdir = readdir;
++    pglob->gl_opendir = opendir;
++    pglob->gl_lstat = Lstat;
++    pglob->gl_stat = Lstat;
 +
- #if test $rpm_cv_glob = no ; then
- #    AC_CACHE_CHECK([for GNU extensions to glob], rpm_cv_glob_ext, [
- #    rm -f t
-@@ -870,11 +869,11 @@
- #    fi
++/*@=type@*/
++      flags |= GLOB_ALTDIRFUNC;
++
+     switch (ut) {
+     case URL_IS_HTTPS:
+     case URL_IS_HTTP:
+--- rpm-4.5/configure.ac~      2010-12-19 13:46:37.917863585 +0100
++++ rpm-4.5/configure.ac       2010-12-19 13:50:49.826071048 +0100
+@@ -1004,8 +1004,8 @@
  #fi
  #
--#if test "$rpm_cv_glob" = yes; then
-+if test "$rpm_cv_glob" = yes; then
-     AC_DEFINE(USE_GNU_GLOB, 1, [Use the included glob.c?])
-     AC_LIBOBJ(glob)
+ #if test "$rpm_cv_glob" = yes; then
+-    AC_DEFINE(USE_GNU_GLOB, 1, [Use the included glob.c?])
+-    AC_LIBOBJ(glob)
++#    AC_DEFINE(USE_GNU_GLOB, 1, [Use the included glob.c?])
++#    AC_LIBOBJ(glob)
      AC_LIBOBJ(fnmatch)
--#fi
-+fi
- dnl
- dnl Auto-detect which python bindings should be built.
- dnl
---- rpm-4.4.1/misc/glob.c.orig 2005-01-28 06:19:54.000000000 +0000
-+++ rpm-4.4.1/misc/glob.c      2005-07-15 20:35:31.000000000 +0000
-@@ -130,7 +130,7 @@
-    If memory cannot be allocated for PGLOB, GLOB_NOSPACE is returned.
-    Otherwise, `glob' returns zero.  */
- int
--glob (const char *pattern, int flags,
-+rpm_glob (const char *pattern, int flags,
-       int (*errfunc) __P ((const char *, int)), glob_t *pglob)
- {
-   const char *filename;
-@@ -831,7 +831,7 @@
+ #fi
  
- /* Free storage allocated in PGLOB by a previous `glob' call.  */
- void
--globfree (glob_t *pglob)
-+rpm_globfree (glob_t *pglob)
- {
-   if (pglob->gl_pathv != NULL)
-     {
+
This page took 0.036785 seconds and 4 git commands to generate.