]> git.pld-linux.org Git - packages/rpm.git/blobdiff - macros.pld.in
- use rpm macros instead of configure.ac gen
[packages/rpm.git] / macros.pld.in
index ffeec4dca00fe2beb8a82842826e2420a516e104..4e1f81b715ac79531ac452778daed79cfed0320d 100644 (file)
@@ -25,7 +25,7 @@
 %_exec_prefix          %{_prefix}
 %_bindir               %{_exec_prefix}/bin
 %_sbindir              %{_exec_prefix}/sbin
-%_libexecdir           %{_exec_prefix}/%{_lib}
+%_libexecdir           %{_exec_prefix}/libexec
 %_datadir              %{_prefix}/share
 %_sysconfdir           %{_prefix}/etc
 %_sharedstatedir       /var/lib
@@ -51,6 +51,7 @@
 %{__spec_install_post_compress_modules}\
 %{__spec_install_post_check_so}\
 %{__spec_install_post_check_tmpfiles}\
+%{__spec_install_post_check_shebangs}\
 %{__spec_install_post_compress_docs}\
 %{__spec_install_post_py_hardlink}\
 %{__spec_install_post_perl_clean}\
@@ -107,7 +108,7 @@ pakietu oraz przy odpluskwianiu samego pakietu.\
 %buildroot             %{_tmppath}/%{name}-%{version}-root-%(id -u -n)
 
 %_source_payload       w9.gzdio
-%_binary_payload       w9.lzdio
+%_binary_payload       w6.lzdio
 
 %_rpmfc_magic_path     /usr/share/file/magic
 
@@ -178,7 +179,8 @@ pakietu oraz przy odpluskwianiu samego pakietu.\
 # cf http://wiki.mandriva.com/en/Development/Packaging/Problems#format_not_a_string_literal_and_no_format_arguments
 %Werror_cflags         -Wformat -Werror=format-security
 
-%_ssp_cflags           -fstack-protector --param=ssp-buffer-size=4
+# Use -Werror=trampolines to prevent GCC from generating code that require executable stack
+%_ssp_cflags           -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines
 %__common_cflags       -O2 -fwrapv -pipe %{Werror_cflags} %{debuginfocflags} %{?_fortify_cflags} %{!?nospecflags:%{?specflags}}
 %__common_cflags_with_ssp      %{__common_cflags} %{?_ssp_cflags}
 
@@ -187,6 +189,9 @@ pakietu oraz przy odpluskwianiu samego pakietu.\
 %x8664 x86_64 amd64 ia32e
 %ppc   ppc ppc7400 ppc7450
 
+# avoid fdatasync syscall flood during database operations.
+%__nofsync     nofsync
+
 #---------------------------------------------------------------------
 #      Expanded at end of %prep
 #
@@ -199,6 +204,8 @@ pakietu oraz przy odpluskwianiu samego pakietu.\
 
 %__id          /bin/id
 
+#
+# DO NOT put anything after this %%{load:...} !
 #
 # rpm5 prolog for loading the standard macro
 %{load:/etc/rpm/macros.d/*.macros}
This page took 0.053672 seconds and 4 git commands to generate.