]> git.pld-linux.org Git - packages/rpm.git/blobdiff - builder
- merged macros.java and find-java-requires script from AC-branch
[packages/rpm.git] / builder
diff --git a/builder b/builder
index ea58a588619e5690d30f593b4f38bb992304084d..da5643699544a2df84397fed8d06d6d0e705665b 100644 (file)
--- a/builder
+++ b/builder
@@ -1,6 +1,5 @@
 #!/bin/ksh
 # -----------
-# $Id$
 # Exit codes:
 #        0 - succesful
 #        1 - help displayed
 #      - when Icon: field is present, -5 and -a5 doesn't work
 #      - builder -R skips installing BR if spec is not present before builder invocation (need to run builder twice)
 
-VERSION="\
+RCSID='$Id$'
+r=${RCSID#* * }
+rev=${r%% *}
+VERSION="v0.18/$rev"
+VERSIONSTRING="\
 Build package utility from PLD Linux CVS repository
-v0.17 (C) 1999-2006 Free Penguins".
+$VERSION (C) 1999-2007 Free Penguins".
+
 PATH="/bin:/usr/bin:/usr/sbin:/sbin:/usr/X11R6/bin"
 
 COMMAND="build"
@@ -44,6 +48,9 @@ NO5=""
 ALWAYS_CVSUP=${ALWAYS_CVSUP:-"yes"}
 CVSROOT=""
 
+# user agent when fetching files
+USER_AGENT="PLD/Builder($VERSION)"
+
 # It can be used i.e. in log file naming.
 # See LOGFILE example.
 DATE=`date +%Y-%m-%d_%H-%M-%S`
@@ -72,6 +79,7 @@ ICONS=""
 PACKAGE_RELEASE=""
 PACKAGE_VERSION=""
 PACKAGE_NAME=""
+ASSUMED_NAME=""
 PROTOCOL="ftp"
 WGET_RETRIES=${MAX_WGET_RETRIES:-0}
 CVS_RETRIES=${MAX_CVS_RETRIES:-1000}
@@ -123,8 +131,10 @@ fi
 SU_SUDO=""
 if [ -n "$HOME_ETC" ]; then
        USER_CFG="$HOME_ETC/.builderrc"
+       BUILDER_MACROS="$HOME_ETC/.builder-rpmmacros"
 else
        USER_CFG=~/.builderrc
+       BUILDER_MACROS=~/.builder-rpmmacros
 fi
 
 [ -f "$USER_CFG" ] && . "$USER_CFG"
@@ -149,6 +159,7 @@ else
        wget --help 2>&1 | grep -q -- ' --no-check-certificate ' && WGET_OPTS="$WGET_OPTS --no-check-certificate"
        wget --help 2>&1 | grep -q -- ' --inet ' && WGET_OPTS="$WGET_OPTS --inet"
        wget --help 2>&1 | grep -q -- ' --retry-connrefused ' && WGET_OPTS="$WGET_OPTS --retry-connrefused"
+       WGET_OPTS="$WGET_OPTS --user-agent=$USER_AGENT"
 
        GETURI="wget --passive-ftp -c -nd -t$WGET_RETRIES $WGET_OPTS"
        GETURI2="wget -c -nd -t$WGET_RETRIES $WGET_OPTS"
@@ -192,33 +203,36 @@ usage()
 {
        if [ -n "$DEBUG" ]; then set -xv; fi
        echo "\
-Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
-[-bb|--build-binary] [-bs|--build-source] [-u|--try-upgrade]
+Usage: builder [-D|--debug] [-V|--version] [--short-version] [-a|--as_anon] [-b|-ba|--build]
+[-bb|--build-binary] [-bs|--build-source] [-bc] [-bi] [-bl] [-u|--try-upgrade]
 [{-cf|--cvs-force}] [{-B|--branch} <branch>] [{-d|--cvsroot} <cvsroot>]
 [-g|--get] [-h|--help] [--http] [{-l|--logtofile} <logfile>] [-m|--mr-proper]
 [-q|--quiet] [--date <yyyy-mm-dd> [-r <cvstag>] [{-T|--tag <cvstag>]
 [-Tvs|--tag-version-stable] [-Ts|--tag-stable] [-Tv|--tag-version]
 [{-Tp|--tag-prefix} <prefix>] [{-tt|--test-tag}]
-[-nu|--no-urls] [-v|--verbose] [--opts <rpm opts>] [--show-bconds]
-[--with/--without <feature>] [--define <macro> <value>] <package>[.spec][:cvstag]
+[-nu|--no-urls] [-v|--verbose] [--opts <rpm opts>] [--short-circuit]
+[--show-bconds] [--with/--without <feature>] [--define <macro> <value>]
+<package>[.spec][:cvstag]
 
 -5, --update-md5    - update md5 comments in spec, implies -nd -ncs
 -a5, --add-md5      - add md5 comments to URL sources, implies -nc -nd -ncs
 -n5, --no-md5       - ignore md5 comments in spec
 -D, --debug         - enable builder script debugging mode,
 -debug              - produce rpm debug package (same as --opts -debug)
--V, --version       - output builder version
+-V, --version       - output builder version string
+--short-version     - output builder short version
 -a, --as_anon       - get files via pserver as cvs@$CVS_SERVER,
 -b, -ba, --build    - get all files from CVS repo or HTTP/FTP and build package
                       from <package>.spec,
 -bb, --build-binary - get all files from CVS repo or HTTP/FTP and build binary
                       only package from <package>.spec,
 -bp, --build-prep   - execute the %prep phase of <package>.spec,
--bc                 - reserved (not implemented)
--bi                   reserved (not implemented)
+-bc                 - execute the %build phase of <package>.spec,
+-bi                 - execute the %install phase of <package>.spec
+-bl                                    - execute the %files phase of <package>.spec
 -bs, --build-source - get all files from CVS repo or HTTP/FTP and only pack
                       them into src.rpm,
---short-circuit     - reserved (not implemented)
+--short-circuit     - short-circuit build
 -B, --branch        - add branch
 -c, --clean         - clean all temporarily created files (in BUILD, SOURCES,
                       SPECS and \$RPM_BUILD_ROOT),
@@ -265,6 +279,7 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
 -sd, --source-distfiles - list sources available from distfiles (intended for offline
                       operations; does not work when Icon field is present
                       but icon file is absent),
+-sc, --source-cvs - list sources available from CVS
 -sdp, --source-distfiles-paths - list sources available from distfiles -
                       paths relative to distfiles directory (intended for offline
                       operations; does not work when Icon field is present
@@ -351,10 +366,11 @@ set_spec_target() {
        if [ -n "$SPECFILE" ] && [ -z "$TARGET" ]; then
                tmp=$(awk '/^BuildArch:/ { print $NF}' $SPECFILE)
                if [ "$tmp" ]; then
+                               target_platform=$(rpm -E '%{_target_vendor}-%{_target_os}%{?_gnu}')
                                TARGET="$tmp"
                                case "$RPMBUILD" in
                                "rpmbuild")
-                                       TARGET_SWITCH="--target $TARGET" ;;
+                                       TARGET_SWITCH="--target ${TARGET}-${target_platform}" ;;
                                "rpm")
                                        TARGET_SWITCH="--target=$TARGET" ;;
                                esac
@@ -362,34 +378,28 @@ set_spec_target() {
        fi
 }
 
-cache_rpm_dump () {
-       if [ -n "$DEBUG" ]; then
-               set -x
-               set -v
-       fi
-
-       update_shell_title "cache_rpm_dump"
-       local rpm_dump
-       rpm_dump=`
-
+# runs rpm with minimal macroset
+minirpm() {
        # we reset macros not to contain macros.build as all the %() macros are
        # executed here, while none of them are actually needed.
-       # what we need from dump is NAME, VERSION, RELEASE and PATCHES/SOURCES.
        # at the time of this writing macros.build + macros contained 70 "%(...)" macros.
-       macrofiles="/usr/lib/rpm/macros:$SPECS_DIR/.builder-rpmmacros:~/etc/.rpmmacros:~/.rpmmacros"
-       dump='%{echo:dummy: PACKAGE_NAME %{name} }%dump'
-       # FIXME: better ideas than .rpmrc?
-       printf 'include:/usr/lib/rpm/rpmrc\nmacrofiles:%s\n' $macrofiles > .builder-rpmrc
-# TODO: move these to /usr/lib/rpm/macros
-       cat > .builder-rpmmacros <<'EOF'
+       safe_macrofiles=$(rpm --showrc | awk -F: '/^macrofiles/ { gsub(/^macrofiles[ \t]+:/, "", $0); gsub(/:.*macros.build:/, ":", $0); print $0 } ')
+
+       # TODO: move these to /usr/lib/rpm/macros
+       cat > $BUILDER_MACROS <<'EOF'
+%x8664 x86_64 amd64 ia32e
+%alt_kernel %{nil}
+%_alt_kernel %{nil}
 %requires_releq_kernel_up %{nil}
 %requires_releq_kernel_smp %{nil}
+%requires_releq_kernel %{nil}
 %requires_releq() %{nil}
 %pyrequires_eq() %{nil}
 %requires_eq() %{nil}
 %requires_eq_to() %{nil}
 %releq_kernel_up ERROR
 %releq_kernel_smp ERROR
+%releq_kernel ERROR
 %kgcc_package ERROR
 %_fontsdir ERROR
 %ruby_version ERROR
@@ -401,22 +411,49 @@ cache_rpm_dump () {
 %py_ver ERROR
 %perl_vendorarch ERROR
 %perl_vendorlib ERROR
+# damn. need it here! - copied from /usr/lib/rpm/macros.build
+%tmpdir                %(echo "${TMPDIR:-/tmp}")
+%patchset_source(f:b:) %(
+       base=%{-b*}%{!-b*:10000};
+       start=$(expr $base + %1);
+       end=$(expr $base + %{?2}%{!?2:%{1}});
+       # we need to call seq twice as it doesn't allow two formats
+       seq -f 'Patch%g:' $start $end > %{tmpdir}/__ps1;
+       seq -f '%{-f*}' %1 %{?2}%{!?2:%{1}} > %{tmpdir}/__ps2;
+       paste %{tmpdir}/__ps{1,2};
+       rm -f %{tmpdir}/__ps{1,2};
+) \
+%{nil}
 EOF
-       case "$RPMBUILD" in
-       rpm)
-               ARGS='-bp'
-               ;;
-       rpmbuild)
-               ARGS='--nodigest --nosignature --nobuild'
-               ;;
-       esac
        if [ "$NOINIT" = "yes" ] ; then
-               cat >> .builder-rpmmacros <<'EOF'
+               cat >> $BUILDER_MACROS <<'EOF'
 %_specdir ./
 %_sourcedir ./
 EOF
        fi
-       $RPMBUILD --rcfile .builder-rpmrc $ARGS $ARGDIRS --nodeps --define "prep $dump" $BCOND $TARGET_SWITCH $SPECFILE 2>&1
+       eval $RPMBUILD --macros "$safe_macrofiles:$BUILDER_MACROS" $QUIET $RPMOPTS $RPMBUILDOPTS $BCOND $TARGET_SWITCH $* 2>&1
+}
+
+cache_rpm_dump() {
+       if [ -n "$DEBUG" ]; then
+               set -x
+               set -v
+       fi
+
+       update_shell_title "cache_rpm_dump"
+       local rpm_dump
+       rpm_dump=`
+               # what we need from dump is NAME, VERSION, RELEASE and PATCHES/SOURCES.
+               dump='%{echo:dummy: PACKAGE_NAME %{name} }%dump'
+               case "$RPMBUILD" in
+               rpm)
+                       ARGS='-bp'
+                       ;;
+               rpmbuild)
+                       ARGS='--nodigest --nosignature --nobuild'
+                       ;;
+               esac
+               minirpm $ARGS --define "'prep $dump'" --nodeps $SPECFILE
        `
        if [ $? -gt 0 ]; then
                error=$(echo "$rpm_dump" | sed -ne '/^error:/,$p')
@@ -435,7 +472,7 @@ EOF
        update_shell_title "cache_rpm_dump: OK!"
 }
 
-rpm_dump () {
+rpm_dump() {
        if [ -z "$rpm_dump_cache" ] ; then
                echo "internal error: cache_rpm_dump not called! (missing %prep?)" 1>&2
        fi
@@ -477,9 +514,13 @@ parse_spec()
 
        PATCHES="`rpm_dump | awk '/PATCHURL[0-9]+/ {print $3}'`"
        ICONS="`awk '/^Icon:/ {print $2}' ${SPECFILE}`"
-       PACKAGE_NAME=$(rpm_dump | awk '$2 == "PACKAGE_NAME" { print $3}')
-       PACKAGE_VERSION=$(rpm_dump | awk '$2 == "PACKAGE_VERSION" { print $3}')
-       PACKAGE_RELEASE=$(rpm_dump | awk '$2 == "PACKAGE_RELEASE" { print $3}')
+       PACKAGE_NAME=$(rpm_dump | awk '$2 == "PACKAGE_NAME" { print $3; exit}')
+       PACKAGE_VERSION=$(rpm_dump | awk '$2 == "PACKAGE_VERSION" { print $3; exit}')
+       PACKAGE_RELEASE=$(rpm_dump | awk '$2 == "PACKAGE_RELEASE" { print $3; exit}')
+
+       if [ "$PACKAGE_NAME" != "$ASSUMED_NAME" ]; then
+               echo "WARNING! Spec name ($ASSUMED_NAME) does not agree with package name ($PACKAGE_NAME)"
+       fi
 
        if [ -n "$BE_VERBOSE" ]; then
                echo "- Sources :  `nourl $SOURCES`"
@@ -515,6 +556,9 @@ Exit_error()
                        remove_build_requires
                        echo "ERROR: spec file name not specified."
                        exit 2 ;;
+               "err_invalid_cmdline" )
+                       echo "ERROR: invalid command line arg ($2)."
+                       exit 2 ;;
                "err_no_spec_in_repo" )
                        remove_build_requires
                        echo "Error: spec file not stored in CVS repo."
@@ -543,7 +587,10 @@ Exit_error()
                        remove_build_requires
                        echo "Tree branch already exists (${2})."
                        exit 11 ;;
-
+               "err_acl_deny" )
+                       remove_build_requires
+                       echo "Error: conditions reject building this spec (${2})."
+                       exit 12 ;;
        esac
        echo "Unknown error."
        exit 100
@@ -557,8 +604,8 @@ init_builder()
        fi
 
        if [ "$NOINIT" != "yes" ] ; then
-               SOURCE_DIR="`eval $RPM $RPMOPTS --eval '%{_sourcedir}'`"
-               SPECS_DIR="`eval $RPM $RPMOPTS --eval '%{_specdir}'`"
+               SOURCE_DIR="`eval $RPM $RPMOPTS --define '"name $ASSUMED_NAME"' --eval '%{_sourcedir}'`"
+               SPECS_DIR="`eval $RPM $RPMOPTS --define '"name $ASSUMED_NAME"' --eval '%{_specdir}'`"
        else
                SOURCE_DIR="."
                SPECS_DIR="."
@@ -895,7 +942,15 @@ get_files()
                                                continue
                                        fi
                                        target="$fp"
-                                       url=$(distfiles_url "$i")
+
+                                       # prefer mirror over distfiles if there's mirror
+                                       # TODO: build url list and then try each url from the list
+                                       if [ -z "$NOMIRRORS" ] && im=$(find_mirror "$i") && [ "$im" != "$i" ]; then
+                                               url="$im"
+                                       else
+                                               url=$(distfiles_url "$i")
+                                       fi
+
                                        url_attic=$(distfiles_attic_url "$i")
                                        FROM_DISTFILES=1
                                        # is $url local file?
@@ -904,9 +959,17 @@ get_files()
                                                ${GETLOCAL} $url $target
                                        else
                                                if [ -z "$NOMIRRORS" ]; then
-                                                       url="`find_mirror "$url"`"
+                                                       url=$(find_mirror "$url")
                                                fi
-                                               update_shell_title "${GETURI%% *}: $url"
+
+                                               local uri=${url}
+                                               # make shorter message for distfiles urls
+                                               if [[ "$uri" = ${PROTOCOL}${DISTFILES_SERVER}* ]] || [[ "$uri" = ${PROTOCOL}${ATTICDISTFILES_SERVER}* ]]; then
+                                                       uri=${uri#${PROTOCOL}${DISTFILES_SERVER}/distfiles/by-md5/?/?/*/}
+                                                       uri=${uri#${PROTOCOL}${ATTICDISTFILES_SERVER}/distfiles/by-md5/?/?/*/}
+                                                       uri="df: $uri"
+                                               fi
+                                               update_shell_title "${GETURI%% *}: $uri"
                                                ${GETURI} ${OUTFILEOPT} "$target" "$url" || \
                                                if [ "`echo $url | grep -E 'ftp://'`" ]; then
                                                        update_shell_title "${GETURI2%% *}: $url"
@@ -1026,10 +1089,18 @@ make_tagver() {
        if [ -z "${PACKAGE_NAME##[_0-9]*}" -a -z "$TAG_PREFIX" ]; then
                TAG_PREFIX=tag_
        fi
-       TAGVER=$TAG_PREFIX$PACKAGE_NAME-`echo $PACKAGE_VERSION | sed -e "s/\./\_/g" -e "s/@/#/g"`-`echo $PACKAGE_RELEASE | sed -e "s/\./\_/g" -e "s/@/#/g"`
+
+       # NOTE: CVS tags may must not contain the characters `$,.:;@'
+       TAGVER=$(echo $TAG_PREFIX$PACKAGE_NAME-$PACKAGE_VERSION-$PACKAGE_RELEASE | tr '[.@]' '[_#]')
+
        # Remove #kernel.version_release from TAGVER because tagging sources
        # could occur with different kernel-headers than kernel-headers used at build time.
-       TAGVER=$(echo "$TAGVER" | sed -e 's/#.*//g')
+       # besides, %{_kernel_ver_str} is not expanded.
+
+       # TAGVER=auto-ac-madwifi-ng-0-0_20070225_1#%{_kernel_ver_str}
+       # TAGVER=auto-ac-madwifi-ng-0-0_20070225_1
+
+       TAGVER=${TAGVER%#*}
        echo -n "$TAGVER"
 }
 
@@ -1045,9 +1116,9 @@ tag_files()
        echo "Version: $PACKAGE_VERSION"
        echo "Release: $PACKAGE_RELEASE"
 
-       TAGVER=`make_tagver`
-
+       local TAGVER
        if [ "$TAG_VERSION" = "yes" ]; then
+               TAGVER=`make_tagver`
                echo "CVS tag: $TAGVER"
        fi
        if [ -n "$TAG" ]; then
@@ -1075,22 +1146,22 @@ tag_files()
        if [ "$tag_files" ]; then
                if [ "$TAG_VERSION" = "yes" ]; then
                        update_shell_title "tag sources: $TAGVER"
-                       cvs $OPTIONS $TAGVER $tag_files
+                       cvs $OPTIONS $TAGVER $tag_files || exit
                fi
                if [ -n "$TAG" ]; then
                        update_shell_title "tag sources: $TAG"
-                       cvs $OPTIONS $TAG $tag_files
+                       cvs $OPTIONS $TAG $tag_files || exit
                fi
        fi
 
        cd "$SPECS_DIR"
        if [ "$TAG_VERSION" = "yes" ]; then
                update_shell_title "tag spec: $TAGVER"
-               cvs $OPTIONS $TAGVER $SPECFILE
+               cvs $OPTIONS $TAGVER $SPECFILE || exit
        fi
        if [ -n "$TAG" ]; then
                update_shell_title "tag spec: $TAG"
-               cvs $OPTIONS $TAG $SPECFILE
+               cvs $OPTIONS $TAG $SPECFILE || exit
        fi
 }
 
@@ -1122,14 +1193,26 @@ branch_files()
                fi
        done
        if [ "$tag_files" ]; then
-               cvs $OPTIONS $TAG $tag_files
+               cvs $OPTIONS $TAG $tag_files || exit
        fi
 
        cd "$SPECS_DIR"
-       cvs $OPTIONS $TAG $SPECFILE
+       cvs $OPTIONS $TAG $SPECFILE || exit
 }
 
 
+# this function should exit early if package can't be built for this arch
+# this avoids unneccessary BR filling.
+check_buildarch() {
+       local out ret
+       out=$(minirpm --short-circuit -bp --define "'prep exit 0'" --nodeps $SPECFILE 2>&1)
+       ret=$?
+       if [ $ret -ne 0 ]; then
+               echo >&2 "$out"
+               exit $ret
+       fi
+}
+
 
 build_package()
 {
@@ -1178,6 +1261,13 @@ build_package()
                        BUILD_SWITCH="-bs --nodeps" ;;
                build-prep )
                        BUILD_SWITCH="-bp --nodeps" ;;
+               build-build )
+                       BUILD_SWITCH="-bc" ;;
+               build-install )
+                       BUILD_SWITCH="-bi" ;;
+               build-list )
+                       BUILD_SWITCH="-bl" ;;
+
        esac
 
        update_shell_title "build_package: $COMMAND"
@@ -1536,37 +1626,39 @@ fetch_build_requires()
        if [ "${FETCH_BUILD_REQUIRES}" = "yes" ]; then
                update_shell_title "fetch build requires"
                if [ "$FETCH_BUILD_REQUIRES_RPMGETDEPS" = "yes" ]; then
-                       local CONF=$(rpm-getdeps $BCOND $SPECFILE 2> /dev/null | awk '/^\-/ { print $3 } ' | _rpm_cnfl_check | xargs)
+                       # TODO: Conflicts list doesn't check versions
+                       local CNFL=$(rpm-getdeps $BCOND $SPECFILE 2> /dev/null | awk '/^\-/ { print $3 } ' | _rpm_cnfl_check | xargs)
                        local DEPS=$(rpm-getdeps $BCOND $SPECFILE 2> /dev/null | awk '/^\+/ { print $3 } ' | _rpm_prov_check | xargs)
 
-                       update_shell_title "poldek: update indexes"
-                       if [ -n "$CONF" ] || [ -n "$DEPS" ]; then
+                       if [ -n "$CNFL" ] || [ -n "$DEPS" ]; then
+                               echo "fetch builderequires: install $DEPS; remove $CNFL"
+                               update_shell_title "poldek: install $DEPS; remove $CNFL"
                                $SU_SUDO /usr/bin/poldek -q --update || $SU_SUDO /usr/bin/poldek -q --upa
                        fi
-                       if [ -n "$CONF" ]; then
-                               update_shell_title "uninstall conflicting packages: $CONF"
-                               echo "Trying to uninstall conflicting packages ($CONF):"
-                               $SU_SUDO /usr/bin/poldek --noask --nofollow -ev $CONF
+                       if [ -n "$CNFL" ]; then
+                               update_shell_title "uninstall conflicting packages: $CNFL"
+                               echo "Trying to uninstall conflicting packages ($CNFL):"
+                               $SU_SUDO /usr/bin/poldek --noask --nofollow -ev $CNFL
                        fi
 
-               while [ "$DEPS" ]; do
-                               update_shell_title "install deps: $DEPS"
-                               echo "Trying to install dependencies ($DEPS):"
-                               local log=.${SPECFILE}_poldek.log
-                               $SU_SUDO /usr/bin/poldek --caplookup -uGq $DEPS | tee $log
-                               failed=$(awk -F: '/^error:/{print $2}' $log)
-                               rm -f $log
-                               local ok
-                               if [ -n "$failed" ]; then
-                                       for package in $failed; do
-                                               # FIXME: sanitise, deps could be not .spec files
-                                               spawn_sub_builder -bb $package && ok="$ok $package"
-                                       done
-                                       DEPS="$ok"
-                               else
-                                       DEPS=""
-                               fi
-               done
+                       while [ "$DEPS" ]; do
+                                       update_shell_title "install deps: $DEPS"
+                                       echo "Trying to install dependencies ($DEPS):"
+                                       local log=.${SPECFILE}_poldek.log
+                                       $SU_SUDO /usr/bin/poldek --caplookup -uGq $DEPS | tee $log
+                                       failed=$(awk -F: '/^error:/{print $2}' $log)
+                                       rm -f $log
+                                       local ok
+                                       if [ -n "$failed" ]; then
+                                               for package in $failed; do
+                                                       # FIXME: sanitise, deps could be not .spec files
+                                                       spawn_sub_builder -bb $package && ok="$ok $package"
+                                               done
+                                               DEPS="$ok"
+                                       else
+                                               DEPS=""
+                                       fi
+                       done
                        return
                fi
 
@@ -1720,7 +1812,7 @@ init_rpm_dir() {
 
        mkdir -p $TOP_DIR/{RPMS,BUILD,SRPMS}
        cd $TOP_DIR
-       cvs -d $CVSROOT co SOURCES/.cvsignore SPECS/{mirrors,adapter{,.awk},fetchsrc_request,builder,{relup,repackage}.sh}
+       cvs -d $CVSROOT co SOURCES/.cvsignore SPECS/{mirrors,adapter{,.awk},fetchsrc_request,builder,{relup,compile,repackage}.sh}
 
        init_builder
 
@@ -1763,16 +1855,24 @@ while [ $# -gt 0 ]; do
                        DEBUG="yes"; shift ;;
                -V | --version )
                        COMMAND="version"; shift ;;
+               --short-version )
+                       COMMAND="short-version"; shift ;;
                -a | --as_anon )
                        CVSROOT=":pserver:cvs@$CVS_SERVER:/cvsroot"; shift ;;
                -b | -ba | --build )
                        COMMAND="build"; shift ;;
                -bb | --build-binary )
                        COMMAND="build-binary"; shift ;;
-               -bs | --build-source )
-                       COMMAND="build-source"; shift ;;
+               -bc )
+                       COMMAND="build-build"; shift ;;
+               -bi )
+                       COMMAND="build-install"; shift ;;
+               -bl )
+                       COMMAND="build-list"; shift ;;
                -bp | --build-prep )
                        COMMAND="build-prep"; shift ;;
+               -bs | --build-source )
+                       COMMAND="build-source"; shift ;;
                -B | --branch )
                        COMMAND="branch"; shift; TAG="${1}"; shift;;
                -c | --clean )
@@ -1868,6 +1968,9 @@ while [ $# -gt 0 ]; do
                -FRB | --force-remove-build-requires)
                        REMOVE_BUILD_REQUIRES="force"
                        shift ;;
+               -sc | --sources-cvs)
+                       COMMAND="list-sources-cvs"
+                       shift ;;
                -sd | --sources-distfiles)
                        COMMAND="list-sources-distfiles"
                        shift ;;
@@ -1943,6 +2046,10 @@ while [ $# -gt 0 ]; do
                                RPMOPTS="${RPMOPTS} --define \"${MACRO} ${VALUE}\""
                        fi
                        ;;
+               --short-circuit)
+                       RPMBUILDOPTS="${RPMBUILDOPTS} --short-circuit"
+                       shift
+                       ;;
                --show-bconds | -show-bconds | -print-bconds | --print-bconds | -display-bconds | --display-bconds )
                        COMMAND="show_bconds"
                        shift
@@ -1956,7 +2063,11 @@ while [ $# -gt 0 ]; do
                        RPMOPTS="${RPMOPTS} --nodeps"
                        ;;
                -debug)
-                       RPMBUILDOPTS="${RPMBUILDOPTS} -debug"; shift ;;
+                       RPMBUILDOPTS="${RPMBUILDOPTS} -debug"; shift
+                       ;;
+               -* )
+                       Exit_error err_invalid_cmdline "$1"
+                       ;;
                * )
                        SPECFILE="${1}"
                        # check if specname was passed as specname:cvstag
@@ -1964,11 +2075,12 @@ while [ $# -gt 0 ]; do
                                CVSTAG="${SPECFILE##*:}"
                                SPECFILE="${SPECFILE%%:*}"
                        fi
+                       ASSUMED_NAME="${SPECFILE%%.spec}"
                        shift
        esac
 done
 
-if [ -z "$CVSTAG" ]; then
+if [ -f CVS/Entries ] && [ -z "$CVSTAG" ]; then
        CVSTAG=$(awk -vSPECFILE="${SPECFILE%.spec}.spec" -F/ '$2 == SPECFILE && $6 ~ /^T/{print substr($6, 2)}' CVS/Entries)
        if [ "$CVSTAG" ]; then
                echo >&2 "builder: Stick tag $CVSTAG active. Use -r TAGNAME to override."
@@ -2018,7 +2130,7 @@ case "$COMMAND" in
                        echo "$BCOND"
                fi
                ;;
-       "build" | "build-binary" | "build-source" | "build-prep" )
+       "build" | "build-binary" | "build-source" | "build-prep" | "build-build" | "build-install" | "build-list")
                init_builder
                if [ -n "$SPECFILE" ]; then
                        get_spec
@@ -2026,6 +2138,9 @@ case "$COMMAND" in
                        set_bconds_values
                        display_bconds
                        display_branches
+                       if [ "$COMMAND" != "build-source" ]; then
+                               check_buildarch
+                       fi
                        fetch_build_requires
                        if [ "$INTEGER_RELEASE" = "yes" ]; then
                                echo "Checking release $PACKAGE_RELEASE..."
@@ -2034,8 +2149,18 @@ case "$COMMAND" in
                                fi
                        fi
 
+                       # ./builder -bs test.spec -r AC-branch -Tp auto-ac- -tt
                        if [ -n "$TEST_TAG" ]; then
-                               TAGVER=`make_tagver`
+                               # - do not allow utf8 encoded specs on AC-branch
+                               if [ "$CVSTAG" = "AC-branch-disabled" ]; then
+                                       local t
+                                       t=$(grep '^Summary(.*\.UTF-8):' $SPECFILE)
+                                       if [ "$t" ]; then
+                                               Exit_error err_acl_deny "UTF-8 .specs not allowed on $CVSTAG"
+                                       fi
+                               fi
+
+                               local TAGVER=`make_tagver`
                                echo "Searching for tag $TAGVER..."
                                TAGREL=$(cvs status -v $SPECFILE | grep -E "^[[:space:]]*${TAGVER}[[[:space:]]" | sed -e 's#.*(revision: ##g' -e 's#).*##g')
                                if [ -n "$TAGREL" ]; then
@@ -2051,6 +2176,7 @@ case "$COMMAND" in
                                                Exit_error err_branch_exists "$TAG_STATUS"
                                        fi
                                fi
+
                        fi
 
                        if [ -n "$NOSOURCE0" ] ; then
@@ -2195,13 +2321,30 @@ case "$COMMAND" in
                        fi
                done
                ;;
+       "list-sources-cvs" )
+               init_builder
+#              NOCVSSPEC="yes"
+               DONT_PRINT_REVISION="yes"
+               get_spec
+               parse_spec
+               for SAP in $SOURCES $PATCHES; do
+                       if [ -z "$(src_md5 "$SAP")" ]; then
+                               echo $SAP | awk '{gsub(/.*\//,"") ; print}'
+                       fi
+               done
+               ;;
        "init_rpm_dir")
                init_rpm_dir
                ;;
        "usage" )
-               usage;;
+               usage
+               ;;
+       "short-version" )
+               echo "$VERSION"
+               ;;
        "version" )
-               echo "$VERSION";;
+               echo "$VERSIONSTRING"
+               ;;
 esac
 if [ -f "`pwd`/.${SPECFILE}_INSTALLED_PACKAGES" -a "$REMOVE_BUILD_REQUIRES" != "" ]; then
        rm "`pwd`/.${SPECFILE}_INSTALLED_PACKAGES"
This page took 0.060284 seconds and 4 git commands to generate.