]> git.pld-linux.org Git - packages/rpm.git/blob - rpm5-db-compat.patch
- cleanup upgrade path from rpm5
[packages/rpm.git] / rpm5-db-compat.patch
1 --- rpm-4.15.1/lib/header.c~    2019-11-04 21:13:13.000000000 +0900
2 +++ rpm-4.15.1/lib/header.c     2019-12-31 19:48:06.709777565 +0900
3 @@ -277,6 +277,12 @@
4      for (i = 0; i < il; i++) {
5         ei2h(&pe[i], &info);
6  
7 +       /* XXX rpm5 compat: convert RPMTAG_FILESTATE to RPM_CHAR_TYPE. */
8 +       if (info.tag == RPMTAG_FILESTATES && info.type == RPM_INT8_TYPE) {
9 +           info.type = RPM_CHAR_TYPE;
10 +           pe[i].type = htonl(info.type);
11 +       }
12 +
13         /* Previous data must not overlap */
14         if (end > info.offset)
15             goto err;
This page took 0.031796 seconds and 3 git commands to generate.