]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- backported %%exclude feature from 4.0.4 ('exclude' patch)
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        73
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Source14:       %{name}-groups-po.awk
28 Source15:       %{name}-compress-doc
29 Patch0:         %{name}-rpmrc.patch
30 Patch1:         %{name}-macros.patch
31 Patch2:         %{name}-arch.patch
32 Patch3:         %{name}-rpmpopt.patch
33 Patch4:         %{name}-perl-macros.patch
34 Patch5:         %{name}-db3.patch
35 Patch6:         %{name}-segv.patch
36 Patch7:         %{name}-am_fix.patch
37 Patch8:         %{name}-perl-req-perlfile.patch
38 Patch9:         %{name}-installplatform.patch
39 Patch10:        %{name}-cache.patch
40 Patch11:        %{name}-suggestions.patch
41 Patch12:        %{name}-rh-lame.patch
42 Patch13:        %{name}-glob.patch
43 Patch14:        %{name}-header_h.patch
44 Patch15:        %{name}-fast-alAddPackage.patch
45 Patch16:        %{name}-byKey.patch
46 Patch17:        %{name}-perlprov.patch
47 Patch18:        %{name}-noperldir.patch
48 Patch19:        popt-cvs20010530.patch
49 Patch20:        %{name}-noexpand.patch
50 Patch21:        %{name}-scripts-closefds.patch
51 Patch22:        %{name}-python-amfix.patch
52 Patch23:        %{name}-non-english-man-pages.patch
53 Patch24:        %{name}-progress-nontty.patch
54 Patch25:        %{name}-am_ac.patch
55 Patch26:        %{name}-python-macros.patch
56 Patch27:        %{name}-hardlink-fixes.patch
57 Patch28:        %{name}-perlprov-regonly.patch
58 Patch29:        %{name}-cxx.patch
59 Patch30:        %{name}-athlon.patch
60 Patch31:        %{name}-athlon-identify.patch
61 Patch32:        %{name}-gettext-in-header.patch
62 Patch33:        %{name}-perlprov-perl5.6.patch
63 Patch34:        %{name}-ac25x.patch
64 Patch35:        %{name}-signverify-fix.patch
65 Patch36:        %{name}-compress-doc.patch
66 Patch37:        %{name}-short_circuit.patch
67 Patch38:        %{name}-test_stage.patch
68 Patch39:        %{name}-exclude.patch
69 URL:            http://www.rpm.org/
70 Icon:           rpm.gif
71 BuildRequires:  autoconf >= 2.50
72 BuildRequires:  automake
73 BuildRequires:  bzip2-devel >= 1.0.1
74 BuildRequires:  db1-devel >= 1.85
75 BuildRequires:  db3-devel >= 3.1.17-9
76 BuildRequires:  gettext-devel >= 0.10.38-3
77 BuildRequires:  libtool
78 BuildRequires:  patch >= 2.2
79 BuildRequires:  python-devel >= 2.2.1
80 BuildRequires:  python-modules >= 2.2.1
81 BuildRequires:  zlib-devel >= 1.1.4
82 %if %{!?_without_static:1}%{?_without_static:0}
83 # Require static library only for static build
84 BuildRequires:  bzip2-static >= 1.0.1
85 BuildRequires:  db1-static >= 1.85
86 BuildRequires:  db3-static >= 3.1.17-9
87 BuildRequires:  glibc-static >= 2.2.0
88 BuildRequires:  zlib-static >= 1.1.4
89 %endif
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91 Obsoletes:      rpm-libs
92 Conflicts:      glibc < 2.2
93
94 %define         __find_provides %{SOURCE4}
95 %define         _binary_payload w9.gzdio
96
97 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
98 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
99 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
100 %define         py_sitedir      %{py_libdir}/site-packages
101 %define         py_dyndir       %{py_libdir}/lib-dynload
102 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
103
104 %description
105 RPM is a powerful package manager, which can be used to build,
106 install, query, verify, update, and uninstall individual software
107 packages. A package consists of an archive of files, and package
108 information, including name, version, and description.
109
110 %description -l de
111 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
112 Installation, Anfrage, Verifizierung, Aktualisierung und
113 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
114 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
115 Beschreibung.
116
117 %description -l es
118 RPM es un poderoso administrador de paquetes, que puede ser usado para
119 construir, instalar, pesquisar, verificar, actualizar y desinstalar
120 paquetes individuales de software. Un paquete consiste en un
121 almacenaje de archivos, y información sobre el paquete, incluyendo
122 nombre, versión y descripción.
123
124 %description -l pl
125 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
126 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
127 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
128 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
129 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
130 odpytywania programu rpm.
131
132 %description -l pt_BR
133 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
134 construir, instalar, pesquisar, verificar, atualizar e desinstalar
135 pacotes individuais de software. Um pacote consiste de um conjunto de
136 arquivos e informações adicionais, incluindo nome, versão e descrição
137 do pacote, permissões dos arquivos, etc.
138
139 %package devel
140 Summary:        Header files and libraries
141 Summary(de):    Header-Dateien uns Libraries
142 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
143 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
144 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
145 Group:          Development/Libraries
146 Requires:       %{name} = %{version}
147 Requires:       popt-devel
148
149 %description devel
150 The RPM packaging system includes a C library that makes it easy to
151 manipulate RPM packages and databases. It is intended to ease the
152 creation of graphical package managers and other tools that need
153 intimate knowledge of RPM packages.
154
155 %description devel -l de
156 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
157 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
158 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
159 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
160
161 %description devel -l es
162 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
163 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
164 facilitar la creación de administradores gráficos de paquetes y otras
165 herramientas que necesiten un conocimiento profundo de paquetes RPM.
166
167 %description devel -l pl
168 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
169 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
170 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
171 szczegó³owej wiedzy na temat pakietów RPM.
172
173 %description devel -l pt_BR
174 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
175 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
176 facilitar a criação de gerenciadores gráficos de pacotes e outras
177 ferramentas que precisem de conhecimento profundo de pacotes RPM.
178
179 %package static
180 Summary:        RPM static libraries
181 Summary(de):    RPMs statische Libraries
182 Summary(pl):    Biblioteki statyczne RPM-a
183 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}
186
187 %description static
188 RPM static libraries.
189
190 %description static -l de
191 RPMs statische Libraries.
192
193 %description static -l pl
194 Biblioteki statyczne RPM-a.
195
196 %description static -l pt_BR
197 Bibliotecas estáticas para desenvolvimento.
198
199 %package utils
200 Summary:        Additional utilities for managing rpm packages and database
201 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
202 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
203 Group:          Applications/File
204 Requires:       %{name} = %{version}
205
206 %description utils
207 Additional utilities for managing rpm packages and database.
208
209 %description utils -l de
210 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
211
212 %description utils -l pl
213 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
214
215 %package perlprov
216 Summary:        Additional utilities for checking perl provides/requires in rpm packages
217 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
218 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
219 Group:          Applications/File
220 Requires:       %{name} = %{version}
221 Requires:       perl-modules
222 Requires:       findutils
223
224 %description perlprov
225 Additional utilities for checking perl provides/requires in rpm
226 packages.
227
228 %description perlprov -l de
229 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
230
231 %description perlprov -l pl
232 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
233 pakietach rpm.
234
235 %package pythonprov
236 Summary:        Python macros, which simplifies creation of rpm packages with Python software
237 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
238 Group:          Applications/File
239 Requires:       %{name} = %{version}
240 Requires:       python-modules
241
242 %description pythonprov
243 Python macros, which simplifies creation of rpm packages with Python
244 software.
245
246 %description pythonprov -l pl
247 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
248 Pythonie.
249
250 %package -n python-rpm
251 Summary:        Python interface to RPM library
252 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
253 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
254 Group:          Libraries/Python
255 Requires:       %{name} = %{version}
256 %pyrequires_eq  python
257 Obsoletes:      rpm-python
258
259 %description -n python-rpm
260 The rpm-python package contains a module which permits applications
261 written in the Python programming language to use the interface
262 supplied by RPM (RPM Package Manager) libraries.
263
264 This package should be installed if you want to develop Python
265 programs that will manipulate RPM packages and databases.
266
267 %description -n python-rpm -l pl
268 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
269 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
270
271 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
272 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
273
274 %description -n python-rpm -l pt_BR
275 O pacote rpm-python contém um módulo que permite que aplicações
276 escritas em Python utilizem a interface fornecida pelas bibliotecas
277 RPM (RPM Package Manager).
278
279 Esse pacote deve ser instalado se você quiser desenvolver programas em
280 Python para manipular pacotes e bancos de dados RPM.
281
282 %package build
283 Summary:        Scripts for building binary RPM packages
284 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
285 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
286 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
287 Group:          Applications/File
288 Requires:       %{name} = %{version}
289 Requires:       /bin/id
290 Requires:       awk
291 Requires:       binutils
292 Requires:       diffutils
293 Requires:       file >= 3.31
294 Requires:       fileutils
295 Requires:       findutils
296 %ifarch athlon
297 Requires:       gcc >= 3.0.3
298 %else
299 Requires:       gcc
300 %endif
301 Requires:       glibc-devel
302 Requires:       grep
303 Requires:       gzip
304 Requires:       make
305 Requires:       patch
306 Requires:       popt >= 1.6.2-2
307 Requires:       sed
308 Requires:       sh-utils
309 Requires:       tar
310 Requires:       textutils
311
312 %description build
313 Scripts for building binary RPM packages.
314
315 %description build -l de
316 Scripts fürs Bauen binärer RPM-Pakete.
317
318 %description build -l pl
319 Skrypty pomocnicze do budowania binarnych RPM-ów.
320
321 %description build -l pt_BR
322 Este pacote contém scripts e programas executáveis que são usados para
323 construir pacotes usando o RPM.
324
325 %prep
326 %setup -q -a12
327 %patch0 -p1
328 %patch1 -p1
329 %patch2 -p1
330 %patch3 -p1
331 %patch4 -p1
332 %patch5 -p1
333 %patch6 -p1
334 %patch7 -p1
335 %patch8 -p1
336 %patch9 -p1
337 %patch10 -p1
338 %patch11 -p0
339 %patch12 -p0
340 %patch13 -p1
341 %patch14 -p1
342 %patch15 -p0
343 %patch16 -p0
344 %patch17 -p1
345 %patch18 -p1
346 %patch19 -p1
347 %patch20 -p1
348 %patch21 -p1
349 %patch22 -p1
350 %patch23 -p1
351 %patch24 -p1
352 %patch25 -p1
353 %patch26 -p0
354 %patch27 -p1
355 %patch28 -p1
356 %patch29 -p1
357 %patch30 -p1
358
359 %ifarch athlon
360 %patch31 -p1
361 %endif
362
363 %patch32 -p1
364 %patch33 -p1
365 %patch34 -p1
366 %patch35 -p1
367 %patch36 -p1
368 %patch37 -p1
369 %patch38 -p1
370 %patch39 -p1
371
372 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
373 cp -f platform.in macros.pld.in
374 install %{SOURCE5} macros.perl.in
375 install %{SOURCE13} macros.python.in
376 install %{SOURCE6} scripts/find-perl-provides
377 install %{SOURCE7} scripts/find-perl-requires
378 install %{SOURCE9} scripts/find-lang.sh
379
380 (cd scripts;
381 mv -f perl.req perl.req.in
382 mv -f perl.prov perl.prov.in)
383
384 chmod +x %{SOURCE4}
385
386 %build
387 # generate Group translations to *.po
388 awk -f %{SOURCE14} %{SOURCE1}
389
390 cd popt
391 rm -f missing
392 libtoolize --force --copy
393 aclocal
394 autoheader
395 %{__autoconf}
396 %{__automake}
397 cd ..
398
399 rm -f missing
400 libtoolize --force --copy
401 gettextize --copy --force
402 aclocal
403 autoupdate
404 autoheader || :
405 %{__autoconf}
406 # ugly workaround for automake
407 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
408         lib/Makefile.am > lib/Makefile.am.new
409 mv -f lib/Makefile.am.new lib/Makefile.am
410 %{__automake}
411 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
412         lib/Makefile.in > lib/Makefile.in.new
413 mv -f lib/Makefile.in.new lib/Makefile.in
414
415 sed -e 's#python1.5#python%{py_ver}#g' \
416         python/Makefile.in > python/Makefile.in.new
417 mv -f python/Makefile.in.new python/Makefile.in
418
419 # config.guess doesn't handle athlon, so we have to change it by hand.
420 # rpm checks for CPU type at runtime, but it looks better
421 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
422         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
423 mv -f macros.tmp macros.in
424
425 %configure \
426         --enable-shared \
427         --enable-v1-packages \
428         --with-python
429
430
431 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
432
433 %install
434 rm -rf $RPM_BUILD_ROOT
435
436 %{__make} install \
437         DESTDIR=$RPM_BUILD_ROOT \
438         pkgbindir="%{_bindir}"
439
440 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
441 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
442
443 install %{SOURCE1} doc/manual/groups
444 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
445 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/rpm/find-rpm-provides
446 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
447 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
448 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
449 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
450
451 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
452
453 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
454 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
455 # customized rpm macros - global for host
456 #
457 #%%_install_langs pl_PL:en_US
458 %%distribution PLD
459 EOF
460
461 %find_lang %{name}
462
463 %clean
464 rm -rf $RPM_BUILD_ROOT
465
466 %post   -p /sbin/ldconfig
467 %postun -p /sbin/ldconfig
468
469 %files -f %{name}.lang
470 %defattr(644,root,root,755)
471 %doc RPM-PGP-KEY CHANGES doc/manual/[a-z]*
472
473 %attr(755,root,root) /bin/rpm
474 %attr(755,root,root) %{_bindir}/rpmdb
475 %attr(755,root,root) %{_bindir}/rpmquery
476 %attr(755,root,root) %{_bindir}/rpmsign
477 %attr(755,root,root) %{_bindir}/rpmverify
478 %attr(755,root,root) %{_libdir}/rpm/rpmdb
479 %attr(755,root,root) %{_libdir}/rpm/rpmq
480 %attr(755,root,root) %{_libdir}/rpm/rpmk
481 %attr(755,root,root) %{_libdir}/rpm/rpmv
482 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
483
484 %dir %{_sysconfdir}/rpm
485 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
486
487 %{_mandir}/man8/rpm.8*
488 %lang(fr) %{_mandir}/fr/man8/rpm.8*
489 %lang(ja) %{_mandir}/ja/man8/rpm.8*
490 %lang(ko) %{_mandir}/ko/man8/rpm.8*
491 %lang(pl) %{_mandir}/pl/man8/rpm.8*
492 %lang(ru) %{_mandir}/ru/man8/rpm.8*
493 %lang(sk) %{_mandir}/sk/man8/rpm.8*
494
495 %dir /var/lib/rpm
496 %dir %{_libdir}/rpm
497
498 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
499
500 %{_libdir}/rpm/rpmrc
501 %{_libdir}/rpm/rpmpopt*
502 %{_libdir}/rpm/macros
503 %{_libdir}/rpm/noarch-linux
504 %{_libdir}/rpm/noarch-pld-linux
505 %ifarch i386 i486 i586 i686 athlon
506 %{_libdir}/rpm/i?86*
507 %{_libdir}/rpm/athlon*
508 %endif
509 %ifarch sparc sparc64
510 %{_libdir}/rpm/sparc*
511 %endif
512 %ifarch alpha
513 %{_libdir}/rpm/alpha*
514 %endif
515 %ifarch ppc
516 %{_libdir}/rpm/ppc*
517 %endif
518
519
520 %files build
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_bindir}/rpmbuild
523 %attr(755,root,root) %{_bindir}/rpme
524 %attr(755,root,root) %{_bindir}/rpmi
525 %attr(755,root,root) %{_bindir}/rpmu
526 %attr(755,root,root) %{_libdir}/rpm/find-requires
527 %attr(755,root,root) %{_libdir}/rpm/find-provides
528 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
529 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
530 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
531 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
532 %attr(755,root,root) %{_libdir}/rpm/config.*
533 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
534 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
535 %attr(755,root,root) %{_libdir}/rpm/brp-*
536 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
537 %attr(755,root,root) %{_libdir}/rpm/compress-doc
538 %attr(755,root,root) %{_libdir}/rpm/cpanflute
539 %attr(755,root,root) %{_libdir}/rpm/http.req
540 %attr(755,root,root) %{_libdir}/rpm/magic.*
541 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
542 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
543 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
544 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
545 %attr(755,root,root) %{_libdir}/rpm/rpmb
546 %attr(755,root,root) %{_libdir}/rpm/rpmi
547 %attr(755,root,root) %{_libdir}/rpm/rpmt
548 %attr(755,root,root) %{_libdir}/rpm/rpme
549 %attr(755,root,root) %{_libdir}/rpm/rpmu
550
551 %files devel
552 %defattr(644,root,root,755)
553 %{_includedir}/rpm
554 %attr(755,root,root) %{_libdir}/librpm*.la
555 %attr(755,root,root) %{_libdir}/librpm*.so
556
557 %files static
558 %defattr(644,root,root,755)
559 %{_libdir}/librpm*.a
560
561 %files utils
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/gendiff
564 %attr(755,root,root) %{_bindir}/javadeps
565 %attr(755,root,root) %{_bindir}/rpm2cpio
566
567 %{_mandir}/man8/rpm2cpio.8*
568 %{_mandir}/man1/*
569 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
570 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
571 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
572 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
573
574 %files perlprov
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/rpm/perl*
577 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
578 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
579 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
580 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
581 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
582
583 %{_libdir}/rpm/macros.perl
584
585 %files pythonprov
586 %defattr(644,root,root,755)
587 %{_libdir}/rpm/macros.python
588
589 %files -n python-rpm
590 %defattr(755,root,root,755)
591 %{py_sitedir}/*.so
This page took 0.073065 seconds and 4 git commands to generate.