]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- Upgraded to 3.0
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        3.0
5 Release:        7
6 Group:          Base
7 Group(pl):      Bazowe
8 Copyright:      GPL
9 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/%{name}-%{version}.tar.gz
10 Source1:        rpm.groups
11 Source2:        rpm.8pl
12 Source3:        rpm.macros
13 Patch0:         rpm-rpmrc.patch
14 Patch1:         rpm-i18n.patch
15 Patch2:         rpm-find-requires.patch
16 Patch3:         rpm-macros.patch
17 Patch4:         rpm-po.patch
18 Patch37:        %{name}-short_circuit.patch
19 Patch38:        %{name}-section_test.patch
20 #BuildPrereq:   bzip2-static
21 #BuildPrereq:   gdbm-static
22 #BuildPrereq:   zlib-static
23 #BuildPrereq:   patch >= 2.2
24 Requires:       glibc >= 2.1
25 BuildRoot:      /tmp/%{name}-%{version}-root
26 Obsoletes:      rpm-libs
27 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
28 RPM is a powerful package manager, which can be used to build, install, 
29 query, verify, update, and uninstall individual software packages. A 
30 package consists of an archive of files, and package information, including 
31 name, version, and description.
32 packages. A package consists of an archive of files, and package
33 nombre, versión y descripción.
34 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
35 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
36 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
37 systemu.
38 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
39 %package        devel
40 Summary:        Header files and libraries 
41 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
42 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
43 Group(pl):      Programowanie/Biblioteki
44 Requires:       %{name} = %{version}
45 Requires:       %{name} = %{version}
46 Requires:       popt-devel
47
48 %description devel
49 The RPM packaging system includes a C library that makes it easy to
50 manipulate RPM packages and databases. It is intended to ease the
51 creation of graphical package managers and other tools that need
52 %description -l pl devel
53 Pliki nag³ówkowe i biblioteki statyczne.
54 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
55 construir pacotes usando o RPM.
56 %setup  -q
57 %patch0 -p1 
58 %patch1 -p1
59 %patch2 -p1
60 %patch1 -p1
61 %patch4 -p1 
62 install %{SOURCE13} macros.python.in
63 mv -f perl.prov perl.prov.in)
64 ( cd popt; autoconf )
65
66 autoconf
67 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
68 ./configure \
69         --prefix=/usr \
70         --disable-shared
71 make
72         --with-python
73
74
75 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
76 install -d $RPM_BUILD_ROOT/var/lib/rpm \
77         $RPM_BUILD_ROOT/usr/man/{ru,pl}/man8
78
79 make DESTDIR="$RPM_BUILD_ROOT" install
80
81 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/rpm/macros.pld
82         pkgbindir="%{_bindir}"
83 install rpm.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm.8
84 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm2cpio.8
85 install %{SOURCE2} $RPM_BUILD_ROOT/usr/man/pl/man8/rpm.8
86
87 install %{SOURCE1} docs/groups
88
89 gzip -9fn $RPM_BUILD_ROOT/usr/man/{{ru,pl}/man8/*,man8/*} \
90         RPM-PGP-KEY CHANGES docs/*
91
92 %post
93 /bin/rpm --initdb
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99
100 %doc RPM-PGP-KEY.gz CHANGES.gz docs/*
101 %postun -p /sbin/ldconfig
102
103 %attr(755,root,root) /usr/bin/gendiff
104 %attr(755,root,root) /usr/bin/rpm2cpio
105 %attr(755,root,root) %{_libdir}/rpm/rpmdb
106 /usr/man/man8/*
107 %lang(ru) /usr/man/ru/man8/*
108 %lang(pl) /usr/man/pl/man8/*
109
110 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
111 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
112 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
113 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
114 %lang(pl)    /usr/share/locale/pl/LC_MESSAGES/rpm.mo
115 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
116 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
117 %lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
118 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
119 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
120 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
121 %lang(ru) %{_mandir}/ru/man8/rpm.8*
122 %attr(755,root,root) %dir /var/lib/rpm
123
124 %dir /usr/lib/rpm
125 %attr(755,root,root) /usr/lib/rpm/find-*
126 %attr(755,root,root) /usr/lib/rpm/freshen.sh
127 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
128 %attr(755,root,root) /usr/lib/rpm/config.*
129 %attr(755,root,root) /usr/lib/rpm/getpo.sh
130
131 /usr/lib/rpm/rpm*
132 /usr/lib/rpm/macros*
133
134 %attr(755,root,root) %{_libdir}/rpm/rpmb
135 %attr(755,root,root) %{_libdir}/rpm/rpmi
136 %attr(755,root,root) %{_libdir}/rpm/rpmt
137 /usr/include/rpm
138 /usr/lib/librpm*.a
139 %files utils
140 %files -n python-rpm
141 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
142   [2.5.6-5]
143 - added rpm-find-requires.patch with beter finding list packages containing
144   required shared libraries (Artur Frysiak <wiget@usa.net>),
145 - added ru man pages,
146 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
147   dlopen() some shared glibc libraries),
148 - removed man group from man pages.
149
150 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
151   [2.5.6-4d]
152 - fixed ignorance about international character sets.
153
154 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
155   [2.5.6-1d]
156 - updated to latest stable version,
157 - added URL,
158 - added Group(pl) && changed gropup to Base,
159 - added small patch against GNU libc-2.1.
160
161 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
162   [2.5.5-1d]
163 - updated to 2.5.5. 
164
165 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
166   [2.5.2-2d]
167 - translation modified for pl,
168 - compressed man pages && documentation,
169 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
170 - moved /usr/src/redhat to /usr/src/rpm.
171
172 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
173   [2.5.2-2]
174 - fixed tr.po,
175 - added -q %setup parameter,
176 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
177 - added using %%{name} and %%{version} in Source,
178 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
179 - added %attr and %defattr macros in %files (allow build package from
180   non-root account),
181 - build against GNU libc-2.1.
182
183 Revision 1.79  2000/02/17 03:42:17  kloczek
184 - release 25,
185 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
186   /bin.
This page took 0.048295 seconds and 4 git commands to generate.