]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- changed revision to 2,
[packages/rpm.git] / rpm.spec
1 Summary:     Red Hat Package Manager
2 Name:        rpm
3 Version:     2.5.2
4 Release:     2
5 Group:       Utilities/System
6 Source:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x/%{name}-%{version}.tar.gz
7 Patch0:      rpm.patch
8 Copyright:   GPL
9 BuildRoot:   /var/tmp/%{name}-%{version}-root
10 Conflicts:   patch < 2.5
11 Obsoletes:      rpm-libs
12 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
13 RPM is a powerful package manager, which can be used to build, install, 
14 query, verify, update, and uninstall individual software packages. A 
15 package consists of an archive of files, and package information, including 
16 name, version, and description.
17 packages. A package consists of an archive of files, and package
18 %package devel
19 Summary:     Header files and libraries for programs that manipulate rpm packages
20 Group:       Development/Libraries
21 Requires:       %{name} = %{version}
22 Requires:       popt-devel
23
24 %description devel
25 The RPM packaging system includes a C library that makes it easy to
26 manipulate RPM packages and databases. It is intended to ease the
27 creation of graphical package managers and other tools that need
28 construir pacotes usando o RPM.
29 %setup -q
30 %patch0 -p1
31 install %{SOURCE13} macros.python.in
32 mv -f perl.prov perl.prov.in)
33 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr
34 make
35         --with-python
36
37
38 install -d $RPM_BUILD_ROOT/usr/{lib,src/redhat{SOURCES,SPECS,RPMS/{$RPM_ARCH,noarch},SRPMS,BUILD}}
39 make installprefix="$RPM_BUILD_ROOT" install
40         pkgbindir="%{_bindir}"
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %post
45 /bin/rpm --initdb
46
47 %files
48 %deffattr(644, root, root, 755)
49 %doc RPM-PGP-KEY CHANGES groups docs/*
50 %attr(755, root, root) /bin/rpm
51 %attr(755, root, root) /usr/bin/*
52 %attr(644, root,  man) /usr/man/man8/*
53 /usr/lib/rpm
54 %dir /usr/src/redhat
55 %lang(cz) /usr/share/locale/cz/LC_MESSAGES/rpm.mo
56 %lang(de) /usr/share/locale/cz/LC_MESSAGES/rpm.mo
57 %lang(fi) /usr/share/locale/cz/LC_MESSAGES/rpm.mo
58 %lang(fr) /usr/share/locale/cz/LC_MESSAGES/rpm.mo
59 %lang(pt) /usr/share/locale/pt-br/LC_MESSAGES/rpm.mo
60 %lang(sv) /usr/share/locale/sv/LC_MESSAGES/rpm.mo
61 %lang(tr) /usr/share/locale/tr/LC_MESSAGES/rpm.mo
62 %lang(ru) %{_mandir}/ru/man8/rpm.8*
63 %attr(755,root,root) %{_libdir}/rpm/rpmi
64 %deffattr(644, root, root, 755)
65 /usr/include/rpm
66 /usr/lib/librpm.a
67 /usr/lib/librpmbuild.a
68 %files utils
69 %files -n python-rpm
70 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
71   [2.5.2-2]
72 - fixed tr.po,
73 - added -q %setup parameter,
74 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
75 - added using %%{name} and %%{version} in Source,
76 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
77 - added %attr and %defattr macros in %files (allow build package from
78   non-root account).
79 Revision 1.79  2000/02/17 03:42:17  kloczek
80 - release 25,
81 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
82   /bin.
This page took 0.036823 seconds and 4 git commands to generate.