]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added cxx patch to set and include __cxx in macros
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        48
7 Release:        47
8 License:        GPL
9 Group:          Base
10 Group(de):      Gründsätzlich
11 Group(es):      Base
12 Group(pl):      Podstawowe
13 Group(pt_BR):   Base
14 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
15 Source1:        %{name}.groups
16 Source2:        %{name}.macros
17 Source3:        %{name}-install-tree
18 Source4:        %{name}-find-rpm-provides
19 Source5:        %{name}-macros.perl
20 Source6:        %{name}-find-perl-provides
21 Source7:        %{name}-find-perl-requires
22 Source8:        %{name}-find-spec-bcond
23 Source9:        %{name}-find-lang
24 Source10:       %{name}-find-provides
25 Source11:       %{name}-find-requires
26 Source12:       %{name}-non-english-man-pages.tar.bz2
27 Source13:       %{name}-macros.python
28 Patch0:         %{name}-rpmrc.patch
29 Patch1:         %{name}-macros.patch
30 Patch2:         %{name}-arch.patch
31 Patch3:         %{name}-rpmpopt.patch
32 Patch4:         %{name}-perl-macros.patch
33 Patch5:         %{name}-db3.patch
34 Patch6:         %{name}-segv.patch
35 Patch7:         %{name}-am_fix.patch
36 Patch8:         %{name}-perl-req-perlfile.patch
37 Patch9:         %{name}-installplatform.patch
38 Patch10:        %{name}-cache.patch
39 Patch11:        %{name}-suggestions.patch
40 Patch12:        %{name}-rh-lame.patch
41 Patch13:        %{name}-glob.patch
42 Patch14:        %{name}-header_h.patch
43 Patch15:        %{name}-fast-alAddPackage.patch
44 Patch16:        %{name}-byKey.patch
45 Patch17:        %{name}-perlprov.patch
46 Patch18:        %{name}-noperldir.patch
47 Patch19:        popt-cvs20010530.patch
48 Patch20:        %{name}-noexpand.patch
49 Patch21:        %{name}-scripts-closefds.patch
50 Patch22:        %{name}-python-amfix.patch
51 Patch23:        %{name}-non-english-man-pages.patch
52 Patch24:        %{name}-progress-nontty.patch
53 Patch25:        %{name}-am_ac.patch
54 Patch26:        %{name}-python-macros.patch
55 Patch27:        %{name}-hardlink-fixes.patch
56 Patch28:        %{name}-perlprov-regonly.patch
57 Patch29:        %{name}-cxx.patch
58 Patch37:        %{name}-short_circuit.patch
59 Patch38:        %{name}-section_test.patch
60 URL:            http://www.rpm.org/
61 Icon:           rpm.gif
62 BuildRequires:  autoconf >= 2.50
63 BuildRequires:  automake
64 BuildRequires:  db3-devel >= 3.1.17-9
65 BuildRequires:  db1-devel >= 1.85
66 BuildRequires:  db3-devel >= 3.1.17-9
67 BuildRequires:  gettext-devel >= 0.10.38-3
68 BuildRequires:  python-devel
69 BuildRequires:  zlib-devel
70 BuildRequires:  python-modules >= 2.2.1
71 BuildRequires:  zlib-devel >= 1.1.4
72 %if %{!?_without_static:1}%{?_without_static:0}
73 # Require static library only for static build
74 BuildRequires:  db3-static >= 3.1.17-9
75 BuildRequires:  db1-static >= 1.85
76 BuildRequires:  zlib-static
77 BuildRequires:  zlib-static >= 1.1.4
78 Obsoletes:      rpm-libs
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80 Obsoletes:      rpm-libs
81 Conflicts:      glibc < 2.2
82
83 %define         __find_provides %{SOURCE4}
84 %define         _binary_payload w9.gzdio
85
86 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
87 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
88 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
89 %define         py_dyndir       %{py_libdir}/lib-dynload
90 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
91
92 %description
93 RPM is a powerful package manager, which can be used to build,
94 install, query, verify, update, and uninstall individual software
95 packages. A package consists of an archive of files, and package
96 information, including name, version, and description.
97
98 %description -l de
99 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
100 Installation, Anfrage, Verifizierung, Aktualisierung und
101 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
102 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
103 nombre, versión y descripción.
104
105 %description -l pl
106 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
107 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
108 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
109 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
110 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
111 do pacote, permissões dos arquivos, etc.
112
113 %package devel
114 Summary(de):    Header-Dateien uns Libraries
115 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
116 Group(de):      Entwicklung/Libraries
117 Group(es):      Desarrollo/Bibliotecas
118 Group(fr):      Development/Librairies
119 Group(pl):      Programowanie/Biblioteki
120 Group(pt_BR):   Desenvolvimento/Bibliotecas
121 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
122 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
123 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
124 Group:          Development/Libraries
125 Requires:       %{name} = %{version}
126 Requires:       popt-devel
127
128 %description devel
129 The RPM packaging system includes a C library that makes it easy to
130 manipulate RPM packages and databases. It is intended to ease the
131 creation of graphical package managers and other tools that need
132 intimate knowledge of RPM packages.
133
134 %description devel -l de
135 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
136 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
137 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
138 herramientas que necesiten un conocimiento profundo de paquetes RPM.
139
140 %description devel -l pl
141 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
142 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
143 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
144 ferramentas que precisem de conhecimento profundo de pacotes RPM.
145
146 %package static
147 Summary:        RPM static libraries
148 Summary(pl):    Biblioteki statyczne RPM-a
149 Group(de):      Entwicklung/Libraries
150 Group(es):      Desarrollo/Bibliotecas
151 Group(fr):      Development/Librairies
152 Group(pl):      Programowanie/Biblioteki
153 Group(pt_BR):   Desenvolvimento/Bibliotecas
154 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
155 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
156 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
157 Group:          Development/Libraries
158 Requires:       %{name}-devel = %{version}
159
160 %description static
161 RPM static libraries.
162
163 %description static -l de
164 RPMs statische Libraries.
165
166 %description static -l pl
167 Bibliotecas estáticas para desenvolvimento.
168
169 %package utils
170 Summary:        Additional utilities for managing rpm packages and database
171 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
172 Group(de):      Applikationen/Datei
173 Group(pl):      Aplikacje/Pliki
174 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
175 Group:          Applications/File
176 Requires:       %{name} = %{version}
177
178 %description utils
179 Additional utilities for managing rpm packages and database.
180
181 %description utils -l de
182 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
183
184 %description utils -l pl
185 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
186
187 %package perlprov
188 Summary:        Additional utilities for checking perl provides/requires in rpm packages
189 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
190 Group(de):      Applikationen/Datei
191 Group(pl):      Aplikacje/Pliki
192 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
193 Group:          Applications/File
194 Requires:       perl-modules
195 Requires:       findutils
196
197 %description perlprov
198 Additional utilities for checking perl provides/requires in rpm
199 packages.
200
201 %description perlprov -l de
202 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
203
204 %description perlprov -l pl
205 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
206 pakietach rpm.
207
208 %package pythonprov
209 Summary:        Python macros, which simplifies creation of rpm packages with Python software
210 Group(de):      Applikationen/Datei
211 Group(pl):      Aplikacje/Pliki
212 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
213 Requires:       python
214 Requires:       %{name} = %{version}
215 Requires:       python-modules
216
217 %description pythonprov
218 Python macros, which simplifies creation of rpm packages with Python
219 software.
220 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi
221 w Pythonie.
222 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
223 %package python
224
225 %package -n python-rpm
226 Group:          Development/Languages/Python
227 Group(de):      Entwicklung/Sprachen/Python
228 Group(pl):      Programowanie/Jêzyki/Python
229 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
230 %pyrequires_eq  python
231 %description python
232
233 %description -n python-rpm
234 The rpm-python package contains a module which permits applications
235 written in the Python programming language to use the interface
236 supplied by RPM (RPM Package Manager) libraries.
237
238 This package should be installed if you want to develop Python
239 %description python -l pl
240 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym
241 w Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
242 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
243 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ
244 w Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
245 Esse pacote deve ser instalado se você quiser desenvolver programas em
246 Python para manipular pacotes e bancos de dados RPM.
247
248 %package build
249 Summary:        Scripts for building binary RPM packages
250 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
251 Group(de):      Applikationen/Datei
252 Group(pl):      Aplikacje/Pliki
253 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
254 Group:          Applications/File
255 Requires:       /bin/id
256 Requires:       awk
257 Requires:       binutils
258 Requires:       diffutils
259 Requires:       file >= 3.31
260 Requires:       gcc >= 3.0.3
261 Requires:       gcc
262 Requires:       glibc-devel
263 Requires:       grep
264 Requires:       gzip
265 Requires:       make
266 Requires:       patch
267 Requires:       popt >= 1.6.2-2
268 Requires:       sed
269 Requires:       tar
270 Requires:       textutils
271
272 %description build
273 Scripts for building binary RPM packages.
274
275 %description build -l de
276 Scripts fürs Bauen binärer RPM-Pakete.
277
278 %description build -l pl
279 construir pacotes usando o RPM.
280
281 %prep
282 %setup -q -a12
283 %patch0 -p1
284 %patch1 -p1
285 %patch2 -p1
286 %patch3 -p1
287 %patch4 -p1
288 %patch5 -p1
289 %patch6 -p1
290 %patch7 -p1
291 %patch8 -p1
292 %patch11 -p0
293 %patch12 -p0
294 %patch11 -p0
295 %patch12 -p0
296 %patch15 -p0
297 %patch16 -p0
298 %patch15 -p0
299 %patch16 -p0
300 %patch17 -p1
301 %patch18 -p1
302 %patch19 -p1
303 %patch22 -p1
304 %patch23 -p1
305 %patch24 -p1
306 %patch25 -p1
307 %patch26 -p0
308 %patch27 -p1
309 %patch28 -p1
310 %patch29 -p1
311 %patch31 -p1
312 %patch36 -p1
313 %patch37 -p1
314 %patch38 -p1
315
316 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
317 cp -f platform.in macros.pld.in
318 install %{SOURCE9} scripts/find-lang.sh
319 install %{SOURCE13} macros.python.in
320 install %{SOURCE6} scripts/find-perl-provides
321 install %{SOURCE7} scripts/find-perl-requires
322 install %{SOURCE9} scripts/find-lang.sh
323
324 (cd scripts;
325 mv -f perl.req perl.req.in
326 mv -f perl.prov perl.prov.in)
327 %build
328 # generate Group translations to *.po
329 awk -f %{SOURCE14} %{SOURCE1}
330
331 cd popt
332 autoconf
333 automake -a -c
334 aclocal
335 autoheader
336 automake -a -c -f
337 %{__automake}
338 cd ..
339
340 rm -f missing
341 libtoolize --force --copy
342 autoconf
343 # ugly workaround for automake
344 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
345         lib/Makefile.am > lib/Makefile.am.new
346 mv -f lib/Makefile.am.new lib/Makefile.am
347 automake -a -c
348 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
349         lib/Makefile.in > lib/Makefile.in.new
350 mv -f lib/Makefile.in.new lib/Makefile.in
351
352 sed -e 's#python1.5#python%{py_ver}#g' \
353         python/Makefile.in > python/Makefile.in.new
354 mv -f python/Makefile.in.new python/Makefile.in
355
356 sed -e 's#python1.5#python%{py_ver}#g' \
357         python/Makefile.in > python/Makefile.in.new
358 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
359         sed 's|@host_cpu@|%{_target_cpu}|' | \
360 # config.guess doesn't handle athlon, so we have to change it by hand.
361 # rpm checks for CPU type at runtime, but it looks better
362 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
363         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
364         --enable-v1-packages \
365         --with-python
366 %configure \
367         --enable-shared \
368         --enable-v1-packages \
369         --with-python
370
371
372 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
373
374 %install
375 rm -rf $RPM_BUILD_ROOT
376
377 %{__make} install \
378         DESTDIR=$RPM_BUILD_ROOT \
379         pkgbindir="%{_bindir}"
380
381 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
382 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
383
384 install %{SOURCE1} doc/manual/groups
385 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
386 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
387 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
388 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
389 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
390
391 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
392
393 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
394 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
395 # customized rpm macros - global for host
396 #
397 #%%_install_langs pl_PL:en_US
398 %%distribution PLD
399 EOF
400
401 %find_lang %{name}
402
403 # DON'T BREAK BUILD TREE!!!
404 # rm -f doc/manual/Makefile*
405
406 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
407
408 %clean
409 rm -rf $RPM_BUILD_ROOT
410
411 %post   -p /sbin/ldconfig
412 %postun -p /sbin/ldconfig
413
414 %attr(755,root,root) %{_libdir}/rpm/rpmdb
415 %attr(755,root,root) %{_libdir}/rpm/rpmq
416 %attr(755,root,root) %{_libdir}/rpm/rpmk
417 %attr(755,root,root) %{_libdir}/rpm/rpmv
418 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
419 %attr(755,root,root) %{_libdir}/rpm/rpmdb
420 %attr(755,root,root) %{_libdir}/rpm/rpmq
421 %attr(755,root,root) %{_libdir}/rpm/rpmk
422 %attr(755,root,root) %{_libdir}/rpm/rpmv
423 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
424
425 %dir %{_sysconfdir}/rpm
426 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
427
428 %{_mandir}/man8/rpm.8*
429 %lang(fr) %{_mandir}/fr/man8/rpm.8*
430 %lang(ja) %{_mandir}/ja/man8/rpm.8*
431 %lang(ko) %{_mandir}/ko/man8/rpm.8*
432 %lang(pl) %{_mandir}/pl/man8/rpm.8*
433 %lang(ru) %{_mandir}/ru/man8/rpm.8*
434 %lang(sk) %{_mandir}/sk/man8/rpm.8*
435
436 %dir /var/lib/rpm
437 %dir %{_libdir}/rpm
438
439 %{_libdir}/rpm/macros.python
440 %{_libdir}/rpm/noarch-linux
441 %{_libdir}/rpm/noarch-pld-linux
442 %ifarch i386 i486 i586 i686
443 %{_libdir}/rpm/rpmpopt*
444 %{_libdir}/rpm/noarch-linux
445 %{_libdir}/rpm/noarch-pld-linux
446 %ifarch i386 i486 i586 i686 athlon
447 %{_libdir}/rpm/i?86*
448 %{_libdir}/rpm/athlon*
449 %endif
450 %ifarch sparc sparc64
451 %{_libdir}/rpm/sparc*
452 %endif
453 %ifarch alpha
454 %{_libdir}/rpm/alpha*
455 %endif
456 %ifarch ppc
457 %{_libdir}/rpm/ppc*
458 %defattr(644,root,root,755)
459 %attr(755,root,root) %{_bindir}/rpmbuild
460 %attr(755,root,root) %{_bindir}/rpme
461 %attr(755,root,root) %{_bindir}/rpmi
462 %attr(755,root,root) %{_bindir}/rpmu
463 %attr(755,root,root) %{_libdir}/rpm/find-requires
464 %attr(755,root,root) %{_libdir}/rpm/find-provides
465 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
466 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
467 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
468 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
469 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
470 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
471 %attr(755,root,root) %{_libdir}/rpm/brp-*
472 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
473 %attr(755,root,root) %{_libdir}/rpm/compress-doc
474 %attr(755,root,root) %{_libdir}/rpm/cpanflute
475 %attr(755,root,root) %{_libdir}/rpm/http.req
476 %attr(755,root,root) %{_libdir}/rpm/magic.*
477 %attr(755,root,root) %{_libdir}/rpm/rpmi
478 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
479 %attr(755,root,root) %{_libdir}/rpm/rpme
480 %attr(755,root,root) %{_libdir}/rpm/rpmu
481 %attr(755,root,root) %{_libdir}/rpm/rpmb
482 %attr(755,root,root) %{_libdir}/rpm/rpmi
483 %attr(755,root,root) %{_libdir}/rpm/rpmt
484 %attr(755,root,root) %{_libdir}/rpm/rpme
485 %attr(755,root,root) %{_libdir}/librpm*.la
486 %attr(755,root,root) %{_libdir}/librpm*.so
487 %files devel
488 %defattr(644,root,root,755)
489 %{_includedir}/rpm
490 %attr(755,root,root) %{_libdir}/librpm*.la
491 %attr(755,root,root) %{_libdir}/librpm*.so
492
493 %files static
494 %attr(755,root,root) %{_bindir}/*
495 %files utils
496 %defattr(644,root,root,755)
497 %{_mandir}/man1/*
498 %attr(755,root,root) %{_bindir}/javadeps
499 %attr(755,root,root) %{_bindir}/rpm2cpio
500
501 %{_mandir}/man8/rpm2cpio.8*
502 %{_mandir}/man1/*
503 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
504 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
505 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
506 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
507
508 %files perlprov
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libdir}/rpm/perl*
511 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
512 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
513 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
514 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
515 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
516
517 %{_libdir}/rpm/macros.perl
518 %files python
519 %defattr(644,root,root,755)
520 %{py_sitedir}/*.so
521 %{_libdir}/rpm/macros.python
522
523 %files -n python-rpm
524 %defattr(755,root,root,755)
525 %{py_sitedir}/*.so
This page took 0.16499 seconds and 4 git commands to generate.