]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
reduce optimization flags ..
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        2.5.6
5 Release:        3d
6 Group:          Base
7 Group(pl):      Bazowe
8 URL:            ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x
9 Source:         %{name}-%{version}.tar.gz
10 Patch0:         %{name}-config.patch
11 Patch1:         %{name}-rpmrc.patch
12 Patch2:         %{name}-glibc.patch
13 Patch3:         %{name}-groups.patch
14 Copyright:      GPL
15 BuildRoot:      /tmp/%{name}-%{version}-root
16 Obsoletes:      rpm-libs
17 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
18 RPM is a powerful package manager, which can be used to build, install, 
19 query, verify, update, and uninstall individual software packages. A 
20 package consists of an archive of files, and package information, including 
21 name, version, and description.
22 packages. A package consists of an archive of files, and package
23 nombre, versión y descripción.
24 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
25 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
26 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
27 systemu.
28 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
29 %package        devel
30 Summary:        Header files and libraries 
31 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
32 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
33 Group(pl):      Programowanie/Biblioteki
34 Requires:       %{name} = %{version}
35 Requires:       %{name} = %{version}
36 Requires:       popt-devel
37
38 %description devel
39 The RPM packaging system includes a C library that makes it easy to
40 manipulate RPM packages and databases. It is intended to ease the
41 creation of graphical package managers and other tools that need
42 %description -l pl devel
43 Pliki nag³ówkowe i biblioteki statyczne.
44 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
45 construir pacotes usando o RPM.
46 %setup  -q
47 %patch0 -p1
48 %patch1 -p1
49 %patch2 -p1
50 %patch1 -p1
51 install %{SOURCE13} macros.python.in
52 mv -f perl.prov perl.prov.in)
53 autoconf
54 CFLAGS=$RPM_OPT_FLAGS LDFLAGS=-s \
55     ./configure \
56         --prefix=/usr
57 make
58         --with-python
59
60
61 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
62 install -d $RPM_BUILD_ROOT/var/lib/rpm
63 install -d $RPM_BUILD_ROOT/usr/src/rpm/{SOURCES,SPECS,SRPMS,BUILD}
64 install -d $RPM_BUILD_ROOT/usr/src/rpm/RPMS/{$RPM_ARCH,noarch}
65
66 make installprefix="$RPM_BUILD_ROOT" install
67         pkgbindir="%{_bindir}"
68 gzip -9fn  $RPM_BUILD_ROOT/usr/man/man8/*
69 bzip2 -9 RPM-PGP-KEY CHANGES groups docs/*
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 /bin/rpm --initdb
76
77 %files
78
79 %doc {RPM-PGP-KEY,CHANGES,groups}.bz2 docs/*
80 %postun -p /sbin/ldconfig
81
82 %attr(755,root,root) /usr/bin/gendiff
83 %attr(755,root,root) /usr/bin/rpm2cpio
84 %attr(644,root, man) /usr/man/man8/*
85
86 %attr(750,root,root) %dir /var/lib/rpm
87
88 %dir /usr/lib/rpm
89 %attr(755,root,root) /usr/lib/rpm/find-*
90 %attr(755,root,root) /usr/lib/rpm/freshen.sh
91 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
92
93 /usr/lib/rpm/rpm*
94
95 %dir /usr/src/rpm/RPMS
96 %attr(755,root,root,755) /usr/src/rpm/RPMS/*
97
98 %dir /usr/src/rpm/SRPMS
99 %dir /usr/src/rpm/SPECS
100 %dir /usr/src/rpm/BUILD
101 %dir /usr/src/rpm/SOURCES
102
103 %lang(cs) /usr/share/locale/cs/LC_MESSAGES/rpm.mo
104 %lang(de) /usr/share/locale/de/LC_MESSAGES/rpm.mo
105 %lang(fi) /usr/share/locale/fi/LC_MESSAGES/rpm.mo
106 %lang(fr) /usr/share/locale/fr/LC_MESSAGES/rpm.mo
107 %lang(pt) /usr/share/locale/pt*/LC_MESSAGES/rpm.mo
108 %lang(ru) /usr/share/locale/ru/LC_MESSAGES/rpm.mo
109 %lang(sk) /usr/share/locale/sk/LC_MESSAGES/rpm.mo
110 %lang(sv) /usr/share/locale/sv/LC_MESSAGES/rpm.mo
111 %lang(sr) /usr/share/locale/sr/LC_MESSAGES/rpm.mo
112 %lang(tr) /usr/share/locale/tr/LC_MESSAGES/rpm.mo
113 %lang(ru) %{_mandir}/ru/man8/rpm.8*
114 %attr(755,root,root) %{_libdir}/rpm/rpmi
115 %attr(755,root,root) %{_libdir}/rpm/rpmt
116
117 %dir /usr/include/rpm
118 /usr/include/rpm/*
119
120 /usr/lib/lib*.a
121 %files utils
122 %files -n python-rpm
123 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
124   [2.5.6-1d]
125 - updated to latest stable version,
126 - added URL,
127 - added Group(pl) && changed gropup to Base,
128 - added small patch against GNU libc-2.1.
129
130 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
131   [2.5.5-1d]
132 - updated to 2.5.5. 
133
134 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
135   [2.5.2-2d]
136 - translation modified for pl,
137 - compressed man pages && documentation,
138 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
139 - moved /usr/src/redhat to /usr/src/rpm.
140
141 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
142   [2.5.2-2]
143 - fixed tr.po,
144 - added -q %setup parameter,
145 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
146 - added using %%{name} and %%{version} in Source,
147 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
148 - added %attr and %defattr macros in %files (allow build package from
149   non-root account),
150 - build against GNU libc-2.1.  
151     
152
153 Revision 1.79  2000/02/17 03:42:17  kloczek
154 - release 25,
155 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
156   /bin.
This page took 0.057453 seconds and 4 git commands to generate.