]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- bugfix: use <rpmio/rpmio.h>, not <rpm/rpmio.h> (wouldn't build)
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        12
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(pl):      Podstawowe
11 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
12 Source1:        %{name}.groups
13 Source2:        %{name}.macros
14 Source3:        %{name}-install-tree
15 Source4:        %{name}-find-rpm-provides
16 Source5:        %{name}-macros.perl
17 Source6:        %{name}-find-perl-provides
18 Source7:        %{name}-find-perl-requires
19 Source8:        %{name}-find-spec-bcond
20 Source9:        %{name}-find-lang
21 Source10:       %{name}-find-provides
22 Source11:       %{name}-find-requires
23 Patch0:         %{name}-rpmrc.patch
24 Patch1:         %{name}-macros.patch
25 Patch2:         %{name}-arch.patch
26 Patch3:         %{name}-rpmpopt.patch
27 Patch4:         %{name}-perl-macros.patch
28 Patch5:         %{name}-db3.patch
29 Patch6:         %{name}-segv.patch
30 Patch7:         %{name}-am_fix.patch
31 Patch8:         %{name}-perl-req-perlfile.patch
32 Patch9:         %{name}-installplatform.patch
33 Patch10:        %{name}-cache.patch
34 Patch11:        %{name}-suggestions.patch
35 Patch12:        %{name}-rh-lame.patch
36 Patch37:        %{name}-short_circuit.patch
37 Patch38:        %{name}-section_test.patch
38 BuildRequires:  gettext-devel
39 BuildRequires:  automake
40 BuildRequires:  db3-devel >= 3.1.17
41 BuildRequires:  bzip2-devel >= 1.0.1
42 BuildRequires:  gdbm-devel
43 BuildRequires:  zlib-devel
44 BuildRequires:  gettext-devel >= 0.10.38-3
45 BuildRequires:  libtool
46 BuildRequires:  automake
47 BuildRequires:  autoconf >= 2.13-8
48 %if %{!?bcond_off_static:1}%{?bcond_off_static:0}
49 BuildRequires:  zlib-devel >= 1.1.4
50 # Require static library only for static build
51 BuildRequires:  db3-static >= 3.1.17
52 BuildRequires:  bzip2-static >= 1.0.1
53 BuildRequires:  gdbm-static
54 BuildRequires:  zlib-static
55 %endif
56 BuildRequires:  zlib-static >= 1.1.4
57 Obsoletes:      rpm-libs
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59 Obsoletes:      rpm-libs
60 %define __find_provides %{SOURCE4}
61 %define _binary_payload w9.gzdio
62 %define         __find_provides %{SOURCE4}
63 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
64
65 %description
66 RPM is a powerful package manager, which can be used to build,
67 install, query, verify, update, and uninstall individual software
68 packages. A package consists of an archive of files, and package
69 information, including name, version, and description.
70
71 %description -l de
72 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
73 Installation, Anfrage, Verifizierung, Aktualisierung und
74 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
75 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
76 nombre, versión y descripción.
77 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³
78 %description -l pl
79 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
80 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów s±
81 przechowywane s± w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
82 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
83 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
84 do pacote, permissões dos arquivos, etc.
85
86 %package devel
87 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
88 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
89 Group(de):      Entwicklung/Libraries
90 Group(fr):      Development/Librairies
91 Group(pl):      Programowanie/Biblioteki
92 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}
95 Requires:       popt-devel
96
97 %description devel
98 The RPM packaging system includes a C library that makes it easy to
99 manipulate RPM packages and databases. It is intended to ease the
100 creation of graphical package managers and other tools that need
101 %description -l de devel
102
103 %description devel -l de
104 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
105 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
106 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
107 %description -l pl devel
108 Pliki nag³ówkowe i biblioteki statyczne.
109 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
110 ferramentas que precisem de conhecimento profundo de pacotes RPM.
111
112 %package static
113 Summary(pl):    Biblioteki statyczne rpm-a
114 Summary(pl):    Biblioteki statyczne RPM-a
115 Group(de):      Entwicklung/Libraries
116 Group(fr):      Development/Librairies
117 Group(pl):      Programowanie/Biblioteki
118 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
119 Group:          Development/Libraries
120 Requires:       %{name}-devel = %{version}
121
122 %description static
123 %description -l de static
124
125 %description static -l de
126 %description -l pl static
127 Biblioteki statyczne rpm-a.
128 %description static -l pl
129 Bibliotecas estáticas para desenvolvimento.
130
131 %package utils
132 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami
133 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
134 Group(de):      Applikationen/Datei
135 Group(pl):      Aplikacje/Pliki
136 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
137 Group:          Applications/File
138 Requires:       %{name} = %{version}
139
140 %description utils
141 %description -l de utils
142
143 %description utils -l de
144 %description -l pl utils
145 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
146 %description utils -l pl
147 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
148
149 %package perlprov
150 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
151 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
152 Group(de):      Applikationen/Datei
153 Group(pl):      Aplikacje/Pliki
154 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
155 Requires:       perl-modules
156 Requires:       findutils
157
158 %description perlprov
159 Additional utilities for checking perl provides/requires in rpm
160 %description -l de perlprov
161
162 %description perlprov -l de
163 %description -l pl perlprov
164 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
165 %description perlprov -l pl
166 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
167 Python para manipular pacotes e bancos de dados RPM.
168
169 %package build
170 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
171 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
172 Group(de):      Applikationen/Datei
173 Group(pl):      Aplikacje/Pliki
174 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
175 Group:          Applications/File
176 Requires:       sh-utils
177 Requires:       binutils
178 Requires:       patch
179 Requires:       texinfo
180 Requires:       file >= 3.31
181 Requires:       binutils
182 Requires:       gcc >= 3.0.3
183 Requires:       gcc
184 Requires:       diffutils
185 Requires:       libtool
186 Requires:       glibc-devel
187 Requires:       sed
188 Requires:       tar
189 Requires:       textutils
190
191 %description build
192 %description -l de build
193
194 %description build -l de
195 %description -l pl build
196 Skrypty pomocnicze do budowania binarnych RPMów.
197 %description build -l pl
198 construir pacotes usando o RPM.
199 %setup  -q
200 %prep
201 %setup -q -a12
202 %patch0 -p1
203 %patch1 -p1
204 %patch4 -p1 
205 %patch3 -p1
206 %patch4 -p1
207 %patch5 -p1
208 %patch6 -p1
209 %patch7 -p1
210 %patch8 -p1
211 %patch11 -p0
212 %patch12 -p0
213 %patch31 -p1
214 install %{SOURCE2} macros.pld.in
215 %patch38 -p1
216 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
217 cp -f platform.in macros.pld.in
218 install %{SOURCE9} scripts/find-lang.sh
219 install %{SOURCE13} macros.python.in
220 (cd scripts; 
221 install %{SOURCE7} scripts/find-perl-requires
222 install %{SOURCE9} scripts/find-lang.sh
223
224 (cd scripts;
225 mv -f perl.req perl.req.in
226 mv -f perl.prov perl.prov.in)
227
228 (cd popt;
229  libtoolize --force --copy
230  aclocal
231  autoheader
232  autoconf
233  automake -a -c)
234 autoheader
235 %{__automake}
236 cd ..
237
238 autoheader
239 autoconf
240 # ugly workaround for automake
241 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
242         lib/Makefile.am > lib/Makefile.am.new
243 mv -f lib/Makefile.am.new lib/Makefile.am
244 automake -a -c
245 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
246         lib/Makefile.in > lib/Makefile.in.new
247 mv -f lib/Makefile.in.new lib/Makefile.in
248 %configure \
249         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
250         --enable-v1-packages
251 %configure \
252 %{__make} %{?bcond_off_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
253 sed -e 's/#include <rpmio\.h>/#include <rpmio\/rpmio\.h>/g' lib/header.h > lib/header.h.new
254 mv -f lib/header.h.new lib/header.h
255         --with-python
256
257
258 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
259
260         DESTDIR="$RPM_BUILD_ROOT" \
261 rm -rf $RPM_BUILD_ROOT
262
263 install macros.pld $RPM_BUILD_ROOT%{_libdir}/rpm/macros.pld
264 %{__make} install \
265         pkgbindir="%{_bindir}"
266
267 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
268 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
269
270 install %{SOURCE1} doc/manual/groups
271 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
272 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
273 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
274 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
275 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
276
277 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
278
279 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
280 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
281 # customized rpm macros - global for host
282 #
283 #%%_install_langs pl_PL:en_US
284 %%distribution PLD
285 EOF
286
287 %find_lang %{name}
288
289 %post   -p /sbin/ldconfig
290
291 %clean
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 rm -rf $RPM_BUILD_ROOT
296
297 %post   -p /sbin/ldconfig
298 %postun -p /sbin/ldconfig
299
300 %attr(755,root,root) %{_libdir}/rpm/rpmdb
301 %attr(755,root,root) %{_libdir}/rpm/rpmq
302 %attr(755,root,root) %{_libdir}/rpm/rpmk
303 %attr(755,root,root) %{_libdir}/rpm/rpmv
304 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
305 %attr(755,root,root) %{_libdir}/rpm/rpmdb
306 %attr(755,root,root) %{_libdir}/rpm/rpmq
307 %attr(755,root,root) %{_libdir}/rpm/rpmk
308 %attr(755,root,root) %{_libdir}/rpm/rpmv
309 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
310 %{_mandir}/man8/rpm.8*
311 %lang(pl) %{_mandir}/pl/man8/rpm.8*
312 %lang(ja) %{_mandir}/ja/man8/rpm.8*
313 %lang(fr) %{_mandir}/fr/man8/rpm.8*
314 %lang(ja) %{_mandir}/ja/man8/rpm.8*
315 %lang(ko) %{_mandir}/ko/man8/rpm.8*
316 %lang(pl) %{_mandir}/pl/man8/rpm.8*
317 %lang(ru) %{_mandir}/ru/man8/rpm.8*
318 %lang(sk) %{_mandir}/sk/man8/rpm.8*
319
320 %dir /var/lib/rpm
321 %dir %{_libdir}/rpm
322
323 %{_libdir}/rpm/macros.pld
324 %{_libdir}/rpm/noarch-linux
325 %{_libdir}/rpm/noarch-pld-linux
326 %ifarch i386 i486 i586 i686
327 %{_libdir}/rpm/i386-pld-linux
328 %endif
329 %ifarch i486 i586 i686
330 %{_libdir}/rpm/i486-pld-linux
331 %endif
332 %ifarch i586 i686
333 %{_libdir}/rpm/i586-pld-linux
334 %endif
335 %ifarch i686
336 %{_libdir}/rpm/i686-pld-linux
337 %{_libdir}/rpm/noarch-linux
338 %{_libdir}/rpm/noarch-pld-linux
339 %{_libdir}/rpm/sparc-pld-linux
340 %endif
341 %ifarch sparc64
342 %{_libdir}/rpm/sparc64-pld-linux
343 %{_libdir}/rpm/i?86*
344 %{_libdir}/rpm/athlon*
345 %{_libdir}/rpm/alpha-pld-linux
346 %ifarch sparc sparc64
347 %endif
348 %ifarch ppc
349 %{_libdir}/rpm/ppc*
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_bindir}/rpmbuild
352 %attr(755,root,root) %{_bindir}/rpme
353 %attr(755,root,root) %{_bindir}/rpmi
354 %attr(755,root,root) %{_bindir}/rpmu
355 %attr(755,root,root) %{_libdir}/rpm/find-requires
356 %attr(755,root,root) %{_libdir}/rpm/find-provides
357 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
358 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
359 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
360 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
361 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
362 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
363 %attr(755,root,root) %{_libdir}/rpm/brp-*
364 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
365 %attr(755,root,root) %{_libdir}/rpm/compress-doc
366 %attr(755,root,root) %{_libdir}/rpm/cpanflute
367 %attr(755,root,root) %{_libdir}/rpm/http.req
368 %attr(755,root,root) %{_libdir}/rpm/magic.*
369 %attr(755,root,root) %{_libdir}/rpm/rpmi
370 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
371 %attr(755,root,root) %{_libdir}/rpm/rpme
372 %attr(755,root,root) %{_libdir}/rpm/rpmu
373 %attr(755,root,root) %{_libdir}/rpm/rpmb
374 %attr(755,root,root) %{_libdir}/rpm/rpmi
375 %attr(755,root,root) %{_libdir}/rpm/rpmt
376 %attr(755,root,root) %{_libdir}/rpm/rpme
377 %attr(755,root,root) %{_libdir}/librpm*.la
378 %attr(755,root,root) %{_libdir}/librpm*.so
379 %files devel
380 %defattr(644,root,root,755)
381 %{_includedir}/rpm
382 %attr(755,root,root) %{_libdir}/librpm*.la
383 %attr(755,root,root) %{_libdir}/librpm*.so
384
385 %files static
386 %attr(755,root,root) %{_bindir}/*
387 %files utils
388 %defattr(644,root,root,755)
389 %{_mandir}/man1/*
390 %{_mandir}/man8/rpm2cpio.8*
391 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
392 %{_mandir}/man1/*
393 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
394 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
395 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
396 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
397
398 %files perlprov
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/rpm/perl*
401 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
402 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
403 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
404
405 %files -n python-rpm
406 * %{date} PLD Team <pld-list@pld.org.pl>
407 %{py_sitedir}/*.so
This page took 0.086105 seconds and 4 git commands to generate.