]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added python subpackage; %%setup call is back; release 33
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        33
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(pl):      Podstawowe
11 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
12 Source1:        %{name}.groups
13 Source2:        %{name}.macros
14 Source3:        %{name}-install-tree
15 Source4:        %{name}-find-rpm-provides
16 Source5:        %{name}-macros.perl
17 Source6:        %{name}-find-perl-provides
18 Source7:        %{name}-find-perl-requires
19 Source8:        %{name}-find-spec-bcond
20 Source9:        %{name}-find-lang
21 Source10:       %{name}-find-provides
22 Source11:       %{name}-find-requires
23 Patch0:         %{name}-rpmrc.patch
24 Patch1:         %{name}-macros.patch
25 Patch2:         %{name}-arch.patch
26 Patch3:         %{name}-rpmpopt.patch
27 Patch4:         %{name}-perl-macros.patch
28 Patch5:         %{name}-db3.patch
29 Patch6:         %{name}-segv.patch
30 Patch7:         %{name}-am_fix.patch
31 Patch8:         %{name}-perl-req-perlfile.patch
32 Patch9:         %{name}-installplatform.patch
33 Patch10:        %{name}-cache.patch
34 Patch11:        %{name}-suggestions.patch
35 Patch12:        %{name}-rh-lame.patch
36 Patch13:        %{name}-glob.patch
37 Patch14:        %{name}-header_h.patch  
38 Patch15:        %{name}-fast-alAddPackage.patch
39 Patch16:        %{name}-byKey.patch
40 Patch17:        %{name}-perlprov.patch
41 Patch18:        %{name}-noperldir.patch
42 Patch19:        popt-cvs20010530.patch
43 Patch20:        %{name}-noexpand.patch
44 Patch37:        %{name}-short_circuit.patch
45 Patch38:        %{name}-section_test.patch
46 BuildRequires:  gettext-devel >= 0.10.38-3
47 BuildRequires:  automake
48 BuildRequires:  db3-devel >= 3.1.17-9
49 BuildRequires:  bzip2-devel >= 1.0.1
50 BuildRequires:  zlib-devel
51 BuildRequires:  gettext-devel >= 0.10.38-3
52 BuildRequires:  libtool
53 BuildRequires:  automake
54 BuildRequires:  autoconf >= 2.50
55 BuildRequires:  python-modules >= 2.2.1
56 BuildRequires:  zlib-devel >= 1.1.4
57 # Require static library only for static build
58 BuildRequires:  db3-static >= 3.1.17-9
59 BuildRequires:  bzip2-static >= 1.0.1
60 BuildRequires:  zlib-static
61 BuildRequires:  glibc-static >= 2.2.0
62 %endif
63 BuildRequires:  zlib-static >= 1.1.4
64 Obsoletes:      rpm-libs
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66 Obsoletes:      rpm-libs
67 %define __find_provides %{SOURCE4}
68 %define _binary_payload w9.gzdio
69 %define         __find_provides %{SOURCE4}
70 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
71 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
72 %define python_includedir  %{_includedir}/python%{python_version}
73 %define python_libdir      %{python_prefix}/lib/python%{python_version}
74 %define python_sitedir     %{python_libdir}/site-packages
75 %define         py_dyndir       %{py_libdir}/lib-dynload
76 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
77
78 %description
79 RPM is a powerful package manager, which can be used to build,
80 install, query, verify, update, and uninstall individual software
81 packages. A package consists of an archive of files, and package
82 information, including name, version, and description.
83
84 %description -l de
85 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
86 Installation, Anfrage, Verifizierung, Aktualisierung und
87 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
88 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
89 nombre, versión y descripción.
90 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³
91 %description -l pl
92 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
93 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
94 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
95 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
96 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
97 do pacote, permissões dos arquivos, etc.
98
99 %package devel
100 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
101 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
102 Group(de):      Entwicklung/Libraries
103 Group(fr):      Development/Librairies
104 Group(pl):      Programowanie/Biblioteki
105 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
106 Group:          Development/Libraries
107 Requires:       %{name} = %{version}
108 Requires:       popt-devel
109
110 %description devel
111 The RPM packaging system includes a C library that makes it easy to
112 manipulate RPM packages and databases. It is intended to ease the
113 creation of graphical package managers and other tools that need
114 intimate knowledge of RPM packages.
115
116 %description devel -l de
117 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
118 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
119 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
120 herramientas que necesiten un conocimiento profundo de paquetes RPM.
121 Pliki nag³ówkowe i biblioteki statyczne.
122 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
123 ferramentas que precisem de conhecimento profundo de pacotes RPM.
124
125 %package static
126 Summary(pl):    Biblioteki statyczne rpm-a
127 Summary(pl):    Biblioteki statyczne RPM-a
128 Group(de):      Entwicklung/Libraries
129 Group(fr):      Development/Librairies
130 Group(pl):      Programowanie/Biblioteki
131 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}
134
135 %description static
136 RPM static libraries.
137
138 %description static -l de
139 RPMs statische Libraries.
140 Biblioteki statyczne rpm-a.
141 %description static -l pl
142 Bibliotecas estáticas para desenvolvimento.
143
144 %package utils
145 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami
146 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
147 Group(de):      Applikationen/Datei
148 Group(pl):      Aplikacje/Pliki
149 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
150 Group:          Applications/File
151 Requires:       %{name} = %{version}
152
153 %description utils
154 Additional utilities for managing rpm packages and database.
155
156 %description utils -l de
157 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
158 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
159 %description utils -l pl
160 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
161
162 %package perlprov
163 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
164 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
165 Group(de):      Applikationen/Datei
166 Group(pl):      Aplikacje/Pliki
167 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
168 Group:          Applications/File
169 Requires:       perl-modules
170 Requires:       findutils
171
172 %description perlprov
173 Additional utilities for checking perl provides/requires in rpm
174 packages.
175
176 %description perlprov -l de
177 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
178 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
179 %description perlprov -l pl
180 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
181 %package python
182
183 Group:          Development/Languages/Python
184 Group(de):      Entwicklung/Sprachen/Python
185 Group(pl):      Programowanie/Jêzyki/Python
186 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
187 %pyrequires_eq  python
188 %description python
189
190 %description -n python-rpm
191 The rpm-python package contains a module which permits applications
192 written in the Python programming language to use the interface
193 supplied by RPM (RPM Package Manager) libraries.
194
195 This package should be installed if you want to develop Python
196 Python para manipular pacotes e bancos de dados RPM.
197
198 %package build
199 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
200 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
201 Group(de):      Applikationen/Datei
202 Group(pl):      Aplikacje/Pliki
203 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
204 Group:          Applications/File
205 Requires:       sh-utils
206 Requires:       binutils
207 Requires:       patch
208 Requires:       texinfo
209 Requires:       file >= 3.31
210 Requires:       binutils
211 Requires:       gcc >= 3.0.3
212 Requires:       gcc
213 Requires:       diffutils
214 Requires:       libtool
215 Requires:       glibc-devel
216 Requires:       sed
217 Requires:       sed
218 Requires:       popt >= 1.6.2-2
219 Requires:       tar
220 Requires:       textutils
221
222 %description build
223 %description -l de build
224
225 %description build -l de
226 %description -l pl build
227 Skrypty pomocnicze do budowania binarnych RPMów.
228 %description build -l pl
229 construir pacotes usando o RPM.
230 %setup -q
231 %prep
232 %setup -q -a12
233 %patch0 -p1
234 %patch1 -p1
235 %patch2 -p1
236 %patch3 -p1
237 %patch4 -p1
238 %patch5 -p1
239 %patch6 -p1
240 %patch7 -p1
241 %patch8 -p1
242 %patch11 -p0
243 %patch12 -p0
244 %patch11 -p0
245 %patch12 -p0
246 %patch15 -p0
247 %patch16 -p0
248 %patch15 -p0
249 %patch16 -p0
250 %patch17 -p1
251 %patch18 -p1
252 %patch31 -p1
253 %patch36 -p1
254 cp platform.in macros.pld.in
255 %patch38 -p1
256 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
257 cp -f platform.in macros.pld.in
258 install %{SOURCE9} scripts/find-lang.sh
259 install %{SOURCE13} macros.python.in
260 install %{SOURCE6} scripts/find-perl-provides
261 install %{SOURCE7} scripts/find-perl-requires
262 install %{SOURCE9} scripts/find-lang.sh
263
264 (cd scripts;
265 mv -f perl.req perl.req.in
266 mv -f perl.prov perl.prov.in)
267 %build
268 awk -f %{SOURCE14} %{SOURCE1}
269
270 cd popt
271 autoconf
272 automake -a -c
273 aclocal
274 autoheader
275 %{__automake}
276 cd ..
277
278 rm -f missing
279 libtoolize --force --copy
280 autoconf
281 # ugly workaround for automake
282 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
283         lib/Makefile.am > lib/Makefile.am.new
284 mv -f lib/Makefile.am.new lib/Makefile.am
285 automake -a -c
286 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
287         lib/Makefile.in > lib/Makefile.in.new
288 mv -f lib/Makefile.in.new lib/Makefile.in
289
290 sed -e 's#python1.5#python%{python_version}#g' \
291         python/Makefile.in > python/Makefile.in.new
292 mv -f python/Makefile.in.new python/Makefile.in
293
294 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
295         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
296         --enable-v1-packages \
297         --with-python
298 %configure \
299         --enable-v1-packages \
300         --with-python
301
302
303 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
304
305         DESTDIR="$RPM_BUILD_ROOT" \
306 rm -rf $RPM_BUILD_ROOT
307
308 %{__make} install \
309         pkgbindir="%{_bindir}"
310
311 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
312 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
313
314 install %{SOURCE1} doc/manual/groups
315 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
316 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
317 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
318 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
319 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
320
321 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
322
323 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
324 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
325 # customized rpm macros - global for host
326 #
327 #%%_install_langs pl_PL:en_US
328 %%distribution PLD
329 EOF
330
331 %find_lang %{name}
332
333 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
334
335 %clean
336 %clean
337 rm -rf $RPM_BUILD_ROOT
338
339 rm -rf $RPM_BUILD_ROOT
340
341 %post   -p /sbin/ldconfig
342 %postun -p /sbin/ldconfig
343
344 %attr(755,root,root) %{_libdir}/rpm/rpmdb
345 %attr(755,root,root) %{_libdir}/rpm/rpmq
346 %attr(755,root,root) %{_libdir}/rpm/rpmk
347 %attr(755,root,root) %{_libdir}/rpm/rpmv
348 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
349 %attr(755,root,root) %{_libdir}/rpm/rpmdb
350 %attr(755,root,root) %{_libdir}/rpm/rpmq
351 %attr(755,root,root) %{_libdir}/rpm/rpmk
352 %attr(755,root,root) %{_libdir}/rpm/rpmv
353 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
354 %{_mandir}/man8/rpm.8*
355 %lang(pl) %{_mandir}/pl/man8/rpm.8*
356 %lang(ja) %{_mandir}/ja/man8/rpm.8*
357 %lang(fr) %{_mandir}/fr/man8/rpm.8*
358 %lang(ja) %{_mandir}/ja/man8/rpm.8*
359 %lang(ko) %{_mandir}/ko/man8/rpm.8*
360 %lang(pl) %{_mandir}/pl/man8/rpm.8*
361 %lang(ru) %{_mandir}/ru/man8/rpm.8*
362 %lang(sk) %{_mandir}/sk/man8/rpm.8*
363
364 %dir /var/lib/rpm
365 %dir %{_libdir}/rpm
366
367 %{_libdir}/rpm/noarch-linux
368 %{_libdir}/rpm/noarch-pld-linux
369 %ifarch i386 i486 i586 i686
370 %{_libdir}/rpm/rpmpopt*
371 %{_libdir}/rpm/noarch-linux
372 %{_libdir}/rpm/noarch-pld-linux
373 %ifarch i386 i486 i586 i686 athlon
374 %{_libdir}/rpm/i?86*
375 %{_libdir}/rpm/athlon*
376 %endif
377 %ifarch sparc sparc64
378 %endif
379 %ifarch ppc
380 %{_libdir}/rpm/ppc*
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_bindir}/rpmbuild
383 %attr(755,root,root) %{_bindir}/rpme
384 %attr(755,root,root) %{_bindir}/rpmi
385 %attr(755,root,root) %{_bindir}/rpmu
386 %attr(755,root,root) %{_libdir}/rpm/find-requires
387 %attr(755,root,root) %{_libdir}/rpm/find-provides
388 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
389 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
390 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
391 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
392 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
393 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
394 %attr(755,root,root) %{_libdir}/rpm/brp-*
395 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
396 %attr(755,root,root) %{_libdir}/rpm/compress-doc
397 %attr(755,root,root) %{_libdir}/rpm/cpanflute
398 %attr(755,root,root) %{_libdir}/rpm/http.req
399 %attr(755,root,root) %{_libdir}/rpm/magic.*
400 %attr(755,root,root) %{_libdir}/rpm/rpmi
401 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
402 %attr(755,root,root) %{_libdir}/rpm/rpme
403 %attr(755,root,root) %{_libdir}/rpm/rpmu
404 %attr(755,root,root) %{_libdir}/rpm/rpmb
405 %attr(755,root,root) %{_libdir}/rpm/rpmi
406 %attr(755,root,root) %{_libdir}/rpm/rpmt
407 %attr(755,root,root) %{_libdir}/rpm/rpme
408 %attr(755,root,root) %{_libdir}/librpm*.la
409 %attr(755,root,root) %{_libdir}/librpm*.so
410 %files devel
411 %defattr(644,root,root,755)
412 %{_includedir}/rpm
413 %attr(755,root,root) %{_libdir}/librpm*.la
414 %attr(755,root,root) %{_libdir}/librpm*.so
415
416 %files static
417 %attr(755,root,root) %{_bindir}/*
418 %files utils
419 %defattr(644,root,root,755)
420 %{_mandir}/man1/*
421 %{_mandir}/man8/rpm2cpio.8*
422 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
423 %{_mandir}/man1/*
424 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
425 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
426 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
427 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
428
429 %files perlprov
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_libdir}/rpm/perl*
432 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
433 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
434 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
435 %files python
436 %defattr(644,root,root,755)
437 %{python_sitedir}/*.so
438 %{_libdir}/rpm/macros.python
439
440 %files -n python-rpm
441 * %{date} PLD Team <pld-list@pld.org.pl>
442 %{py_sitedir}/*.so
This page took 0.051065 seconds and 4 git commands to generate.