]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- changed polish description of devel subpackage.
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        45
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(es):      Base
11 Group(pl):      Podstawowe
12 Group(pt_BR):   Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch37:        %{name}-short_circuit.patch
55 Patch38:        %{name}-section_test.patch
56 BuildRequires:  gettext-devel >= 0.10.38-3
57 BuildRequires:  automake
58 BuildRequires:  db3-devel >= 3.1.17-9
59 BuildRequires:  bzip2-devel >= 1.0.1
60 BuildRequires:  zlib-devel
61 BuildRequires:  gettext-devel >= 0.10.38-3
62 BuildRequires:  libtool
63 BuildRequires:  automake
64 BuildRequires:  autoconf >= 2.50
65 BuildRequires:  python-devel
66 BuildRequires:  python-modules >= 2.2.1
67 BuildRequires:  zlib-devel >= 1.1.4
68 # Require static library only for static build
69 BuildRequires:  db3-static >= 3.1.17-9
70 BuildRequires:  bzip2-static >= 1.0.1
71 BuildRequires:  zlib-static
72 BuildRequires:  glibc-static >= 2.2.0
73 %endif
74 BuildRequires:  zlib-static >= 1.1.4
75 Obsoletes:      rpm-libs
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77 Obsoletes:      rpm-libs
78 %define __find_provides %{SOURCE4}
79 %define _binary_payload w9.gzdio
80 %define         __find_provides %{SOURCE4}
81 %define py_ver         %(echo `python -c "import sys; print sys.version[:3]"`)
82 %define py_prefix      %(echo `python -c "import sys; print sys.prefix"`)
83 %define py_libdir      %{py_prefix}/lib/python%{py_ver}
84 %define py_sitedir     %{py_libdir}/site-packages
85 %define py_dyndir      %{py_libdir}/lib-dynload
86 %define         py_dyndir       %{py_libdir}/lib-dynload
87 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
88
89 %description
90 RPM is a powerful package manager, which can be used to build,
91 install, query, verify, update, and uninstall individual software
92 packages. A package consists of an archive of files, and package
93 information, including name, version, and description.
94
95 %description -l de
96 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
97 Installation, Anfrage, Verifizierung, Aktualisierung und
98 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
99 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
100 nombre, versión y descripción.
101
102 %description -l pl
103 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
104 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
105 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
106 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
107 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
108 do pacote, permissões dos arquivos, etc.
109
110 %package devel
111 Summary(de):    Header-Dateien uns Libraries
112 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
113 Group(de):      Entwicklung/Libraries
114 Group(es):      Desarrollo/Bibliotecas
115 Group(fr):      Development/Librairies
116 Group(pl):      Programowanie/Biblioteki
117 Group(pt_BR):   Desenvolvimento/Bibliotecas
118 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
119 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
120 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
121 Group:          Development/Libraries
122 Requires:       %{name} = %{version}
123 Requires:       popt-devel
124
125 %description devel
126 The RPM packaging system includes a C library that makes it easy to
127 manipulate RPM packages and databases. It is intended to ease the
128 creation of graphical package managers and other tools that need
129 intimate knowledge of RPM packages.
130
131 %description devel -l de
132 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
133 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
134 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
135 herramientas que necesiten un conocimiento profundo de paquetes RPM.
136
137 %description devel -l pl
138 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
139 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
140 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
141 ferramentas que precisem de conhecimento profundo de pacotes RPM.
142
143 %package static
144 Summary:        RPM static libraries
145 Summary(pl):    Biblioteki statyczne RPM-a
146 Group(de):      Entwicklung/Libraries
147 Group(es):      Desarrollo/Bibliotecas
148 Group(fr):      Development/Librairies
149 Group(pl):      Programowanie/Biblioteki
150 Group(pt_BR):   Desenvolvimento/Bibliotecas
151 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
152 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
153 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}
156
157 %description static
158 RPM static libraries.
159
160 %description static -l de
161 RPMs statische Libraries.
162
163 %description static -l pl
164 Bibliotecas estáticas para desenvolvimento.
165
166 %package utils
167 Summary:        Additional utilities for managing rpm packages and database
168 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
169 Group(de):      Applikationen/Datei
170 Group(pl):      Aplikacje/Pliki
171 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
172 Group:          Applications/File
173 Requires:       %{name} = %{version}
174
175 %description utils
176 Additional utilities for managing rpm packages and database.
177
178 %description utils -l de
179 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
180
181 %description utils -l pl
182 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
183
184 %package perlprov
185 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
186 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
187 Group(de):      Applikationen/Datei
188 Group(pl):      Aplikacje/Pliki
189 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
190 Group:          Applications/File
191 Requires:       perl-modules
192 Requires:       findutils
193
194 %description perlprov
195 Additional utilities for checking perl provides/requires in rpm
196 packages.
197
198 %description perlprov -l de
199 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
200 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
201 %description perlprov -l pl
202 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
203 pakietach rpm.
204
205 %package pythonprov
206 Summary:        Python macros, which simplifies creation of rpm packages with Python software
207 Group(de):      Applikationen/Datei
208 Group(pl):      Aplikacje/Pliki
209 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
210 Requires:       python
211 Requires:       %{name} = %{version}
212 Requires:       python-modules
213
214 %description pythonprov
215 Python macros, which simplifies creation of rpm packages with Python
216 software.
217 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi
218 w Pythonie.
219 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
220 %package python
221
222 Group:          Development/Languages/Python
223 Group(de):      Entwicklung/Sprachen/Python
224 Group(pl):      Programowanie/Jêzyki/Python
225 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
226 %pyrequires_eq  python
227 %description python
228
229 %description -n python-rpm
230 The rpm-python package contains a module which permits applications
231 written in the Python programming language to use the interface
232 supplied by RPM (RPM Package Manager) libraries.
233
234 This package should be installed if you want to develop Python
235 %description python -l pl
236 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym
237 w Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki rpma.
238 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
239 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ
240 w Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
241 Esse pacote deve ser instalado se você quiser desenvolver programas em
242 Python para manipular pacotes e bancos de dados RPM.
243
244 %package build
245 Summary:        Scripts for building binary RPM packages
246 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
247 Group(de):      Applikationen/Datei
248 Group(pl):      Aplikacje/Pliki
249 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
250 Group:          Applications/File
251 Requires:       sh-utils
252 Requires:       binutils
253 Requires:       patch
254 Requires:       file >= 3.31
255 Requires:       binutils
256 Requires:       make
257 Requires:       gcc >= 3.0.3
258 Requires:       gcc
259 Requires:       diffutils
260 Requires:       glibc-devel
261 Requires:       sed
262 Requires:       sed
263 Requires:       popt >= 1.6.2-2
264 Requires:       tar
265 Requires:       textutils
266
267 %description build
268 Scripts for building binary RPM packages.
269
270 %description build -l de
271 Scripts fürs Bauen binärer RPM-Pakete.
272
273 %description build -l pl
274 construir pacotes usando o RPM.
275
276 %prep
277 %setup -q -a12
278 %patch0 -p1
279 %patch1 -p1
280 %patch2 -p1
281 %patch3 -p1
282 %patch4 -p1
283 %patch5 -p1
284 %patch6 -p1
285 %patch7 -p1
286 %patch8 -p1
287 %patch11 -p0
288 %patch12 -p0
289 %patch11 -p0
290 %patch12 -p0
291 %patch15 -p0
292 %patch16 -p0
293 %patch15 -p0
294 %patch16 -p0
295 %patch17 -p1
296 %patch18 -p1
297 %patch19 -p1
298 %patch22 -p1
299 %patch23 -p1
300 %patch24 -p1
301 %patch25 -p1
302 %patch26 -p0
303 %patch31 -p1
304 %patch36 -p1
305 %patch37 -p1
306 %patch38 -p1
307
308 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
309 cp -f platform.in macros.pld.in
310 install %{SOURCE9} scripts/find-lang.sh
311 install %{SOURCE13} macros.python.in
312 install %{SOURCE6} scripts/find-perl-provides
313 install %{SOURCE7} scripts/find-perl-requires
314 install %{SOURCE9} scripts/find-lang.sh
315
316 (cd scripts;
317 mv -f perl.req perl.req.in
318 mv -f perl.prov perl.prov.in)
319 %build
320 awk -f %{SOURCE14} %{SOURCE1}
321
322 cd popt
323 autoconf
324 automake -a -c
325 aclocal
326 autoheader
327 %{__automake}
328 cd ..
329
330 rm -f missing
331 libtoolize --force --copy
332 autoconf
333 # ugly workaround for automake
334 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
335         lib/Makefile.am > lib/Makefile.am.new
336 mv -f lib/Makefile.am.new lib/Makefile.am
337 automake -a -c
338 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
339         lib/Makefile.in > lib/Makefile.in.new
340 mv -f lib/Makefile.in.new lib/Makefile.in
341
342 sed -e 's#python1.5#python%{py_ver}#g' \
343         python/Makefile.in > python/Makefile.in.new
344 mv -f python/Makefile.in.new python/Makefile.in
345
346 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
347         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
348         --enable-v1-packages \
349         --with-python
350 %configure \
351         --enable-v1-packages \
352         --with-python
353
354
355 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
356
357         DESTDIR"$RPM_BUILD_ROOT \
358 rm -rf $RPM_BUILD_ROOT
359
360 %{__make} install \
361         DESTDIR=$RPM_BUILD_ROOT \
362         pkgbindir="%{_bindir}"
363
364 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
365 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
366
367 install %{SOURCE1} doc/manual/groups
368 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
369 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
370 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
371 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
372 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
373
374 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
375
376 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
377 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
378 # customized rpm macros - global for host
379 #
380 #%%_install_langs pl_PL:en_US
381 %%distribution PLD
382 EOF
383
384 %find_lang %{name}
385
386 # DON'T BREAK BUILD TREE!!!
387 # rm -f doc/manual/Makefile*
388
389 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
390
391 %clean
392 rm -rf $RPM_BUILD_ROOT
393
394 %post   -p /sbin/ldconfig
395 %postun -p /sbin/ldconfig
396
397 %attr(755,root,root) %{_libdir}/rpm/rpmdb
398 %attr(755,root,root) %{_libdir}/rpm/rpmq
399 %attr(755,root,root) %{_libdir}/rpm/rpmk
400 %attr(755,root,root) %{_libdir}/rpm/rpmv
401 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
402 %attr(755,root,root) %{_libdir}/rpm/rpmdb
403 %attr(755,root,root) %{_libdir}/rpm/rpmq
404 %attr(755,root,root) %{_libdir}/rpm/rpmk
405 %attr(755,root,root) %{_libdir}/rpm/rpmv
406 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
407
408 %dir %{_sysconfdir}/rpm
409 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
410
411 %{_mandir}/man8/rpm.8*
412 %lang(fr) %{_mandir}/fr/man8/rpm.8*
413 %lang(ja) %{_mandir}/ja/man8/rpm.8*
414 %lang(ko) %{_mandir}/ko/man8/rpm.8*
415 %lang(pl) %{_mandir}/pl/man8/rpm.8*
416 %lang(ru) %{_mandir}/ru/man8/rpm.8*
417 %lang(sk) %{_mandir}/sk/man8/rpm.8*
418
419 %dir /var/lib/rpm
420 %dir %{_libdir}/rpm
421
422 %{_libdir}/rpm/macros.python
423 %{_libdir}/rpm/noarch-linux
424 %{_libdir}/rpm/noarch-pld-linux
425 %ifarch i386 i486 i586 i686
426 %{_libdir}/rpm/rpmpopt*
427 %{_libdir}/rpm/noarch-linux
428 %{_libdir}/rpm/noarch-pld-linux
429 %ifarch i386 i486 i586 i686 athlon
430 %{_libdir}/rpm/i?86*
431 %{_libdir}/rpm/athlon*
432 %endif
433 %ifarch sparc sparc64
434 %{_libdir}/rpm/sparc*
435 %endif
436 %ifarch alpha
437 %{_libdir}/rpm/alpha*
438 %endif
439 %ifarch ppc
440 %{_libdir}/rpm/ppc*
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_bindir}/rpmbuild
443 %attr(755,root,root) %{_bindir}/rpme
444 %attr(755,root,root) %{_bindir}/rpmi
445 %attr(755,root,root) %{_bindir}/rpmu
446 %attr(755,root,root) %{_libdir}/rpm/find-requires
447 %attr(755,root,root) %{_libdir}/rpm/find-provides
448 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
449 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
450 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
451 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
452 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
453 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
454 %attr(755,root,root) %{_libdir}/rpm/brp-*
455 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
456 %attr(755,root,root) %{_libdir}/rpm/compress-doc
457 %attr(755,root,root) %{_libdir}/rpm/cpanflute
458 %attr(755,root,root) %{_libdir}/rpm/http.req
459 %attr(755,root,root) %{_libdir}/rpm/magic.*
460 %attr(755,root,root) %{_libdir}/rpm/rpmi
461 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
462 %attr(755,root,root) %{_libdir}/rpm/rpme
463 %attr(755,root,root) %{_libdir}/rpm/rpmu
464 %attr(755,root,root) %{_libdir}/rpm/rpmb
465 %attr(755,root,root) %{_libdir}/rpm/rpmi
466 %attr(755,root,root) %{_libdir}/rpm/rpmt
467 %attr(755,root,root) %{_libdir}/rpm/rpme
468 %attr(755,root,root) %{_libdir}/librpm*.la
469 %attr(755,root,root) %{_libdir}/librpm*.so
470 %files devel
471 %defattr(644,root,root,755)
472 %{_includedir}/rpm
473 %attr(755,root,root) %{_libdir}/librpm*.la
474 %attr(755,root,root) %{_libdir}/librpm*.so
475
476 %files static
477 %attr(755,root,root) %{_bindir}/*
478 %files utils
479 %defattr(644,root,root,755)
480 %{_mandir}/man1/*
481 %attr(755,root,root) %{_bindir}/javadeps
482 %attr(755,root,root) %{_bindir}/rpm2cpio
483
484 %{_mandir}/man8/rpm2cpio.8*
485 %{_mandir}/man1/*
486 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
487 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
488 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
489 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
490
491 %files perlprov
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_libdir}/rpm/perl*
494 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
495 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
496 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
497 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
498 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
499
500 %{_libdir}/rpm/macros.perl
501 %files python
502 %defattr(644,root,root,755)
503 %{py_sitedir}/*.so
504 %{_libdir}/rpm/macros.python
505
506 %files -n python-rpm
507 * %{date} PLD Team <pld-list@pld.org.pl>
508 %{py_sitedir}/*.so
This page took 0.056756 seconds and 4 git commands to generate.