]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- and next bunch fixes s/allow build package/allows build package/.
[packages/rpm.git] / rpm.spec
1 Summary:     Red Hat Package Manager
2 Summary(pl): Aplikacja do zarz±dzania pakietami
3 Name:        rpm
4 Version:     2.5.5
5 Release:     2
6 Group:       Utilities/System
7 Source:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x/%{name}-%{version}.tar.gz
8 Patch0:      rpm.patch
9 Patch1:      rpm-no_vrfy_symlinks.patch
10 Copyright:   GPL
11 BuildRoot:   /tmp/%{name}-%{version}-root
12 Conflicts:   patch < 2.5
13 Obsoletes:      rpm-libs
14 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
15 RPM is a powerful package manager, which can be used to build, install, 
16 query, verify, update, and uninstall individual software packages. A 
17 package consists of an archive of files, and package information, including 
18 name, version, and description.
19 packages. A package consists of an archive of files, and package
20 nombre, versión y descripción.
21
22 RPM jest programem s³u¿±cym do zarz±dzania oprogramowaniem (menad¿erem
23 pakietów). Dziêki niemu bêdziesz móg³ przebudowaæ, zainstalowaæ czy
24 zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego pakietu s±
25 przechowywane w bazie danych i dostêpne tylko dla administratora systemu.
26 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
27 %package devel
28 Summary:     Header files and libraries for programs that manipulate rpm packages
29 Summary(pl): Pliki nag³ówkowe i biblioteki statyczne
30 Group:       Development/Libraries
31 Requires:    %{name} = %{version}
32 Requires:       %{name} = %{version}
33 Requires:       popt-devel
34
35 %description devel
36 The RPM packaging system includes a C library that makes it easy to
37 manipulate RPM packages and databases. It is intended to ease the
38 creation of graphical package managers and other tools that need
39 %description -l pl devel
40 RPM to tak¿e 
41 Pliki nag³ówkowe i biblioteki statyczne.
42 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
43 construir pacotes usando o RPM.
44 %setup -q
45 %patch0 -p1
46 %patch1 -p1
47 install %{SOURCE13} macros.python.in
48 mv -f perl.prov perl.prov.in)
49 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr
50 make
51         --with-python
52
53
54 install -d $RPM_BUILD_ROOT/{var/lib/rpm,usr/src/rpm/{SOURCES,SPECS,RPMS/{$RPM_ARCH,noarch},SRPMS,BUILD}}
55 make installprefix="$RPM_BUILD_ROOT" install
56         pkgbindir="%{_bindir}"
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 /bin/rpm --initdb
62
63 %files
64 %defattr(644, root, root, 755)
65 %doc RPM-PGP-KEY CHANGES groups docs/*
66 %attr(755, root, root) /bin/rpm
67 %attr(755, root, root) /usr/bin/*
68 %dir /usr/lib/rpm
69 %attr(755, root, root) /usr/lib/rpm/find-*
70 %attr(755, root, root) /usr/lib/rpm/freshen.sh
71 %attr(755, root, root) /usr/lib/rpm/mkinstalldirs
72 /usr/lib/rpm/rpmrc
73 /usr/lib/rpm/rpmpopt
74 %attr(644, root,  man) /usr/man/man8/*
75 %attr(700, root, root) %dir /var/lib/rpm
76 /usr/src/rpm
77 %lang(cs) /usr/share/locale/cs/LC_MESSAGES/rpm.mo
78 %lang(de) /usr/share/locale/de/LC_MESSAGES/rpm.mo
79 %lang(fi) /usr/share/locale/fi/LC_MESSAGES/rpm.mo
80 %lang(fr) /usr/share/locale/fr/LC_MESSAGES/rpm.mo
81 %lang(pt) /usr/share/locale/pt*/LC_MESSAGES/rpm.mo
82 %lang(ru) /usr/share/locale/ru/LC_MESSAGES/rpm.mo
83 %lang(sk) /usr/share/locale/sk/LC_MESSAGES/rpm.mo
84 %lang(sr) /usr/share/locale/sr/LC_MESSAGES/rpm.mo
85 %lang(sv) /usr/share/locale/sv/LC_MESSAGES/rpm.mo
86 %lang(tr) /usr/share/locale/tr/LC_MESSAGES/rpm.mo
87 %lang(ru) %{_mandir}/ru/man8/rpm.8*
88 %attr(755,root,root) %{_libdir}/rpm/rpmi
89 %defattr(644, root, root, 755)
90 /usr/include/rpm
91 /usr/lib/lib*.a
92 %files utils
93 %files -n python-rpm
94 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
95   [2.5.2-3]
96 - added pl translation.
97
98 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
99   [2.5.2-2]
100 - fixed tr.po,
101 - added -q %setup parameter,
102 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
103 - added using %%{name} and %%{version} in Source,
104 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
105 - added %attr and %defattr macros in %files (allows build package from
106   non-root account).
107 Revision 1.79  2000/02/17 03:42:17  kloczek
108 - release 25,
109 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
110   /bin.
This page took 0.031863 seconds and 4 git commands to generate.