]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- rebuild with fixed zlib
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        58
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch28:        %{name}-perlprov-regonly.patch
56 Patch29:        %{name}-cxx.patch
57 Patch30:        %{name}-athlon.patch
58 Patch31:        %{name}-athlon-identify.patch
59 Patch32:        %{name}-gettext-in-header.patch
60 Patch33:        %{name}-perlprov-perl5.6.patch
61 Patch37:        %{name}-short_circuit.patch
62 Patch38:        %{name}-section_test.patch
63 URL:            http://www.rpm.org/
64 Icon:           rpm.gif
65 BuildRequires:  autoconf >= 2.50
66 BuildRequires:  automake
67 BuildRequires:  bzip2-devel >= 1.0.1
68 BuildRequires:  db1-devel >= 1.85
69 BuildRequires:  db3-devel >= 3.1.17-9
70 BuildRequires:  gettext-devel >= 0.10.38-3
71 BuildRequires:  python-devel >= 2.2
72 BuildRequires:  python-modules >= 2.2
73 BuildRequires:  python-devel >= 2.2.1
74 BuildRequires:  python-modules >= 2.2.1
75 BuildRequires:  zlib-devel >= 1.1.4
76 %if %{!?_without_static:1}%{?_without_static:0}
77 # Require static library only for static build
78 BuildRequires:  bzip2-static >= 1.0.1
79 BuildRequires:  db1-static >= 1.85
80 BuildRequires:  db3-static >= 3.1.17-9
81 BuildRequires:  glibc-static >= 2.2.0
82 BuildRequires:  zlib-static >= 1.1.4
83 %endif
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85 Obsoletes:      rpm-libs
86 Conflicts:      glibc < 2.2
87
88 %define         __find_provides %{SOURCE4}
89 %define         _binary_payload w9.gzdio
90
91 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
92 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
93 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
94 %define         py_dyndir       %{py_libdir}/lib-dynload
95 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
96
97 %description
98 RPM is a powerful package manager, which can be used to build,
99 install, query, verify, update, and uninstall individual software
100 packages. A package consists of an archive of files, and package
101 information, including name, version, and description.
102
103 %description -l de
104 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
105 Installation, Anfrage, Verifizierung, Aktualisierung und
106 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
107 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
108 Beschreibung.
109
110 %description -l es
111 RPM es un poderoso administrador de paquetes, que puede ser usado para
112 construir, instalar, pesquisar, verificar, actualizar y desinstalar
113 paquetes individuales de software. Un paquete consiste en un
114 almacenaje de archivos, y información sobre el paquete, incluyendo
115 nombre, versión y descripción.
116
117 %description -l pl
118 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
119 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
120 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
121 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
122 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
123 odpytywania programu rpm.
124
125 %description -l pt_BR
126 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
127 construir, instalar, pesquisar, verificar, atualizar e desinstalar
128 pacotes individuais de software. Um pacote consiste de um conjunto de
129 arquivos e informações adicionais, incluindo nome, versão e descrição
130 do pacote, permissões dos arquivos, etc.
131
132 %package devel
133 Summary:        Header files and libraries
134 Summary(de):    Header-Dateien uns Libraries
135 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
136 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
137 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
138 Group:          Development/Libraries
139 Requires:       %{name} = %{version}
140 Requires:       popt-devel
141
142 %description devel
143 The RPM packaging system includes a C library that makes it easy to
144 manipulate RPM packages and databases. It is intended to ease the
145 creation of graphical package managers and other tools that need
146 intimate knowledge of RPM packages.
147
148 %description devel -l de
149 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
150 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
151 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
152 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
153
154 %description devel -l es
155 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
156 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
157 facilitar la creación de administradores gráficos de paquetes y otras
158 herramientas que necesiten un conocimiento profundo de paquetes RPM.
159
160 %description devel -l pl
161 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
162 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
163 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
164 szczegó³owej wiedzy na temat pakietów RPM.
165
166 %description devel -l pt_BR
167 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
168 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
169 facilitar a criação de gerenciadores gráficos de pacotes e outras
170 ferramentas que precisem de conhecimento profundo de pacotes RPM.
171
172 %package static
173 Summary:        RPM static libraries
174 Summary(de):    RPMs statische Libraries
175 Summary(pl):    Biblioteki statyczne RPM-a
176 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
177 Group:          Development/Libraries
178 Requires:       %{name}-devel = %{version}
179
180 %description static
181 RPM static libraries.
182
183 %description static -l de
184 RPMs statische Libraries.
185
186 %description static -l pl
187 Biblioteki statyczne RPM-a.
188
189 %description static -l pt_BR
190 Bibliotecas estáticas para desenvolvimento.
191
192 %package utils
193 Summary:        Additional utilities for managing rpm packages and database
194 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
195 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
196 Group:          Applications/File
197 Requires:       %{name} = %{version}
198
199 %description utils
200 Additional utilities for managing rpm packages and database.
201
202 %description utils -l de
203 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
204
205 %description utils -l pl
206 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
207
208 %package perlprov
209 Summary:        Additional utilities for checking perl provides/requires in rpm packages
210 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
211 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
212 Group:          Applications/File
213 Requires:       %{name} = %{version}
214 Requires:       perl-modules
215 Requires:       findutils
216
217 %description perlprov
218 Additional utilities for checking perl provides/requires in rpm
219 packages.
220
221 %description perlprov -l de
222 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
223
224 %description perlprov -l pl
225 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
226 pakietach rpm.
227
228 %package pythonprov
229 Summary:        Python macros, which simplifies creation of rpm packages with Python software
230 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
231 Group:          Applications/File
232 Requires:       %{name} = %{version}
233 Requires:       python-modules
234
235 %description pythonprov
236 Python macros, which simplifies creation of rpm packages with Python
237 software.
238
239 %description pythonprov -l pl
240 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
241 Pythonie.
242
243 %package -n python-rpm
244 Summary:        Python interface to RPM library
245 Group:          Development/Languages/Python
246 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
247 %requires_eq    python
248 Requires:       %{name} = %{version}
249 %pyrequires_eq  python
250 Obsoletes:      rpm-python
251
252 %description -n python-rpm
253 The rpm-python package contains a module which permits applications
254 written in the Python programming language to use the interface
255 supplied by RPM (RPM Package Manager) libraries.
256
257 This package should be installed if you want to develop Python
258 programs that will manipulate RPM packages and databases.
259
260 %description -n python-rpm -l pl
261 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
262 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
263
264 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
265 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
266
267 %description -n python-rpm -l pt_BR
268 O pacote rpm-python contém um módulo que permite que aplicações
269 escritas em Python utilizem a interface fornecida pelas bibliotecas
270 RPM (RPM Package Manager).
271
272 Esse pacote deve ser instalado se você quiser desenvolver programas em
273 Python para manipular pacotes e bancos de dados RPM.
274
275 %package build
276 Summary:        Scripts for building binary RPM packages
277 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
278 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
279 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
280 Group:          Applications/File
281 Requires:       %{name} = %{version}
282 Requires:       /bin/id
283 Requires:       awk
284 Requires:       binutils
285 Requires:       diffutils
286 Requires:       file >= 3.31
287 Requires:       fileutils
288 Requires:       findutils
289 %ifarch athlon
290 Requires:       gcc >= 3.0.3
291 %else
292 Requires:       gcc
293 Requires:       glibc-devel
294 Requires:       grep
295 Requires:       gzip
296 Requires:       make
297 Requires:       patch
298 Requires:       popt >= 1.6.2-2
299 Requires:       sed
300 Requires:       sh-utils
301 Requires:       tar
302 Requires:       textutils
303
304 %description build
305 Scripts for building binary RPM packages.
306
307 %description build -l de
308 Scripts fürs Bauen binärer RPM-Pakete.
309
310 %description build -l pl
311 Skrypty pomocnicze do budowania binarnych RPM-ów.
312
313 %description build -l pt_BR
314 Este pacote contém scripts e programas executáveis que são usados para
315 construir pacotes usando o RPM.
316
317 %prep
318 %setup -q -a12
319 %patch0 -p1
320 %patch1 -p1
321 %patch2 -p1
322 %patch3 -p1
323 %patch4 -p1
324 %patch5 -p1
325 %patch6 -p1
326 %patch7 -p1
327 %patch8 -p1
328 %patch9 -p1
329 %patch10 -p1
330 %patch11 -p0
331 %patch12 -p0
332 %patch13 -p1
333 %patch14 -p1
334 %patch15 -p0
335 %patch16 -p0
336 %patch17 -p1
337 %patch18 -p1
338 %patch19 -p1
339 %patch20 -p1
340 %patch21 -p1
341 %patch22 -p1
342 %patch23 -p1
343 %patch24 -p1
344 %patch25 -p1
345 %patch26 -p0
346 %patch27 -p1
347 %patch28 -p1
348 %patch29 -p1
349 %patch30 -p1
350
351 %ifarch athlon
352 %patch31 -p1
353 %endif
354
355 %patch35 -p1
356 %patch36 -p1
357 %patch37 -p1
358 %patch38 -p1
359
360 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
361 cp -f platform.in macros.pld.in
362 install %{SOURCE5} macros.perl.in
363 install %{SOURCE13} macros.python.in
364 install %{SOURCE6} scripts/find-perl-provides
365 install %{SOURCE7} scripts/find-perl-requires
366 install %{SOURCE9} scripts/find-lang.sh
367
368 (cd scripts;
369 mv -f perl.req perl.req.in
370 mv -f perl.prov perl.prov.in)
371 %build
372 # generate Group translations to *.po
373 awk -f %{SOURCE14} %{SOURCE1}
374
375 cd popt
376 autoconf
377 automake -a -c
378 aclocal
379 autoheader
380 automake -a -c -f
381 %{__automake}
382 cd ..
383
384 rm -f missing
385 libtoolize --force --copy
386 autoconf
387 aclocal
388 autoupdate
389 autoheader || :
390 %{__autoconf}
391 automake -a -c
392 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
393         lib/Makefile.am > lib/Makefile.am.new
394 mv -f lib/Makefile.am.new lib/Makefile.am
395 %{__automake}
396 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
397         lib/Makefile.in > lib/Makefile.in.new
398 mv -f lib/Makefile.in.new lib/Makefile.in
399
400 sed -e 's#python1.5#python%{py_ver}#g' \
401         python/Makefile.in > python/Makefile.in.new
402 mv -f python/Makefile.in.new python/Makefile.in
403
404 # config.guess doesn't handle athlon, so we have to change it by hand.
405 # rpm checks for CPU type at runtime, but it looks better
406 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
407         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
408 mv -f macros.tmp macros.in
409
410 %configure \
411         --enable-shared \
412         --enable-v1-packages \
413         --with-python
414
415
416 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
417
418 %install
419 rm -rf $RPM_BUILD_ROOT
420
421 %{__make} install \
422         DESTDIR=$RPM_BUILD_ROOT \
423         pkgbindir="%{_bindir}"
424
425 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
426 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
427
428 install %{SOURCE1} doc/manual/groups
429 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
430 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
431 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
432 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
433 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
434
435 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
436
437 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
438 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
439 # customized rpm macros - global for host
440 #
441 #%%_install_langs pl_PL:en_US
442 %%distribution PLD
443 EOF
444
445 %find_lang %{name}
446
447 # DON'T BREAK BUILD TREE!!!
448 # rm -f doc/manual/Makefile*
449
450 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %post   -p /sbin/ldconfig
456 %postun -p /sbin/ldconfig
457
458 %files -f %{name}.lang
459 %defattr(644,root,root,755)
460 %doc RPM-PGP-KEY.gz CHANGES.gz doc/manual/*
461
462 %attr(755,root,root) /bin/rpm
463 %attr(755,root,root) %{_bindir}/rpmdb
464 %attr(755,root,root) %{_bindir}/rpmquery
465 %attr(755,root,root) %{_bindir}/rpmsign
466 %attr(755,root,root) %{_bindir}/rpmverify
467 %attr(755,root,root) %{_libdir}/rpm/rpmdb
468 %attr(755,root,root) %{_libdir}/rpm/rpmq
469 %attr(755,root,root) %{_libdir}/rpm/rpmk
470 %attr(755,root,root) %{_libdir}/rpm/rpmv
471 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
472
473 %dir %{_sysconfdir}/rpm
474 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
475
476 %{_mandir}/man8/rpm.8*
477 %lang(fr) %{_mandir}/fr/man8/rpm.8*
478 %lang(ja) %{_mandir}/ja/man8/rpm.8*
479 %lang(ko) %{_mandir}/ko/man8/rpm.8*
480 %lang(pl) %{_mandir}/pl/man8/rpm.8*
481 %lang(ru) %{_mandir}/ru/man8/rpm.8*
482 %lang(sk) %{_mandir}/sk/man8/rpm.8*
483
484 %dir /var/lib/rpm
485 %dir %{_libdir}/rpm
486
487 %{_libdir}/rpm/macros.python
488 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
489
490 %{_libdir}/rpm/rpmrc
491 %{_libdir}/rpm/rpmpopt*
492 %{_libdir}/rpm/macros
493 %{_libdir}/rpm/noarch-linux
494 %{_libdir}/rpm/noarch-pld-linux
495 %ifarch i386 i486 i586 i686 athlon
496 %{_libdir}/rpm/i?86*
497 %{_libdir}/rpm/athlon*
498 %endif
499 %ifarch sparc sparc64
500 %{_libdir}/rpm/sparc*
501 %endif
502 %ifarch alpha
503 %{_libdir}/rpm/alpha*
504 %endif
505 %ifarch ppc
506 %{_libdir}/rpm/ppc*
507 %endif
508
509
510 %files build
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_bindir}/rpmbuild
513 %attr(755,root,root) %{_bindir}/rpme
514 %attr(755,root,root) %{_bindir}/rpmi
515 %attr(755,root,root) %{_bindir}/rpmu
516 %attr(755,root,root) %{_libdir}/rpm/find-requires
517 %attr(755,root,root) %{_libdir}/rpm/find-provides
518 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
519 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
520 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
521 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
522 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
523 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
524 %attr(755,root,root) %{_libdir}/rpm/brp-*
525 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
526 %attr(755,root,root) %{_libdir}/rpm/compress-doc
527 %attr(755,root,root) %{_libdir}/rpm/cpanflute
528 %attr(755,root,root) %{_libdir}/rpm/http.req
529 %attr(755,root,root) %{_libdir}/rpm/magic.*
530 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
531 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
532 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
533 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
534 %attr(755,root,root) %{_libdir}/rpm/rpmb
535 %attr(755,root,root) %{_libdir}/rpm/rpmi
536 %attr(755,root,root) %{_libdir}/rpm/rpmt
537 %attr(755,root,root) %{_libdir}/rpm/rpme
538 %attr(755,root,root) %{_libdir}/rpm/rpmu
539
540 %files devel
541 %defattr(644,root,root,755)
542 %{_includedir}/rpm
543 %attr(755,root,root) %{_libdir}/librpm*.la
544 %attr(755,root,root) %{_libdir}/librpm*.so
545
546 %files static
547 %defattr(644,root,root,755)
548 %{_libdir}/librpm*.a
549
550 %files utils
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_bindir}/gendiff
553 %attr(755,root,root) %{_bindir}/javadeps
554 %attr(755,root,root) %{_bindir}/rpm2cpio
555
556 %{_mandir}/man8/rpm2cpio.8*
557 %{_mandir}/man1/*
558 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
559 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
560 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
561 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
562
563 %files perlprov
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/rpm/perl*
566 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
567 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
568 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
569 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
570 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
571
572 %{_libdir}/rpm/macros.perl
573
574 %files pythonprov
575 %defattr(644,root,root,755)
576 %{_libdir}/rpm/macros.python
577
578 %files -n python-rpm
579 %defattr(755,root,root,755)
580 %{py_sitedir}/*.so
This page took 0.125477 seconds and 4 git commands to generate.