]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- revision up to 5,
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        2.5.6
5 Release:        5
6 Group:          Base
7 Group(pl):      Bazowe
8 Copyright:      GPL
9 Source:         ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x/%{name}-%{version}.tar.gz
10 Patch0:         rpm-config.patch
11 Patch1:         rpm-rpmrc.patch
12 Patch2:         rpm-glibc.patch
13 Patch3:         rpm-groups.patch
14 Patch4:         rpm-i18n.patch
15 Patch5:         rpm-find-requires.patch
16 Patch37:        %{name}-short_circuit.patch
17 Requires:       glibc >= 2.1
18 BuildRoot:      /tmp/%{name}-%{version}-root
19 Obsoletes:      rpm-libs
20 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
21 RPM is a powerful package manager, which can be used to build, install, 
22 query, verify, update, and uninstall individual software packages. A 
23 package consists of an archive of files, and package information, including 
24 name, version, and description.
25 packages. A package consists of an archive of files, and package
26 nombre, versión y descripción.
27 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
28 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
29 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
30 systemu.
31 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
32 %package        devel
33 Summary:        Header files and libraries 
34 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
35 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
36 Group(pl):      Programowanie/Biblioteki
37 Requires:       %{name} = %{version}
38 Requires:       %{name} = %{version}
39 Requires:       popt-devel
40
41 %description devel
42 The RPM packaging system includes a C library that makes it easy to
43 manipulate RPM packages and databases. It is intended to ease the
44 creation of graphical package managers and other tools that need
45 %description -l pl devel
46 Pliki nag³ówkowe i biblioteki statyczne.
47 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
48 construir pacotes usando o RPM.
49 %setup  -q
50 %patch0 -p1
51 %patch1 -p1
52 %patch2 -p1
53 %patch1 -p1
54 %patch4 -p1
55 %patch5 -p1
56 install %{SOURCE13} macros.python.in
57 mv -f perl.prov perl.prov.in)
58 autoconf
59 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
60 ./configure \
61         --prefix=/usr
62 make
63         --with-python
64
65
66 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
67 install -d $RPM_BUILD_ROOT/var/lib/rpm \
68         $RPM_BUILD_ROOT/usr/src/rpm/{SOURCES,SPECS,SRPMS,BUILD} \
69         $RPM_BUILD_ROOT/usr/src/rpm/RPMS/{$RPM_ARCH,noarch} \
70         $RPM_BUILD_ROOT/usr/man/ru/man8
71
72 make installprefix="$RPM_BUILD_ROOT" install
73         pkgbindir="%{_bindir}"
74 install rpm.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm.8
75 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm2cpio.8
76
77 gzip -9fn $RPM_BUILD_ROOT/usr/man/{ru/man8/*,man8/*}
78
79 gzip -9nf RPM-PGP-KEY CHANGES groups docs/*
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 /bin/rpm --initdb
86
87 %files
88
89 %doc {RPM-PGP-KEY,CHANGES,groups}.gz docs/*
90 %postun -p /sbin/ldconfig
91
92 %attr(755,root,root) /usr/bin/gendiff
93 %attr(755,root,root) /usr/bin/rpm2cpio
94 %attr(755,root,root) %{_libdir}/rpm/rpmdb
95 /usr/man/man8/*
96 %lang(ru) /usr/man/ru/man8/*
97
98 %attr(750,root,root) %dir /var/lib/rpm
99
100 %dir /usr/lib/rpm
101 %attr(755,root,root) /usr/lib/rpm/find-*
102 %attr(755,root,root) /usr/lib/rpm/freshen.sh
103 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
104
105 /usr/lib/rpm/rpm*
106
107 %dir /usr/src/rpm/RPMS
108 %attr(755,root,root,755) /usr/src/rpm/RPMS/*
109
110 %dir /usr/src/rpm/SRPMS
111 %dir /usr/src/rpm/SPECS
112 %dir /usr/src/rpm/BUILD
113 %dir /usr/src/rpm/SOURCES
114
115 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
116 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
117 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
118 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
119 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
120 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
121 %lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
122 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
123 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
124 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
125 %lang(ru) %{_mandir}/ru/man8/rpm.8*
126 %attr(755,root,root) %{_libdir}/rpm/rpmi
127 %attr(755,root,root) %{_libdir}/rpm/rpmt
128
129 %dir /usr/include/rpm
130 /usr/include/rpm/*
131
132 /usr/lib/lib*.a
133 %files utils
134 %files -n python-rpm
135 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
136   [2.5.6-5]
137 - added rpm-find-requires.patch with beter finding list packages containing
138   required shared libraries (Artur Frysiak <wiget@usa.net>),
139 - added ru man pages,
140 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
141   dlopen() some shared glibc libraries),
142 - removed man group from man pages.
143
144 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
145   [2.5.6-4d]
146 - fixed ignorance about international character sets.
147
148 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
149   [2.5.6-1d]
150 - updated to latest stable version,
151 - added URL,
152 - added Group(pl) && changed gropup to Base,
153 - added small patch against GNU libc-2.1.
154
155 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
156   [2.5.5-1d]
157 - updated to 2.5.5. 
158
159 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
160   [2.5.2-2d]
161 - translation modified for pl,
162 - compressed man pages && documentation,
163 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
164 - moved /usr/src/redhat to /usr/src/rpm.
165
166 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
167   [2.5.2-2]
168 - fixed tr.po,
169 - added -q %setup parameter,
170 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
171 - added using %%{name} and %%{version} in Source,
172 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
173 - added %attr and %defattr macros in %files (allow build package from
174   non-root account),
175 - build against GNU libc-2.1.
176 Revision 1.79  2000/02/17 03:42:17  kloczek
177 - release 25,
178 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
179   /bin.
This page took 0.036474 seconds and 4 git commands to generate.