]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- fixed bug in %GNUconfigure
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        3.0.1
5 Release:        3
6 Group:          Base
7 Group(pl):      Bazowe
8 Copyright:      GPL
9 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/%{name}-%{version}.tar.gz
10 Source1:        rpm.groups
11 Source2:        rpm.8pl
12 Source3:        rpm.macros
13 Source4:        rpm.pl.po
14 Patch0:         rpm-rpmrc.patch
15 Patch1:         rpm-i18n.patch
16 Patch2:         rpm-find-requires.patch
17 Patch3:         rpm-macros.patch
18 Patch4:         rpm-po.patch
19 Patch5:         rpm-GNUconfigure.patch
20 Patch37:        %{name}-short_circuit.patch
21 Patch38:        %{name}-section_test.patch
22 BuildPrereq:    bzip2-static
23 BuildPrereq:    gdbm-static
24 BuildPrereq:    zlib-static
25 BuildPrereq:    patch >= 2.2
26 BuildPrereq:    libtool
27 BuildPrereq:    automake
28 BuildPrereq:    autoconf
29 BuildPrereq:    gettext
30 Requires:       glibc >= 2.1
31 BuildRoot:      /tmp/%{name}-%{version}-root
32 Obsoletes:      rpm-libs
33 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
34 RPM is a powerful package manager, which can be used to build, install, 
35 query, verify, update, and uninstall individual software packages. A 
36 package consists of an archive of files, and package information, including 
37 name, version, and description.
38 packages. A package consists of an archive of files, and package
39 nombre, versión y descripción.
40 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
41 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
42 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
43 systemu.
44 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
45 %package        devel
46 Summary:        Header files and libraries 
47 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
48 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
49 Group(pl):      Programowanie/Biblioteki
50 Requires:       %{name} = %{version}
51 Requires:       %{name} = %{version}
52 Requires:       popt-devel
53
54 %description devel
55 The RPM packaging system includes a C library that makes it easy to
56 manipulate RPM packages and databases. It is intended to ease the
57 creation of graphical package managers and other tools that need
58 %description -l pl devel
59 Pliki nag³ówkowe i biblioteki statyczne.
60 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
61 construir pacotes usando o RPM.
62 %setup  -q
63 %patch0 -p1 
64 %patch1 -p1
65 %patch2 -p1
66 %patch1 -p1
67 %patch4 -p1 
68 %patch5 -p1
69 %patch31 -p1
70 install %{SOURCE4} po/pl.po
71 install %{SOURCE13} macros.python.in
72 mv -f perl.prov perl.prov.in)
73 LDFLAGS="-s"; export LDFLAGS
74
75 ( cd popt; 
76 %GNUconfigure
77 )
78
79 %GNUconfigure -- --disable-shared 
80 %configure \
81 make
82         --with-python
83
84
85 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
86 install -d $RPM_BUILD_ROOT/var/lib/rpm \
87         $RPM_BUILD_ROOT/usr/man/{ru,pl}/man8
88
89 make DESTDIR="$RPM_BUILD_ROOT" install
90
91 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/rpm/macros.pld
92         pkgbindir="%{_bindir}"
93 install rpm.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm.8
94 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm2cpio.8
95 install %{SOURCE2} $RPM_BUILD_ROOT/usr/man/pl/man8/rpm.8
96
97 install %{SOURCE1} docs/groups
98 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
99 strip  $RPM_BUILD_ROOT/bin/rpm
100
101 gzip -9fn $RPM_BUILD_ROOT/usr/man/{{ru,pl}/man8/*,man8/*} \
102         RPM-PGP-KEY CHANGES docs/*
103
104 %post
105 /bin/rpm --initdb
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111
112 %doc RPM-PGP-KEY.gz CHANGES.gz docs/*
113 %postun -p /sbin/ldconfig
114
115 %attr(755,root,root) /usr/bin/gendiff
116 %attr(755,root,root) /usr/bin/rpm2cpio
117 %attr(755,root,root) %{_libdir}/rpm/rpmdb
118 /usr/man/man8/*
119 %lang(ru) /usr/man/ru/man8/*
120 %lang(pl) /usr/man/pl/man8/*
121
122 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
123 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
124 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
125 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
126 %lang(pl)    /usr/share/locale/pl/LC_MESSAGES/rpm.mo
127 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
128 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
129 %lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
130 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
131 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
132 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
133 %lang(ru) %{_mandir}/ru/man8/rpm.8*
134 %attr(755,root,root) %dir /var/lib/rpm
135
136 %dir /usr/lib/rpm
137 %attr(755,root,root) /usr/lib/rpm/find-*
138 %attr(755,root,root) /usr/lib/rpm/freshen.sh
139 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
140 %attr(755,root,root) /usr/lib/rpm/config.*
141 %attr(755,root,root) /usr/lib/rpm/getpo.sh
142
143 /usr/lib/rpm/rpm*
144 /usr/lib/rpm/macros*
145
146 %attr(755,root,root) %{_libdir}/rpm/rpmb
147 %attr(755,root,root) %{_libdir}/rpm/rpmi
148 %attr(755,root,root) %{_libdir}/rpm/rpmt
149 /usr/include/rpm
150 /usr/lib/librpm*.a
151 %files utils
152 %files -n python-rpm
153 * Mon Apr 19 1999 Artur Frysiak <wiget@pld.org.pl>
154   [3.0-7]
155 - upgraded to 3.0
156 - added polish man page
157 - added macros for PLD
158
159 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
160   [2.5.6-5]
161 - added rpm-find-requires.patch with beter finding list packages containing
162   required shared libraries (Artur Frysiak <wiget@usa.net>),
163 - added ru man pages,
164 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
165   dlopen() some shared glibc libraries),
166 - removed man group from man pages.
167
168 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
169   [2.5.6-4d]
170 - fixed ignorance about international character sets.
171
172 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
173   [2.5.6-1d]
174 - updated to latest stable version,
175 - added URL,
176 - added Group(pl) && changed gropup to Base,
177 - added small patch against GNU libc-2.1.
178
179 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
180   [2.5.5-1d]
181 - updated to 2.5.5. 
182
183 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
184   [2.5.2-2d]
185 - translation modified for pl,
186 - compressed man pages && documentation,
187 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
188 - moved /usr/src/redhat to /usr/src/rpm.
189
190 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
191   [2.5.2-2]
192 - fixed tr.po,
193 - added -q %setup parameter,
194 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
195 - added using %%{name} and %%{version} in Source,
196 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
197 - added %attr and %defattr macros in %files (allow build package from
198   non-root account),
199 - build against GNU libc-2.1.
200
201 Revision 1.79  2000/02/17 03:42:17  kloczek
202 - release 25,
203 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
204   /bin.
This page took 0.085859 seconds and 4 git commands to generate.