]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added gettext in header patch (by pawelk)
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        Red Hat (and now also PLD) Package Manager
4 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        51
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch28:        %{name}-perlprov-regonly.patch
56 Patch29:        %{name}-cxx.patch
57 Patch30:        %{name}-athlon.patch
58 Patch31:        %{name}-athlon-identify.patch
59 Patch32:        %{name}-gettext-in-header.patch
60 Patch37:        %{name}-short_circuit.patch
61 Patch38:        %{name}-section_test.patch
62 URL:            http://www.rpm.org/
63 Icon:           rpm.gif
64 BuildRequires:  autoconf >= 2.50
65 BuildRequires:  automake
66 BuildRequires:  bzip2-devel >= 1.0.1
67 BuildRequires:  db1-devel >= 1.85
68 BuildRequires:  db3-devel >= 3.1.17-9
69 BuildRequires:  gettext-devel >= 0.10.38-3
70 BuildRequires:  python-devel >= 2.2
71 BuildRequires:  python-modules >= 2.2
72 BuildRequires:  zlib-devel
73 BuildRequires:  python-modules >= 2.2.1
74 BuildRequires:  zlib-devel >= 1.1.4
75 %if %{!?_without_static:1}%{?_without_static:0}
76 # Require static library only for static build
77 BuildRequires:  bzip2-static >= 1.0.1
78 BuildRequires:  db1-static >= 1.85
79 BuildRequires:  zlib-static
80 BuildRequires:  glibc-static >= 2.2.0
81 BuildRequires:  zlib-static >= 1.1.4
82 %endif
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84 Obsoletes:      rpm-libs
85 Conflicts:      glibc < 2.2
86
87 %define         __find_provides %{SOURCE4}
88 %define         _binary_payload w9.gzdio
89
90 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
91 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
92 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
93 %define         py_dyndir       %{py_libdir}/lib-dynload
94 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
95
96 %description
97 RPM is a powerful package manager, which can be used to build,
98 install, query, verify, update, and uninstall individual software
99 packages. A package consists of an archive of files, and package
100 information, including name, version, and description.
101
102 %description -l de
103 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
104 Installation, Anfrage, Verifizierung, Aktualisierung und
105 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
106 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
107 Beschreibung.
108
109 %description -l es
110 RPM es un poderoso administrador de paquetes, que puede ser usado para
111 construir, instalar, pesquisar, verificar, actualizar y desinstalar
112 paquetes individuales de software. Un paquete consiste en un
113 almacenaje de archivos, y información sobre el paquete, incluyendo
114 nombre, versión y descripción.
115
116 %description -l pl
117 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
118 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
119 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
120 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
121 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
122 odpytywania programu rpm.
123
124 %description -l pt_BR
125 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
126 construir, instalar, pesquisar, verificar, atualizar e desinstalar
127 pacotes individuais de software. Um pacote consiste de um conjunto de
128 arquivos e informações adicionais, incluindo nome, versão e descrição
129 do pacote, permissões dos arquivos, etc.
130
131 %package devel
132 Summary:        Header files and libraries
133 Summary(de):    Header-Dateien uns Libraries
134 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
135 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
136 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
137 Group:          Development/Libraries
138 Requires:       %{name} = %{version}
139 Requires:       popt-devel
140
141 %description devel
142 The RPM packaging system includes a C library that makes it easy to
143 manipulate RPM packages and databases. It is intended to ease the
144 creation of graphical package managers and other tools that need
145 intimate knowledge of RPM packages.
146
147 %description devel -l de
148 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
149 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
150 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
151 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
152
153 %description devel -l es
154 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
155 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
156 facilitar la creación de administradores gráficos de paquetes y otras
157 herramientas que necesiten un conocimiento profundo de paquetes RPM.
158
159 %description devel -l pl
160 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
161 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
162 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
163 szczegó³owej wiedzy na temat pakietów RPM.
164
165 %description devel -l pt_BR
166 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
167 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
168 facilitar a criação de gerenciadores gráficos de pacotes e outras
169 ferramentas que precisem de conhecimento profundo de pacotes RPM.
170
171 %package static
172 Summary:        RPM static libraries
173 Summary(de):    RPMs statische Libraries
174 Summary(pl):    Biblioteki statyczne RPM-a
175 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
176 Group:          Development/Libraries
177 Requires:       %{name}-devel = %{version}
178
179 %description static
180 RPM static libraries.
181
182 %description static -l de
183 RPMs statische Libraries.
184
185 %description static -l pl
186 Biblioteki statyczne RPM-a.
187
188 %description static -l pt_BR
189 Bibliotecas estáticas para desenvolvimento.
190
191 %package utils
192 Summary:        Additional utilities for managing rpm packages and database
193 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
194 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
195 Group:          Applications/File
196 Requires:       %{name} = %{version}
197
198 %description utils
199 Additional utilities for managing rpm packages and database.
200
201 %description utils -l de
202 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
203
204 %description utils -l pl
205 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
206
207 %package perlprov
208 Summary:        Additional utilities for checking perl provides/requires in rpm packages
209 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
210 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
211 Group:          Applications/File
212 Requires:       perl-modules
213 Requires:       findutils
214
215 %description perlprov
216 Additional utilities for checking perl provides/requires in rpm
217 packages.
218
219 %description perlprov -l de
220 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
221
222 %description perlprov -l pl
223 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
224 pakietach rpm.
225
226 %package pythonprov
227 Summary:        Python macros, which simplifies creation of rpm packages with Python software
228 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
229 Group:          Applications/File
230 Requires:       %{name} = %{version}
231 Requires:       python-modules
232
233 %description pythonprov
234 Python macros, which simplifies creation of rpm packages with Python
235 software.
236
237 %description pythonprov -l pl
238 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
239 Pythonie.
240
241 %package -n python-rpm
242 Summary:        Python interface to RPM library
243 Group:          Development/Languages/Python
244 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
245 %requires_eq    python
246 Requires:       %{name} = %{version}
247 %pyrequires_eq  python
248 Obsoletes:      rpm-python
249
250 %description -n python-rpm
251 The rpm-python package contains a module which permits applications
252 written in the Python programming language to use the interface
253 supplied by RPM (RPM Package Manager) libraries.
254
255 This package should be installed if you want to develop Python
256 programs that will manipulate RPM packages and databases.
257
258 %description -n python-rpm -l pl
259 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
260 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
261
262 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
263 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
264
265 %description -n python-rpm -l pt_BR
266 O pacote rpm-python contém um módulo que permite que aplicações
267 escritas em Python utilizem a interface fornecida pelas bibliotecas
268 RPM (RPM Package Manager).
269
270 Esse pacote deve ser instalado se você quiser desenvolver programas em
271 Python para manipular pacotes e bancos de dados RPM.
272
273 %package build
274 Summary:        Scripts for building binary RPM packages
275 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
276 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
277 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
278 Group:          Applications/File
279 Requires:       %{name} = %{version}
280 Requires:       /bin/id
281 Requires:       awk
282 Requires:       binutils
283 Requires:       diffutils
284 Requires:       file >= 3.31
285 Requires:       fileutils
286 Requires:       findutils
287 %ifarch athlon
288 Requires:       gcc >= 3.0.3
289 %else
290 Requires:       gcc
291 Requires:       glibc-devel
292 Requires:       grep
293 Requires:       gzip
294 Requires:       make
295 Requires:       patch
296 Requires:       popt >= 1.6.2-2
297 Requires:       sed
298 Requires:       tar
299 Requires:       textutils
300
301 %description build
302 Scripts for building binary RPM packages.
303
304 %description build -l de
305 Scripts fürs Bauen binärer RPM-Pakete.
306
307 %description build -l pl
308 Skrypty pomocnicze do budowania binarnych RPM-ów.
309
310 %description build -l pt_BR
311 Este pacote contém scripts e programas executáveis que são usados para
312 construir pacotes usando o RPM.
313
314 %prep
315 %setup -q -a12
316 %patch0 -p1
317 %patch1 -p1
318 %patch2 -p1
319 %patch3 -p1
320 %patch4 -p1
321 %patch5 -p1
322 %patch6 -p1
323 %patch7 -p1
324 %patch8 -p1
325 %patch9 -p1
326 %patch10 -p1
327 %patch11 -p0
328 %patch12 -p0
329 %patch13 -p1
330 %patch14 -p1
331 %patch15 -p0
332 %patch16 -p0
333 %patch17 -p1
334 %patch18 -p1
335 %patch19 -p1
336 %patch20 -p1
337 %patch21 -p1
338 %patch22 -p1
339 %patch23 -p1
340 %patch24 -p1
341 %patch25 -p1
342 %patch26 -p0
343 %patch27 -p1
344 %patch28 -p1
345 %patch29 -p1
346 %patch30 -p1
347
348 %ifarch athlon
349 %patch31 -p1
350 %endif
351 %patch35 -p1
352 %patch36 -p1
353 %patch37 -p1
354 %patch38 -p1
355
356 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
357 cp -f platform.in macros.pld.in
358 install %{SOURCE5} macros.perl.in
359 install %{SOURCE13} macros.python.in
360 install %{SOURCE6} scripts/find-perl-provides
361 install %{SOURCE7} scripts/find-perl-requires
362 install %{SOURCE9} scripts/find-lang.sh
363
364 (cd scripts;
365 mv -f perl.req perl.req.in
366 mv -f perl.prov perl.prov.in)
367 %build
368 # generate Group translations to *.po
369 awk -f %{SOURCE14} %{SOURCE1}
370
371 cd popt
372 autoconf
373 automake -a -c
374 aclocal
375 autoheader
376 automake -a -c -f
377 %{__automake}
378 cd ..
379
380 rm -f missing
381 libtoolize --force --copy
382 autoconf
383 aclocal
384 autoupdate
385 autoheader || :
386 %{__autoconf}
387 automake -a -c
388 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
389         lib/Makefile.am > lib/Makefile.am.new
390 mv -f lib/Makefile.am.new lib/Makefile.am
391 %{__automake}
392 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
393         lib/Makefile.in > lib/Makefile.in.new
394 mv -f lib/Makefile.in.new lib/Makefile.in
395
396 sed -e 's#python1.5#python%{py_ver}#g' \
397         python/Makefile.in > python/Makefile.in.new
398 mv -f python/Makefile.in.new python/Makefile.in
399
400 # config.guess doesn't handle athlon, so we have to change it by hand.
401 # rpm checks for CPU type at runtime, but it looks better
402 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
403         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
404 mv -f macros.tmp macros.in
405
406 %configure \
407         --enable-shared \
408         --enable-v1-packages \
409         --with-python
410
411
412 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
413
414 %install
415 rm -rf $RPM_BUILD_ROOT
416
417 %{__make} install \
418         DESTDIR=$RPM_BUILD_ROOT \
419         pkgbindir="%{_bindir}"
420
421 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
422 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
423
424 install %{SOURCE1} doc/manual/groups
425 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
426 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
427 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
428 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
429 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
430
431 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
432
433 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
434 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
435 # customized rpm macros - global for host
436 #
437 #%%_install_langs pl_PL:en_US
438 %%distribution PLD
439 EOF
440
441 %find_lang %{name}
442
443 # DON'T BREAK BUILD TREE!!!
444 # rm -f doc/manual/Makefile*
445
446 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
447
448 %clean
449 rm -rf $RPM_BUILD_ROOT
450
451 %post   -p /sbin/ldconfig
452 %postun -p /sbin/ldconfig
453
454 %attr(755,root,root) /bin/rpm
455 %attr(755,root,root) %{_bindir}/rpmdb
456 %attr(755,root,root) %{_bindir}/rpmquery
457 %attr(755,root,root) %{_bindir}/rpmsign
458 %attr(755,root,root) %{_bindir}/rpmverify
459 %attr(755,root,root) %{_libdir}/rpm/rpmdb
460 %attr(755,root,root) %{_libdir}/rpm/rpmq
461 %attr(755,root,root) %{_libdir}/rpm/rpmk
462 %attr(755,root,root) %{_libdir}/rpm/rpmv
463 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
464
465 %dir %{_sysconfdir}/rpm
466 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
467
468 %{_mandir}/man8/rpm.8*
469 %lang(fr) %{_mandir}/fr/man8/rpm.8*
470 %lang(ja) %{_mandir}/ja/man8/rpm.8*
471 %lang(ko) %{_mandir}/ko/man8/rpm.8*
472 %lang(pl) %{_mandir}/pl/man8/rpm.8*
473 %lang(ru) %{_mandir}/ru/man8/rpm.8*
474 %lang(sk) %{_mandir}/sk/man8/rpm.8*
475
476 %dir /var/lib/rpm
477 %dir %{_libdir}/rpm
478
479 %{_libdir}/rpm/macros.python
480 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
481
482 %{_libdir}/rpm/rpmrc
483 %{_libdir}/rpm/rpmpopt*
484 %{_libdir}/rpm/macros
485 %{_libdir}/rpm/noarch-linux
486 %{_libdir}/rpm/noarch-pld-linux
487 %ifarch i386 i486 i586 i686 athlon
488 %{_libdir}/rpm/i?86*
489 %{_libdir}/rpm/athlon*
490 %endif
491 %ifarch sparc sparc64
492 %{_libdir}/rpm/sparc*
493 %endif
494 %ifarch alpha
495 %{_libdir}/rpm/alpha*
496 %endif
497 %ifarch ppc
498 %{_libdir}/rpm/ppc*
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_bindir}/rpmbuild
501 %attr(755,root,root) %{_bindir}/rpme
502 %attr(755,root,root) %{_bindir}/rpmi
503 %attr(755,root,root) %{_bindir}/rpmu
504 %attr(755,root,root) %{_libdir}/rpm/find-requires
505 %attr(755,root,root) %{_libdir}/rpm/find-provides
506 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
507 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
508 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
509 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
510 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
511 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
512 %attr(755,root,root) %{_libdir}/rpm/brp-*
513 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
514 %attr(755,root,root) %{_libdir}/rpm/compress-doc
515 %attr(755,root,root) %{_libdir}/rpm/cpanflute
516 %attr(755,root,root) %{_libdir}/rpm/http.req
517 %attr(755,root,root) %{_libdir}/rpm/magic.*
518 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
519 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
520 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
521 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
522 %attr(755,root,root) %{_libdir}/rpm/rpmb
523 %attr(755,root,root) %{_libdir}/rpm/rpmi
524 %attr(755,root,root) %{_libdir}/rpm/rpmt
525 %attr(755,root,root) %{_libdir}/rpm/rpme
526 %attr(755,root,root) %{_libdir}/rpm/rpmu
527
528 %files devel
529 %defattr(644,root,root,755)
530 %{_includedir}/rpm
531 %attr(755,root,root) %{_libdir}/librpm*.la
532 %attr(755,root,root) %{_libdir}/librpm*.so
533
534 %files static
535 %attr(755,root,root) %{_bindir}/*
536 %files utils
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_bindir}/gendiff
539 %attr(755,root,root) %{_bindir}/javadeps
540 %attr(755,root,root) %{_bindir}/rpm2cpio
541
542 %{_mandir}/man8/rpm2cpio.8*
543 %{_mandir}/man1/*
544 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
545 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
546 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
547 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
548
549 %files perlprov
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_libdir}/rpm/perl*
552 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
553 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
554 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
555 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
556 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
557
558 %{_libdir}/rpm/macros.perl
559
560 %defattr(644,root,root,755)
561 %defattr(644,root,root,755)
562 %{_libdir}/rpm/macros.python
563
564 %files -n python-rpm
565 %defattr(755,root,root,755)
566 %{py_sitedir}/*.so
This page took 0.072918 seconds and 4 git commands to generate.