]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- used %GNUconfigure macro
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        3.0.1
5 Release:        3
6 Group:          Base
7 Group(pl):      Bazowe
8 Copyright:      GPL
9 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/%{name}-%{version}.tar.gz
10 Source1:        rpm.groups
11 Source2:        rpm.8pl
12 Source3:        rpm.macros
13 Patch0:         rpm-rpmrc.patch
14 Patch1:         rpm-i18n.patch
15 Patch2:         rpm-find-requires.patch
16 Patch3:         rpm-macros.patch
17 Patch4:         rpm-po.patch
18 Patch37:        %{name}-short_circuit.patch
19 Patch38:        %{name}-section_test.patch
20 BuildPrereq:    bzip2-static
21 BuildPrereq:    gdbm-static
22 BuildPrereq:    zlib-static
23 BuildPrereq:    patch >= 2.2
24 BuildPrereq:    libtool
25 BuildPrereq:    automake
26 BuildPrereq:    autoconf
27 BuildPrereq:    gettext
28 Requires:       glibc >= 2.1
29 BuildRoot:      /tmp/%{name}-%{version}-root
30 Obsoletes:      rpm-libs
31 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
32 RPM is a powerful package manager, which can be used to build, install, 
33 query, verify, update, and uninstall individual software packages. A 
34 package consists of an archive of files, and package information, including 
35 name, version, and description.
36 packages. A package consists of an archive of files, and package
37 nombre, versión y descripción.
38 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
39 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
40 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
41 systemu.
42 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
43 %package        devel
44 Summary:        Header files and libraries 
45 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
46 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
47 Group(pl):      Programowanie/Biblioteki
48 Requires:       %{name} = %{version}
49 Requires:       %{name} = %{version}
50 Requires:       popt-devel
51
52 %description devel
53 The RPM packaging system includes a C library that makes it easy to
54 manipulate RPM packages and databases. It is intended to ease the
55 creation of graphical package managers and other tools that need
56 %description -l pl devel
57 Pliki nag³ówkowe i biblioteki statyczne.
58 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
59 construir pacotes usando o RPM.
60 %setup  -q
61 %patch0 -p1 
62 %patch1 -p1
63 %patch2 -p1
64 %patch1 -p1
65 %patch4 -p1 
66 install %{SOURCE13} macros.python.in
67 mv -f perl.prov perl.prov.in)
68 LDFLAGS="-s"; export LDFLAGS
69
70 ( cd popt; %GNUconfigure )
71 %configure \
72 %GNUconfigure \
73         --disable-shared
74 make
75         --with-python
76
77
78 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
79 install -d $RPM_BUILD_ROOT/var/lib/rpm \
80         $RPM_BUILD_ROOT/usr/man/{ru,pl}/man8
81
82 make DESTDIR="$RPM_BUILD_ROOT" install
83
84 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/rpm/macros.pld
85         pkgbindir="%{_bindir}"
86 install rpm.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm.8
87 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm2cpio.8
88 install %{SOURCE2} $RPM_BUILD_ROOT/usr/man/pl/man8/rpm.8
89
90 install %{SOURCE1} docs/groups
91 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
92 strip  $RPM_BUILD_ROOT/bin/rpm
93
94 gzip -9fn $RPM_BUILD_ROOT/usr/man/{{ru,pl}/man8/*,man8/*} \
95         RPM-PGP-KEY CHANGES docs/*
96
97 %post
98 /bin/rpm --initdb
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104
105 %doc RPM-PGP-KEY.gz CHANGES.gz docs/*
106 %postun -p /sbin/ldconfig
107
108 %attr(755,root,root) /usr/bin/gendiff
109 %attr(755,root,root) /usr/bin/rpm2cpio
110 %attr(755,root,root) %{_libdir}/rpm/rpmdb
111 /usr/man/man8/*
112 %lang(ru) /usr/man/ru/man8/*
113 %lang(pl) /usr/man/pl/man8/*
114
115 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
116 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
117 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
118 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
119 %lang(pl)    /usr/share/locale/pl/LC_MESSAGES/rpm.mo
120 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
121 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
122 %lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
123 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
124 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
125 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
126 %lang(ru) %{_mandir}/ru/man8/rpm.8*
127 %attr(755,root,root) %dir /var/lib/rpm
128
129 %dir /usr/lib/rpm
130 %attr(755,root,root) /usr/lib/rpm/find-*
131 %attr(755,root,root) /usr/lib/rpm/freshen.sh
132 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
133 %attr(755,root,root) /usr/lib/rpm/config.*
134 %attr(755,root,root) /usr/lib/rpm/getpo.sh
135
136 /usr/lib/rpm/rpm*
137 /usr/lib/rpm/macros*
138
139 %attr(755,root,root) %{_libdir}/rpm/rpmb
140 %attr(755,root,root) %{_libdir}/rpm/rpmi
141 %attr(755,root,root) %{_libdir}/rpm/rpmt
142 /usr/include/rpm
143 /usr/lib/librpm*.a
144 %files utils
145 %files -n python-rpm
146 * Mon Apr 19 1999 Artur Frysiak <wiget@pld.org.pl>
147   [3.0-7]
148 - upgraded to 3.0
149 - added polish man page
150 - added macros for PLD
151
152 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
153   [2.5.6-5]
154 - added rpm-find-requires.patch with beter finding list packages containing
155   required shared libraries (Artur Frysiak <wiget@usa.net>),
156 - added ru man pages,
157 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
158   dlopen() some shared glibc libraries),
159 - removed man group from man pages.
160
161 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
162   [2.5.6-4d]
163 - fixed ignorance about international character sets.
164
165 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
166   [2.5.6-1d]
167 - updated to latest stable version,
168 - added URL,
169 - added Group(pl) && changed gropup to Base,
170 - added small patch against GNU libc-2.1.
171
172 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
173   [2.5.5-1d]
174 - updated to 2.5.5. 
175
176 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
177   [2.5.2-2d]
178 - translation modified for pl,
179 - compressed man pages && documentation,
180 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
181 - moved /usr/src/redhat to /usr/src/rpm.
182
183 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
184   [2.5.2-2]
185 - fixed tr.po,
186 - added -q %setup parameter,
187 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
188 - added using %%{name} and %%{version} in Source,
189 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
190 - added %attr and %defattr macros in %files (allow build package from
191   non-root account),
192 - build against GNU libc-2.1.
193
194 Revision 1.79  2000/02/17 03:42:17  kloczek
195 - release 25,
196 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
197   /bin.
This page took 0.041966 seconds and 4 git commands to generate.