]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- removed automake, autoconf from Requires list in build subpackage.
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        36
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(pl):      Podstawowe
11 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
12 Source1:        %{name}.groups
13 Source2:        %{name}.macros
14 Source3:        %{name}-install-tree
15 Source4:        %{name}-find-rpm-provides
16 Source5:        %{name}-macros.perl
17 Source6:        %{name}-find-perl-provides
18 Source7:        %{name}-find-perl-requires
19 Source8:        %{name}-find-spec-bcond
20 Source9:        %{name}-find-lang
21 Source10:       %{name}-find-provides
22 Source11:       %{name}-find-requires
23 Source12:       %{name}-non-english-man-pages.tar.gz
24 Patch0:         %{name}-rpmrc.patch
25 Patch1:         %{name}-macros.patch
26 Patch2:         %{name}-arch.patch
27 Patch3:         %{name}-rpmpopt.patch
28 Patch4:         %{name}-perl-macros.patch
29 Patch5:         %{name}-db3.patch
30 Patch6:         %{name}-segv.patch
31 Patch7:         %{name}-am_fix.patch
32 Patch8:         %{name}-perl-req-perlfile.patch
33 Patch9:         %{name}-installplatform.patch
34 Patch10:        %{name}-cache.patch
35 Patch11:        %{name}-suggestions.patch
36 Patch12:        %{name}-rh-lame.patch
37 Patch13:        %{name}-glob.patch
38 Patch14:        %{name}-header_h.patch  
39 Patch15:        %{name}-fast-alAddPackage.patch
40 Patch16:        %{name}-byKey.patch
41 Patch17:        %{name}-perlprov.patch
42 Patch18:        %{name}-noperldir.patch
43 Patch19:        popt-cvs20010530.patch
44 Patch20:        %{name}-noexpand.patch
45 Patch21:        %{name}-scripts-closefds.patch
46 Patch22:        %{name}-python-amfix.patch
47 Patch23:        %{name}-non-english-man-pages.patch
48 Patch37:        %{name}-short_circuit.patch
49 Patch38:        %{name}-section_test.patch
50 BuildRequires:  gettext-devel >= 0.10.38-3
51 BuildRequires:  automake
52 BuildRequires:  db3-devel >= 3.1.17-9
53 BuildRequires:  bzip2-devel >= 1.0.1
54 BuildRequires:  zlib-devel
55 BuildRequires:  gettext-devel >= 0.10.38-3
56 BuildRequires:  libtool
57 BuildRequires:  automake
58 BuildRequires:  autoconf >= 2.50
59 BuildRequires:  python-devel
60 BuildRequires:  python-modules >= 2.2.1
61 BuildRequires:  zlib-devel >= 1.1.4
62 # Require static library only for static build
63 BuildRequires:  db3-static >= 3.1.17-9
64 BuildRequires:  bzip2-static >= 1.0.1
65 BuildRequires:  zlib-static
66 BuildRequires:  glibc-static >= 2.2.0
67 %endif
68 BuildRequires:  zlib-static >= 1.1.4
69 Obsoletes:      rpm-libs
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71 Obsoletes:      rpm-libs
72 %define __find_provides %{SOURCE4}
73 %define _binary_payload w9.gzdio
74 %define         __find_provides %{SOURCE4}
75 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
76 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
77 %define python_includedir  %{_includedir}/python%{python_version}
78 %define python_libdir      %{python_prefix}/lib/python%{python_version}
79 %define python_sitedir     %{python_libdir}/site-packages
80 %define         py_dyndir       %{py_libdir}/lib-dynload
81 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
82
83 %description
84 RPM is a powerful package manager, which can be used to build,
85 install, query, verify, update, and uninstall individual software
86 packages. A package consists of an archive of files, and package
87 information, including name, version, and description.
88
89 %description -l de
90 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
91 Installation, Anfrage, Verifizierung, Aktualisierung und
92 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
93 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
94 nombre, versión y descripción.
95
96 %description -l pl
97 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
98 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
99 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
100 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
101 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
102 do pacote, permissões dos arquivos, etc.
103
104 %package devel
105 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
106 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
107 Group(de):      Entwicklung/Libraries
108 Group(fr):      Development/Librairies
109 Group(pl):      Programowanie/Biblioteki
110 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
111 Group:          Development/Libraries
112 Requires:       %{name} = %{version}
113 Requires:       popt-devel
114
115 %description devel
116 The RPM packaging system includes a C library that makes it easy to
117 manipulate RPM packages and databases. It is intended to ease the
118 creation of graphical package managers and other tools that need
119 intimate knowledge of RPM packages.
120
121 %description devel -l de
122 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
123 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
124 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
125 herramientas que necesiten un conocimiento profundo de paquetes RPM.
126 Pliki nag³ówkowe i biblioteki statyczne.
127 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
128 ferramentas que precisem de conhecimento profundo de pacotes RPM.
129
130 %package static
131 Summary(pl):    Biblioteki statyczne rpm-a
132 Summary(pl):    Biblioteki statyczne RPM-a
133 Group(de):      Entwicklung/Libraries
134 Group(fr):      Development/Librairies
135 Group(pl):      Programowanie/Biblioteki
136 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}
139
140 %description static
141 RPM static libraries.
142
143 %description static -l de
144 RPMs statische Libraries.
145 Biblioteki statyczne rpm-a.
146 %description static -l pl
147 Bibliotecas estáticas para desenvolvimento.
148
149 %package utils
150 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami
151 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
152 Group(de):      Applikationen/Datei
153 Group(pl):      Aplikacje/Pliki
154 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
155 Group:          Applications/File
156 Requires:       %{name} = %{version}
157
158 %description utils
159 Additional utilities for managing rpm packages and database.
160
161 %description utils -l de
162 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
163 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
164 %description utils -l pl
165 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
166
167 %package perlprov
168 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
169 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
170 Group(de):      Applikationen/Datei
171 Group(pl):      Aplikacje/Pliki
172 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
173 Group:          Applications/File
174 Requires:       perl-modules
175 Requires:       findutils
176
177 %description perlprov
178 Additional utilities for checking perl provides/requires in rpm
179 packages.
180
181 %description perlprov -l de
182 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
183 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
184 %description perlprov -l pl
185 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
186 %package python
187
188 Group:          Development/Languages/Python
189 Group(de):      Entwicklung/Sprachen/Python
190 Group(pl):      Programowanie/Jêzyki/Python
191 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
192 %pyrequires_eq  python
193 %description python
194
195 %description -n python-rpm
196 The rpm-python package contains a module which permits applications
197 written in the Python programming language to use the interface
198 supplied by RPM (RPM Package Manager) libraries.
199
200 This package should be installed if you want to develop Python
201 Python para manipular pacotes e bancos de dados RPM.
202
203 %package build
204 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
205 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
206 Group(de):      Applikationen/Datei
207 Group(pl):      Aplikacje/Pliki
208 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
209 Group:          Applications/File
210 Requires:       sh-utils
211 Requires:       binutils
212 Requires:       patch
213 Requires:       texinfo
214 Requires:       file >= 3.31
215 Requires:       binutils
216 Requires:       gcc >= 3.0.3
217 Requires:       gcc
218 Requires:       diffutils
219 Requires:       libtool
220 Requires:       glibc-devel
221 Requires:       sed
222 Requires:       sed
223 Requires:       popt >= 1.6.2-2
224 Requires:       tar
225 Requires:       textutils
226
227 %description build
228 %description -l de build
229
230 %description build -l de
231 %description -l pl build
232 Skrypty pomocnicze do budowania binarnych RPMów.
233 %description build -l pl
234 construir pacotes usando o RPM.
235
236 %prep
237 %setup -q -a12
238 %patch0 -p1
239 %patch1 -p1
240 %patch2 -p1
241 %patch3 -p1
242 %patch4 -p1
243 %patch5 -p1
244 %patch6 -p1
245 %patch7 -p1
246 %patch8 -p1
247 %patch11 -p0
248 %patch12 -p0
249 %patch11 -p0
250 %patch12 -p0
251 %patch15 -p0
252 %patch16 -p0
253 %patch15 -p0
254 %patch16 -p0
255 %patch17 -p1
256 %patch18 -p1
257 %patch19 -p1
258 %patch22 -p1
259 %patch23 -p1
260 %patch31 -p1
261 %patch36 -p1
262 cp platform.in macros.pld.in
263 %patch38 -p1
264 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
265 cp -f platform.in macros.pld.in
266 install %{SOURCE9} scripts/find-lang.sh
267 install %{SOURCE13} macros.python.in
268 install %{SOURCE6} scripts/find-perl-provides
269 install %{SOURCE7} scripts/find-perl-requires
270 install %{SOURCE9} scripts/find-lang.sh
271
272 (cd scripts;
273 mv -f perl.req perl.req.in
274 mv -f perl.prov perl.prov.in)
275 %build
276 awk -f %{SOURCE14} %{SOURCE1}
277
278 cd popt
279 autoconf
280 automake -a -c
281 aclocal
282 autoheader
283 %{__automake}
284 cd ..
285
286 rm -f missing
287 libtoolize --force --copy
288 autoconf
289 # ugly workaround for automake
290 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
291         lib/Makefile.am > lib/Makefile.am.new
292 mv -f lib/Makefile.am.new lib/Makefile.am
293 automake -a -c
294 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
295         lib/Makefile.in > lib/Makefile.in.new
296 mv -f lib/Makefile.in.new lib/Makefile.in
297
298 sed -e 's#python1.5#python%{python_version}#g' \
299         python/Makefile.in > python/Makefile.in.new
300 mv -f python/Makefile.in.new python/Makefile.in
301
302 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
303         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
304         --enable-v1-packages \
305         --with-python
306 %configure \
307         --enable-v1-packages \
308         --with-python
309
310
311 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
312
313         DESTDIR="$RPM_BUILD_ROOT" \
314 rm -rf $RPM_BUILD_ROOT
315
316 %{__make} install \
317         pkgbindir="%{_bindir}"
318
319 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
320 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
321
322 install %{SOURCE1} doc/manual/groups
323 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
324 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
325 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
326 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
327 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
328
329 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
330
331 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
332 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
333 # customized rpm macros - global for host
334 #
335 #%%_install_langs pl_PL:en_US
336 %%distribution PLD
337 EOF
338
339 %find_lang %{name}
340
341 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
342
343 %clean
344 %clean
345 rm -rf $RPM_BUILD_ROOT
346
347 rm -rf $RPM_BUILD_ROOT
348
349 %post   -p /sbin/ldconfig
350 %postun -p /sbin/ldconfig
351
352 %attr(755,root,root) %{_libdir}/rpm/rpmdb
353 %attr(755,root,root) %{_libdir}/rpm/rpmq
354 %attr(755,root,root) %{_libdir}/rpm/rpmk
355 %attr(755,root,root) %{_libdir}/rpm/rpmv
356 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
357 %attr(755,root,root) %{_libdir}/rpm/rpmdb
358 %attr(755,root,root) %{_libdir}/rpm/rpmq
359 %attr(755,root,root) %{_libdir}/rpm/rpmk
360 %attr(755,root,root) %{_libdir}/rpm/rpmv
361 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
362
363 %dir %{_sysconfdir}/rpm
364 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
365
366 %{_mandir}/man8/rpm.8*
367 %lang(fr) %{_mandir}/fr/man8/rpm.8*
368 %lang(ja) %{_mandir}/ja/man8/rpm.8*
369 %lang(ko) %{_mandir}/ko/man8/rpm.8*
370 %lang(pl) %{_mandir}/pl/man8/rpm.8*
371 %lang(ru) %{_mandir}/ru/man8/rpm.8*
372 %lang(sk) %{_mandir}/sk/man8/rpm.8*
373
374 %dir /var/lib/rpm
375 %dir %{_libdir}/rpm
376
377 %{_libdir}/rpm/noarch-linux
378 %{_libdir}/rpm/noarch-pld-linux
379 %ifarch i386 i486 i586 i686
380 %{_libdir}/rpm/rpmpopt*
381 %{_libdir}/rpm/noarch-linux
382 %{_libdir}/rpm/noarch-pld-linux
383 %ifarch i386 i486 i586 i686 athlon
384 %{_libdir}/rpm/i?86*
385 %{_libdir}/rpm/athlon*
386 %endif
387 %ifarch sparc sparc64
388 %endif
389 %ifarch ppc
390 %{_libdir}/rpm/ppc*
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_bindir}/rpmbuild
393 %attr(755,root,root) %{_bindir}/rpme
394 %attr(755,root,root) %{_bindir}/rpmi
395 %attr(755,root,root) %{_bindir}/rpmu
396 %attr(755,root,root) %{_libdir}/rpm/find-requires
397 %attr(755,root,root) %{_libdir}/rpm/find-provides
398 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
399 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
400 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
401 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
402 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
403 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
404 %attr(755,root,root) %{_libdir}/rpm/brp-*
405 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
406 %attr(755,root,root) %{_libdir}/rpm/compress-doc
407 %attr(755,root,root) %{_libdir}/rpm/cpanflute
408 %attr(755,root,root) %{_libdir}/rpm/http.req
409 %attr(755,root,root) %{_libdir}/rpm/magic.*
410 %attr(755,root,root) %{_libdir}/rpm/rpmi
411 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
412 %attr(755,root,root) %{_libdir}/rpm/rpme
413 %attr(755,root,root) %{_libdir}/rpm/rpmu
414 %attr(755,root,root) %{_libdir}/rpm/rpmb
415 %attr(755,root,root) %{_libdir}/rpm/rpmi
416 %attr(755,root,root) %{_libdir}/rpm/rpmt
417 %attr(755,root,root) %{_libdir}/rpm/rpme
418 %attr(755,root,root) %{_libdir}/librpm*.la
419 %attr(755,root,root) %{_libdir}/librpm*.so
420 %files devel
421 %defattr(644,root,root,755)
422 %{_includedir}/rpm
423 %attr(755,root,root) %{_libdir}/librpm*.la
424 %attr(755,root,root) %{_libdir}/librpm*.so
425
426 %files static
427 %attr(755,root,root) %{_bindir}/*
428 %files utils
429 %defattr(644,root,root,755)
430 %{_mandir}/man1/*
431 %attr(755,root,root) %{_bindir}/javadeps
432 %attr(755,root,root) %{_bindir}/rpm2cpio
433
434 %{_mandir}/man8/rpm2cpio.8*
435 %{_mandir}/man1/*
436 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
437 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
438 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
439 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
440
441 %files perlprov
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_libdir}/rpm/perl*
444 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
445 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
446 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
447 %files python
448 %defattr(644,root,root,755)
449 %{python_sitedir}/*.so
450 %{_libdir}/rpm/macros.python
451
452 %files -n python-rpm
453 * %{date} PLD Team <pld-list@pld.org.pl>
454 %{py_sitedir}/*.so
This page took 0.065322 seconds and 4 git commands to generate.