]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- mention that rpm requires python-devel to be built
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        35
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(pl):      Podstawowe
11 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
12 Source1:        %{name}.groups
13 Source2:        %{name}.macros
14 Source3:        %{name}-install-tree
15 Source4:        %{name}-find-rpm-provides
16 Source5:        %{name}-macros.perl
17 Source6:        %{name}-find-perl-provides
18 Source7:        %{name}-find-perl-requires
19 Source8:        %{name}-find-spec-bcond
20 Source9:        %{name}-find-lang
21 Source10:       %{name}-find-provides
22 Source11:       %{name}-find-requires
23 Patch0:         %{name}-rpmrc.patch
24 Patch1:         %{name}-macros.patch
25 Patch2:         %{name}-arch.patch
26 Patch3:         %{name}-rpmpopt.patch
27 Patch4:         %{name}-perl-macros.patch
28 Patch5:         %{name}-db3.patch
29 Patch6:         %{name}-segv.patch
30 Patch7:         %{name}-am_fix.patch
31 Patch8:         %{name}-perl-req-perlfile.patch
32 Patch9:         %{name}-installplatform.patch
33 Patch10:        %{name}-cache.patch
34 Patch11:        %{name}-suggestions.patch
35 Patch12:        %{name}-rh-lame.patch
36 Patch13:        %{name}-glob.patch
37 Patch14:        %{name}-header_h.patch  
38 Patch15:        %{name}-fast-alAddPackage.patch
39 Patch16:        %{name}-byKey.patch
40 Patch17:        %{name}-perlprov.patch
41 Patch18:        %{name}-noperldir.patch
42 Patch19:        popt-cvs20010530.patch
43 Patch20:        %{name}-noexpand.patch
44 Patch21:        %{name}-scripts-closefds.patch
45 Patch22:        %{name}-python-amfix.patch
46 Patch37:        %{name}-short_circuit.patch
47 Patch38:        %{name}-section_test.patch
48 BuildRequires:  gettext-devel >= 0.10.38-3
49 BuildRequires:  automake
50 BuildRequires:  db3-devel >= 3.1.17-9
51 BuildRequires:  bzip2-devel >= 1.0.1
52 BuildRequires:  zlib-devel
53 BuildRequires:  gettext-devel >= 0.10.38-3
54 BuildRequires:  libtool
55 BuildRequires:  automake
56 BuildRequires:  autoconf >= 2.50
57 BuildRequires:  python-devel
58 BuildRequires:  python-modules >= 2.2.1
59 BuildRequires:  zlib-devel >= 1.1.4
60 # Require static library only for static build
61 BuildRequires:  db3-static >= 3.1.17-9
62 BuildRequires:  bzip2-static >= 1.0.1
63 BuildRequires:  zlib-static
64 BuildRequires:  glibc-static >= 2.2.0
65 %endif
66 BuildRequires:  zlib-static >= 1.1.4
67 Obsoletes:      rpm-libs
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69 Obsoletes:      rpm-libs
70 %define __find_provides %{SOURCE4}
71 %define _binary_payload w9.gzdio
72 %define         __find_provides %{SOURCE4}
73 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
74 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
75 %define python_includedir  %{_includedir}/python%{python_version}
76 %define python_libdir      %{python_prefix}/lib/python%{python_version}
77 %define python_sitedir     %{python_libdir}/site-packages
78 %define         py_dyndir       %{py_libdir}/lib-dynload
79 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
80
81 %description
82 RPM is a powerful package manager, which can be used to build,
83 install, query, verify, update, and uninstall individual software
84 packages. A package consists of an archive of files, and package
85 information, including name, version, and description.
86
87 %description -l de
88 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
89 Installation, Anfrage, Verifizierung, Aktualisierung und
90 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
91 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
92 nombre, versión y descripción.
93
94 %description -l pl
95 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
96 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
97 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
98 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
99 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
100 do pacote, permissões dos arquivos, etc.
101
102 %package devel
103 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
104 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
105 Group(de):      Entwicklung/Libraries
106 Group(fr):      Development/Librairies
107 Group(pl):      Programowanie/Biblioteki
108 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
109 Group:          Development/Libraries
110 Requires:       %{name} = %{version}
111 Requires:       popt-devel
112
113 %description devel
114 The RPM packaging system includes a C library that makes it easy to
115 manipulate RPM packages and databases. It is intended to ease the
116 creation of graphical package managers and other tools that need
117 intimate knowledge of RPM packages.
118
119 %description devel -l de
120 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
121 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
122 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
123 herramientas que necesiten un conocimiento profundo de paquetes RPM.
124 Pliki nag³ówkowe i biblioteki statyczne.
125 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
126 ferramentas que precisem de conhecimento profundo de pacotes RPM.
127
128 %package static
129 Summary(pl):    Biblioteki statyczne rpm-a
130 Summary(pl):    Biblioteki statyczne RPM-a
131 Group(de):      Entwicklung/Libraries
132 Group(fr):      Development/Librairies
133 Group(pl):      Programowanie/Biblioteki
134 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
135 Group:          Development/Libraries
136 Requires:       %{name}-devel = %{version}
137
138 %description static
139 RPM static libraries.
140
141 %description static -l de
142 RPMs statische Libraries.
143 Biblioteki statyczne rpm-a.
144 %description static -l pl
145 Bibliotecas estáticas para desenvolvimento.
146
147 %package utils
148 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami
149 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
150 Group(de):      Applikationen/Datei
151 Group(pl):      Aplikacje/Pliki
152 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
153 Group:          Applications/File
154 Requires:       %{name} = %{version}
155
156 %description utils
157 Additional utilities for managing rpm packages and database.
158
159 %description utils -l de
160 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
161 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
162 %description utils -l pl
163 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
164
165 %package perlprov
166 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
167 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
168 Group(de):      Applikationen/Datei
169 Group(pl):      Aplikacje/Pliki
170 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
171 Group:          Applications/File
172 Requires:       perl-modules
173 Requires:       findutils
174
175 %description perlprov
176 Additional utilities for checking perl provides/requires in rpm
177 packages.
178
179 %description perlprov -l de
180 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
181 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
182 %description perlprov -l pl
183 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
184 %package python
185
186 Group:          Development/Languages/Python
187 Group(de):      Entwicklung/Sprachen/Python
188 Group(pl):      Programowanie/Jêzyki/Python
189 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
190 %pyrequires_eq  python
191 %description python
192
193 %description -n python-rpm
194 The rpm-python package contains a module which permits applications
195 written in the Python programming language to use the interface
196 supplied by RPM (RPM Package Manager) libraries.
197
198 This package should be installed if you want to develop Python
199 Python para manipular pacotes e bancos de dados RPM.
200
201 %package build
202 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
203 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
204 Group(de):      Applikationen/Datei
205 Group(pl):      Aplikacje/Pliki
206 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
207 Group:          Applications/File
208 Requires:       sh-utils
209 Requires:       binutils
210 Requires:       patch
211 Requires:       texinfo
212 Requires:       file >= 3.31
213 Requires:       binutils
214 Requires:       gcc >= 3.0.3
215 Requires:       gcc
216 Requires:       diffutils
217 Requires:       libtool
218 Requires:       glibc-devel
219 Requires:       sed
220 Requires:       sed
221 Requires:       autoconf
222 Requires:       automake
223 Requires:       popt >= 1.6.2-2
224 Requires:       tar
225 Requires:       textutils
226
227 %description build
228 %description -l de build
229
230 %description build -l de
231 %description -l pl build
232 Skrypty pomocnicze do budowania binarnych RPMów.
233 %description build -l pl
234 construir pacotes usando o RPM.
235 %setup -q
236 %prep
237 %setup -q -a12
238 %patch0 -p1
239 %patch1 -p1
240 %patch2 -p1
241 %patch3 -p1
242 %patch4 -p1
243 %patch5 -p1
244 %patch6 -p1
245 %patch7 -p1
246 %patch8 -p1
247 %patch11 -p0
248 %patch12 -p0
249 %patch11 -p0
250 %patch12 -p0
251 %patch15 -p0
252 %patch16 -p0
253 %patch15 -p0
254 %patch16 -p0
255 %patch17 -p1
256 %patch18 -p1
257 %patch19 -p1
258 %patch22 -p1
259 %patch31 -p1
260 %patch36 -p1
261 cp platform.in macros.pld.in
262 %patch38 -p1
263 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
264 cp -f platform.in macros.pld.in
265 install %{SOURCE9} scripts/find-lang.sh
266 install %{SOURCE13} macros.python.in
267 install %{SOURCE6} scripts/find-perl-provides
268 install %{SOURCE7} scripts/find-perl-requires
269 install %{SOURCE9} scripts/find-lang.sh
270
271 (cd scripts;
272 mv -f perl.req perl.req.in
273 mv -f perl.prov perl.prov.in)
274 %build
275 awk -f %{SOURCE14} %{SOURCE1}
276
277 cd popt
278 autoconf
279 automake -a -c
280 aclocal
281 autoheader
282 %{__automake}
283 cd ..
284
285 rm -f missing
286 libtoolize --force --copy
287 autoconf
288 # ugly workaround for automake
289 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
290         lib/Makefile.am > lib/Makefile.am.new
291 mv -f lib/Makefile.am.new lib/Makefile.am
292 automake -a -c
293 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
294         lib/Makefile.in > lib/Makefile.in.new
295 mv -f lib/Makefile.in.new lib/Makefile.in
296
297 sed -e 's#python1.5#python%{python_version}#g' \
298         python/Makefile.in > python/Makefile.in.new
299 mv -f python/Makefile.in.new python/Makefile.in
300
301 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
302         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
303         --enable-v1-packages \
304         --with-python
305 %configure \
306         --enable-v1-packages \
307         --with-python
308
309
310 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
311
312         DESTDIR="$RPM_BUILD_ROOT" \
313 rm -rf $RPM_BUILD_ROOT
314
315 %{__make} install \
316         pkgbindir="%{_bindir}"
317
318 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
319 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
320
321 install %{SOURCE1} doc/manual/groups
322 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
323 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
324 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
325 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
326 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
327
328 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
329
330 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
331 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
332 # customized rpm macros - global for host
333 #
334 #%%_install_langs pl_PL:en_US
335 %%distribution PLD
336 EOF
337
338 %find_lang %{name}
339
340 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
341
342 %clean
343 %clean
344 rm -rf $RPM_BUILD_ROOT
345
346 rm -rf $RPM_BUILD_ROOT
347
348 %post   -p /sbin/ldconfig
349 %postun -p /sbin/ldconfig
350
351 %attr(755,root,root) %{_libdir}/rpm/rpmdb
352 %attr(755,root,root) %{_libdir}/rpm/rpmq
353 %attr(755,root,root) %{_libdir}/rpm/rpmk
354 %attr(755,root,root) %{_libdir}/rpm/rpmv
355 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
356 %attr(755,root,root) %{_libdir}/rpm/rpmdb
357 %attr(755,root,root) %{_libdir}/rpm/rpmq
358 %attr(755,root,root) %{_libdir}/rpm/rpmk
359 %attr(755,root,root) %{_libdir}/rpm/rpmv
360 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
361 %{_mandir}/man8/rpm.8*
362 %lang(pl) %{_mandir}/pl/man8/rpm.8*
363 %lang(ja) %{_mandir}/ja/man8/rpm.8*
364 %lang(fr) %{_mandir}/fr/man8/rpm.8*
365 %lang(ja) %{_mandir}/ja/man8/rpm.8*
366 %lang(ko) %{_mandir}/ko/man8/rpm.8*
367 %lang(pl) %{_mandir}/pl/man8/rpm.8*
368 %lang(ru) %{_mandir}/ru/man8/rpm.8*
369 %lang(sk) %{_mandir}/sk/man8/rpm.8*
370
371 %dir /var/lib/rpm
372 %dir %{_libdir}/rpm
373
374 %{_libdir}/rpm/noarch-linux
375 %{_libdir}/rpm/noarch-pld-linux
376 %ifarch i386 i486 i586 i686
377 %{_libdir}/rpm/rpmpopt*
378 %{_libdir}/rpm/noarch-linux
379 %{_libdir}/rpm/noarch-pld-linux
380 %ifarch i386 i486 i586 i686 athlon
381 %{_libdir}/rpm/i?86*
382 %{_libdir}/rpm/athlon*
383 %endif
384 %ifarch sparc sparc64
385 %endif
386 %ifarch ppc
387 %{_libdir}/rpm/ppc*
388 %defattr(644,root,root,755)
389 %attr(755,root,root) %{_bindir}/rpmbuild
390 %attr(755,root,root) %{_bindir}/rpme
391 %attr(755,root,root) %{_bindir}/rpmi
392 %attr(755,root,root) %{_bindir}/rpmu
393 %attr(755,root,root) %{_libdir}/rpm/find-requires
394 %attr(755,root,root) %{_libdir}/rpm/find-provides
395 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
396 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
397 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
398 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
399 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
400 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
401 %attr(755,root,root) %{_libdir}/rpm/brp-*
402 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
403 %attr(755,root,root) %{_libdir}/rpm/compress-doc
404 %attr(755,root,root) %{_libdir}/rpm/cpanflute
405 %attr(755,root,root) %{_libdir}/rpm/http.req
406 %attr(755,root,root) %{_libdir}/rpm/magic.*
407 %attr(755,root,root) %{_libdir}/rpm/rpmi
408 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
409 %attr(755,root,root) %{_libdir}/rpm/rpme
410 %attr(755,root,root) %{_libdir}/rpm/rpmu
411 %attr(755,root,root) %{_libdir}/rpm/rpmb
412 %attr(755,root,root) %{_libdir}/rpm/rpmi
413 %attr(755,root,root) %{_libdir}/rpm/rpmt
414 %attr(755,root,root) %{_libdir}/rpm/rpme
415 %attr(755,root,root) %{_libdir}/librpm*.la
416 %attr(755,root,root) %{_libdir}/librpm*.so
417 %files devel
418 %defattr(644,root,root,755)
419 %{_includedir}/rpm
420 %attr(755,root,root) %{_libdir}/librpm*.la
421 %attr(755,root,root) %{_libdir}/librpm*.so
422
423 %files static
424 %attr(755,root,root) %{_bindir}/*
425 %files utils
426 %defattr(644,root,root,755)
427 %{_mandir}/man1/*
428 %{_mandir}/man8/rpm2cpio.8*
429 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
430 %{_mandir}/man1/*
431 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
432 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
433 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
434 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
435
436 %files perlprov
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/rpm/perl*
439 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
440 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
441 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
442 %files python
443 %defattr(644,root,root,755)
444 %{python_sitedir}/*.so
445 %{_libdir}/rpm/macros.python
446
447 %files -n python-rpm
448 * %{date} PLD Team <pld-list@pld.org.pl>
449 %{py_sitedir}/*.so
This page took 0.07287 seconds and 4 git commands to generate.